MFH: r551605
devel/ipython5: Use newest version of pygments The pinned dependency 'pygments<2.6' is only necessary to solve an issue with Python 2.7, and devel/ipython5 is now python3.5+ only. [1] [2] This fixes a conflict introduced on ports r549076 and r549418 between textproc/py-pygments and textproc/py-pygments-25 when building at least textproc/py-sphinx and math/sage. 1 - https://github.com/ipython/ipython/pull/12174 2 - https://github.com/ipython/ipython/issues/12173 PR: 249131, 250074, 250144 Reported by: thierry, swills Approved by: python (with hat) Approved by: ports-secteam (fluffy)
This commit is contained in:
parent
b3e697eef4
commit
9344180e12
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q4/; revision=551675
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= ipython
|
||||
PORTVERSION= 5.10.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
@ -19,7 +20,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pexpect>=0:misc/py-pexpect@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}decorator>=0:devel/py-decorator@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pickleshare>=0:databases/py-pickleshare@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}prompt_toolkit1>=1.0.4<2.0.0:devel/py-prompt_toolkit1@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pygments-25<2.6:textproc/py-pygments-25@${PY_FLAVOR} \
|
||||
${PY_PYGMENTS} \
|
||||
${PYTHON_PKGNAMEPREFIX}simplegeneric>0.8:devel/py-simplegeneric@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}traitlets>=4.2:devel/py-traitlets@${PY_FLAVOR}
|
||||
|
||||
@ -35,15 +36,6 @@ OPTIONS_DEFINE= EXAMPLES
|
||||
|
||||
PORTSCOUT= limit:^5\.
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PYTHON_REL} < 3000
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports.shutil_get_terminal_size>=0:devel/py-backports.shutil_get_terminal_size@${PY_FLAVOR}
|
||||
.endif
|
||||
.if ${PYTHON_REL} < 3400
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pathlib2>=0:devel/py-pathlib2@${PY_FLAVOR}
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${ECHO_CMD} "/EASY-INSTALL" > ${WRKDIR}/ex.script
|
||||
@${ECHO_CMD} "a" >> ${WRKDIR}/ex.script
|
||||
@ -58,4 +50,4 @@ post-install:
|
||||
post-install-EXAMPLES-on:
|
||||
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
26
devel/ipython5/files/patch-setup.py
Normal file
26
devel/ipython5/files/patch-setup.py
Normal file
@ -0,0 +1,26 @@
|
||||
# Release pygments because devel/ipython5 is python:3.5+ now.
|
||||
# https://github.com/ipython/ipython/pull/12174
|
||||
#
|
||||
# This avoids some conflicts:
|
||||
# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=250074
|
||||
# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=250144
|
||||
--- setup.py.orig 2020-05-01 18:12:21 UTC
|
||||
+++ setup.py
|
||||
@@ -182,7 +182,7 @@ extras_require = dict(
|
||||
parallel = ['ipyparallel'],
|
||||
qtconsole = ['qtconsole'],
|
||||
doc = ['Sphinx>=1.3'],
|
||||
- test = ['nose>=0.10.1', 'requests', 'testpath', 'pygments<2.6', 'nbformat', 'ipykernel'],
|
||||
+ test = ['nose>=0.10.1', 'requests', 'testpath', 'pygments', 'nbformat', 'ipykernel'],
|
||||
terminal = [],
|
||||
kernel = ['ipykernel'],
|
||||
nbformat = ['nbformat'],
|
||||
@@ -197,7 +197,7 @@ install_requires = [
|
||||
'simplegeneric>0.8',
|
||||
'traitlets>=4.2',
|
||||
'prompt_toolkit>=1.0.4,<2.0.0',
|
||||
- 'pygments<2.6',
|
||||
+ 'pygments',
|
||||
]
|
||||
|
||||
# Platform-specific dependencies:
|
Loading…
Reference in New Issue
Block a user