Remove expired ports

2014-09-28 archivers/rpm5: Broken for more than 6 months
2014-09-28 devel/cocaine-core: Broken for more than 6 months
2014-09-28 graphics/ruby-tgif: Broken for more than 6 months
This commit is contained in:
Antoine Brodin 2014-09-28 21:10:35 +00:00
parent 7fcfd8ed5e
commit 932199d4be
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=369500
20 changed files with 3 additions and 905 deletions

3
MOVED
View File

@ -7132,3 +7132,6 @@ sysutils/rubygem-chef-solr||2014-09-25|Has expired: Depends on broken rubygem-de
www/rubygem-chef-server-webui||2014-09-25|Has expired: Depends on broken rubygem-dep_selector
www/rubygem-chef-server-api||2014-09-25|Has expired: Depends on broken rubygem-dep_selector
databases/freetds-msdblib||2014-09-27|No longer required, now covered by databases/freetds
archivers/rpm5||2014-09-28|Has expired: Broken for more than 6 months
devel/cocaine-core||2014-09-28|Has expired: Broken for more than 6 months
graphics/ruby-tgif||2014-09-28|Has expired: Broken for more than 6 months

View File

@ -170,7 +170,6 @@
SUBDIR += rox-archive
SUBDIR += rpm2cpio
SUBDIR += rpm4
SUBDIR += rpm5
SUBDIR += ruby-lha
SUBDIR += ruby-zip
SUBDIR += rubygem-archive-tar-minitar

View File

@ -1,119 +0,0 @@
# Created by: Greg Lewis <glewis@FreeBSD.org>
# $FreeBSD$
PORTNAME= rpm
PORTVERSION= 5.2.1
PORTREVISION= 6
CATEGORIES= archivers
MASTER_SITES= http://rpm5.org/files/rpm/rpm-${PORTVERSION:R}/
PKGNAMESUFFIX= 5
MAINTAINER= afb@rpm5.org
COMMENT= The RPM Package Manager
BROKEN= Does not package
DEPRECATED= Broken for more than 6 months
EXPIRATION_DATE= 2014-09-28
LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
libpopt.so:${PORTSDIR}/devel/popt \
libbeecrypt.so:${PORTSDIR}/security/beecrypt \
libneon.so:${PORTSDIR}/www/neon29 \
libmagic.so:${PORTSDIR}/sysutils/file \
libxar.so:${PORTSDIR}/archivers/xar \
libpcre.so:${PORTSDIR}/devel/pcre
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed \
${LOCALBASE}/lib/libuuid.a:${PORTSDIR}/misc/ossp-uuid \
bash:${PORTSDIR}/shells/bash
SH= ${LOCALBASE}/bin/bash
OPTIONS_DEFINE= PERL PYTHON LUA DOCS
OPTIONS_DEFAULT= PYTHON LUA
DB_VERSION?= 47
USE_BDB= ${DB_VERSION}
USE_AUTOTOOLS= libtool
LIBTOOLFILES= configure db3/configure db/dist/configure \
file/configure xar/configure
CONFIGURE_ARGS= --without-js
USES= gmake perl5 shebangfix
SHEBANG_FILES= scripts/*
USE_PERL5= build
USE_LDCONFIG= yes
CONFLICTS= rpm-3.* rpm-4.* rpm4-*
OPTIONS_SUB= yes
LUA_USES= lua:5.1
LUA_BUILD_DEPENDS= ${LOCALBASE}/lib/libsyck.a:${PORTSDIR}/textproc/syck
LUA_CPPFLAGS= -I${LUA_INCDIR}
LUA_LDFLAGS= -L${LUA_LIBDIR}
LUA_CONFIGURE_ON= --with-lua=external --with-syck=external
LUA_CONFIGURE_OFF= --without-lua --without-syck
PERL_CONFIGURE_WITH= perl
PERL_USE= PERL5=run
PERL_CONFIGURE_ENV= __PERL=${PERL}
PYTHON_USE= PYTHON=yes
PYTHON_CONFIGURE_ON= --with-python=${PYTHON_VER}
PYTHON_CONFIGURE_OFF= --without-python
PYTHON_CONFIGURE_ENV= __PYTHON=${PYTHON_CMD}
PYTHON_CPPFLAGS= -I${PYTHON_INCLUDEDIR}
PYTHON_LDFLAGS= -L${PYTHON_LIBDIR}
NLS_USES= gettext iconv
NLS_CONFIGURE_ENABLE= nls
DOCS_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen \
dot:${PORTSDIR}/graphics/graphviz \
${LOCALBASE}/lib/X11/fonts/freefont-ttf/FreeSans.ttf:${PORTSDIR}/x11-fonts/freefont-ttf
DOCS_CONFIGURE_WITH= apidocs
PORTDOCS= *
CPPFLAGS+= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include -I${LOCALBASE}/include/xar
LDFLAGS+= -L${BDB_LIB_DIR} -L${LOCALBASE}/lib
CONFIGURE_ARGS+=--with-db=external --with-bugreport="${MAINTAINER}" \
--with-sqlite=external --with-dbabi=db \
--with-zlib=external \
--with-file=external \
--with-xar=external \
--with-xz=external \
--with-pcre=external \
--with-uuid=external \
--program-prefix="" \
--sysconfdir=${PREFIX}/etc \
--with-path-cfg=${PREFIX}/etc/rpm \
--with-path-magic=${LOCALBASE}/share/file/magic
MAN3PREFIX?= ${PREFIX}/lib/perl5/${PERL_VER}
.include <bsd.port.options.mk>
post-patch::
@${REINPLACE_CMD} -E -e \
's:\$$\(libdir\)/pkgconfig:${PREFIX}/libdata/pkgconfig:' \
${WRKSRC}/scripts/Makefile.am ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s:/bin/sh:/usr/bin/env bash:" \
${WRKSRC}/scripts/gendiff
post-configure:
.if ${PORT_OPTIONS:MPERL}
@${REINPLACE_CMD} -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' ${CONFIGURE_WRKSRC}/perl/Makefile
.endif
@echo "DOT_FONTPATH = ${LOCALBASE}/lib/X11/fonts/freefont-ttf" >> ${WRKSRC}/Doxyfile
.if ${PORT_OPTIONS:MDOCS}
post-build:
${MAKE} -C ${WRKSRC} apidocs
.endif
post-install:
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}/apidocs/html
cd ${WRKSRC}/apidocs/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/apidocs/html/
.endif
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (rpm-5.2.1.tar.gz) = ce301adc959b5139ae0c9e83af315ed11049efd081cc7ca9b2f7a8f3026e108c
SIZE (rpm-5.2.1.tar.gz) = 15544959

View File

@ -1,300 +0,0 @@
--- configure.orig 2010-05-01 18:57:15.000000000 +0200
+++ configure 2010-10-23 18:07:03.000000000 +0200
@@ -36085,15 +36085,15 @@
withval=$with_python;
if test ".$withval" != .no; then
case "$withval" in
- 2.x|2.3|2.4|2.5|2.6)
+ 2.x|2.3|2.4|2.5|2.6|2.7)
python_version=$withval
;;
yes)
- python_version="2.6 2.5 2.4 2.3 2.x"
+ python_version="2.7 2.6 2.5 2.4 2.3 2.x"
;;
*)
- { $as_echo "$as_me:$LINENO: WARNING: --with-python only supports values \"2.x\", \"2.3\", \"2.4\", \"2.5\", or \"2.6\" ignoring..." >&5
-$as_echo "$as_me: WARNING: --with-python only supports values \"2.x\", \"2.3\", \"2.4\", \"2.5\", or \"2.6\" ignoring..." >&2;}
+ { $as_echo "$as_me:$LINENO: WARNING: --with-python only supports values \"2.x\", \"2.3\", \"2.4\", \"2.5\", \"2.6\", or \"2.7\" ignoring..." >&5
+$as_echo "$as_me: WARNING: --with-python only supports values \"2.x\", \"2.3\", \"2.4\", \"2.5\", \"2.6\", or \"2.7\" ignoring..." >&2;}
python_version=""
;;
esac
@@ -53679,6 +53679,64 @@
rm -f conftest.err conftest.$ac_ext
__rcl_safe_LIBS="${LIBS}"
+ LIBS="-lpython2.7 ${LIBS}"
+ cat >conftest.$ac_ext <<_ACEOF
+/* confdefs.h. */
+_ACEOF
+cat confdefs.h >>conftest.$ac_ext
+cat >>conftest.$ac_ext <<_ACEOF
+/* end confdefs.h. */
+
+/* Override any GCC internal prototype to avoid an error.
+ Use char because int might match the return type of a GCC
+ builtin and then its argument prototype would still apply. */
+#ifdef __cplusplus
+extern "C"
+#endif
+char Py_Initialize ();
+int
+main ()
+{
+return Py_Initialize ();
+ ;
+ return 0;
+}
+_ACEOF
+rm -f conftest.$ac_objext conftest$ac_exeext
+if { (ac_try="$ac_link"
+case "(($ac_try" in
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+ *) ac_try_echo=$ac_try;;
+esac
+eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
+$as_echo "$ac_try_echo") >&5
+ (eval "$ac_link") 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+ cat conftest.err >&5
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } && {
+ test -z "$ac_c_werror_flag" ||
+ test ! -s conftest.err
+ } && test -s conftest$ac_exeext && {
+ test "$cross_compiling" = yes ||
+ $as_test_x conftest$ac_exeext
+ }; then
+ __rcl_found_lib=yes
+else
+ $as_echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
+
+fi
+
+rm -rf conftest.dSYM
+rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
+ conftest$ac_exeext conftest.$ac_ext
+ LIBS="${__rcl_safe_LIBS}"
+
+ __rcl_safe_LIBS="${LIBS}"
LIBS="-lpython2.6 ${LIBS}"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
@@ -53838,6 +53896,64 @@
rm -f conftest.err conftest.$ac_ext
__rcl_safe_LIBS="${LIBS}"
+ LIBS="-lpython2.7 ${LIBS}"
+ cat >conftest.$ac_ext <<_ACEOF
+/* confdefs.h. */
+_ACEOF
+cat confdefs.h >>conftest.$ac_ext
+cat >>conftest.$ac_ext <<_ACEOF
+/* end confdefs.h. */
+
+/* Override any GCC internal prototype to avoid an error.
+ Use char because int might match the return type of a GCC
+ builtin and then its argument prototype would still apply. */
+#ifdef __cplusplus
+extern "C"
+#endif
+char Py_Initialize ();
+int
+main ()
+{
+return Py_Initialize ();
+ ;
+ return 0;
+}
+_ACEOF
+rm -f conftest.$ac_objext conftest$ac_exeext
+if { (ac_try="$ac_link"
+case "(($ac_try" in
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+ *) ac_try_echo=$ac_try;;
+esac
+eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
+$as_echo "$ac_try_echo") >&5
+ (eval "$ac_link") 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+ cat conftest.err >&5
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } && {
+ test -z "$ac_c_werror_flag" ||
+ test ! -s conftest.err
+ } && test -s conftest$ac_exeext && {
+ test "$cross_compiling" = yes ||
+ $as_test_x conftest$ac_exeext
+ }; then
+ __rcl_found_lib=yes
+else
+ $as_echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
+
+fi
+
+rm -rf conftest.dSYM
+rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
+ conftest$ac_exeext conftest.$ac_ext
+ LIBS="${__rcl_safe_LIBS}"
+
+ __rcl_safe_LIBS="${LIBS}"
LIBS="-lpython2.6 ${LIBS}"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
@@ -54240,6 +54356,40 @@
__rcl_found=no
for __rcl_dir in ${__rcl_location}/lib/pythonembed ${__rcl_location}/lib ${__rcl_location}; do
+ if test -f "${__rcl_dir}/libpython2.7.la" && \
+ test -d "${__rcl_dir}/.libs"; then
+ if test ".${__rcl_dir}" != "./usr/lib"; then
+
+ if test ".$verbose" = .yes; then
+ $as_echo "-- extending LDFLAGS: -L${__rcl_dir}" >&6
+ fi
+
+
+ if test ".$verbose" = .yes; then
+ $as_echo "-- extending LDFLAGS: -L${__rcl_dir}/.libs" >&6
+ fi
+
+ LDFLAGS="${LDFLAGS} -L${__rcl_dir} -L${__rcl_dir}/.libs"
+ fi
+ __rcl_found=yes
+ break
+ fi
+ if test -f "${__rcl_dir}/libpython2.7.a" || \
+ test -f "${__rcl_dir}/libpython2.7.so" || \
+ test -f "${__rcl_dir}/libpython2.7.sl" || \
+ test -f "${__rcl_dir}/libpython2.7.dylib"; then
+ if test ".${__rcl_dir}" != "./usr/lib"; then
+
+ if test ".$verbose" = .yes; then
+ $as_echo "-- extending LDFLAGS: -L${__rcl_dir}" >&6
+ fi
+
+ LDFLAGS="${LDFLAGS} -L${__rcl_dir}"
+ fi
+ __rcl_found=yes
+ break
+ fi
+
if test -f "${__rcl_dir}/libpython2.6.la" && \
test -d "${__rcl_dir}/.libs"; then
if test ".${__rcl_dir}" != "./usr/lib"; then
@@ -54332,6 +54482,22 @@
if test ".${__rcl_found}" = .yes; then
__rcl_found=no
+ for __rcl_file in _ `find ${__rcl_location} -name "libpython2.7.*" -type f -print 2>/dev/null | \
+ egrep '\.(a|so|sl|dylib)$'`; do
+ test .${__rcl_file} = ._ && continue
+ __rcl_dir=`echo ${__rcl_file} | sed -e 's;[^/]*$;;' -e 's;\(.\)/$;\1;'`
+ if test ".${__rcl_dir}" != "./usr/lib"; then
+
+ if test ".$verbose" = .yes; then
+ $as_echo "-- extending LDFLAGS: -L${__rcl_dir}" >&6
+ fi
+
+ LDFLAGS="${LDFLAGS} -L${__rcl_dir}"
+ fi
+ __rcl_found=yes
+ break
+ done
+
for __rcl_file in _ `find ${__rcl_location} -name "libpython2.6.*" -type f -print 2>/dev/null | \
egrep '\.(a|so|sl|dylib)$'`; do
test .${__rcl_file} = ._ && continue
@@ -54538,6 +54704,83 @@
__rcl_found_lib=no
+{ $as_echo "$as_me:$LINENO: checking for Py_Initialize in -lpython2.7" >&5
+$as_echo_n "checking for Py_Initialize in -lpython2.7... " >&6; }
+if test "${ac_cv_lib_python2_7_Py_Initialize+set}" = set; then
+ $as_echo_n "(cached) " >&6
+else
+ ac_check_lib_save_LIBS=$LIBS
+LIBS="-lpython2.7 $LIBS"
+cat >conftest.$ac_ext <<_ACEOF
+/* confdefs.h. */
+_ACEOF
+cat confdefs.h >>conftest.$ac_ext
+cat >>conftest.$ac_ext <<_ACEOF
+/* end confdefs.h. */
+
+/* Override any GCC internal prototype to avoid an error.
+ Use char because int might match the return type of a GCC
+ builtin and then its argument prototype would still apply. */
+#ifdef __cplusplus
+extern "C"
+#endif
+char Py_Initialize ();
+int
+main ()
+{
+return Py_Initialize ();
+ ;
+ return 0;
+}
+_ACEOF
+rm -f conftest.$ac_objext conftest$ac_exeext
+if { (ac_try="$ac_link"
+case "(($ac_try" in
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+ *) ac_try_echo=$ac_try;;
+esac
+eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
+$as_echo "$ac_try_echo") >&5
+ (eval "$ac_link") 2>conftest.er1
+ ac_status=$?
+ grep -v '^ *+' conftest.er1 >conftest.err
+ rm -f conftest.er1
+ cat conftest.err >&5
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } && {
+ test -z "$ac_c_werror_flag" ||
+ test ! -s conftest.err
+ } && test -s conftest$ac_exeext && {
+ test "$cross_compiling" = yes ||
+ $as_test_x conftest$ac_exeext
+ }; then
+ ac_cv_lib_python2_7_Py_Initialize=yes
+else
+ $as_echo "$as_me: failed program was:" >&5
+sed 's/^/| /' conftest.$ac_ext >&5
+
+ ac_cv_lib_python2_7_Py_Initialize=no
+fi
+
+rm -rf conftest.dSYM
+rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
+ conftest$ac_exeext conftest.$ac_ext
+LIBS=$ac_check_lib_save_LIBS
+fi
+{ $as_echo "$as_me:$LINENO: result: $ac_cv_lib_python2_7_Py_Initialize" >&5
+$as_echo "$ac_cv_lib_python2_7_Py_Initialize" >&6; }
+if test "x$ac_cv_lib_python2_7_Py_Initialize" = x""yes; then
+ cat >>confdefs.h <<_ACEOF
+#define HAVE_LIBPYTHON2_7 1
+_ACEOF
+
+ LIBS="-lpython2.7 $LIBS"
+
+fi
+
+ test ".${ac_cv_lib_python2_7_Py_Initialize}" = .yes && __rcl_found_lib=yes
+
+
{ $as_echo "$as_me:$LINENO: checking for Py_Initialize in -lpython2.6" >&5
$as_echo_n "checking for Py_Initialize in -lpython2.6... " >&6; }
if test "${ac_cv_lib_python2_6_Py_Initialize+set}" = set; then

View File

@ -1,11 +0,0 @@
--- tools/rpmdigest.c.orig 2009-01-16 21:47:11.000000000 +0100
+++ tools/rpmdigest.c 2010-09-13 21:30:57.000000000 +0200
@@ -887,7 +887,7 @@
When checking, the input should be a former output of this program. The\n\
default mode is to print a line with digest, a character indicating type\n\
(`*' for binary, ` ' for text), and name for each FILE.\n\
-"), NULL },
+\0"), NULL }, /* embed NUL to work around expandMacro bug in Doxygen 1.7.1 */
POPT_TABLEEND
};

View File

@ -1,17 +0,0 @@
#!/bin/sh
# $FreeBSD$
# The RPM database directory
RPM_DATABASE_DIR=/var/local/lib/rpm
# Provide instructions for removing the RPM database.
if [ "$2" = "POST-DEINSTALL" ]; then
if [ -d "${RPM_DATABASE_DIR}" ]; then
echo ""
echo "If you are removing RPM permanently you can remove the"
echo "RPM database with the command:"
echo ""
echo " rm -rf ${RPM_DATABASE_DIR}"
echo ""
fi
fi

View File

@ -1,10 +0,0 @@
The RPM Package Manager is a powerful command line driven package
management system capable of installing, uninstalling, verifying,
querying, and updating computer software packages. Each software
package consists of an archive of files along with information about
the package like its version, a description, and the like. There
is also a related API ("Application Program Interface"), permitting
advanced developers to bypass 'shelling out' to a command line, and
to manage such transactions from within a native coding language.
WWW: http://www.rpm5.org/

View File

@ -1,18 +0,0 @@
#!/bin/sh
# $FreeBSD$
# The RPM database directory
RPM_DATABASE_DIR=/var/local/lib/rpm
# Provide instructions for initialising the RPM database.
if [ "$2" = "POST-INSTALL" ]; then
if [ -d "${RPM_DATABASE_DIR}" ]; then
echo ""
echo "Old RPM database found. If you are upgrading RPM from a"
echo "different version of Berkeley DB, you might need to rebuild"
echo "with the command:"
echo ""
echo " ${PKG_PREFIX}/bin/rpm --rebuilddb"
echo ""
fi
fi

View File

@ -1,233 +0,0 @@
bin/gendiff
bin/rpm
bin/rpm2cpio
bin/rpmbuild
bin/rpmconstant
include/rpm/db.h
include/rpm/mire.h
include/rpm/pkgio.h
include/rpm/rpm4compat.h
include/rpm/rpm46compat.h
include/rpm/rpmbuild.h
include/rpm/rpmcb.h
include/rpm/rpmcli.h
include/rpm/rpmconstant.h
include/rpm/rpmdb.h
include/rpm/rpmds.h
include/rpm/rpmevr.h
include/rpm/rpmfi.h
include/rpm/rpmio.h
include/rpm/rpmiotypes.h
include/rpm/rpmlog.h
include/rpm/rpmmacro.h
include/rpm/rpmns.h
include/rpm/rpmpgp.h
include/rpm/rpmps.h
include/rpm/rpmrc.h
include/rpm/rpmspec.h
include/rpm/rpmsw.h
include/rpm/rpmsx.h
include/rpm/rpmtag.h
include/rpm/rpmte.h
include/rpm/rpmts.h
include/rpm/rpmtypes.h
include/rpm/rpmversion.h
include/rpm/rpmzlog.h
include/rpm/yarn.h
lib/librpm-5.2.so
lib/librpm.a
lib/librpm.la
lib/librpm.so
lib/librpmbuild-5.2.so
lib/librpmbuild.a
lib/librpmbuild.la
lib/librpmbuild.so
lib/librpmconstant-5.2.so
lib/librpmconstant.a
lib/librpmconstant.la
lib/librpmconstant.so
lib/librpmdb-5.2.so
lib/librpmdb.a
lib/librpmdb.la
lib/librpmdb.so
lib/librpmio-5.2.so
lib/librpmio.a
lib/librpmio.la
lib/librpmio.so
lib/librpmmisc-5.2.so
lib/librpmmisc.a
lib/librpmmisc.la
lib/librpmmisc.so
lib/rpm/bin/rpmcache
lib/rpm/bin/rpmdigest
lib/rpm/bin/grep
lib/rpm/bin/mtree
lib/rpm/bin/rpmrepo
lib/rpm/bin/rpmspecdump
lib/rpm/bin/wget
lib/rpm/bin/rpmcmp
lib/rpm/bin/rpmdeps
lib/rpm/bin/txar
lib/rpm/brp-compress
lib/rpm/brp-java-gcjcompile
lib/rpm/brp-nobuildrootpath
lib/rpm/brp-python-bytecompile
lib/rpm/brp-sparc64-linux
lib/rpm/brp-strip
lib/rpm/brp-strip-comment-note
lib/rpm/brp-strip-shared
lib/rpm/brp-strip-static-archive
lib/rpm/check-files
lib/rpm/cpuinfo.yaml
lib/rpm/cross-build
lib/rpm/executabledeps.sh
lib/rpm/find-debuginfo.sh
lib/rpm/find-lang.sh
lib/rpm/find-prov.pl
lib/rpm/find-provides.perl
lib/rpm/find-req.pl
lib/rpm/find-requires.perl
lib/rpm/getpo.sh
lib/rpm/helpers/makeshlibs
lib/rpm/http.req
lib/rpm/install-sh
lib/rpm/javadeps.sh
lib/rpm/libtooldeps.sh
lib/rpm/macros
lib/rpm/mkinstalldirs
lib/rpm/mono-find-provides
lib/rpm/mono-find-requires
lib/rpm/osgideps.pl
lib/rpm/perl.prov
lib/rpm/perl.req
lib/rpm/perldeps.pl
lib/rpm/php.prov
lib/rpm/php.req
lib/rpm/pkgconfigdeps.sh
lib/rpm/pythondeps.sh
lib/rpm/qf/deb_Packages
lib/rpm/qf/deb_Sources
lib/rpm/qf/deb_control
lib/rpm/qf/deb_md5sums
lib/rpm/qf/deb_postinst
lib/rpm/qf/deb_postrm
lib/rpm/qf/deb_preinst
lib/rpm/qf/deb_prerm
lib/rpm/qf/wnh_filelists_yaml
lib/rpm/qf/wnh_other_yaml
lib/rpm/qf/wnh_primary_yaml
lib/rpm/qf/yum_filelists_sqlite
lib/rpm/qf/yum_other_sqlite
lib/rpm/qf/yum_primary_sqlite
lib/rpm/qf/yum_filelists_xml
lib/rpm/qf/yum_other_xml
lib/rpm/qf/yum_primary_xml
lib/rpm/rpm.daily
lib/rpm/rpm.log
lib/rpm/rpm.xinetd
lib/rpm/rpm2cpio
lib/rpm/rpmdb_loadcvt
lib/rpm/rpmpopt
lib/rpm/tgpg
lib/rpm/u_pkg.sh
lib/rpm/vcheck
lib/rpm/vpkg-provides.sh
lib/rpm/vpkg-provides2.sh
libdata/pkgconfig/rpm.pc
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/RPM.pm
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/RPM/Constant.pm
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/RPM/Dependencies.pm
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/RPM/Files.pm
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/RPM/Header.pm
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/RPM/PackageIterator.pm
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/RPM/Problems.pm
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/RPM/Spec.pm
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/RPM/Transaction.pm
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/RPM/.packlist
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/RPM/RPM.so
%%PERL%%%%PERL5_MAN3%%/RPM.3.gz
%%PERL%%%%PERL5_MAN3%%/RPM::Constant.3.gz
%%PERL%%%%PERL5_MAN3%%/RPM::Dependencies.3.gz
%%PERL%%%%PERL5_MAN3%%/RPM::Files.3.gz
%%PERL%%%%PERL5_MAN3%%/RPM::Header.3.gz
%%PERL%%%%PERL5_MAN3%%/RPM::PackageIterator.3.gz
%%PERL%%%%PERL5_MAN3%%/RPM::Problems.3.gz
%%PERL%%%%PERL5_MAN3%%/RPM::Spec.3.gz
%%PERL%%%%PERL5_MAN3%%/RPM::Transaction.3.gz
%%PYTHON%%%%PYTHON_SITELIBDIR%%/rpm/__init__.py
%%PYTHON%%%%PYTHON_SITELIBDIR%%/rpm/_rpmmodule.a
%%PYTHON%%%%PYTHON_SITELIBDIR%%/rpm/_rpmmodule.la
%%PYTHON%%%%PYTHON_SITELIBDIR%%/rpm/_rpmmodule.so
share/locale/cs/LC_MESSAGES/rpm.mo
share/locale/da/LC_MESSAGES/rpm.mo
share/locale/de/LC_MESSAGES/rpm.mo
share/locale/es/LC_MESSAGES/rpm.mo
share/locale/fi/LC_MESSAGES/rpm.mo
share/locale/fr/LC_MESSAGES/rpm.mo
share/locale/id/LC_MESSAGES/rpm.mo
share/locale/is/LC_MESSAGES/rpm.mo
share/locale/it/LC_MESSAGES/rpm.mo
share/locale/ja/LC_MESSAGES/rpm.mo
share/locale/ko/LC_MESSAGES/rpm.mo
share/locale/nb/LC_MESSAGES/rpm.mo
share/locale/nl/LC_MESSAGES/rpm.mo
share/locale/pa/LC_MESSAGES/rpm.mo
share/locale/pl/LC_MESSAGES/rpm.mo
share/locale/pt/LC_MESSAGES/rpm.mo
share/locale/pt_BR/LC_MESSAGES/rpm.mo
share/locale/ru/LC_MESSAGES/rpm.mo
share/locale/sk/LC_MESSAGES/rpm.mo
share/locale/sl/LC_MESSAGES/rpm.mo
share/locale/sr/LC_MESSAGES/rpm.mo
share/locale/sv/LC_MESSAGES/rpm.mo
share/locale/tr/LC_MESSAGES/rpm.mo
share/locale/uk/LC_MESSAGES/rpm.mo
share/locale/vi/LC_MESSAGES/rpm.mo
share/locale/zh_TW/LC_MESSAGES/rpm.mo
man/fr/man8/rpm.8.gz
man/ja/man8/rpm.8.gz
man/ja/man8/rpm2cpio.8.gz
man/ja/man8/rpmbuild.8.gz
man/ja/man8/rpmcache.8.gz
man/ja/man8/rpmgraph.8.gz
man/ko/man8/rpm.8.gz
man/ko/man8/rpm2cpio.8.gz
man/man1/gendiff.1.gz
man/man1/rpmgrep.1.gz
man/man8/rpm.8.gz
man/man8/rpm2cpio.8.gz
man/man8/rpmbuild.8.gz
man/man8/rpmcache.8.gz
man/man8/rpmconstant.8.gz
man/man8/rpmdeps.8.gz
man/man8/rpmmtree.8.gz
man/pl/man1/gendiff.1.gz
man/pl/man8/rpm.8.gz
man/pl/man8/rpm2cpio.8.gz
man/pl/man8/rpmbuild.8.gz
man/pl/man8/rpmcache.8.gz
man/pl/man8/rpmdeps.8.gz
man/pl/man8/rpmgraph.8.gz
man/ru/man8/rpm.8.gz
man/ru/man8/rpm2cpio.8.gz
man/sk/man8/rpm.8.gz
@dirrmtry man/fr/man8
@dirrmtry man/ko/man8
@dirrmtry man/pl/man1
@dirrmtry man/pl/man8
@dirrmtry man/ru/man8
@dirrmtry man/sk/man8
@dirrmtry man/fr
@dirrmtry man/ko
@dirrmtry man/pl
@dirrmtry man/ru
@dirrmtry man/sk
@dirrm lib/rpm/bin
@dirrm lib/rpm/helpers
@dirrm lib/rpm/qf
@dirrm lib/rpm
%%PERL%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/RPM
%%PYTHON%%@dirrm %%PYTHON_SITELIBDIR%%/rpm
@dirrm include/rpm
@dirrmtry var/spool/repackage
@dirrmtry var/local/lib/rpm

View File

@ -238,7 +238,6 @@
SUBDIR += cmph
SUBDIR += cmunge
SUBDIR += cobf
SUBDIR += cocaine-core
SUBDIR += coccinelle
SUBDIR += codeblocks
SUBDIR += codeville

View File

@ -1,36 +0,0 @@
# Created by: Veniamin Gvozdikov <vg@FreeBSD.org>
# $FreeBSD$
PORTNAME= cocaine-core
PORTVERSION= 0.10
PORTREVISION= 6
CATEGORIES= devel
MASTER_SITES= GH GHC
MAINTAINER= vg@FreeBSD.org
COMMENT= Cocaine Application Engine
LICENSE= GPLv3
BROKEN= Does not build
DEPRECATED= Broken for more than 6 months
EXPIRATION_DATE= 2014-09-28
LIB_DEPENDS= libboost_iostreams.so:${PORTSDIR}/devel/boost-libs \
libev.so:${PORTSDIR}/devel/libev \
libltdl.so:${PORTSDIR}/devel/libltdl \
libmsgpack.so:${PORTSDIR}/devel/msgpack \
libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid \
libzmq.so:${PORTSDIR}/net/libzmq2
USES= cmake
USE_GCC= yes
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= zloidemon
GH_COMMIT= 7d0f35c
GH_TAGNAME= ${GH_COMMIT}
CONFLICTS= json-c-[0-9]*
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (cocaine-core-0.10.tar.gz) = 9e9ba7972338c1813887bdc32be1440d79777466c51991cdbb5243090c1b0c26
SIZE (cocaine-core-0.10.tar.gz) = 176761

View File

@ -1,5 +0,0 @@
Your personal app engine. Technically speaking, it's an open-source cloud
platform enabling you to build your own PaaS clouds using simple yet
effective dynamic components.
WWW: http://reverbrain.com/cocaine/

View File

@ -1,67 +0,0 @@
bin/cocaine-runtime
bin/cocaine-tool
include/cocaine/api/client.hpp
include/cocaine/api/driver.hpp
include/cocaine/api/event.hpp
include/cocaine/api/isolate.hpp
include/cocaine/api/logger.hpp
include/cocaine/api/reactor.hpp
include/cocaine/api/sandbox.hpp
include/cocaine/api/service.hpp
include/cocaine/api/storage.hpp
include/cocaine/api/stream.hpp
include/cocaine/app.hpp
include/cocaine/archive.hpp
include/cocaine/asio.hpp
include/cocaine/auth.hpp
include/cocaine/cached.hpp
include/cocaine/common.hpp
include/cocaine/config.hpp
include/cocaine/context.hpp
include/cocaine/engine.hpp
include/cocaine/exceptions.hpp
include/cocaine/forwards.hpp
include/cocaine/helpers/atomic.hpp
include/cocaine/helpers/birth_control.hpp
include/cocaine/helpers/format.hpp
include/cocaine/helpers/json.hpp
include/cocaine/helpers/pid_file.hpp
include/cocaine/io.hpp
include/cocaine/isolates/process.hpp
include/cocaine/loggers/files.hpp
include/cocaine/loggers/stdout.hpp
include/cocaine/loggers/syslog.hpp
include/cocaine/logging.hpp
include/cocaine/manifest.hpp
include/cocaine/profile.hpp
include/cocaine/repository.hpp
include/cocaine/rpc.hpp
include/cocaine/session.hpp
include/cocaine/slave.hpp
include/cocaine/storages/files.hpp
include/cocaine/traits.hpp
include/cocaine/traits/json.hpp
include/cocaine/traits/policy.hpp
include/cocaine/traits/unique_id.hpp
include/cocaine/unique_id.hpp
include/json/autolink.h
include/json/config.h
include/json/features.h
include/json/forwards.h
include/json/json.h
include/json/reader.h
include/json/value.h
include/json/writer.h
lib/libcocaine-common.so
lib/libcocaine-common.so.2
lib/libcocaine-core.so
lib/libcocaine-core.so.2
lib/libjson.a
@dirrm include/cocaine/traits
@dirrm include/cocaine/storages
@dirrm include/cocaine/loggers
@dirrm include/cocaine/isolates
@dirrm include/cocaine/helpers
@dirrm include/cocaine/api
@dirrm include/cocaine
@dirrm include/json

View File

@ -910,7 +910,6 @@
SUBDIR += ruby-image_size
SUBDIR += ruby-imlib2
SUBDIR += ruby-svg
SUBDIR += ruby-tgif
SUBDIR += rubygem-cairo
SUBDIR += rubygem-captcha
SUBDIR += rubygem-chunky_png

View File

@ -1,66 +0,0 @@
# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
# $FreeBSD$
PORTNAME= tgif
PORTVERSION= 20010408
PORTREVISION= 12
CATEGORIES= graphics ruby
MASTER_SITES= http://www2s.biglobe.ne.jp/~Nori/ruby/dist/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}-${PORTVERSION}-2
DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby extension library to draw Tgif graphics
BROKEN= Does not compile
DEPRECATED= Broken for more than 6 months
EXPIRATION_DATE= 2014-09-28
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/${TGIF_PORT}:build \
imake:${PORTSDIR}/devel/imake
# NB not USE_IMAKE; this is required for the tgif build but this
# port doesn't use it directly.
USES= gettext
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
TGIF_PORT= graphics/tgif
WRKSRC= ${WRKDIR}/ruby-${PORTNAME}-${PORTVERSION}
CONFIGURE_ARGS= --with-x-dir="${LOCALBASE}" \
--with-ldflags=" `cd ${WRKSRC}/tgif; ${MAKE} -V LDOPTIONS -V LOCAL_LIBRARIES -V LDLIBS -V EXTRA_LOAD_FLAGS | paste -s -`"
INSTALL_TARGET= site-install
DOCS_EN= README
DOCS_JA= ChangeLog.ja README.ja
OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
BROKEN= Does not build on amd64 or ia64 (missing -fPIC)
.endif
post-extract:
${LN} -sf `cd ${PORTSDIR}/${TGIF_PORT}; ${MAKE} -V WRKSRC` ${WRKSRC}/tgif
post-patch:
${RUBY} -i -pe 'gsub %r|\.\./|, "tgif/"' ${WRKSRC}/extconf.rb ${WRKSRC}/*.c
post-install:
${MKDIR} ${RUBY_MODEXAMPLESDIR}/ja
${INSTALL_DATA} ${WRKSRC}/examples/test??.rb ${RUBY_MODEXAMPLESDIR}/
${INSTALL_DATA} ${WRKSRC}/examples/test??_ja.rb ${RUBY_MODEXAMPLESDIR}/ja/
${MKDIR} ${RUBY_MODDOCDIR}/ja
.for f in ${DOCS_EN}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
.for f in ${DOCS_JA}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
.endfor
.include <bsd.port.post.mk>

View File

@ -1,2 +0,0 @@
SHA256 (ruby/ruby-tgif-20010408-2.tar.gz) = 804894327a22f25cdae37330961fbea325dab061b8a0a6070ee2bf7c85ca5742
SIZE (ruby/ruby-tgif-20010408-2.tar.gz) = 13098

View File

@ -1,3 +0,0 @@
Ruby/Tgif is a Ruby extension library to draw Tgif graphics.
WWW: http://www2s.biglobe.ne.jp/~Nori/ruby/

View File

@ -1,11 +0,0 @@
%%RUBY_SITEARCHLIBDIR%%/tgif.so
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/ChangeLog.ja
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/README.ja
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/ja
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test01.rb
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test02.rb
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/ja/test01_ja.rb
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%/ja
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%