Virtuoso is an innovative Virtualization platform that transparently

integrates Data, Services, and Business Processes across the enterprise.
Its unique product architecture enables it to delivery traditionally
distinct server functionality, within a single product offering,
along the following lines:
* Data Management & Integration (SQL, XML and EII)
* Application Integration (Web Services & SOA)
* Process Management & Integration (BPEL)
* Collaboration and Network Effects

WWW: http://virtuoso.openlinksw.com/

- Hosting modules (python and ruby) will be added as slave ports later.
- Mono hosting is broken on FreeBSD
- Perl hosting is broken on FreeBSD
(perl* ports are built without -Dusemultiplicity)
- PHP4/5 hosting is broken on FreeBSD (php* ports do not install libphp).
- JDBC driver will be added as a slave port later.
This commit is contained in:
Max Khon 2006-12-09 13:05:29 +00:00
parent dda7615110
commit 92f7662c0e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=179292
8 changed files with 1416 additions and 0 deletions

View File

@ -483,6 +483,7 @@
SUBDIR += unixODBC
SUBDIR += useracc
SUBDIR += usogres
SUBDIR += virtuoso
SUBDIR += wfb2sql
SUBDIR += wmjsql
SUBDIR += xapian-core

105
databases/virtuoso/Makefile Normal file
View File

@ -0,0 +1,105 @@
# New ports collection makefile for: virtuoso
# Date created: Jul 08, 2006
# Whom: Max Khon <fjoe@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= virtuoso
PORTVERSION= 4.5.6
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-opensource-${PORTVERSION}
MAINTAINER= fjoe@FreeBSD.org
COMMENT= Universal SQL/Application Server
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-readline\
--with-iodbc=${LOCALBASE}\
--enable-bpel-vad\
--enable-krb\
--disable-jdbc
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}"\
LDFLAGS="-L${LOCALBASE}/lib"
LIB_DEPENDS= iodbc.3:${PORTSDIR}/databases/libiodbc
OPTIONS= IMAGEMAGICK "ImageMagick support" off\
OPENLDAP "OpenLDAP support" off
# JDBC "JDBC driver" off\
# PERL "Perl hosting" off
# PYTHON "Python hosting" off
# MONO "Mono extension" off\
# PHP4 "PHP4 extension" off\
# PHP5 "PHP5 extension" off\
# RUBY "Ruby hosting" off\
post-patch:
${REINPLACE_CMD}\
-e 's,-lpthreads,${PTHREAD_LIBS},g'\
-e 's,-lgssapi_krb5 -lk5crypto -lkrb5,-lasn1 -lroken -lcrypto -lcrypt,g'\
-e 's,-lruby,-lruby${RUBY_VER:S,.,,},g'\
${WRKSRC}/configure
pre-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
post-install:
${CHMOD} +w ${PREFIX}/virtuoso/demo/demo.db
.include <bsd.port.pre.mk>
.if defined(WITH_IMAGEMAGICK)
CONFIGURE_ARGS+=--enable-imagemagick=${LOCALBASE}
LIB_DEPENDS+= Magick.10:${PORTSDIR}/graphics/ImageMagick
PLIST_SUB+= WITH_IMAGEMAGICK=""
.else
PLIST_SUB+= WITH_IMAGEMAGICK="@comment "
.endif
#.if defined(WITH_JDBC)
#USE_JAVA= yes
#JAVA_VERSION= 1.4+
#JAVA_BUILD= yes
#.endif
# XXX broken (does not build, requires gc.h)
#.if defined(WITH_MONO)
#CONFIGURE_ARGS+=--enable-mono
#.endif
.if defined(WITH_OPENLDAP)
CONFIGURE_ARGS+=--enable-openldap=${LOCALBASE}
USE_OPENLDAP= yes
.endif
# XXX broken (requires perl to be built with -Dusemultiplicity)
#.if defined(WITH_PERL)
#CONFIGURE_ARGS+=--enable-perl
#USE_PERL5= yes
#.endif
# XXX broken (no libphp)
#.if defined(WITH_PHP4)
#CONFIGURE_ARGS+=--enable-php4
#.endif
# XXX broken (no libphp)
#.if defined(WITH_PHP5)
#CONFIGURE_ARGS+=--enable-php5
#.endif
# XXX broken (USE_PYTHON does not work with OPTIONS)
#.if defined(WITH_PYTHON)
#CONFIGURE_ARGS+=--enable-python
#USE_PYTHON= yes
#.endif
# XXX broken (USE_LIBRUBY does not work with OPTIONS)
#.if defined(WITH_RUBY)
#CONFIGURE_ARGS+=--enable-ruby
#USE_LIBRUBY= yes
#.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,3 @@
MD5 (virtuoso-opensource-4.5.6.tar.gz) = 302fe33fe439cf8331cac2e8386eb665
SHA256 (virtuoso-opensource-4.5.6.tar.gz) = e9bb7f5d487a4ba786c5ac23f343d38d440cce578aafcf7ae78ddc5704d490ce
SIZE (virtuoso-opensource-4.5.6.tar.gz) = 38224271

View File

@ -0,0 +1,46 @@
--- configure.orig Sat Oct 28 01:47:57 2006
+++ configure Fri Dec 8 00:21:26 2006
@@ -2201,6 +2201,7 @@
#actually prefer /lib/cpp : it's to be run on Java
case $host in
*-darwin*) CPP=/usr/bin/cpp ;;
+ *-freebsd*) CPP=/usr/bin/cpp ;;
*) CPP=/lib/cpp ;;
esac
@@ -31280,7 +31281,7 @@
-for ac_header in krb5.h gssapi/gssapi.h gssapi/gssapi_generic.h gssapi/gssapi_krb5.h
+for ac_header in krb5.h gssapi/gssapi.h gssapi/gssapi_generic.h gssapi/gssapi_krb5.h gssapi.h
do
as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
if eval "test \"\${$as_ac_Header+set}\" = set"; then
@@ -31756,8 +31757,8 @@
openldap_LDFLAGS="-lldap -llber"
LDFLAGS="$LDFLAGS $openldap_LDFLAGS" ;;
*)
- openssl_CFLAGS="-I$with_ldap/include"
- openssl_LDFLAGS="-L$with_ldap/lib -lldap -llber"
+ openldap_CFLAGS="-I$with_ldap/include"
+ openldap_LDFLAGS="-L$with_ldap/lib -lldap -llber"
CPPFLAGS="$CPPFLAGS $openldap_CFLAGS"
LDFLAGS="$LDFLAGS $openldap_LDFLAGS"
LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$with_ldap/lib" ;;
@@ -35797,13 +35798,13 @@
## various destination dirs ##
## ##
##########################################################################
-virtdatadir=$datadir/virtuoso
+virtdatadir=$prefix/virtuoso
vaddir=$virtdatadir/vad
docdir=$virtdatadir/doc
htmldocdir=$docdir/html
pdfdocdir=$docdir/pdf
-virtstatedir=$localstatedir/lib/virtuoso
+virtstatedir=$prefix/virtuoso
demodir=$virtstatedir/demo
dbdir=$virtstatedir/db
httprootdir=$virtstatedir/vsp

View File

@ -0,0 +1,53 @@
#!/bin/sh
# $FreeBSD$
#
# PROVIDE: virtuoso
# REQUIRE: LOGIN
# KEYWORD: shutdown
#
# Add the following line to /etc/rc.conf to enable Virtuoso Universal Server:
#
# virtuoso_enable="YES"
# # optional
# virtuoso_config="%%PREFIX%%/virtuoso/db/virtuoso.ini"
# virtuoso_flags=""
#
# This scripts takes one of the following commands:
#
# start stop restart reload status
#
prefix=%%PREFIX%%
command=${prefix}/bin/virtuoso
. %%RC_SUBR%%
load_rc_config virtuoso
# set defaults
virtuoso_enable=${virtuoso_enable:-"NO"}
virtuoso_flags=${virtuoso_flags:-""}
virtuoso_user=virtuoso
eval virtuoso_config=${virtuoso_config:-"~${virtuoso_user}/db/virtuoso.ini"}
virtuoso_class=${virtuoso_class:-"default"}
name=virtuoso
rcvar=`set_rcvar`
command_args="-D ${virtuoso_data} ${virtuoso_flags}"
extra_commands="reload"
start_cmd="virtuoso_command start"
stop_cmd="virtuoso_command stop"
restart_cmd="virtuoso_command restart"
reload_cmd="virtuoso_command reload"
status_cmd="virtuoso_command status"
initdb_cmd="virtuoso_initdb"
virtuoso_command()
{
su -l ${virtuoso_user} -c "exec ${command} ${command_args} ${rc_arg}"
}
run_rc_command "$1"

View File

@ -0,0 +1,11 @@
Virtuoso is an innovative Virtualization platform that transparently
integrates Data, Services, and Business Processes across the enterprise.
Its unique product architecture enables it to delivery traditionally
distinct server functionality, within a single product offering,
along the following lines:
* Data Management & Integration (SQL, XML and EII)
* Application Integration (Web Services & SOA)
* Process Management & Integration (BPEL)
* Collaboration and Network Effects
WWW: http://virtuoso.openlinksw.com/

View File

@ -0,0 +1,71 @@
#!/bin/sh
#
# $FreeBSD$
#
PKG_PREFIX=${PKG_PREFIX:=/usr/local}
BATCH=${BATCH:=no}
ask() {
local question default answer
question=$1
default=$2
if [ -z "${PACKAGE_BUILDING}" -a x${BATCH} = xno ]; then
read -p "${question} [${default}]? " answer
fi
if [ x${answer} = x ]; then
answer=${default}
fi
echo ${answer}
}
yesno() {
local question default answer
question=$1
default=$2
while :; do
answer=$(ask "${question}" "${default}")
case "${answer}" in
[Yy]*) return 0;;
[Nn]*) return 1;;
esac
echo "Please answer yes or no."
done
}
if [ x"$2" = xPRE-INSTALL ]; then
USER=virtuoso
GROUP=virtuoso
UID=79
GID=79
if /usr/sbin/pw groupshow "${GROUP}" 2>/dev/null; then
echo "You already have a group \"${GROUP}\", so I will use it."
else
if /usr/sbin/pw groupadd ${GROUP} -g ${GID}
then
echo "Added group \"${GROUP}\"."
else
echo "Adding group \"${GROUP}\" failed..."
echo "Please create it, and try again."
exit 1
fi
fi
if /usr/sbin/pw user show "${USER}" 2>/dev/null; then
echo "You already have a user \"${USER}\", so I will use it."
else
if /usr/sbin/pw useradd ${USER} -u ${UID} -g ${GROUP} -h - \
-d ${PKG_PREFIX}/virtuoso \
-c "Virtuoso Universal Server"
then
echo "Added user \"${USER}\"."
else
echo "Adding user \"${USER}\" failed..."
echo "Please create it, and try again."
exit 1
fi
fi
fi

1126
databases/virtuoso/pkg-plist Normal file

File diff suppressed because it is too large Load Diff