add mpgtx
A command line MPEG audio/video/system file toolbox
This commit is contained in:
parent
b4daf5a013
commit
92dc1699fb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=42607
@ -145,6 +145,7 @@
|
||||
SUBDIR += mpeg_play
|
||||
SUBDIR += mpeg_stat
|
||||
SUBDIR += mpegedit
|
||||
SUBDIR += mpgtx
|
||||
SUBDIR += mplex
|
||||
SUBDIR += mtv
|
||||
SUBDIR += netpbm
|
||||
|
31
graphics/mpgtx/Makefile
Normal file
31
graphics/mpgtx/Makefile
Normal file
@ -0,0 +1,31 @@
|
||||
# ex:ts=8
|
||||
# New ports collection makefile for: mpgtx
|
||||
# Date created: May 15, 2001
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mpgtx
|
||||
PORTVERSION= 0.6b
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-1-src
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= ijliao@FreeBSD.org
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
ALL_TARGET= shared
|
||||
MAKE_ENV= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
|
||||
INSTALL_MAN="${INSTALL_MAN}"
|
||||
|
||||
MAN1= mpgtx.1 mp3tag.1
|
||||
MLINKS= mpgtx.1 mpgdemux.1 \
|
||||
mpgtx.1 mpgjoin.1 \
|
||||
mpgtx.1 mpgsplit.1 \
|
||||
mpgtx.1 mpgcat.1 \
|
||||
mpgtx.1 mpginfo.1
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/mpgtx/distinfo
Normal file
1
graphics/mpgtx/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (mpgtx-0.6b-1-src.tgz) = 8d86be5a71390fb87ac2bd64261aa0ff
|
35
graphics/mpgtx/files/patch-Makefile
Normal file
35
graphics/mpgtx/files/patch-Makefile
Normal file
@ -0,0 +1,35 @@
|
||||
--- Makefile.orig Tue Apr 24 21:02:33 2001
|
||||
+++ Makefile Tue May 15 10:06:09 2001
|
||||
@@ -1,5 +1,4 @@
|
||||
# installation dirs : Edit at your convenance
|
||||
-PREFIX=/usr
|
||||
INSTALLDIR=$(PREFIX)/bin
|
||||
MANDIR=$(PREFIX)/man/man1
|
||||
|
||||
@@ -7,7 +6,7 @@
|
||||
|
||||
# compilation flags
|
||||
DEVEL_CFLAGS= -g -Wall -Werror -pedantic -fno-builtin
|
||||
-RELEASE_CFLAGS= -Wall -O3 -pedantic
|
||||
+RELEASE_CFLAGS= ${CFLAGS}
|
||||
SHARED_LFLAGS= -s
|
||||
STATIC_LFLAGS= -static -s
|
||||
DEVEL_LFLAGS= #-lefence
|
||||
@@ -48,14 +47,9 @@
|
||||
ln -sf mpgtx mpginfo
|
||||
ln -sf mpgtx mpgdemux
|
||||
ln -sf mpgtx mp3tag
|
||||
- install -d -m 755 $(INSTALLDIR)
|
||||
- install -d -m 755 $(MANDIR)
|
||||
- install -s -m 755 mpgtx $(INSTALLDIR)
|
||||
- cp -df mpgdemux mpgjoin mpgcat mpginfo mpgsplit mp3tag $(INSTALLDIR)
|
||||
- install -m 644 man/mpgtx.1 man/mp3tag.1 $(MANDIR)
|
||||
- cd man ; make
|
||||
- cd ..
|
||||
- cp -df ./man/mpgdemux.1 ./man/mpgjoin.1 man/mpgsplit.1 man/mpgcat.1 man/mpginfo.1 $(MANDIR)
|
||||
+ ${INSTALL_PROGRAM} mpgtx $(INSTALLDIR)
|
||||
+ cp -f mpgdemux mpgjoin mpgcat mpginfo mpgsplit mp3tag $(INSTALLDIR)
|
||||
+ ${INSTALL_MAN} man/mpgtx.1 man/mp3tag.1 $(MANDIR)
|
||||
|
||||
uninstall:
|
||||
rm -f $(INSTALLDIR)/mpgtx
|
1
graphics/mpgtx/pkg-comment
Normal file
1
graphics/mpgtx/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A command line MPEG audio/video/system file toolbox
|
16
graphics/mpgtx/pkg-descr
Normal file
16
graphics/mpgtx/pkg-descr
Normal file
@ -0,0 +1,16 @@
|
||||
mpgtx was designed with the good old Unix philosophy in mind : do few but
|
||||
do it well and provide end user an austary yet powerfull command line
|
||||
interface.
|
||||
|
||||
- mpgtx can currently split and join MPEG 1 video files and most MPEG
|
||||
audio files.
|
||||
- mpgtx can fetch detailed informations from MPEG 1 and MPEG 2.
|
||||
- mpgtx can demultiplex MPEG 1 and MPEG 2 files (System layer, Program
|
||||
layer and Transport Layer).
|
||||
- mpgtx can add, remove and edit ID3 tags from mp3 files and rename mp3
|
||||
files according to their ID3 tags.
|
||||
- DivX ;) is not yet supported, neither is MPEG 4
|
||||
- splitting and joining of MPEG 2 video files is experimental. (read "will
|
||||
work only in your wildest dreams")
|
||||
|
||||
WWW: http://mpgtx.sourceforge.net/
|
7
graphics/mpgtx/pkg-plist
Normal file
7
graphics/mpgtx/pkg-plist
Normal file
@ -0,0 +1,7 @@
|
||||
bin/mpgtx
|
||||
bin/mpgjoin
|
||||
bin/mpgsplit
|
||||
bin/mpgcat
|
||||
bin/mpginfo
|
||||
bin/mpgdemux
|
||||
bin/mp3tag
|
31
multimedia/mpgtx/Makefile
Normal file
31
multimedia/mpgtx/Makefile
Normal file
@ -0,0 +1,31 @@
|
||||
# ex:ts=8
|
||||
# New ports collection makefile for: mpgtx
|
||||
# Date created: May 15, 2001
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mpgtx
|
||||
PORTVERSION= 0.6b
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-1-src
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= ijliao@FreeBSD.org
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
ALL_TARGET= shared
|
||||
MAKE_ENV= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
|
||||
INSTALL_MAN="${INSTALL_MAN}"
|
||||
|
||||
MAN1= mpgtx.1 mp3tag.1
|
||||
MLINKS= mpgtx.1 mpgdemux.1 \
|
||||
mpgtx.1 mpgjoin.1 \
|
||||
mpgtx.1 mpgsplit.1 \
|
||||
mpgtx.1 mpgcat.1 \
|
||||
mpgtx.1 mpginfo.1
|
||||
|
||||
.include <bsd.port.mk>
|
1
multimedia/mpgtx/distinfo
Normal file
1
multimedia/mpgtx/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (mpgtx-0.6b-1-src.tgz) = 8d86be5a71390fb87ac2bd64261aa0ff
|
35
multimedia/mpgtx/files/patch-Makefile
Normal file
35
multimedia/mpgtx/files/patch-Makefile
Normal file
@ -0,0 +1,35 @@
|
||||
--- Makefile.orig Tue Apr 24 21:02:33 2001
|
||||
+++ Makefile Tue May 15 10:06:09 2001
|
||||
@@ -1,5 +1,4 @@
|
||||
# installation dirs : Edit at your convenance
|
||||
-PREFIX=/usr
|
||||
INSTALLDIR=$(PREFIX)/bin
|
||||
MANDIR=$(PREFIX)/man/man1
|
||||
|
||||
@@ -7,7 +6,7 @@
|
||||
|
||||
# compilation flags
|
||||
DEVEL_CFLAGS= -g -Wall -Werror -pedantic -fno-builtin
|
||||
-RELEASE_CFLAGS= -Wall -O3 -pedantic
|
||||
+RELEASE_CFLAGS= ${CFLAGS}
|
||||
SHARED_LFLAGS= -s
|
||||
STATIC_LFLAGS= -static -s
|
||||
DEVEL_LFLAGS= #-lefence
|
||||
@@ -48,14 +47,9 @@
|
||||
ln -sf mpgtx mpginfo
|
||||
ln -sf mpgtx mpgdemux
|
||||
ln -sf mpgtx mp3tag
|
||||
- install -d -m 755 $(INSTALLDIR)
|
||||
- install -d -m 755 $(MANDIR)
|
||||
- install -s -m 755 mpgtx $(INSTALLDIR)
|
||||
- cp -df mpgdemux mpgjoin mpgcat mpginfo mpgsplit mp3tag $(INSTALLDIR)
|
||||
- install -m 644 man/mpgtx.1 man/mp3tag.1 $(MANDIR)
|
||||
- cd man ; make
|
||||
- cd ..
|
||||
- cp -df ./man/mpgdemux.1 ./man/mpgjoin.1 man/mpgsplit.1 man/mpgcat.1 man/mpginfo.1 $(MANDIR)
|
||||
+ ${INSTALL_PROGRAM} mpgtx $(INSTALLDIR)
|
||||
+ cp -f mpgdemux mpgjoin mpgcat mpginfo mpgsplit mp3tag $(INSTALLDIR)
|
||||
+ ${INSTALL_MAN} man/mpgtx.1 man/mp3tag.1 $(MANDIR)
|
||||
|
||||
uninstall:
|
||||
rm -f $(INSTALLDIR)/mpgtx
|
1
multimedia/mpgtx/pkg-comment
Normal file
1
multimedia/mpgtx/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A command line MPEG audio/video/system file toolbox
|
16
multimedia/mpgtx/pkg-descr
Normal file
16
multimedia/mpgtx/pkg-descr
Normal file
@ -0,0 +1,16 @@
|
||||
mpgtx was designed with the good old Unix philosophy in mind : do few but
|
||||
do it well and provide end user an austary yet powerfull command line
|
||||
interface.
|
||||
|
||||
- mpgtx can currently split and join MPEG 1 video files and most MPEG
|
||||
audio files.
|
||||
- mpgtx can fetch detailed informations from MPEG 1 and MPEG 2.
|
||||
- mpgtx can demultiplex MPEG 1 and MPEG 2 files (System layer, Program
|
||||
layer and Transport Layer).
|
||||
- mpgtx can add, remove and edit ID3 tags from mp3 files and rename mp3
|
||||
files according to their ID3 tags.
|
||||
- DivX ;) is not yet supported, neither is MPEG 4
|
||||
- splitting and joining of MPEG 2 video files is experimental. (read "will
|
||||
work only in your wildest dreams")
|
||||
|
||||
WWW: http://mpgtx.sourceforge.net/
|
7
multimedia/mpgtx/pkg-plist
Normal file
7
multimedia/mpgtx/pkg-plist
Normal file
@ -0,0 +1,7 @@
|
||||
bin/mpgtx
|
||||
bin/mpgjoin
|
||||
bin/mpgsplit
|
||||
bin/mpgcat
|
||||
bin/mpginfo
|
||||
bin/mpgdemux
|
||||
bin/mp3tag
|
Loading…
Reference in New Issue
Block a user