- Preserve version 1.4.4 of astro/gpsbabel as astro/gpsbabel14

Newer gpsbabel version needlessly pulls in heavyweight dependencies
(such as qt4-gui, qt4-webkit) via qt4-linguist, and until that's
resolved, it's useful to keep around older version which doesn't
have such problem.

PR:		190791
Approved by:	dev2@heesakkers.info (maintainer)
This commit is contained in:
Dmitry Marakasov 2014-06-10 22:03:56 +00:00
parent 0f11dc56f2
commit 92d656c848
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=357391
5 changed files with 73 additions and 0 deletions

View File

@ -22,6 +22,7 @@
SUBDIR += gmapcatcher
SUBDIR += google-earth
SUBDIR += gpsbabel
SUBDIR += gpsbabel14
SUBDIR += gpscorrelate
SUBDIR += gpsd
SUBDIR += gpsdrive

28
astro/gpsbabel14/Makefile Normal file
View File

@ -0,0 +1,28 @@
# Created by: Laurent Courty
# $FreeBSD$
PORTNAME= gpsbabel
PORTVERSION= 1.4.4
CATEGORIES= astro geography
MASTER_SITES= https://secure.ohos.nl/downloads/ \
LOCAL/beech
PKGNAMESUFFIX= 14
MAINTAINER= dev2@heesakkers.info
COMMENT= GPS file translating tool (pre-qt version)
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
USE_AUTOTOOLS= autoconf
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-expathdr=${LOCALBASE}/include \
--with-libexpat=${LOCALBASE}/lib
PLIST_FILES= bin/gpsbabel
CONFLICTS= gpsbabel-[0-9]*
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
SHA256 (gpsbabel-1.4.4.tar.gz) = 9dd2a06e887cb286c9a07164a8f2ede11aed1147e6419007370c528412321944
SIZE (gpsbabel-1.4.4.tar.gz) = 7811264

View File

@ -0,0 +1,31 @@
--- configure.in.orig 2008-10-31 15:43:21.000000000 +0300
+++ configure.in 2009-03-07 01:08:46.000000000 +0300
@@ -170,6 +169,28 @@
AC_DEFINE(HAVE_LIBUSB, 1)
CFLAGS="$CFLAGS -Imac/libusb/"
;;
+ *-*-freebsd*)
+ GBSER=gbser_posix.o
+ AC_MSG_CHECKING(for libusb)
+ if test "$with_libusb" = no ; then
+ AC_MSG_RESULT(check not done)
+ OSJEEPS=jeeps/gpsusbstub.o
+ else
+ OLDFLAGS=$LDFLAGS
+ OCFLAGS=$CFLAGS
+ LDFLAGS="$LDFLAGS -lusb"
+ CFLAGS="$OCFLAGS"
+
+ AC_CHECK_LIB([usb], [usb_interrupt_read],
+ AC_DEFINE(HAVE_LIBUSB, 1, [Defined if you have libusb])
+ [USB_CFLAGS=""]
+ [USB_LIBS="-lusb"]
+# ,[AC_MSG_ERROR([libusb is needed])]
+ )
+ OSJEEPS=jeeps/gpslibusb.o
+ CFLAGS="$OCFLAGS"
+ fi
+ ;;
*)
GBSER=gbser_posix.o
AC_MSG_CHECKING(for libusb)

View File

@ -0,0 +1,11 @@
GPSBabel converts waypoints, tracks, and routes from one format to another,
whether that format is a common mapping format like Delorme, Streets and Trips,
or even a serial upload or download to a GPS unit such as those from Garmin and
Magellan. By flattening the Tower of Babel that the authors of various programs
for manipulating GPS data have imposed upon us, it returns to us the ability
to freely move our own waypoint data between the programs and hardware we
choose to use.
It contains extensive data manipulation abilities making it a convenient for
server-side processing or as the backend for other tools.
WWW: http://www.gpsbabel.org/