Add patches to fix the build with freetype 2.5.1.

Stageify, use new lib_depend syntax.
This commit is contained in:
Koop Mast 2013-12-06 18:57:55 +00:00
parent 3ac17805b7
commit 92c7f047a0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=335782
3 changed files with 34 additions and 6 deletions

View File

@ -16,8 +16,8 @@ USE_BZIP2= yes
.if !defined(REFERENCE_PORT)
LIB_DEPENDS= fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
popt:${PORTSDIR}/devel/popt
LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libpopt.so:${PORTSDIR}/devel/popt
USES= bison pathfix gettext gmake pkgconfig
USE_GNOME= gnomeprefix intlhack gnomehier glib20 pango libxml2 \
@ -33,12 +33,11 @@ PLIST_SUB= VERSION=${PORTVERSION} \
OPTIONS_DEFINE= CUPS
OPTIONS_DEFAULT=CUPS
NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCUPS}
CONFIGURE_ARGS+= --with-cups
LIB_DEPENDS+= gnomecups-1:${PORTSDIR}/print/libgnomecups
LIB_DEPENDS+= libgnomecups-1.0.so:${PORTSDIR}/print/libgnomecups
PLIST_SUB+= CUPS:=""
.else
CONFIGURE_ARGS+= --without-cups
@ -52,8 +51,11 @@ post-patch:
@${REINPLACE_CMD} -e "/^SUBDIRS =/s|doc||" ${WRKSRC}/Makefile.in
post-install:
@${MKDIR} ${PREFIX}/etc/gnome/libgnomeprint-2.0/fonts
@${TOUCH} ${PREFIX}/etc/gnome/libgnomeprint-2.0/fonts/gnome-print.fontmap
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/gnome/libgnomeprint-2.0/fonts
@${TOUCH} ${STAGEDIR}${PREFIX}/etc/gnome/libgnomeprint-2.0/fonts/gnome-print.fontmap
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgnomeprint-2-2.so.0
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgnomeprint/2.18.8/modules/*.so
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgnomeprint/2.18.8/modules/*/*.so
.include <bsd.port.mk>

View File

@ -0,0 +1,12 @@
--- libgnomeprint/gnome-font-face.c.orig 2013-12-06 19:26:26.000000000 +0100
+++ libgnomeprint/gnome-font-face.c 2013-12-06 19:27:43.000000000 +0100
@@ -36,7 +36,8 @@
#include <stdarg.h>
#include <locale.h>
-#include <freetype/ftoutln.h>
+#include <ft2build.h>
+#include FT_OUTLINE_H
#include <libgnomeprint/gnome-print-private.h>
#include <libgnomeprint/gnome-font-private.h>

View File

@ -0,0 +1,14 @@
--- libgnomeprint/gnome-rfont.c.orig 2013-12-06 19:28:40.000000000 +0100
+++ libgnomeprint/gnome-rfont.c 2013-12-06 19:29:56.000000000 +0100
@@ -27,9 +27,8 @@
#include <string.h>
#include <ft2build.h>
-#include FT_FREETYPE_H
-#include <freetype/ftglyph.h>
-#include <freetype/ftbbox.h>
+#include FT_GLYPH_H
+#include FT_BBOX_H
#include <libart_lgpl/art_misc.h>
#include <libart_lgpl/art_affine.h>
#include <libart_lgpl/art_vpath.h>