Arora is a simple cross platform web browser. Currently Arora is a

very basic browser whose feature list includes things like "History"
and "Bookmarks". It does not have support for netscape plugins, so
no flash support until Qt 4.5. But it is small, less than 10,000
lines of code, very fast, lean, mean and loads of fun to hack on.
Arora and QtWebKit is developed to be cross-platform using the Qt
library. It was originally created as a demo for Qt to help test
the QtWebKit component and find API issues and bugs before the
release.

WWW:	http://code.google.com/p/arora/

Submitted by:	Andy Fawcett <andy at athame.co.uk>
This commit is contained in:
Martin Wilke 2008-08-09 21:03:44 +00:00
parent b38cc6a2fe
commit 92834942cc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=218290
7 changed files with 126 additions and 0 deletions

View File

@ -31,6 +31,7 @@
SUBDIR += aria
SUBDIR += aria2
SUBDIR += aria2fe
SUBDIR += arora
SUBDIR += ashe
SUBDIR += asp2php
SUBDIR += asterisk-fop

44
www/arora/Makefile Normal file
View File

@ -0,0 +1,44 @@
# New ports collection makefile for: arora
# Date created: 08 Aug 2008
# Whom: Andy Fawcett <andy@athame.co.uk>
#
# $FreeBSD$
PORTNAME= arora
PORTVERSION= 0.3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= andy@athame.co.uk
COMMENT= Simple Qt4 based browser
USE_QT_VER= 4
QT_COMPONENTS= network webkit qmake_build moc_build uic_build rcc_build
HAS_CONFIGURE= yes
QMAKE_ARGS+= -unix -recursive PREFIX=${PREFIX}
MAN1= arora.1
.if !defined(WITHOUT_NLS)
QT_COMPONENTS+= linguist_build
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
.endif
do-configure:
.if defined(WITHOUT_NLS)
@${REINPLACE_CMD} -e "/INSTALLS/s|translations||" \
-e "/PRE_TARGETDEPS/s|compiler_updateqm_make_all||" \
${WRKSRC}/src/src.pro
.endif
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKE_ARGS}
post-configure:
@${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} -e \
's|^CC .*|CC=${CC}|; s|^CXX .*|CXX=${CXX}|; s|^LINK .*|LINK=${CXX}|'
post-install:
${INSTALL_MAN} ${WRKSRC}/src/data/arora.1 ${PREFIX}/man/man1/
.include <bsd.port.mk>

3
www/arora/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (arora-0.3.tar.gz) = 6da3c659f99775cee38b38b1ca85e173
SHA256 (arora-0.3.tar.gz) = c632a6a75f7fe22ad5cdad2a58f1bc4ed50bb8827c299f89add9f03967634afe
SIZE (arora-0.3.tar.gz) = 644516

View File

@ -0,0 +1,11 @@
--- ./src/src.pri.orig 2008-08-05 00:21:54.000000000 +0400
+++ ./src/src.pri 2008-08-09 00:11:30.000000000 +0400
@@ -14,8 +14,6 @@
QT += webkit network
-GITVERSION=$$system(git log -n1 --pretty=format:%h)
-GITCHANGENUMBER=$$system(git log --pretty=format:%h | wc -l)
DEFINES += GITVERSION=\"\\\"$$GITVERSION\\\"\"
DEFINES += GITCHANGENUMBER=\"\\\"$$GITCHANGENUMBER\\\"\"

View File

@ -0,0 +1,20 @@
--- ./src/src.pro.orig 2008-08-05 00:21:54.000000000 +0400
+++ ./src/src.pro 2008-08-09 00:10:20.000000000 +0400
@@ -15,7 +15,7 @@
isEmpty(QMAKE_LRELEASE) {
win32:QMAKE_LRELEASE = $$[QT_INSTALL_BINS]\lrelease.exe
- else:QMAKE_LRELEASE = $$[QT_INSTALL_BINS]/lrelease
+ else:QMAKE_LRELEASE = $$[QT_INSTALL_BINS]/lrelease-qt4
}
TRANSLATIONS += \
@@ -45,7 +45,7 @@
PRE_TARGETDEPS += compiler_updateqm_make_all
unix {
- INSTALLS += target translations desktop iconxpm iconsvg icon16 icon32 icon128 man man-compress
+ INSTALLS += target translations desktop iconxpm iconsvg icon16 icon32 icon128
target.path = $$BINDIR

11
www/arora/pkg-descr Normal file
View File

@ -0,0 +1,11 @@
Arora is a simple cross platform web browser. Currently Arora is a
very basic browser whose feature list includes things like "History"
and "Bookmarks". It does not have support for netscape plugins, so
no flash support until Qt 4.5. But it is small, less than 10,000
lines of code, very fast, lean, mean and loads of fun to hack on.
Arora and QtWebKit is developed to be cross-platform using the Qt
library. It was originally created as a demo for Qt to help test
the QtWebKit component and find API issues and bugs before the
release.
WWW: http://code.google.com/p/arora/

36
www/arora/pkg-plist Normal file
View File

@ -0,0 +1,36 @@
bin/arora
share/applications/arora.desktop
%%NLS%%share/arora/locale/cs_CZ.qm
%%NLS%%share/arora/locale/da.qm
%%NLS%%share/arora/locale/de.qm
%%NLS%%share/arora/locale/en.qm
%%NLS%%share/arora/locale/es.qm
%%NLS%%share/arora/locale/et.qm
%%NLS%%share/arora/locale/fr_CA.qm
%%NLS%%share/arora/locale/fr_FR.qm
%%NLS%%share/arora/locale/hu.qm
%%NLS%%share/arora/locale/it.qm
%%NLS%%share/arora/locale/nl.qm
%%NLS%%share/arora/locale/pl.qm
%%NLS%%share/arora/locale/pt_BR.qm
%%NLS%%share/arora/locale/ru.qm
%%NLS%%share/arora/locale/tr.qm
%%NLS%%share/arora/locale/zh_CN.qm
share/icons/hicolor/128x128/apps/arora.png
share/icons/hicolor/16x16/apps/arora.png
share/icons/hicolor/32x32/apps/arora.png
share/icons/hicolor/scalable/apps/arora.svg
share/pixmaps/arora.xpm
@dirrmtry share/icons/hicolor/scalable/apps
@dirrmtry share/icons/hicolor/scalable
@dirrmtry share/icons/hicolor/32x32/apps
@dirrmtry share/icons/hicolor/32x32
@dirrmtry share/icons/hicolor/16x16/apps
@dirrmtry share/icons/hicolor/16x16
@dirrmtry share/icons/hicolor/128x128/apps
@dirrmtry share/icons/hicolor/128x128
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
@dirrm share/arora/locale
@dirrm share/arora
@dirrmtry share/applications