Update to a a 2003-01-26 snapshot of PostgreSQL. Documentation is not

included in this port at the moment, please see the developer docs online.

http://developer.postgresql.org/docs/postgres/

For a list of changes (mostly significant improvements for large queries):

http://developer.postgresql.org/docs/postgres/release.html#RELEASE-DEVEL
This commit is contained in:
Sean Chittenden 2003-01-27 23:22:02 +00:00
parent 01cd67a161
commit 926df10142
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=74112
5 changed files with 424 additions and 117 deletions

View File

@ -6,63 +6,42 @@
#
PORTNAME?= postgresql
PORTVERSION?= 7.3.1
PORTREVISION= 1
PKGNAMESUFFIX= -devel
PORTVERSION?= 7.4.2003.01.26
CATEGORIES?= databases
MASTER_SITES= ftp://ftp9.us.postgresql.org/pub/mirrors/postgresql/%SUBDIR%/ \
ftp://ftp5.us.postgresql.org/pub/PostgreSQL/%SUBDIR%/ \
ftp://ftp3.us.postgresql.org/pub/postgresql/%SUBDIR%/ \
ftp://ftp13.us.postgresql.org/mirror/postresql/%SUBDIR%/ \
ftp://ftp8.us.postgresql.org/pub/pgsql/%SUBDIR%/ \
ftp://ftp10.us.postgresql.org/pub/postgresql/%SUBDIR%/ \
ftp://ftp.se.postgresql.org/pub/database/relational/postgresql/%SUBDIR%/ \
ftp://ftp2.ch.postgresql.org/mirror/postgresql/%SUBDIR%/ \
ftp://ftp.de.postgresql.org/mirror/postgresql/%SUBDIR%/ \
ftp://ftp.chg.ru/pub/databases/postgresql/%SUBDIR%/ \
ftp://ftp.sunet.se/pub/unix/databases/relational/postgresql/%SUBDIR%/ \
ftp://ftp.jaist.ac.jp/pub/dbms/PostgreSQL/%SUBDIR%/ \
ftp://ftp.us.postgresql.org/%SUBDIR%/ \
ftp://ftp.postgresql.org/pub/%SUBDIR%/
MASTER_SITE_SUBDIR= source/v${PORTVERSION}
DISTFILES= postgresql-base-${PORTVERSION}${EXTRACT_SUFX} \
postgresql-opt-${PORTVERSION}${EXTRACT_SUFX} \
postgresql-test-${PORTVERSION}${EXTRACT_SUFX}
MASTER_SITES= http://freebsd.sean.chittenden.org/ports/
PKGNAMESUFFIX= -devel
MAINTAINER?= seanc@FreeBSD.org
WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
USE_BZIP2= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
.if defined(POSTGRESQL_SUBPORT)
## the POSTGRESQL_SUBPORTS use this port's distinfo
MD5_FILE= ${.CURDIR}/../postgresql-devel/distinfo
MD5_FILE= ${.CURDIR}/../postgresql7/distinfo
.else
## POSTGRESQL_SUBPORTS stops here
## The rest of this file is for normal base installation
INSTALLS_SHLIB= YES
CONFIGURE_ARGS= --docdir=${PREFIX}/share/doc --with-libdir=${LOCALBASE}/lib \
--with-includes=${LOCALBASE}/include
CONFIGURE_ARGS= --with-libraries=${LOCALBASE}/lib \
--with-includes=${LOCALBASE}/include \
--with-docdir=${LOCALBASE}/share/doc/$PORTNAME}${PKGNAMESUFFIX}
.if !defined(WITHOUT_GNUGETOPT)
LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
.endif
# if you want localized messages, make -DWITH_GETTEXT
# WARNING: this seems to require relinking binaries depending on
# libpq.so, including for example mod_php and tcl.
.if defined(WITHOUT_GETTEXT)
CONFIGURE_ARGS+=--disable-nls
.if !defined(WITHOUT_GETTEXT)
CONFIGURE_ARGS+=--enable-nls
LIB_DEPENDS+= intl.4:${PORTSDIR}/devel/gettext
PLIST_SUB+= GETTEXT=""
.else
CONFIGURE_ENV+= "LDFLAGS=-L${LOCALBASE}/lib"
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --enable-nls
LIB_DEPENDS+= intl.4:${PORTSDIR}/devel/gettext
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= GETTEXT="@comment "
.endif
@ -80,39 +59,32 @@ CFLAGS+= -O3 -funroll-loops
CONFIGURE_ARGS+= --enable-debug
.endif
.if defined(WITH_STRIPBIN)
INSTALL_TARGET= install-strip
.endif
.if !defined(WITHOUT_SSL)
USE_OPENSSL= yes
CONFIGURE_ARGS+= "--with-openssl=${OPENSSLBASE}"
.endif
.if defined(WITH_MIT_KRB5) && defined(WITH_HEIMDAL_KRB5)
@${ECHO} "WITH_MIT_KRB5 and WITH_HEIMDAL_KRB5 are mutually exclusive."
@${ECHO} "Please choose one or the other."
@exit 1
.if defined(WITHOUT_SERVER)
PKGMESSAGE= ${PKGDIR}/pkg-message.client
PLIST_SUB+= SERVER="@comment "
PKGNAMESUFFIX= -client
.else
PLIST_SUB+= SERVER=""
INSTALL_TARGET= install-all-headers
.if defined(WITH_STRIPBIN)
INSTALL_TARGET+= install-strip
.else
INSTALL_TARGET+= install
.endif
.endif
.if defined(WITH_MIT_KRB5)
KRB5CONF= ${LOCALBASE}/bin/krb5-config
.if !exists(${KRB5CONFIG})
@${ECHO} "Unable to find krb5-config in your local base, please verify that"
@${ECHO} "security/krb5 is installed or undefine the WITH_MIT_KRB5 tunable."
@exit 1
.endif
WITH_KRB5= yes
.endif
.if defined(WITH_HEIMDAL_KRB5)
KRB5CONF= /usr/bin/krb5-config
.if !exists(${KRB5CONFIG})
@${ECHO} "Unable to find krb5-config in the base system. Undefine"
@${ECHO} "WITH_HEIMDAL_KRB5 or add MAKE_KERBEROS5=yes to /etc/make.conf"
@${ECHO} "and remake world (or undefine the WITH_HEIMDAL_KRB5 tunable)."
@exit 1
.endif
LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
@ -122,47 +94,54 @@ CONFIGURE_ARGS+= --with-krb5="`${KRB5CONF} --prefix krb5`"
LDFLAGS+= `${KRB5CONF} --libs krb5`
.endif
.if defined(WITHOUT_SERVER)
PKGMESSAGE= ${PKGDIR}/pkg-message.client
PLIST_SUB+= SERVER="@comment "
.else
PLIST_SUB+= SERVER=""
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -funroll-loops
.endif
pre-everything::
@${SH} ${PKGDIR}/pkg-install ${PORTNAME} BACKUPWARNING
@${ECHO} ""
@${ECHO} "CAUTION!!!!!"
@${ECHO} "${PORTNAME} has several tunables that can be used to configure PostgreSQL:"
@${ECHO} ""
@${ECHO} " This is a development port! You will have to re-initdb between"
@${ECHO} " upgrades as the system catalogs have changed between snapshots."
@${ECHO} " WITHOUT_GNUGETOPT Don't install GNU getopt (will"
@${ECHO} " still be used if already installed)"
@${ECHO} " WITHOUT_GETTEXT Skips building with support for"
@${ECHO} " internationalized error messages"
@${ECHO} " WITHOUT_SERVER Installs the headers and libraries for"
@${ECHO} " PostgreSQL clients"
@${ECHO} " WITHOUT_SSL Builds without OpenSSL support"
@${ECHO} " WITH_MIT_KRB5 Builds with MIT's kerberos support"
@${ECHO} " WITH_HEIMDAL_KRB5 Builds with Heimdal's kerberos support"
@${ECHO} " WITH_OPTIMIZED_CFLAGS Builds with compiler optimizations (-O3)"
@${ECHO} " WITH_DEBUG Builds with debugging symbols"
@${ECHO} " WITH_STRIPBIN Installs stripped binaries"
@${ECHO} ""
@${ECHO} " Running this version of the port implies a large degree of"
@${ECHO} " familiarity with the PostgreSQL development cycle and process."
@${ECHO} " You should _always_ backup your data using pg_dump(all) before"
@${ECHO} " every upgrade. If you have not backed up your data yet, exit"
@${ECHO} " this installation and backup your data now!!!!"
@${ECHO} ""
@${ECHO} ""
@${ECHO} "${PORTNAME} has several tunables that used to configure PostgreSQL:"
@${ECHO} ""
@${ECHO} " WITHOUT_GNUGETOPT=yes Skips building with GNU getopt"
@${ECHO} " WITHOUT_GETTEXT=yes Skips building with support for"
@${ECHO} " internationalized error messages"
@${ECHO} " WITH_DEBUG=yes Builds with debugging symbols"
@${ECHO} " WITH_STRIPBIN=yes Installs stripped binaries"
@${ECHO} " WITHOUT_SSL=yes Builds without OpenSSL support"
@${ECHO} " WITHOUT_SERVER=yes Installs the headers and libraries for"
@${ECHO} " PostgreSQL clients"
@${ECHO} " WITH_MIT_KRB5=yes Builds with MIT's kerberos support"
@${ECHO} " WITH_HEIMDAL_KRB5=yes Builds with Heimdal's kerberos support"
@${ECHO} " WITH_OPTIMIZED_CFLAGS=yes Builds with compiler optimizations (-O3)"
@${ECHO} ""
.if !defined(BATCH)
@sleep 5
.if defined(WITH_MIT_KRB5) && defined(WITH_HEIMDAL_KRB5)
@${ECHO} "WITH_MIT_KRB5 and WITH_HEIMDAL_KRB5 are mutually exclusive."
@${ECHO} "Please choose one or the other."
@exit 1
.endif
.if defined(WITH_MIT_KRB5) && !exists(${KRB5CONFIG})
@${ECHO} "Unable to find krb5-config in your local base, please verify that"
@${ECHO} "security/krb5 is installed or undefine the WITH_MIT_KRB5 tunable."
@exit 1
.endif
.if defined(WITH_HEIMDAL_KRB5) && !exists(${KRB5CONFIG})
@${ECHO} "Unable to find krb5-config in the base system. Undefine"
@${ECHO} "WITH_HEIMDAL_KRB5 or add MAKE_KERBEROS5=yes to /etc/make.conf"
@${ECHO} "and remake world (or undefine the WITH_HEIMDAL_KRB5 tunable)."
@exit 1
.endif
.if defined(WITHOUT_SERVER)
do-install:
@ cd ${WRKSRC}; \
${GMAKE} -C src/bin ${INSTALL_TARGET} ;\
${GMAKE} -C src/include ${INSTALL_TARGET} ;\
${GMAKE} -C src/interfaces ${INSTALL_TARGET} ;\
${GMAKE} -C doc ${INSTALL_TARGET}
pre-install:
.if !defined(WITHOUT_SERVER)
@ ${SETENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGDIR}/pkg-install ${PORTNAME} PRE-INSTALL
.endif
@ -172,14 +151,8 @@ post-install:
${CAT} ${FILESDIR}/post-install-notes ${PKGMESSAGE} |\
${SED} "s|/usr/local|${PREFIX}|g" |\
tee ${PREFIX}/share/postgresql/post-install-notes
.if !defined(DEBUG_FLAGS)
.for file in ecpg pg_dump pg_id pg_restore psql
@ strip ${PREFIX}/bin/${file}
.endfor
.endif
.if !defined(WITHOUT_SERVER)
# install shell defaults for pgsql user
@ strip ${PREFIX}/bin/postgres
.for i in profile cshrc
@ ${SED} "s|%%PREFIX%%|${PREFIX}|g" \
< ${FILESDIR}/dot.$i.in \
@ -198,12 +171,6 @@ post-install:
${CHOWN} -R pgsql:pgsql ~pgsql/. ;\
${INSTALL_DATA} ${FILESDIR}/502.pgsql \
${PREFIX}/share/postgresql
.else
do-install:
@ cd ${WRKSRC}; \
${GMAKE} -C src/bin ${INSTALL_TARGET} ;\
${GMAKE} -C src/include ${INSTALL_TARGET} ;\
${GMAKE} -C src/interfaces ${INSTALL_TARGET}
.endif
check:

View File

@ -1,5 +1 @@
MD5 (postgresql/postgresql-7.3.1.tar.gz) = 924b21c3114f595834e2456277f1bffb
MD5 (postgresql/postgresql-base-7.3.1.tar.gz) = d31f4be7ada55e4914d1a9134e4441c7
MD5 (postgresql/postgresql-docs-7.3.1.tar.gz) = 42384cb2ded505243878231acb779bd6
MD5 (postgresql/postgresql-opt-7.3.1.tar.gz) = 65e3db9df55b71b504a2f385da231de8
MD5 (postgresql/postgresql-test-7.3.1.tar.gz) = 8f231ca3470f3be6b33e1def77dcf7fc
MD5 (postgresql/postgresql-7.4.2003.01.26.tar.bz2) = 7ed2d6cb2e7a9a61726b42830ba0da08

View File

@ -1,10 +0,0 @@
--- src/include/port/freebsd.h.orig Wed Jan 1 16:43:31 2003
+++ src/include/port/freebsd.h Wed Jan 1 16:43:39 2003
@@ -7,6 +7,7 @@
#if defined(__sparc__)
#define NEED_SPARC_TAS_ASM
#define HAS_TEST_AND_SET
+typedef unsigned char slock_t;
#endif
#if defined(__alpha__)

View File

@ -1 +1 @@
The most advanced open-source database available anywhere.
Development snapshots of PostgreSQL's latest features

View File

@ -22,21 +22,356 @@ bin/pg_config
bin/pg_controldata
bin/pg_resetxlog
bin/pg_encoding
include/libpq/libpq-fs.h
@dirrm include/libpq
include/postgresql/internal/libpq/pqcomm.h
@dirrm include/postgresql/internal/libpq
include/postgresql/internal/lib/dllist.h
@dirrm include/postgresql/internal/lib
include/postgresql/internal/c.h
include/postgresql/internal/postgres_fe.h
include/postgresql/internal/libpq-int.h
include/postgresql/internal/pqexpbuffer.h
@dirrm include/postgresql/internal/lib
@dirrm include/postgresql/internal/libpq
@dirrm include/postgresql/internal
include/postgresql/server/access/attnum.h
include/postgresql/server/access/clog.h
include/postgresql/server/access/genam.h
include/postgresql/server/access/gist.h
include/postgresql/server/access/gistscan.h
include/postgresql/server/access/hash.h
include/postgresql/server/access/heapam.h
include/postgresql/server/access/hio.h
include/postgresql/server/access/htup.h
include/postgresql/server/access/ibit.h
include/postgresql/server/access/iqual.h
include/postgresql/server/access/istrat.h
include/postgresql/server/access/itup.h
include/postgresql/server/access/nbtree.h
include/postgresql/server/access/printtup.h
include/postgresql/server/access/relscan.h
include/postgresql/server/access/rmgr.h
include/postgresql/server/access/rtree.h
include/postgresql/server/access/rtscan.h
include/postgresql/server/access/sdir.h
include/postgresql/server/access/skey.h
include/postgresql/server/access/strat.h
include/postgresql/server/access/transam.h
include/postgresql/server/access/tupdesc.h
include/postgresql/server/access/tupmacs.h
include/postgresql/server/access/valid.h
include/postgresql/server/access/tuptoaster.h
include/postgresql/server/access/xact.h
include/postgresql/server/access/xlog.h
include/postgresql/server/access/xlogdefs.h
include/postgresql/server/access/xlogutils.h
include/postgresql/server/bootstrap/bootstrap.h
include/postgresql/server/catalog/catalog.h
include/postgresql/server/catalog/catname.h
include/postgresql/server/catalog/catversion.h
include/postgresql/server/catalog/dependency.h
include/postgresql/server/catalog/heap.h
include/postgresql/server/catalog/index.h
include/postgresql/server/catalog/indexing.h
include/postgresql/server/catalog/namespace.h
include/postgresql/server/catalog/pg_aggregate.h
include/postgresql/server/catalog/pg_am.h
include/postgresql/server/catalog/pg_amop.h
include/postgresql/server/catalog/pg_amproc.h
include/postgresql/server/catalog/pg_attrdef.h
include/postgresql/server/catalog/pg_attribute.h
include/postgresql/server/catalog/pg_cast.h
include/postgresql/server/catalog/pg_class.h
include/postgresql/server/catalog/pg_constraint.h
include/postgresql/server/catalog/pg_control.h
include/postgresql/server/catalog/pg_conversion.h
include/postgresql/server/catalog/pg_database.h
include/postgresql/server/catalog/pg_depend.h
include/postgresql/server/catalog/pg_group.h
include/postgresql/server/catalog/pg_description.h
include/postgresql/server/catalog/pg_index.h
include/postgresql/server/catalog/pg_inherits.h
include/postgresql/server/catalog/pg_language.h
include/postgresql/server/catalog/pg_largeobject.h
include/postgresql/server/catalog/pg_listener.h
include/postgresql/server/catalog/pg_namespace.h
include/postgresql/server/catalog/pg_opclass.h
include/postgresql/server/catalog/pg_operator.h
include/postgresql/server/catalog/pg_proc.h
include/postgresql/server/catalog/pg_rewrite.h
include/postgresql/server/catalog/pg_shadow.h
include/postgresql/server/catalog/pg_statistic.h
include/postgresql/server/catalog/pg_trigger.h
include/postgresql/server/catalog/pg_type.h
include/postgresql/server/catalog/pg_version.h
include/postgresql/server/commands/async.h
include/postgresql/server/commands/cluster.h
include/postgresql/server/commands/comment.h
include/postgresql/server/commands/conversioncmds.h
include/postgresql/server/commands/copy.h
include/postgresql/server/commands/dbcommands.h
include/postgresql/server/commands/defrem.h
include/postgresql/server/commands/explain.h
include/postgresql/server/commands/lockcmds.h
include/postgresql/server/commands/portalcmds.h
include/postgresql/server/commands/prepare.h
include/postgresql/server/commands/proclang.h
include/postgresql/server/commands/schemacmds.h
include/postgresql/server/commands/sequence.h
include/postgresql/server/commands/tablecmds.h
include/postgresql/server/commands/trigger.h
include/postgresql/server/commands/typecmds.h
include/postgresql/server/commands/user.h
include/postgresql/server/commands/vacuum.h
include/postgresql/server/commands/variable.h
include/postgresql/server/commands/version.h
include/postgresql/server/commands/view.h
include/postgresql/server/executor/execdebug.h
include/postgresql/server/executor/execdefs.h
include/postgresql/server/executor/execdesc.h
include/postgresql/server/executor/executor.h
include/postgresql/server/executor/functions.h
include/postgresql/server/executor/hashjoin.h
include/postgresql/server/executor/instrument.h
include/postgresql/server/executor/nodeAgg.h
include/postgresql/server/executor/nodeAppend.h
include/postgresql/server/executor/nodeFunctionscan.h
include/postgresql/server/executor/nodeGroup.h
include/postgresql/server/executor/nodeHash.h
include/postgresql/server/executor/nodeHashjoin.h
include/postgresql/server/executor/nodeIndexscan.h
include/postgresql/server/executor/nodeLimit.h
include/postgresql/server/executor/nodeMaterial.h
include/postgresql/server/executor/nodeMergejoin.h
include/postgresql/server/executor/nodeNestloop.h
include/postgresql/server/executor/nodeResult.h
include/postgresql/server/executor/nodeSeqscan.h
include/postgresql/server/executor/nodeSetOp.h
include/postgresql/server/executor/nodeSort.h
include/postgresql/server/executor/nodeSubplan.h
include/postgresql/server/executor/nodeSubqueryscan.h
include/postgresql/server/executor/nodeTidscan.h
include/postgresql/server/executor/nodeUnique.h
include/postgresql/server/executor/spi.h
include/postgresql/server/executor/spi_priv.h
include/postgresql/server/executor/tuptable.h
include/postgresql/server/lib/dllist.h
include/postgresql/server/lib/lispsort.h
include/postgresql/server/lib/stringinfo.h
include/postgresql/server/libpq/auth.h
include/postgresql/server/libpq/be-fsstubs.h
include/postgresql/server/libpq/crypt.h
include/postgresql/server/libpq/hba.h
include/postgresql/server/libpq/ip.h
include/postgresql/server/libpq/libpq-be.h
include/postgresql/server/libpq/libpq-fs.h
include/postgresql/server/libpq/libpq.h
include/postgresql/server/libpq/password.h
include/postgresql/server/libpq/pqcomm.h
include/postgresql/server/libpq/pqformat.h
include/postgresql/server/libpq/pqsignal.h
include/postgresql/server/mb/pg_wchar.h
include/postgresql/server/nodes/execnodes.h
include/postgresql/server/nodes/makefuncs.h
include/postgresql/server/nodes/memnodes.h
include/postgresql/server/nodes/nodeFuncs.h
include/postgresql/server/nodes/nodes.h
include/postgresql/server/nodes/params.h
include/postgresql/server/nodes/parsenodes.h
include/postgresql/server/nodes/pg_list.h
include/postgresql/server/nodes/plannodes.h
include/postgresql/server/nodes/primnodes.h
include/postgresql/server/nodes/print.h
include/postgresql/server/nodes/readfuncs.h
include/postgresql/server/nodes/relation.h
include/postgresql/server/optimizer/clauses.h
include/postgresql/server/optimizer/cost.h
include/postgresql/server/optimizer/geqo.h
include/postgresql/server/optimizer/geqo_copy.h
include/postgresql/server/optimizer/geqo_gene.h
include/postgresql/server/optimizer/geqo_misc.h
include/postgresql/server/optimizer/geqo_mutation.h
include/postgresql/server/optimizer/geqo_pool.h
include/postgresql/server/optimizer/geqo_random.h
include/postgresql/server/optimizer/geqo_recombination.h
include/postgresql/server/optimizer/geqo_selection.h
include/postgresql/server/optimizer/joininfo.h
include/postgresql/server/optimizer/pathnode.h
include/postgresql/server/optimizer/paths.h
include/postgresql/server/optimizer/plancat.h
include/postgresql/server/optimizer/planmain.h
include/postgresql/server/optimizer/planner.h
include/postgresql/server/optimizer/prep.h
include/postgresql/server/optimizer/restrictinfo.h
include/postgresql/server/optimizer/subselect.h
include/postgresql/server/optimizer/tlist.h
include/postgresql/server/optimizer/var.h
include/postgresql/server/parser/analyze.h
include/postgresql/server/parser/gramparse.h
include/postgresql/server/parser/keywords.h
include/postgresql/server/parser/parse.h
include/postgresql/server/parser/parse_agg.h
include/postgresql/server/parser/parse_clause.h
include/postgresql/server/parser/parse_coerce.h
include/postgresql/server/parser/parse_expr.h
include/postgresql/server/parser/parse_func.h
include/postgresql/server/parser/parse_node.h
include/postgresql/server/parser/parse_oper.h
include/postgresql/server/parser/parse_relation.h
include/postgresql/server/parser/parse_target.h
include/postgresql/server/parser/parse_type.h
include/postgresql/server/parser/parser.h
include/postgresql/server/parser/parsetree.h
include/postgresql/server/parser/scansup.h
include/postgresql/server/port/aix.h
include/postgresql/server/port/beos.h
include/postgresql/server/port/bsdi.h
include/postgresql/server/port/darwin.h
include/postgresql/server/port/dgux.h
include/postgresql/server/port/freebsd.h
include/postgresql/server/port/hpux.h
include/postgresql/server/port/irix5.h
include/postgresql/server/port/linux.h
include/postgresql/server/port/netbsd.h
include/postgresql/server/port/nextstep.h
include/postgresql/server/port/openbsd.h
include/postgresql/server/port/osf.h
include/postgresql/server/port/qnx4.h
include/postgresql/server/port/sco.h
include/postgresql/server/port/solaris.h
include/postgresql/server/port/sunos4.h
include/postgresql/server/port/svr4.h
include/postgresql/server/port/ultrix4.h
include/postgresql/server/port/univel.h
include/postgresql/server/port/unixware.h
include/postgresql/server/port/win.h
include/postgresql/server/port/win32.h
include/postgresql/server/regex/cclass.h
include/postgresql/server/regex/cname.h
include/postgresql/server/regex/regex.h
include/postgresql/server/regex/regex2.h
include/postgresql/server/regex/utils.h
include/postgresql/server/rewrite/prs2lock.h
include/postgresql/server/rewrite/rewriteDefine.h
include/postgresql/server/rewrite/rewriteHandler.h
include/postgresql/server/rewrite/rewriteManip.h
include/postgresql/server/rewrite/rewriteRemove.h
include/postgresql/server/rewrite/rewriteSupport.h
include/postgresql/server/storage/backendid.h
include/postgresql/server/storage/block.h
include/postgresql/server/storage/buf.h
include/postgresql/server/storage/buf_internals.h
include/postgresql/server/storage/buffile.h
include/postgresql/server/storage/bufmgr.h
include/postgresql/server/storage/bufpage.h
include/postgresql/server/storage/fd.h
include/postgresql/server/storage/freespace.h
include/postgresql/server/storage/ipc.h
include/postgresql/server/storage/item.h
include/postgresql/server/storage/itemid.h
include/postgresql/server/storage/itempos.h
include/postgresql/server/storage/itemptr.h
include/postgresql/server/storage/large_object.h
include/postgresql/server/storage/lmgr.h
include/postgresql/server/storage/lock.h
include/postgresql/server/storage/lwlock.h
include/postgresql/server/storage/off.h
include/postgresql/server/storage/page.h
include/postgresql/server/storage/pg_sema.h
include/postgresql/server/storage/pg_shmem.h
include/postgresql/server/storage/pmsignal.h
include/postgresql/server/storage/pos.h
include/postgresql/server/storage/proc.h
include/postgresql/server/storage/relfilenode.h
include/postgresql/server/storage/s_lock.h
include/postgresql/server/storage/shmem.h
include/postgresql/server/storage/sinval.h
include/postgresql/server/storage/sinvaladt.h
include/postgresql/server/storage/smgr.h
include/postgresql/server/storage/spin.h
include/postgresql/server/tcop/dest.h
include/postgresql/server/tcop/fastpath.h
include/postgresql/server/tcop/pquery.h
include/postgresql/server/tcop/tcopdebug.h
include/postgresql/server/tcop/tcopprot.h
include/postgresql/server/tcop/utility.h
include/postgresql/server/utils/acl.h
include/postgresql/server/utils/array.h
include/postgresql/server/utils/ascii.h
include/postgresql/server/utils/builtins.h
include/postgresql/server/utils/cash.h
include/postgresql/server/utils/catcache.h
include/postgresql/server/utils/date.h
include/postgresql/server/utils/datetime.h
include/postgresql/server/utils/datum.h
include/postgresql/server/utils/dynahash.h
include/postgresql/server/utils/dynamic_loader.h
include/postgresql/server/utils/elog.h
include/postgresql/server/utils/fmgroids.h
include/postgresql/server/utils/fmgrtab.h
include/postgresql/server/utils/formatting.h
include/postgresql/server/utils/geo_decls.h
include/postgresql/server/utils/guc.h
include/postgresql/server/utils/hsearch.h
include/postgresql/server/utils/inet.h
include/postgresql/server/utils/int8.h
include/postgresql/server/utils/inval.h
include/postgresql/server/utils/logtape.h
include/postgresql/server/utils/lsyscache.h
include/postgresql/server/utils/memutils.h
include/postgresql/server/utils/rel.h
include/postgresql/server/utils/nabstime.h
include/postgresql/server/utils/numeric.h
include/postgresql/server/utils/palloc.h
include/postgresql/server/utils/pg_crc.h
include/postgresql/server/utils/pg_locale.h
include/postgresql/server/utils/pg_lzcompress.h
include/postgresql/server/utils/portal.h
include/postgresql/server/utils/ps_status.h
include/postgresql/server/utils/relcache.h
include/postgresql/server/utils/selfuncs.h
include/postgresql/server/utils/sets.h
include/postgresql/server/utils/syscache.h
include/postgresql/server/utils/timestamp.h
include/postgresql/server/utils/tqual.h
include/postgresql/server/utils/tuplesort.h
include/postgresql/server/utils/tuplestore.h
include/postgresql/server/utils/varbit.h
include/postgresql/server/pg_config.h
include/postgresql/server/pg_config_os.h
include/postgresql/server/c.h
include/postgresql/server/dynloader.h
include/postgresql/server/fmgr.h
include/postgresql/server/funcapi.h
include/postgresql/server/getopt_long.h
include/postgresql/server/miscadmin.h
include/postgresql/server/pgstat.h
include/postgresql/server/postgres.h
include/postgresql/server/postgres_ext.h
include/postgresql/server/postgres_fe.h
include/postgresql/server/rusagestub.h
include/postgresql/server/strdup.h
@dirrm include/postgresql/server/access
@dirrm include/postgresql/server/bootstrap
@dirrm include/postgresql/server/catalog
@dirrm include/postgresql/server/commands
@dirrm include/postgresql/server/executor
@dirrm include/postgresql/server/lib
@dirrm include/postgresql/server/libpq
@dirrm include/postgresql/server/mb
@dirrm include/postgresql/server/nodes
@dirrm include/postgresql/server/optimizer
@dirrm include/postgresql/server/parser
@dirrm include/postgresql/server/port
@dirrm include/postgresql/server/regex
@dirrm include/postgresql/server/rewrite
@dirrm include/postgresql/server/storage
@dirrm include/postgresql/server/tcop
@dirrm include/postgresql/server/utils
@dirrm include/postgresql/server
@dirrm include/postgresql
include/postgres_ext.h
include/pg_config.h
include/pg_config_os.h
include/libpq/libpq-fs.h
@dirrm include/libpq
include/libpq-fe.h
include/ecpgerrno.h
include/ecpglib.h
@ -77,6 +412,9 @@ lib/libecpg.so.3
%%SERVER%%lib/postgresql/utf8_and_win1256.so
%%SERVER%%lib/postgresql/utf8_and_win874.so
@unexec rmdir %D/lib/postgresql 2>/dev/null || true
%%SERVER%%share/postgresql/information_schema.sql
%%SERVER%%share/postgresql/sql_features.txt
%%SERVER%%share/postgresql/pg_service.conf.sample
%%SERVER%%share/postgresql/502.pgsql
%%SERVER%%share/postgresql/conversion_create.sql
%%SERVER%%share/postgresql/postgres.bki
@ -86,6 +424,22 @@ lib/libecpg.so.3
%%SERVER%%share/postgresql/postgresql.conf.sample
share/postgresql/post-install-notes
@unexec rmdir %D/share/postgresql 2>/dev/null || true
@unexec rmdir %D/pgsql 2>/dev/null || true
%%GETTEXT%%share/locale/de/LC_MESSAGES/pg_resetxlog.mo
%%GETTEXT%%share/locale/de/LC_MESSAGES/pg_controldata.mo
%%GETTEXT%%share/locale/es/LC_MESSAGES/postgres.mo
%%GETTEXT%%share/locale/es/LC_MESSAGES/libpq.mo
%%GETTEXT%%share/locale/es/LC_MESSAGES/pg_controldata.mo
%%GETTEXT%%share/locale/pt_BR/LC_MESSAGES/libpq.mo
%%GETTEXT%%share/locale/pt_BR/LC_MESSAGES/pg_controldata.mo
%%GETTEXT%%share/locale/pt_BR/LC_MESSAGES/pg_resetxlog.mo
%%GETTEXT%%share/locale/ru/LC_MESSAGES/pg_resetxlog.mo
%%GETTEXT%%share/locale/ru/LC_MESSAGES/pg_controldata.mo
%%GETTEXT%%share/locale/sv/LC_MESSAGES/postgres.mo
%%GETTEXT%%share/locale/sv/LC_MESSAGES/pg_controldata.mo
%%GETTEXT%%share/locale/sv/LC_MESSAGES/pg_resetxlog.mo
%%GETTEXT%%share/locale/zh_CN/LC_MESSAGES/pg_controldata.mo
%%GETTEXT%%share/locale/zh_CN/LC_MESSAGES/pg_resetxlog.mo
%%GETTEXT%%share/locale/cs/LC_MESSAGES/postgres.mo
%%GETTEXT%%share/locale/cs/LC_MESSAGES/libpq.mo
%%GETTEXT%%share/locale/cs/LC_MESSAGES/pg_dump.mo