Update to 2.4.0.
This commit is contained in:
parent
902def07c4
commit
923bc1d093
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=45019
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= libxml2
|
||||
PORTVERSION= 2.3.10
|
||||
PORTVERSION= 2.4.0
|
||||
CATEGORIES= textproc gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= stable/sources/libxml
|
||||
|
@ -1 +1 @@
|
||||
MD5 (libxml2-2.3.10.tar.gz) = 8625086f7134417d530527c1efbb756b
|
||||
MD5 (libxml2-2.4.0.tar.gz) = 38634715dd81ceb2a69bac3da8b5e56c
|
||||
|
@ -1,26 +1,95 @@
|
||||
--- configure.orig Fri Jun 1 03:33:59 2001
|
||||
+++ configure Mon Jun 18 13:39:58 2001
|
||||
@@ -3545,3 +3545,3 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- configure.orig Tue Jul 10 18:51:46 2001
|
||||
+++ configure Wed Jul 11 10:25:59 2001
|
||||
@@ -3569,7 +3569,7 @@
|
||||
|
||||
|
||||
XML_LIBDIR='-L${libdir}'
|
||||
-XML_INCLUDEDIR='-I${includedir}/libxml -I${includedir}'
|
||||
+XML_INCLUDEDIR='-I${includedir}/libxml2 -I${includedir}/libxml2/libxml'
|
||||
|
||||
@@ -4028,3 +4028,3 @@
|
||||
builtin and then its argument prototype would still apply. */
|
||||
-char iconv();
|
||||
+char libiconv();
|
||||
|
||||
@@ -4038,3 +4038,3 @@
|
||||
#else
|
||||
-iconv();
|
||||
+libiconv();
|
||||
#endif
|
||||
@@ -4074,6 +4074,6 @@
|
||||
builtin and then its argument prototype would still apply. */
|
||||
-char iconv();
|
||||
+char libiconv();
|
||||
XML_CFLAGS=""
|
||||
RDL_LIBS=""
|
||||
@@ -4020,16 +4020,16 @@
|
||||
ICONV_LIBS="-L$with_iconv/lib"
|
||||
fi
|
||||
|
||||
- ac_safe=`echo "iconv.h" | sed 'y%./+-%__p_%'`
|
||||
-echo $ac_n "checking for iconv.h""... $ac_c" 1>&6
|
||||
-echo "configure:4026: checking for iconv.h" >&5
|
||||
+ ac_safe=`echo "giconv.h" | sed 'y%./+-%__p_%'`
|
||||
+echo $ac_n "checking for giconv.h""... $ac_c" 1>&6
|
||||
+echo "configure:4026: checking for giconv.h" >&5
|
||||
if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 4031 "configure"
|
||||
#include "confdefs.h"
|
||||
-#include <iconv.h>
|
||||
+#include <giconv.h>
|
||||
EOF
|
||||
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
|
||||
{ (eval echo configure:4036: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
||||
@@ -4048,17 +4048,17 @@
|
||||
fi
|
||||
if eval "test \"`echo '$ac_cv_header_'$ac_safe`\" = yes"; then
|
||||
echo "$ac_t""yes" 1>&6
|
||||
- echo $ac_n "checking for iconv""... $ac_c" 1>&6
|
||||
-echo "configure:4053: checking for iconv" >&5
|
||||
+ echo $ac_n "checking for libiconv""... $ac_c" 1>&6
|
||||
+echo "configure:4053: checking for libiconv" >&5
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 4055 "configure"
|
||||
#include "confdefs.h"
|
||||
#include <stdlib.h>
|
||||
-#include <iconv.h>
|
||||
+#include <giconv.h>
|
||||
int main() {
|
||||
-iconv()
|
||||
+libiconv()
|
||||
|
||||
iconv_t cd = iconv_open ("","");
|
||||
-iconv (cd, NULL, NULL, NULL, NULL);
|
||||
+libiconv (cd, NULL, NULL, NULL, NULL);
|
||||
; return 0; }
|
||||
EOF
|
||||
if { (eval echo configure:4065: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
@@ -4072,23 +4072,23 @@
|
||||
rm -rf conftest*
|
||||
|
||||
echo "$ac_t""no" 1>&6
|
||||
- echo $ac_n "checking for iconv in -liconv""... $ac_c" 1>&6
|
||||
-echo "configure:4077: checking for iconv in -liconv" >&5
|
||||
+ echo $ac_n "checking for libiconv in -lgiconv""... $ac_c" 1>&6
|
||||
+echo "configure:4077: checking for libiconv in -lgiconv" >&5
|
||||
|
||||
_ldflags="${LDFLAGS}"
|
||||
_libs="${LIBS}"
|
||||
LDFLAGS="${LDFLAGS} ${ICONV_LIBS}"
|
||||
- LIBS="${LIBS} -liconv"
|
||||
+ LIBS="${LIBS} -lgiconv"
|
||||
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 4085 "configure"
|
||||
#include "confdefs.h"
|
||||
#include <stdlib.h>
|
||||
-#include <iconv.h>
|
||||
+#include <giconv.h>
|
||||
int main() {
|
||||
|
||||
iconv_t cd = iconv_open ("","");
|
||||
-iconv (cd, NULL, NULL, NULL, NULL);
|
||||
+libiconv (cd, NULL, NULL, NULL, NULL);
|
||||
; return 0; }
|
||||
EOF
|
||||
if { (eval echo configure:4095: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
@@ -4096,7 +4096,7 @@
|
||||
|
||||
echo "$ac_t""yes" 1>&6
|
||||
WITH_ICONV=1
|
||||
- ICONV_LIBS="${ICONV_LIBS} -liconv"
|
||||
+ ICONV_LIBS="${ICONV_LIBS} -lgiconv"
|
||||
LIBS="${_libs}"
|
||||
LDFLAGS="${_ldflags}"
|
||||
else
|
||||
|
@ -1,14 +0,0 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- include/Makefile.in.orig Thu Feb 8 13:47:30 2001
|
||||
+++ include/Makefile.in Fri Feb 9 02:04:41 2001
|
||||
@@ -111,7 +111,7 @@
|
||||
Z_CFLAGS = @Z_CFLAGS@
|
||||
Z_LIBS = @Z_LIBS@
|
||||
|
||||
-xmlincdir = $(includedir)
|
||||
+xmlincdir = $(includedir)/libxml2
|
||||
|
||||
xmlinc_HEADERS = libxml/SAX.h libxml/entities.h libxml/encoding.h libxml/parser.h libxml/parserInternals.h libxml/xmlerror.h libxml/HTMLparser.h libxml/HTMLtree.h libxml/debugXML.h libxml/tree.h libxml/hash.h libxml/xpath.h libxml/xpathInternals.h libxml/xpointer.h libxml/xinclude.h libxml/xmlIO.h libxml/xmlmemory.h libxml/nanohttp.h libxml/nanoftp.h libxml/uri.h libxml/valid.h libxml/xlink.h libxml/xmlversion.h
|
||||
|
23
textproc/libxml2/files/patch-include::libxml::Makefile.in
Normal file
23
textproc/libxml2/files/patch-include::libxml::Makefile.in
Normal file
@ -0,0 +1,23 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- include/libxml/Makefile.in.orig Wed Jul 11 10:26:41 2001
|
||||
+++ include/libxml/Makefile.in Wed Jul 11 10:34:18 2001
|
||||
@@ -116,7 +116,7 @@
|
||||
Z_CFLAGS = @Z_CFLAGS@
|
||||
Z_LIBS = @Z_LIBS@
|
||||
|
||||
-xmlincdir = $(includedir)/libxml
|
||||
+xmlincdir = $(includedir)/libxml2/libxml
|
||||
|
||||
xmlinc_HEADERS = SAX.h entities.h encoding.h parser.h parserInternals.h xmlerror.h HTMLparser.h HTMLtree.h debugXML.h tree.h list.h hash.h xpath.h xpathInternals.h xpointer.h xinclude.h xmlIO.h xmlmemory.h nanohttp.h nanoftp.h uri.h valid.h xlink.h xmlversion.h xmlwin32version.h DOCBparser.h catalog.h
|
||||
|
||||
@@ -275,7 +275,7 @@
|
||||
|
||||
|
||||
install-exec-hook:
|
||||
- $(mkinstalldirs) $(DESTDIR)$(xmlincdir) $(DESTDIR)$(xmlincdir)/libxml
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(xmlincdir)
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
@ -24,6 +24,7 @@ include/libxml2/libxml/xmlIO.h
|
||||
include/libxml2/libxml/xmlerror.h
|
||||
include/libxml2/libxml/xmlmemory.h
|
||||
include/libxml2/libxml/xmlversion.h
|
||||
include/libxml2/libxml/xmlwin32version.h
|
||||
include/libxml2/libxml/xpath.h
|
||||
include/libxml2/libxml/xpathInternals.h
|
||||
include/libxml2/libxml/xpointer.h
|
||||
|
Loading…
Reference in New Issue
Block a user