MFH: r551238

graphics/electricsheep: Update 2.7 -> 3.0.2.20191005; Fix build

Approved by:	ports-secteam (fluffy)
This commit is contained in:
Yuri Victorovich 2020-10-02 23:00:45 +00:00
parent 7a1cd0fa3a
commit 91aa1becd6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q4/; revision=551241
3 changed files with 60 additions and 8 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= electricsheep
DISTVERSION= 2.7 # configure.ac says that the version is 2.7b33
PORTREVISION= 7
DISTVERSION= 3.0.2.20191005 # configure.ac though says that the version is 2.7b33
PORTEPOCH= 1
CATEGORIES= graphics
@ -27,7 +26,7 @@ USES= autoreconf compiler:c++11-lang dos2unix gl gnome libtool \
localbase:ldflags lua:51 pkgconfig gettext-runtime xorg
USE_GITHUB= yes
GH_ACCOUNT= scottdraves
GH_TAGNAME= 4949c31
GH_TAGNAME= 37ba0fd692d6581f8fe009ed11c9650cd8174123
DOS2UNIX_FILES= ContentDownloader/SheepDownloader.cpp DisplayOutput/OpenGL/glx.cpp
GNU_CONFIGURE= yes
USE_WX= 3.1

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1534644362
SHA256 (scottdraves-electricsheep-2.7-4949c31_GH0.tar.gz) = 5d3eadf8b00abebc8d8ad7c84e10b12461990216f3f06af70a6748e25c04ff4c
SIZE (scottdraves-electricsheep-2.7-4949c31_GH0.tar.gz) = 10380806
TIMESTAMP = 1601677601
SHA256 (scottdraves-electricsheep-3.0.2.20191005-37ba0fd692d6581f8fe009ed11c9650cd8174123_GH0.tar.gz) = fd085c779408822ff8fa94b1614f916e328fb0d770befaf0314e7fb0f4620d46
SIZE (scottdraves-electricsheep-3.0.2.20191005-37ba0fd692d6581f8fe009ed11c9650cd8174123_GH0.tar.gz) = 11115290

View File

@ -1,6 +1,6 @@
--- ContentDownloader/SheepDownloader.cpp.orig 2018-05-31 14:38:12 UTC
--- ContentDownloader/SheepDownloader.cpp.orig 2020-10-02 21:49:58 UTC
+++ ContentDownloader/SheepDownloader.cpp
@@ -41,7 +41,10 @@
@@ -41,7 +42,10 @@
#include <sys/param.h>
#include <sys/mount.h>
#endif
@ -12,3 +12,56 @@
#include <sys/statfs.h>
#include <limits.h>
#define MAX_PATH PATH_MAX
@@ -780,7 +784,7 @@ void SheepDownloader::findSheepToDownload()
// Make sure we are really deeply settled asleep, avoids lots of timed out frames.
g_Log->Info( "Chilling for %d seconds before trying to download sheeps...", ContentDownloader::INIT_DELAY );
- thread::sleep( get_system_time() + posix_time::seconds(ContentDownloader::INIT_DELAY) );
+ boost::thread::sleep( get_system_time() + posix_time::seconds(ContentDownloader::INIT_DELAY) );
}
#endif
@@ -793,7 +797,7 @@ void SheepDownloader::findSheepToDownload()
while( 1 )
{
- this_thread::interruption_point();
+ boost::this_thread::interruption_point();
bool incorrect_folder = false;
#ifdef WIN32
ULARGE_INTEGER winlpFreeBytesAvailable, winlpTotalNumberOfBytes, winlpRealBytesAvailable;
@@ -820,14 +824,14 @@ void SheepDownloader::findSheepToDownload()
const char *err = "Content folder is not working. Downloading disabled.\n";
Shepherd::addMessageText( err, strlen(err), 180 ); //3 minutes
- thread::sleep( get_system_time() + posix_time::seconds(TIMEOUT) );
+ boost::thread::sleep( get_system_time() + posix_time::seconds(TIMEOUT) );
}
else
{
const char *err = "Low disk space. Downloading disabled.\n";
Shepherd::addMessageText( err, strlen(err), 180 ); //3 minutes
- thread::sleep( get_system_time() + posix_time::seconds(TIMEOUT) );
+ boost::thread::sleep( get_system_time() + posix_time::seconds(TIMEOUT) );
boost::mutex::scoped_lock lockthis( s_DownloaderMutex );
@@ -938,7 +942,7 @@ void SheepDownloader::findSheepToDownload()
best_anim_old_url = fServerFlock[ static_cast<size_t>(best_anim_old) ]->URL();
}
}
- this_thread::interruption_point();
+ boost::this_thread::interruption_point();
} while (best_anim != -1);
if (best_anim_old == -1)
@@ -976,7 +980,7 @@ void SheepDownloader::findSheepToDownload()
badSheepSleepDuration = 10;
}
- thread::sleep( get_system_time() + posix_time::seconds(failureSleepDuration) );
+ boost::thread::sleep( get_system_time() + posix_time::seconds(failureSleepDuration) );
//failureSleepDuration = TIMEOUT;