Upgrade to 4.8.2. Fix up more warnings in the code and the tests.

The build now passses with -Werror. The regression-test target will only
be enabled after the ports thaw, as condition for approval...

Approved by:	maintainer (mezz)
This commit is contained in:
Mikhail Teterin 2009-11-11 05:36:53 +00:00
parent 16a74f6132
commit 9180591531
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=244096
5 changed files with 481 additions and 167 deletions

View File

@ -6,8 +6,7 @@
# $MCom: ports-experimental/devel/nspr/Makefile,v 1.6 2008/03/12 13:06:56 ahze Exp $
PORTNAME= nspr
DISTVERSION= 4.8
PORTREVISION= 1
DISTVERSION= 4.8.2
CATEGORIES= devel
#MASTER_SITES= LOCAL/ahze
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@ -20,6 +19,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/mozilla/nsprpub/build
USE_LDCONFIG= yes
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_SCRIPT=../configure
CONFIGURE_ARGS= --disable-debug \
@ -79,6 +79,8 @@ libtests:
test: libtests prtests
#regression-test: test
#.if defined(PACKAGE_BUILDING)
#post-build: test
#.else

View File

@ -1,3 +1,3 @@
MD5 (nspr-4.8.tar.gz) = e0916a72bcc6c427551ea262183fdb26
SHA256 (nspr-4.8.tar.gz) = a2de84aa21a7bbabd93c4f172123d58c6432c2358807bb260ac338b2dc61dbfe
SIZE (nspr-4.8.tar.gz) = 1170419
MD5 (nspr-4.8.2.tar.gz) = 2a6fbfa56c9760ed3651d527272249c7
SHA256 (nspr-4.8.2.tar.gz) = 23ec182a42eec4b6df01f3c02c632ed9f7e004d6c320d048d5fe24054d319bce
SIZE (nspr-4.8.2.tar.gz) = 1232677

View File

@ -1,6 +1,15 @@
--- ../pr/src/pthreads/ptio.c.orig Mon Feb 2 10:41:43 2004
+++ ../pr/src/pthreads/ptio.c Mon Feb 2 10:44:49 2004
@@ -3470,6 +3470,17 @@
--- ../pr/src/pthreads/ptio.c 2009-05-09 23:07:02.000000000 -0400
+++ ../pr/src/pthreads/ptio.c 2009-11-04 15:24:47.000000000 -0500
@@ -1168,7 +1168,7 @@
osfd = socket(AF_INET6, SOCK_STREAM, 0);
if (osfd != -1) {
int on;
- int optlen = sizeof(on);
+ socklen_t optlen = sizeof(on);
if (getsockopt(osfd, IPPROTO_IPV6, IPV6_V6ONLY,
&on, &optlen) == 0) {
_pr_ipv6_v6only_on_by_default = on;
@@ -3495,6 +3495,17 @@
&on, sizeof(on));
}
#endif
@ -18,3 +27,20 @@
fd = pt_SetMethods(osfd, ftype, PR_FALSE, PR_FALSE);
if (fd == NULL) close(osfd);
}
@@ -3758,7 +3769,7 @@
* We use these variables to figure out how much time has
* elapsed and how much of the timeout still remains.
*/
- PRIntervalTime start, elapsed, remaining;
+ PRIntervalTime start = 0, elapsed, remaining;
if (pt_TestAbort()) return -1;
@@ -4927,6 +4938,7 @@
if (timeout == PR_INTERVAL_NO_TIMEOUT) {
tvp = NULL;
+ start = 0; /* Not needed, but shuts down a warning */
} else {
tv.tv_sec = (PRInt32)PR_IntervalToSeconds(timeout);
tv.tv_usec = (PRInt32)PR_IntervalToMicroseconds(

File diff suppressed because it is too large Load Diff

View File

@ -55,3 +55,83 @@
+#define PR_FIND_NEXT_COUNTER_QNAME(next,handle)
#endif
--- ../pr/src/io/prprf.c 2008-05-31 11:10:17.000000000 -0400
+++ ../pr/src/io/prprf.c 2009-11-04 14:27:19.000000000 -0500
@@ -698,5 +698,5 @@
int rv, i;
struct NumArg* nas = NULL;
- struct NumArg* nap;
+ struct NumArg* nap = NULL;
struct NumArg nasArray[ NAS_DEFAULT_NUM ];
char pattern[20];
--- ../pr/src/io/prscanf.c 2005-08-05 18:44:06.000000000 -0400
+++ ../pr/src/io/prscanf.c 2009-11-04 14:31:24.000000000 -0500
@@ -230,5 +230,5 @@
{
char buf[FMAX + 1], *p;
- int ch;
+ int ch = -1;
static const char digits[] = "0123456789abcdefABCDEF";
PRBool seenDigit = PR_FALSE;
@@ -340,5 +340,5 @@
{
char buf[FMAX + 1], *p;
- int ch;
+ int ch = -1;
PRBool seenDigit = PR_FALSE;
--- ../pr/src/misc/pralarm.c 2009-05-06 01:40:37.000000000 -0400
+++ ../pr/src/misc/pralarm.c 2009-11-04 14:34:27.000000000 -0500
@@ -134,5 +134,5 @@
while (why != abort)
{
- PRIntervalTime pause;
+ PRIntervalTime pause = 0;
PR_Lock(alarm->lock);
--- ../pr/src/misc/prdtoa.c 2009-10-05 18:58:41.000000000 -0400
+++ ../pr/src/misc/prdtoa.c 2009-11-04 14:36:24.000000000 -0500
@@ -2765,5 +2765,5 @@
*/
- int bbits, b2, b5, be, dig, i, ieps, ilim, ilim0, ilim1,
+ int bbits, b2, b5, be, dig, i, ieps, ilim = -1, ilim0, ilim1 = -1,
j, j1, k, k0, k_check, leftright, m2, m5, s2, s5,
spec_case, try_quick;
--- ../pr/src/misc/prenv.c 2009-05-06 01:40:37.000000000 -0400
+++ ../pr/src/misc/prenv.c 2009-11-04 15:02:32.000000000 -0500
@@ -94,5 +94,10 @@
_PR_LOCK_ENV();
- result = _PR_MD_PUT_ENV(string);
+ /*
+ * putenv() does not modify the contents, but allows
+ * the caller to modify it later. So, it is Ok to
+ * drop the const-ness here...
+ */
+ result = _PR_MD_PUT_ENV((char *)string);
_PR_UNLOCK_ENV();
return (result)? PR_FAILURE : PR_SUCCESS;
--- ../pr/src/misc/prtpool.c 2005-04-28 18:37:25.000000000 -0400
+++ ../pr/src/misc/prtpool.c 2009-11-04 15:08:05.000000000 -0500
@@ -314,6 +314,6 @@
int rv;
PRCList *qp, *nextqp;
-PRPollDesc *pollfds;
-PRJob **polljobs;
+PRPollDesc *pollfds = NULL;
+PRJob **polljobs = NULL;
int poll_timeout;
PRIntervalTime now;
--- ../pr/include/prlog.h 2009-02-22 14:56:13.000000000 -0500
+++ ../pr/include/prlog.h 2009-11-04 15:30:48.000000000 -0500
@@ -232,7 +232,8 @@
#endif /* NO_NSPR_10_SUPPORT */
+NSPR_API(void) PR_Assert(const char *s, const char *file, PRIntn ln);
+
#if defined(DEBUG) || defined(FORCE_PR_ASSERT)
-NSPR_API(void) PR_Assert(const char *s, const char *file, PRIntn ln);
#define PR_ASSERT(_expr) \
((_expr)?((void)0):PR_Assert(# _expr,__FILE__,__LINE__))