- OPTIONS'ify.

- Add support for XMLRPC (default: on).
This commit is contained in:
Florent Thoumie 2007-12-18 22:08:56 +00:00
parent 90f973349d
commit 916edfcd48
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=204043
3 changed files with 32 additions and 9 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= rtorrent-devel
PORTVERSION= 0.7.9
PORTREVISION= 0
PORTREVISION= 1
DISTNAME= ${PORTNAME:S/-devel//}-${PORTVERSION}
MAINTAINER= flz@FreeBSD.org

View File

@ -7,7 +7,7 @@
PORTNAME?= rtorrent
PORTVERSION?= 0.7.9
PORTREVISION?= 0
PORTREVISION?= 1
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/ \
${MASTER_SITE_LOCAL}
@ -36,16 +36,16 @@ SUB_FILES= pkg-message
PORTDOCS= README
#OPTIONS= XMLRPC "Compile with xmlrpc-c support" on
OPTIONS= XMLRPC "Compile with xmlrpc-c support" on
.include <bsd.port.pre.mk>
#.if !defined(WITHOUT_XMLRPC)
#CONFIGURE_ARGS+= --with-xmlrpc-c
#LIB_DEPENDS+= xmlrpc.7:${PORTSDIR}/net/xmlrpc-c
#.else
#CONFIGURE_ARGS+= --with-xmlrpc-c=no
#.endif
.if !defined(WITHOUT_XMLRPC)
CONFIGURE_ARGS+= --with-xmlrpc-c
LIB_DEPENDS+= xmlrpc.9:${PORTSDIR}/net/xmlrpc-c
.else
CONFIGURE_ARGS+= --with-xmlrpc-c=no
.endif
post-patch:
@${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/configure

View File

@ -0,0 +1,23 @@
--- src/command_network.cc.orig 2007-12-18 21:13:53.000000000 +0000
+++ src/command_network.cc 2007-12-18 21:14:26.000000000 +0000
@@ -224,6 +224,8 @@
saPtr->set_port(port);
control->scgi()->open_port(saPtr, saPtr->length(), rpc::call_command_value("get_scgi_dont_route"));
+ rak::address_info::free_address_info(ai);
+
break;
case 2:
@@ -232,10 +234,8 @@
break;
}
- rak::address_info::free_address_info(ai);
-
} catch (torrent::local_error& e) {
- rak::address_info::free_address_info(ai);
+ //rak::address_info::free_address_info(ai);
throw torrent::input_error(e.what());
}