- Update to 0.8.1
PR: 144091 Submitted by: Jason E. Hale <bsdkaffee@gmail.com> (maintainer)
This commit is contained in:
parent
94f45fa808
commit
912f080856
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=250799
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= playwolf
|
||||
PORTVERSION= 0.7.2
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 0.8.1
|
||||
CATEGORIES= deskutils kde
|
||||
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
|
||||
PKGNAMEPREFIX= plasma-applet-
|
||||
@ -19,7 +18,7 @@ USE_BZIP2= yes
|
||||
USE_CMAKE= yes
|
||||
USE_KDE4= automoc4 kdeprefix kdelibs
|
||||
USE_QT_VER= 4
|
||||
QT_COMPONENTS= gui dbus network opengl svg webkit xml \
|
||||
QT_COMPONENTS= gui dbus network opengl phonon svg webkit xml xmlpatterns \
|
||||
qmake_build moc_build rcc_build uic_build
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
@ -28,17 +27,17 @@ PLIST_FILES= lib/kde4/plasma_applet_playwolf.so \
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
ADD_NEWLINE_TO= flowlayout.cpp flowlayout.h playwolf.cpp playwolf.h \
|
||||
wolfbuttons.cpp wolflabel.h
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
ADD_NEWLINE_TO= flowlayout.cpp \
|
||||
flowlayout.h \
|
||||
lyricswidget.cpp \
|
||||
playwolf.cpp \
|
||||
playwolf.h \
|
||||
wolfbuttons.cpp \
|
||||
wolflabel.h
|
||||
|
||||
post-patch:
|
||||
.for i in ${ADD_NEWLINE_TO}
|
||||
${ECHO_CMD} >> ${WRKSRC}/${i}
|
||||
.endfor
|
||||
|
||||
cd ${WRKSRC} && ${REINPLACE_CMD} -e 's|usr|${KDE4_PREFIX}|g' \
|
||||
infomanager.cpp wolflabel.cpp
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (playwolf-0.7.2.tar.bz2) = 0f9f051aa5e1762ad5bbad0197d3bedf
|
||||
SHA256 (playwolf-0.7.2.tar.bz2) = 3978ac01cbe23bc701a1256d5c1538953d3339ade53d6a2255f514051a1dc424
|
||||
SIZE (playwolf-0.7.2.tar.bz2) = 22217
|
||||
MD5 (playwolf-0.8.1.tar.bz2) = 28ec4f7abfcc367c0dae67f4d423d569
|
||||
SHA256 (playwolf-0.8.1.tar.bz2) = f41a39f8f4078baa9a7e9fa44f0a81164f8b468eddfc06f5d73cf491a58dad04
|
||||
SIZE (playwolf-0.8.1.tar.bz2) = 22840
|
||||
|
24
deskutils/plasma-applet-playwolf/files/patch-infomanager.cpp
Normal file
24
deskutils/plasma-applet-playwolf/files/patch-infomanager.cpp
Normal file
@ -0,0 +1,24 @@
|
||||
--- ./infomanager.cpp.orig 2010-01-13 16:32:23.000000000 -0500
|
||||
+++ ./infomanager.cpp 2010-02-05 01:27:39.000000000 -0500
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <QtGui/QGraphicsWidget>
|
||||
|
||||
#include <KDebug>
|
||||
+#include <KStandardDirs>
|
||||
|
||||
#include "playercontroller.h"
|
||||
|
||||
@@ -105,9 +106,11 @@
|
||||
if (metadata.value("arturl").toString() != QString()) {
|
||||
emit updateCover(metadata.value("arturl").toString());
|
||||
} else if (mode == QString("lastfm")) {
|
||||
- emit updateCover("file:///usr/share/apps/amarok/images/lastfm-default-cover.png");
|
||||
+ QString lastfmcover = KGlobal::dirs()->findResource("data", QString("amarok/images/lastfm-default-cover.png"));
|
||||
+ emit updateCover(lastfmcover);
|
||||
} else {
|
||||
- emit updateCover("file:///usr/share/apps/amarok/images/nocover.png");
|
||||
+ QString nocover = KGlobal::dirs()->findResource("data", QString("amarok/images/nocover.png"));
|
||||
+ emit updateCover(nocover);
|
||||
}
|
||||
|
||||
emit updateInfos(metadata.value("artist").toString(),
|
Loading…
Reference in New Issue
Block a user