editors/kakoune: Fix tmux-repl.kak

It fails on FreeBSD and claims that tmux' version is too old even though
tmux >= 2 is installed.
This commit is contained in:
Tobias Kortkamp 2018-04-25 10:52:10 +00:00
parent b9e35d2306
commit 9110aad970
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=468274
2 changed files with 24 additions and 3 deletions

View File

@ -2,7 +2,7 @@
PORTNAME= kakoune
DISTVERSION= 2018.04.13
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= editors
MASTER_SITES= https://github.com/mawww/kakoune/releases/download/v${DISTVERSION}/
@ -10,7 +10,7 @@ MAINTAINER= tobik@FreeBSD.org
COMMENT= Modal code editor with a focus on interactivity
LICENSE= UNLICENSE
LICENSE_FILE= ${WRKSRC}/../UNLICENSE
LICENSE_FILE= ${WRKSRC:H}/UNLICENSE
BUILD_DEPENDS= a2x:textproc/asciidoc
@ -18,6 +18,7 @@ USES= compiler:c++14-lang gmake ncurses tar:bzip2
DATADIR= ${PREFIX}/share/kak
DOCSDIR= ${PREFIX}/share/doc/kak
PATCH_WRKSRC= ${WRKSRC:H}
WRKSRC_SUBDIR= src
OPTIONS_DEFINE= DEBUG DOCS
@ -33,6 +34,6 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/kak
do-test:
@cd ${WRKSRC}/../test && ${SETENV} LC_ALL=en_US.UTF-8 ./run
@cd ${WRKSRC:H}/test && ${SETENV} LC_ALL=en_US.UTF-8 ./run
.include <bsd.port.mk>

View File

@ -0,0 +1,20 @@
tmux-repl fails on FreeBSD and claims that tmux' version is too old even
though tmux >= 2 is installed.
The expr is only compatible with GNU expr.
https://github.com/mawww/kakoune/pull/2006
--- rc/extra/tmux-repl.kak.orig 2018-04-12 11:28:15 UTC
+++ rc/extra/tmux-repl.kak
@@ -4,8 +4,8 @@
hook global KakBegin .* %{
%sh{
if [ -n "$TMUX" ]; then
- VERSION_TMUX=$(tmux -V)
- VERSION_TMUX=$(expr "${VERSION_TMUX}" : 'tmux \([0-9]*\|master\)')
+ VERSION_TMUX=$(tmux -V | cut -d' ' -f2)
+ VERSION_TMUX=${VERSION_TMUX%%.*}
if [ "${VERSION_TMUX}" = "master" ] \
|| [ "${VERSION_TMUX}" -ge 2 ]; then