add gmetadom 0.0.3c

A Collection of DOM Implementations
This commit is contained in:
Ying-Chieh Liao 2002-10-15 12:06:20 +00:00
parent 1bdd845e2e
commit 9103303804
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=68093
9 changed files with 264 additions and 0 deletions

View File

@ -73,6 +73,7 @@
SUBDIR += glark
SUBDIR += glimpse
SUBDIR += gmat
SUBDIR += gmetadom
SUBDIR += gnomespell
SUBDIR += gpp
SUBDIR += grap

View File

@ -0,0 +1,33 @@
# ex:ts=8
# Ports collection makefile for: gmetadom
# Date created: Jul 10, 2002
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= gmetadom
PORTVERSION= 0.0.3c
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-0.0.3
MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib
LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
xslt:${PORTSDIR}/textproc/libxslt \
gdome:${PORTSDIR}/textproc/gdome2 \
iconv:${PORTSDIR}/converters/libiconv
USE_GNOMENG= yes
USE_GNOME= glib12
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
INSTALLS_SHLIB= yes
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (gmetadom-0.0.3.tar.gz) = ad692f245eda39e2dc4d909a5e246b57

View File

@ -0,0 +1,11 @@
--- src/gdome_cpp_smart/basic/GdomeSmartDOMDOMString.cc.orig Wed Jul 10 13:37:44 2002
+++ src/gdome_cpp_smart/basic/GdomeSmartDOMDOMString.cc Wed Jul 10 13:38:17 2002
@@ -83,7 +83,7 @@
while (inBytesLeft > 0) {
//cout << "before: " << (void*) inbuf << " " << inBytesLeft << " " << (void*) outbuf << " " << outBytesLeft << endl;
- size_t iconv_res = iconv(cd, &inbuf, &inBytesLeft, &outbuf, &outBytesLeft);
+ size_t iconv_res = iconv(cd, (const char**)&inbuf, &inBytesLeft, &outbuf, &outBytesLeft);
//cout << "after: " << (void*) inbuf << " " << inBytesLeft << " " << (void*) outbuf << " " << outBytesLeft << endl;
unsigned n = outbuf - outbuf0;

View File

@ -0,0 +1,11 @@
--- src/gdome_cpp_smart/basic/GdomeSmartDOMDOMStringAux.cc.orig Wed Jul 10 13:54:33 2002
+++ src/gdome_cpp_smart/basic/GdomeSmartDOMDOMStringAux.cc Wed Jul 10 13:55:19 2002
@@ -47,7 +47,7 @@
int save_width = o.width(4);
o << ch;
o.fill(save_fill);
- o.setf(save_flags);
+ o.setf((std::_Ios_Fmtflags)save_flags);
o.width(save_width);
}
}

View File

@ -0,0 +1,11 @@
--- src/gdome_cpp_smart/include/GdomeSmartDOMDOMStringAux.hh.orig Tue Oct 15 19:18:15 2002
+++ src/gdome_cpp_smart/include/GdomeSmartDOMDOMStringAux.hh Tue Oct 15 19:32:13 2002
@@ -35,7 +35,7 @@
}
-namespace std {
+namespace __gnu_cxx {
struct hash<GdomeSmartDOM::DOMString> {
size_t operator()(const GdomeSmartDOM::DOMString& key) const;

View File

@ -0,0 +1 @@
A Collection of DOM Implementations

View File

@ -0,0 +1,25 @@
GMetaDOM is a collection of librares, each library providing a DOM
implementation. Currently available bindings are for C++ (smart pointers)
and Objective Caml.
The basic idea is that, given the availability of DOM implementations for
the C programming language (like Gdome2), and given the uniformity of the
DOM interfaces, bindings for various programming languages based on the C
implementation can be built automatically, providing a small number of hand-
coded classes and a set of scripts for the automatic generation of the
remaining ones.
Furthermore, since a XML description of the DOM interfaces is provided as
part of the documentation in the W3C DOM specification, GMetaDOM adopts XSLT
as the transformation language for the automatic generation of the interfaces,
and uses the xsltproc utility as the XSLT processor.
The advantages of such approach should be evident. In particular, for
languages like C++ where a number of different alternative DOM implementations
are feasible, each with different characteristics like easiness of use,
runtime flexibility, resource requirements, the approach of automatic
generation permits to create a set of coherent implementations addressing
such issues separately, ultimately allowing the developer to choose the
library which fits best her needs.
WWW: http://gmetadom.sourceforge.net/

170
textproc/gmetadom/pkg-plist Normal file
View File

@ -0,0 +1,170 @@
bin/gmetadom-config
include/gmetadom/gdome_cpp_smart/GdomeSmartDOM.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMAttr.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMBasic.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMCDATASection.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMChar.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMCharacterData.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMComment.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMCore.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMDOMException.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMDOMImplementation.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMDOMString.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMDOMStringAux.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMDOMTimeStamp.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMDocument.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMDocumentFragment.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMDocumentType.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMElement.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMEntity.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMEntityReference.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMEvent.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMEventListener.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMEventTarget.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMEvents.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMGdomeStringAux.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMHelper.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMMutationEvent.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMNamedNodeMap.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMNode.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMNodeList.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMNotation.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMProcessingInstruction.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMText.hh
lib/libgmetadom_gdome_cpp_smart.a
lib/libgmetadom_gdome_cpp_smart.so
lib/libgmetadom_gdome_cpp_smart.so.0
lib/ocaml/gdome2/META
lib/ocaml/gdome2/gdome.cmi
lib/ocaml/gdome2/gdome.ml
lib/ocaml/gdome2/gdome.mli
lib/ocaml/gdome2/gdomeDOMExceptionT.cmi
lib/ocaml/gdome2/gdomeDOMExceptionT.mli
lib/ocaml/gdome2/gdomeInit.cmi
lib/ocaml/gdome2/gdomeInit.cmo
lib/ocaml/gdome2/gdomeInit.cmx
lib/ocaml/gdome2/gdomeInit.ml
lib/ocaml/gdome2/gdomeInit.mli
lib/ocaml/gdome2/gdomeInit.o
lib/ocaml/gdome2/gdomeNodeTypeT.cmi
lib/ocaml/gdome2/gdomeNodeTypeT.mli
lib/ocaml/gdome2/gdomeT.cmi
lib/ocaml/gdome2/gdomeT.mli
lib/ocaml/gdome2/iAttr.cmi
lib/ocaml/gdome2/iAttr.ml
lib/ocaml/gdome2/iCDATASection.cmi
lib/ocaml/gdome2/iCDATASection.ml
lib/ocaml/gdome2/iCharacterData.cmi
lib/ocaml/gdome2/iCharacterData.ml
lib/ocaml/gdome2/iComment.cmi
lib/ocaml/gdome2/iComment.ml
lib/ocaml/gdome2/iDOMImplementation.cmi
lib/ocaml/gdome2/iDOMImplementation.ml
lib/ocaml/gdome2/iDOMImplementation.mli
lib/ocaml/gdome2/iDOMString.cmi
lib/ocaml/gdome2/iDOMString.ml
lib/ocaml/gdome2/iDocument.cmi
lib/ocaml/gdome2/iDocument.ml
lib/ocaml/gdome2/iDocumentFragment.cmi
lib/ocaml/gdome2/iDocumentFragment.ml
lib/ocaml/gdome2/iDocumentType.cmi
lib/ocaml/gdome2/iDocumentType.ml
lib/ocaml/gdome2/iElement.cmi
lib/ocaml/gdome2/iElement.ml
lib/ocaml/gdome2/iEntity.cmi
lib/ocaml/gdome2/iEntity.ml
lib/ocaml/gdome2/iEntityReference.cmi
lib/ocaml/gdome2/iEntityReference.ml
lib/ocaml/gdome2/iEvent.cmi
lib/ocaml/gdome2/iEvent.ml
lib/ocaml/gdome2/iEventTarget.cmi
lib/ocaml/gdome2/iEventTarget.ml
lib/ocaml/gdome2/iMutationEvent.cmi
lib/ocaml/gdome2/iMutationEvent.ml
lib/ocaml/gdome2/iNamedNodeMap.cmi
lib/ocaml/gdome2/iNamedNodeMap.ml
lib/ocaml/gdome2/iNode.cmi
lib/ocaml/gdome2/iNode.ml
lib/ocaml/gdome2/iNodeList.cmi
lib/ocaml/gdome2/iNodeList.ml
lib/ocaml/gdome2/iNotation.cmi
lib/ocaml/gdome2/iNotation.ml
lib/ocaml/gdome2/iProcessingInstruction.cmi
lib/ocaml/gdome2/iProcessingInstruction.ml
lib/ocaml/gdome2/iText.cmi
lib/ocaml/gdome2/iText.ml
lib/ocaml/gdome2/libmlgdome.a
lib/ocaml/gdome2/libmlgdome.so
lib/ocaml/gdome2/libmlgdome.so.0
lib/ocaml/gdome2/mlbasic.a
lib/ocaml/gdome2/mlbasic.cma
lib/ocaml/gdome2/mlbasic.cmxa
lib/ocaml/gdome2/mlcore.a
lib/ocaml/gdome2/mlcore.cma
lib/ocaml/gdome2/mlcore.cmxa
lib/ocaml/gdome2/mlevents.a
lib/ocaml/gdome2/mlevents.cma
lib/ocaml/gdome2/mlevents.cmxa
lib/ocaml/gdome2/mlgdome.a
lib/ocaml/gdome2/mlgdome.cma
lib/ocaml/gdome2/mlgdome.cmxa
lib/ocaml/gdome2/mlgdomevalue.h
lib/ocaml/gdome2/mlogdome.a
lib/ocaml/gdome2/mlogdome.cma
lib/ocaml/gdome2/mlogdome.cmxa
lib/ocaml/gdome2/tAttr.cmi
lib/ocaml/gdome2/tAttr.mli
lib/ocaml/gdome2/tCDATASection.cmi
lib/ocaml/gdome2/tCDATASection.mli
lib/ocaml/gdome2/tCharacterData.cmi
lib/ocaml/gdome2/tCharacterData.mli
lib/ocaml/gdome2/tComment.cmi
lib/ocaml/gdome2/tComment.mli
lib/ocaml/gdome2/tDOMImplementation.cmi
lib/ocaml/gdome2/tDOMImplementation.mli
lib/ocaml/gdome2/tDOMString.cmi
lib/ocaml/gdome2/tDOMString.mli
lib/ocaml/gdome2/tDOMTimeStamp.cmi
lib/ocaml/gdome2/tDOMTimeStamp.mli
lib/ocaml/gdome2/tDocument.cmi
lib/ocaml/gdome2/tDocument.mli
lib/ocaml/gdome2/tDocumentFragment.cmi
lib/ocaml/gdome2/tDocumentFragment.mli
lib/ocaml/gdome2/tDocumentType.cmi
lib/ocaml/gdome2/tDocumentType.mli
lib/ocaml/gdome2/tElement.cmi
lib/ocaml/gdome2/tElement.mli
lib/ocaml/gdome2/tEntity.cmi
lib/ocaml/gdome2/tEntity.mli
lib/ocaml/gdome2/tEntityReference.cmi
lib/ocaml/gdome2/tEntityReference.mli
lib/ocaml/gdome2/tEvent.cmi
lib/ocaml/gdome2/tEvent.mli
lib/ocaml/gdome2/tEventListener.cmi
lib/ocaml/gdome2/tEventListener.mli
lib/ocaml/gdome2/tEventTarget.cmi
lib/ocaml/gdome2/tEventTarget.mli
lib/ocaml/gdome2/tMutationEvent.cmi
lib/ocaml/gdome2/tMutationEvent.mli
lib/ocaml/gdome2/tNamedNodeMap.cmi
lib/ocaml/gdome2/tNamedNodeMap.mli
lib/ocaml/gdome2/tNode.cmi
lib/ocaml/gdome2/tNode.mli
lib/ocaml/gdome2/tNodeList.cmi
lib/ocaml/gdome2/tNodeList.mli
lib/ocaml/gdome2/tNotation.cmi
lib/ocaml/gdome2/tNotation.mli
lib/ocaml/gdome2/tProcessingInstruction.cmi
lib/ocaml/gdome2/tProcessingInstruction.mli
lib/ocaml/gdome2/tText.cmi
lib/ocaml/gdome2/tText.mli
lib/ocaml/site-lib/gdome2/META
lib/ocaml/site-lib/gdome2/libmlgdome.so
share/gmetadom/gdome_cpp_smart.conf
@dirrm include/gmetadom/gdome_cpp_smart
@dirrm include/gmetadom
@dirrm lib/ocaml/gdome2
@dirrm lib/ocaml/site-lib/gdome2
@dirrm share/gmetadom
@exec echo "Updating %D/lib/ocaml/ld.conf"; echo "%D/lib/ocaml/site-lib/gdome2" >> %D/lib/ocaml/ld.conf
@unexec echo "Updating %D/lib/ocaml/ld.conf"; cp %D/lib/ocaml/ld.conf %D/lib/ocaml/ld.conf.tmp; grep -v "lib/ocaml/site-lib/gdome2" %D/lib/ocaml/ld.conf.tmp > %D/lib/ocaml/ld.conf; rm %D/lib/ocaml/ld.conf.tmp