o Use DOCSDIR and EXAMPLESDIR.
o Add patches now avialable for 1.5.4. o Bump PORTREVISION. PR: ports/57172 Submitted by: Udo Schweigert <udo.schweigert@siemens.com> (maintainer)
This commit is contained in:
parent
82321c277b
commit
909ac3ac52
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=89245
@ -72,7 +72,7 @@
|
||||
|
||||
PORTNAME= mutt-devel
|
||||
PORTVERSION= 1.5.4
|
||||
PORTREVISION?= 7
|
||||
PORTREVISION?= 8
|
||||
CATEGORIES+= mail ipv6
|
||||
.if defined(WITH_MUTT_NNTP)
|
||||
CATEGORIES+= news
|
||||
@ -94,11 +94,14 @@ MAINTAINER?= udo.schweigert@siemens.com
|
||||
COMMENT?= The Mongrel of Mail User Agents (part Elm, Pine, Mush, mh, etc.)
|
||||
|
||||
DIST_SUBDIR= mutt
|
||||
DOCSDIR?= ${PREFIX}/share/doc/mutt
|
||||
EXAMPLESDIR?= ${PREFIX}/share/examples/mutt
|
||||
DATADIR?= ${PREFIX}/share/mutt
|
||||
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LDFLAGS="${LDFLAGS}"
|
||||
CONFIGURE_ARGS= --enable-flock --disable-fcntl --with-ssl=${OPENSSLBASE} \
|
||||
--with-sharedir=${PREFIX}/share/mutt \
|
||||
--with-docdir=${PREFIX}/share/doc/mutt \
|
||||
--with-sharedir=${PREFIX}/share/mutt --with-docdir=${DOCSDIR} \
|
||||
--sysconfdir=${PREFIX}/etc --enable-external-dotlock \
|
||||
--with-libiconv-prefix=${PREFIX} --enable-pop --enable-imap
|
||||
.if defined(MUTT_CONFIGURE_ARGS)
|
||||
@ -115,7 +118,7 @@ SCRIPTS_ENV= WRKDIR="${WRKDIR}"
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
CD_PATCH_VERSION= 1.5.3
|
||||
CD_PATCH_VERSION= 1.5.4
|
||||
.if !defined(VVV_PATCH_VERSION)
|
||||
VVV_PATCH_VERSION= ${PORTVERSION}
|
||||
.endif
|
||||
@ -217,12 +220,11 @@ PATCHFILES+= patch-${VVV_PATCH_VERSION}.vvv.initials.gz:vvv \
|
||||
SGML_NEEDED= yes
|
||||
.endif
|
||||
.if defined(WITH_MUTT_EDIT_THREADS)
|
||||
PATCHFILES+= patch-${CD_PATCH_VERSION}.cd.edit_threads.9.3:cd
|
||||
PATCHFILES+= patch-${CD_PATCH_VERSION}.cd.edit_threads.9.5:cd
|
||||
CONFIGURE_ARGS+= --enable-imap-edit-threads
|
||||
SGML_NEEDED= yes
|
||||
.endif
|
||||
.if defined(WITH_MUTT_SIGNATURE_MENU)
|
||||
.error The WITH_MUTT_SIGNATURE_MENU is not available at the moment.
|
||||
PATCHFILES+= patch-${CD_PATCH_VERSION}.cd.signatures_menu.2.1:cd
|
||||
SGML_NEEDED= yes
|
||||
.endif
|
||||
@ -241,6 +243,8 @@ MAN5= muttrc.5 mbox.5
|
||||
post-patch::
|
||||
@${REINPLACE_CMD} -e 's,/usr/bin/gpg,${LOCALBASE}/bin/gpg,g' \
|
||||
${WRKSRC}/contrib/gpg.rc
|
||||
${REINPLACE_CMD} -E -e 's|@samplesdir@|${EXAMPLESDIR}|g' \
|
||||
${WRKSRC}/contrib/Makefile.in
|
||||
|
||||
pre-configure::
|
||||
@(cd ${WRKSRC}; ${SETENV} ${AUTOMAKE_ENV} ${ACLOCAL} -I m4)
|
||||
@ -278,8 +282,10 @@ post-patch::
|
||||
SCRIPTS_ENV+= MUTT_PORTDOCS="yes"
|
||||
post-build:
|
||||
${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-doc-ref
|
||||
printf ",s|\$${PREFIX}|%s|g\nw\nq\n" ${PREFIX} | \
|
||||
ed -s ${WRKSRC}/doc/mutt.man
|
||||
${REINPLACE_CMD} -E -e 's|\$$\{PREFIX\}|${PREFIX}|g' \
|
||||
-e 's|\$$\{DOCSDIR\}|${DOCSDIR}|g' \
|
||||
-e 's|\$$\{EXAMPLESDIR\}|${EXAMPLESDIR}|g' \
|
||||
${WRKSRC}/doc/mutt.man
|
||||
.if ! defined(WITHOUT_MUTT_HTML)
|
||||
SGML_USED= yes
|
||||
.endif
|
||||
@ -306,23 +312,18 @@ post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/Muttrc ${PREFIX}/etc/Muttrc.dist
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${ECHO} "===> Installing Mutt documentation"
|
||||
@${MKDIR} ${PREFIX}/share/doc/mutt && \
|
||||
${CHMOD} a+rx ${PREFIX}/share/doc/mutt
|
||||
@cd ${WRKSRC}/doc ; ${INSTALL_MAN} manual.txt \
|
||||
PGP-Notes.txt ../ABOUT-NLS ../contrib/language* \
|
||||
${PREFIX}/share/doc/mutt
|
||||
@${MKDIR} ${DOCSDIR} && ${CHMOD} a+rx ${DOCSDIR}
|
||||
@cd ${WRKSRC}/doc ; ${INSTALL_MAN} manual.txt PGP-Notes.txt \
|
||||
../ABOUT-NLS ../contrib/language* ${DOCSDIR}
|
||||
.if ${SGML_USED} == yes
|
||||
@cd ${WRKSRC}/doc ; ${INSTALL_MAN} manual.latin1 manual.ps \
|
||||
${PREFIX}/share/doc/mutt
|
||||
@cd ${WRKSRC}/doc ; ${INSTALL_MAN} manual.latin1 manual.ps ${DOCSDIR}
|
||||
.endif
|
||||
.if defined(WITH_MUTT_NNTP)
|
||||
@cd ${WRKSRC} ; ${INSTALL_MAN} ChangeLog.nntp \
|
||||
${PREFIX}/share/doc/mutt
|
||||
@cd ${WRKSRC} ; ${INSTALL_MAN} ChangeLog.nntp ${DOCSDIR}
|
||||
.endif
|
||||
.if ! defined(WITHOUT_MUTT_HTML)
|
||||
@${MKDIR} ${PREFIX}/share/doc/mutt/html && \
|
||||
${CHMOD} a+rx ${PREFIX}/share/doc/mutt/html
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/*.html ${PREFIX}/share/doc/mutt/html
|
||||
@${MKDIR} ${DOCSDIR}/html && ${CHMOD} a+rx ${DOCSDIR}/html
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/*.html ${DOCSDIR}/html
|
||||
.endif
|
||||
.endif
|
||||
.if defined(USE_SLANG)
|
||||
|
@ -3,7 +3,7 @@ MD5 (mutt/patch-1.5.4.rr.compressed.gz) = a7b37150c35ea65049b3cd1edab5079d
|
||||
MD5 (mutt/patch-1.5.4.vvv.nntp.gz) = d0cb0f609aa0461d1b17137bd49c14cb
|
||||
MD5 (mutt/patch-1.5.4.vvv.initials.gz) = d92517da934f5c32692aecf7ece596b7
|
||||
MD5 (mutt/patch-1.5.4.vvv.quote.gz) = 80d91491679b426b0f670fa965ae3777
|
||||
MD5 (mutt/patch-1.5.3.cd.edit_threads.9.3) = 753a19d8efdece04cd521c3a3079dc9f
|
||||
MD5 (mutt/patch-1.5.3.cd.signatures_menu.2.1) = 6db636f0004e73ee2d9f577acd4ed380
|
||||
MD5 (mutt/patch-1.5.3.cd.ifdef.1) = 01b47e075364834b82da053cac4eb69f
|
||||
MD5 (mutt/patch-1.5.4.cd.edit_threads.9.5) = f8d7fe6ea1a6a1b92c942f4446918433
|
||||
MD5 (mutt/patch-1.5.4.cd.signatures_menu.2.1) = 5b2298335071c46ee1f3ed8c689066b1
|
||||
MD5 (mutt/patch-1.5.4.cd.ifdef.1) = a545036cdb55519154d0b35465f52daa
|
||||
MD5 (mutt/p0-patch-1.5.4.dw.mbox-hook.1) = 326f415380cc377c99d2232f16267ffe
|
||||
|
@ -6,7 +6,7 @@
|
||||
mail under unix operating systems, including support color terminals, MIME,
|
||||
-and a threaded sorting mode.
|
||||
+and a threaded sorting mode. Details of how to use all of this is
|
||||
+available in \fI${PREFIX}/share/doc/mutt/\fP.
|
||||
+available in \fI${DOCSDIR}\fP.
|
||||
.SH OPTIONS
|
||||
.IP "-a \fIfile\fP"
|
||||
Attach a file to your message using MIME.
|
||||
|
14
mail/mutt-devel/files/patch-doc-mutt.man
Normal file
14
mail/mutt-devel/files/patch-doc-mutt.man
Normal file
@ -0,0 +1,14 @@
|
||||
--- doc/mutt.man.orig Wed Nov 13 11:07:05 2002
|
||||
+++ doc/mutt.man Wed Sep 24 15:36:17 2003
|
||||
@@ -148,9 +148,9 @@
|
||||
User's personal mapping between MIME types and file extensions.
|
||||
.IP "/etc/mime.types"
|
||||
System mapping between MIME types and file extensions.
|
||||
-.IP "/usr/local/bin/mutt_dotlock"
|
||||
+.IP "${PREFIX}/bin/mutt_dotlock"
|
||||
The privileged dotlocking program.
|
||||
-.IP "/usr/local/doc/mutt/manual.txt"
|
||||
+.IP "${DOCSDIR}/manual.txt"
|
||||
The Mutt manual.
|
||||
.SH BUGS
|
||||
.PP
|
@ -4,7 +4,7 @@
|
||||
mandir = @mandir@
|
||||
srcdir = @srcdir@
|
||||
docdir = @docdir@
|
||||
+samplesdir = @prefix@/share/examples/mutt
|
||||
+samplesdir = @samplesdir@
|
||||
top_srcdir = @top_srcdir@
|
||||
top_builddir = ..
|
||||
INSTALL = @INSTALL@
|
||||
|
@ -61,64 +61,64 @@ EOF
|
||||
|
||||
if [ "$MUTT_PORTDOCS" = "yes" ]; then
|
||||
cat >> $tmp_first <<EOF
|
||||
share/doc/mutt/ABOUT-NLS
|
||||
share/doc/mutt/COPYRIGHT
|
||||
share/doc/mutt/ChangeLog
|
||||
share/doc/mutt/ChangeLog.old
|
||||
share/doc/mutt/GPL
|
||||
share/doc/mutt/INSTALL
|
||||
share/doc/mutt/NEWS
|
||||
share/doc/mutt/PGP-Notes.txt
|
||||
share/doc/mutt/README
|
||||
share/doc/mutt/README.SECURITY
|
||||
share/doc/mutt/README.SSL
|
||||
share/doc/mutt/TODO
|
||||
share/doc/mutt/applying-patches.txt
|
||||
share/doc/mutt/devel-notes.txt
|
||||
share/doc/mutt/language.txt
|
||||
share/doc/mutt/language50.txt
|
||||
share/doc/mutt/manual.txt
|
||||
share/doc/mutt/patch-notes.txt
|
||||
share/doc/mutt/smime-notes.txt
|
||||
share/examples/mutt/Mush.rc
|
||||
share/examples/mutt/Pine.rc
|
||||
share/examples/mutt/Tin.rc
|
||||
share/examples/mutt/ca-bundle.crt
|
||||
share/examples/mutt/gpg.rc
|
||||
share/examples/mutt/pgp2.rc
|
||||
share/examples/mutt/pgp5.rc
|
||||
share/examples/mutt/pgp6.rc
|
||||
share/examples/mutt/sample.mailcap
|
||||
share/examples/mutt/sample.muttrc
|
||||
share/examples/mutt/sample.muttrc-tlr
|
||||
share/examples/mutt/smime.rc
|
||||
share/examples/mutt/smime_keys_test.pl
|
||||
share/examples/mutt/iconv/iconv.aix-3.2.5.rc
|
||||
share/examples/mutt/iconv/iconv.aix-4.1.5.rc
|
||||
share/examples/mutt/iconv/iconv.aix-4.2.0.rc
|
||||
share/examples/mutt/iconv/iconv.aix-4.3.2.rc
|
||||
share/examples/mutt/iconv/iconv.freebsd-3.3.rc
|
||||
share/examples/mutt/iconv/iconv.glibc-2.1.3.rc
|
||||
share/examples/mutt/iconv/iconv.glibc-2.1.90.rc
|
||||
share/examples/mutt/iconv/iconv.hpux-10.01.rc
|
||||
share/examples/mutt/iconv/iconv.hpux-10.20.rc
|
||||
share/examples/mutt/iconv/iconv.hpux-11.00.rc
|
||||
share/examples/mutt/iconv/iconv.irix-6.5.rc
|
||||
share/examples/mutt/iconv/iconv.osf1-4.0a.rc
|
||||
share/examples/mutt/iconv/iconv.osf1-4.0d.rc
|
||||
share/examples/mutt/iconv/iconv.solaris-2.4.rc
|
||||
share/examples/mutt/iconv/iconv.solaris-2.5.1.rc
|
||||
share/examples/mutt/iconv/iconv.solaris-2.6-cjk.rc
|
||||
share/examples/mutt/iconv/iconv.solaris-2.6.rc
|
||||
share/examples/mutt/iconv/iconv.solaris-2.7.rc
|
||||
%%DOCSDIR%%/ABOUT-NLS
|
||||
%%DOCSDIR%%/COPYRIGHT
|
||||
%%DOCSDIR%%/ChangeLog
|
||||
%%DOCSDIR%%/ChangeLog.old
|
||||
%%DOCSDIR%%/GPL
|
||||
%%DOCSDIR%%/INSTALL
|
||||
%%DOCSDIR%%/NEWS
|
||||
%%DOCSDIR%%/PGP-Notes.txt
|
||||
%%DOCSDIR%%/README
|
||||
%%DOCSDIR%%/README.SECURITY
|
||||
%%DOCSDIR%%/README.SSL
|
||||
%%DOCSDIR%%/TODO
|
||||
%%DOCSDIR%%/applying-patches.txt
|
||||
%%DOCSDIR%%/devel-notes.txt
|
||||
%%DOCSDIR%%/language.txt
|
||||
%%DOCSDIR%%/language50.txt
|
||||
%%DOCSDIR%%/manual.txt
|
||||
%%DOCSDIR%%/patch-notes.txt
|
||||
%%DOCSDIR%%/smime-notes.txt
|
||||
%%EXAMPLESDIR%%/Mush.rc
|
||||
%%EXAMPLESDIR%%/Pine.rc
|
||||
%%EXAMPLESDIR%%/Tin.rc
|
||||
%%EXAMPLESDIR%%/ca-bundle.crt
|
||||
%%EXAMPLESDIR%%/gpg.rc
|
||||
%%EXAMPLESDIR%%/pgp2.rc
|
||||
%%EXAMPLESDIR%%/pgp5.rc
|
||||
%%EXAMPLESDIR%%/pgp6.rc
|
||||
%%EXAMPLESDIR%%/sample.mailcap
|
||||
%%EXAMPLESDIR%%/sample.muttrc
|
||||
%%EXAMPLESDIR%%/sample.muttrc-tlr
|
||||
%%EXAMPLESDIR%%/smime.rc
|
||||
%%EXAMPLESDIR%%/smime_keys_test.pl
|
||||
%%EXAMPLESDIR%%/iconv/iconv.aix-3.2.5.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.aix-4.1.5.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.aix-4.2.0.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.aix-4.3.2.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.freebsd-3.3.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.glibc-2.1.3.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.glibc-2.1.90.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.hpux-10.01.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.hpux-10.20.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.hpux-11.00.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.irix-6.5.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.osf1-4.0a.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.osf1-4.0d.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.solaris-2.4.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.solaris-2.5.1.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.solaris-2.6-cjk.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.solaris-2.6.rc
|
||||
%%EXAMPLESDIR%%/iconv/iconv.solaris-2.7.rc
|
||||
EOF
|
||||
|
||||
if [ "$MUTT_NNTP" = "yes" ]; then
|
||||
echo "share/doc/mutt/ChangeLog.nntp" >> $tmp_first
|
||||
echo "%%DOCSDIR%%/ChangeLog.nntp" >> $tmp_first
|
||||
fi
|
||||
if [ "$MUTT_SGML" = "yes" ]; then
|
||||
echo "share/doc/mutt/manual.latin1" >> $tmp_first
|
||||
echo "share/doc/mutt/manual.ps" >> $tmp_first
|
||||
echo "%%DOCSDIR%%/manual.latin1" >> $tmp_first
|
||||
echo "%%DOCSDIR%%/manual.ps" >> $tmp_first
|
||||
fi
|
||||
|
||||
if [ "$MUTT_HTML" = "yes" ]; then
|
||||
@ -144,19 +144,19 @@ EOF
|
||||
if [ "$MUTT_PGP_PATCH" = "yes" ]; then
|
||||
html=$(($html + 2))
|
||||
fi
|
||||
echo "share/doc/mutt/html/manual.html" >> $tmp_first
|
||||
echo "share/doc/mutt/html/manual_toc.html" >> $tmp_first
|
||||
echo "%%DOCSDIR%%/html/manual.html" >> $tmp_first
|
||||
echo "%%DOCSDIR%%/html/manual_toc.html" >> $tmp_first
|
||||
i=1
|
||||
while [ $i -le $html ]; do
|
||||
echo "share/doc/mutt/html/manual$i.html" >> $tmp_first
|
||||
echo "%%DOCSDIR%%/html/manual$i.html" >> $tmp_first
|
||||
i=$(($i + 1))
|
||||
done
|
||||
echo "@dirrm share/doc/mutt/html" >> $tmp_last
|
||||
echo "@dirrm %%DOCSDIR%%/html" >> $tmp_last
|
||||
fi
|
||||
cat >> $tmp_last <<EOF
|
||||
@dirrm share/examples/mutt/iconv
|
||||
@dirrm share/examples/mutt
|
||||
@dirrm share/doc/mutt
|
||||
@dirrm %%EXAMPLESDIR%%/iconv
|
||||
@dirrm %%EXAMPLESDIR%%
|
||||
@dirrm %%DOCSDIR%%
|
||||
EOF
|
||||
fi
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user