Update to 0.15

- Update WWW

Changes:	https://github.com/ArtifexSoftware/jbig2dec/blob/master/CHANGES
Notified by:	tijl
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2018-09-04 18:40:08 +00:00
parent 6fc05eefd3
commit 908f997221
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=478973
4 changed files with 13 additions and 23 deletions

View File

@ -1,11 +1,9 @@
# $FreeBSD$
PORTNAME= jbig2dec
PORTVERSION= 0.14
PORTVERSION= 0.15
CATEGORIES= graphics devel
MASTER_SITES= http://downloads.ghostscript.com/public/${PORTNAME}/ \
LOCAL/sunpoet:tests
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MASTER_SITES= LOCAL/sunpoet:tests
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Decoder implementation of the JBIG2 image compression format
@ -23,6 +21,9 @@ INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
USES= autoreconf libtool
GH_ACCOUNT= ArtifexSoftware
USE_GITHUB= yes
SHEBANG_FILES= test_jbig2dec.py
python_CMD= ${PYTHON_CMD}
@ -37,10 +38,10 @@ post-patch:
@${RM} ${WRKSRC}/getopt* ${WRKSRC}/sha1.h
@${REINPLACE_CMD} -E 's|SHA1_Final\( *([^,]+), *([^\)]+)\)|SHA1_Final(\2, \1)|' ${WRKSRC}/jbig2dec.c ${WRKSRC}/sha1.c
post-patch-PNG-on:
@${REINPLACE_CMD} 's|png_check_sig|png_sig_cmp|g' ${WRKSRC}/configure
post-patch-TESTS-off:
@${REINPLACE_CMD} -e '/^TESTS = / s| test_jbig2dec.py||' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/^TESTS = / s| test_jbig2dec.py||' ${WRKSRC}/Makefile.am
pre-configure:
@cd ${WRKSRC}/ && ${SH} autogen.sh
.include <bsd.port.mk>

View File

@ -1,5 +1,5 @@
TIMESTAMP = 1507190988
SHA256 (jbig2dec-0.14.tar.gz) = 21b498c3ba566f283d02946f7e78e12abbad89f12fe4958974e50882c185014c
SIZE (jbig2dec-0.14.tar.gz) = 463572
TIMESTAMP = 1536075971
SHA256 (jb2streams.tar.gz) = 1b070a15468d186010047b5525b2eb99cdcda655576600d2d8a0d008b80a5ba2
SIZE (jb2streams.tar.gz) = 1000034
SHA256 (ArtifexSoftware-jbig2dec-0.15_GH0.tar.gz) = 1bae90922610244334f3d93d7d4f76ba31d8618e2f62c203e8b8e5de7023e4e3
SIZE (ArtifexSoftware-jbig2dec-0.15_GH0.tar.gz) = 130944

View File

@ -1,10 +0,0 @@
--- test_jbig2dec.py.orig 2015-12-01 15:52:01 UTC
+++ test_jbig2dec.py
@@ -52,6 +52,7 @@ class SelfTestSuite:
(len(self.fails),len(self.tests)))
else:
self.stream.write('PASSED all %d tests\n' % len(self.tests))
+ return 1
class KnownFileHash(SelfTest):
'self test to check for correct decode of known test files'

View File

@ -4,5 +4,4 @@ images at moderately high resolution, and in particular scanned paper documents.
In this domain it is very efficient, offering compression ratios on the order of
100:1.
WWW: http://www.ghostscript.com/jbig2dec.html
WWW: http://git.ghostscript.com/?p=jbig2dec.git
WWW: https://github.com/ArtifexSoftware/jbig2dec