- Snownews can take env argument so that it shows characters other that

iso-8859-1. Update makes possible to choose desired CHARSET upon
  the configuration time.
- replace "-lncursesw" to "-lncurses" when make with "CHARSET=UTF-8"
- bump PORTREVISION for those who may need to define CHARSET.

PR:		79286
Submitted by:	Aleksander Fafula <alex AT bsdguru dot org>
This commit is contained in:
Cheng-Lung Sung 2005-04-06 07:10:00 +00:00
parent 0beb95e46d
commit 907633217b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=132612
2 changed files with 20 additions and 7 deletions

View File

@ -8,6 +8,7 @@
PORTNAME= snownews
PORTVERSION= 1.5.6.1
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://kiza.kcore.de/software/snownews/download/
@ -18,12 +19,31 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= libxml2
USE_REINPLACE= yes
HAS_CONFIGURE= yes
.if defined(CHARSET)
CONFIGURE_ARGS= --charset=${CHARSET}
.if ${CHARSET} == "UTF-8"
post-configure:
@${REINPLACE_CMD} -e 's|ncursesw|ncurses|g' ${WRKSRC}/platform_settings
.endif
.endif
MAN1= snownews.1
MANLANG= "" de nl fr it ru_RU.KOI8-R
pre-everything::
@${ECHO_MSG} " "
@${ECHO_MSG} " You can set up CHARSET variable for your localization."
@${ECHO_MSG} " Example: make CHARSET=ISO-8859-2"
@${ECHO_MSG} " Default is ISO-8859-1."
@${ECHO_MSG} " "
post-patch:
@${REINPLACE_CMD} -e 's|CFLAGS=|CFLAGS+=|g' ${WRKSRC}/platform_settings
@${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/Makefile
pre-build:
@${REINPLACE_CMD} -e 's|^PREFIX|#PREFIX|' ${WRKSRC}/platform_settings
.include <bsd.port.mk>

View File

@ -1,7 +0,0 @@
--- platform_settings.orig Thu Dec 9 19:29:08 2004
+++ platform_settings Wed Jan 26 14:37:44 2005
@@ -1,3 +1,3 @@
-PREFIX= /usr/local
+#PREFIX= /usr/local
CFLAGS= -Wall -Wno-format-y2k -O2 -DLOCALEPATH="\"$(LOCALEPATH)\"" -DOS=\"$(shell uname)\" `xml2-config --cflags` $(EXTRA_CFLAGS) -DSTATIC_CONST_ICONV -I/usr/local/include
LDFLAGS= -lncurses `xml2-config --libs` $(EXTRA_LDFLAGS) -lintl -liconv