multimedia/kodi-devel: Update to latest commit
- Enable LIBBLURAY option by default
Changes: 4e01f3da2b...d571386e6f
This commit is contained in:
parent
013168e4fc
commit
9074133c81
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=465285
@ -1,8 +1,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= kodi
|
||||
DISTVERSION= 18.0.g201801112007
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 18.0.g201803211302
|
||||
CATEGORIES= multimedia
|
||||
PKGNAMESUFFIX?= -devel
|
||||
|
||||
@ -32,6 +31,7 @@ LIB_DEPENDS= libass.so:multimedia/libass \
|
||||
libfreetype.so:print/freetype2 \
|
||||
libfribidi.so:converters/fribidi \
|
||||
libgif.so:graphics/giflib \
|
||||
libgnutls.so:security/gnutls \
|
||||
liblcms2.so:graphics/lcms2 \
|
||||
liblzo2.so:archivers/lzo2 \
|
||||
libpcre.so:devel/pcre \
|
||||
@ -53,7 +53,7 @@ USES= autoreconf:build cmake:outsource,noninja compiler:c++11-lib \
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= xbmc
|
||||
GH_PROJECT= xbmc
|
||||
GH_TAGNAME= 4e01f3da2b0f17bd4da4c507691666695393527a
|
||||
GH_TAGNAME= d571386e6f848db993ac7f855fc911abc23e308a
|
||||
USE_GNOME= libxslt libxml2
|
||||
USE_JAVA= yes
|
||||
JAVA_BUILD= yes
|
||||
@ -78,7 +78,7 @@ PLIST_SUB= ARCH=${KODIARCH_${ARCH}:U${ARCH}} OPSYS=${OPSYS:tl} \
|
||||
|
||||
OPTIONS_DEFINE= AVAHI CEC DBUS LIBBLURAY MYSQL NFS SMB SSH UPNP VAAPI \
|
||||
VDPAU WEBSERVER
|
||||
OPTIONS_DEFAULT= SNDIO SSH UPNP VAAPI VDPAU WEBSERVER X11
|
||||
OPTIONS_DEFAULT= LIBBLURAY SNDIO SSH UPNP VAAPI VDPAU WEBSERVER X11
|
||||
OPTIONS_SINGLE= PLATFORM
|
||||
OPTIONS_SINGLE_PLATFORM= GBM RPI X11
|
||||
OPTIONS_EXCLUDE_amd64= RPI
|
||||
@ -154,7 +154,7 @@ VAAPI_CMAKE_BOOL= ENABLE_VAAPI
|
||||
VDPAU_LIB_DEPENDS= libvdpau.so:multimedia/libvdpau
|
||||
VDPAU_CMAKE_BOOL= ENABLE_VDPAU
|
||||
|
||||
WAYLAND_BROKEN= Requires default WAYLAND in graphics/mesa-libs and missing graphics/waylandpp port
|
||||
# Not enabled: Requires default WAYLAND in graphics/mesa-libs and missing graphics/waylandpp port
|
||||
WAYLAND_BUILD_DEPENDS= wayland-protocols>=0:graphics/wayland-protocols
|
||||
WAYLAND_CMAKE_ON= -DCORE_PLATFORM_NAME:STRING="wayland" \
|
||||
-DWAYLAND_RENDER_SYSTEM:STRING="gl"
|
||||
@ -167,6 +167,12 @@ WEBSERVER_CMAKE_BOOL= ENABLE_MICROHTTPD
|
||||
X11_CMAKE_ON= -DCORE_PLATFORM_NAME:STRING="x11"
|
||||
X11_USE= XORG=x11,xext,xrandr
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${SLAVE_PORT} == no
|
||||
PORTDATA= *
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
# Do not try to download dvdnav/dvdread during the build, instead
|
||||
# we'll manually point the build to the system's libdvd{nav,read}.so
|
||||
@ -175,9 +181,9 @@ post-patch:
|
||||
${WRKSRC}/cmake/modules/FindLibDvd.cmake
|
||||
@${CP} ${WRKSRC}/cmake/platform/linux/gbm.cmake \
|
||||
${WRKSRC}/cmake/platform/linux/rbpi.cmake \
|
||||
${WRKSRC}/cmake/platform/linux/wayland.cmake \
|
||||
${WRKSRC}/cmake/platform/freebsd
|
||||
|
||||
.if ${SLAVE_PORT} == no
|
||||
post-install:
|
||||
${INSTALL_MAN} ${WRKSRC}/docs/manpages/kodi.bin.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
|
||||
@cd ${STAGEDIR}${MAN1PREFIX}/man/man1 && ${LN} -sf kodi.bin.1.gz kodi.1.gz
|
||||
@ -185,5 +191,6 @@ post-install:
|
||||
@${FIND} ${STAGEDIR}${PREFIX}/lib/kodi -name '*.so' | ${XARGS} ${STRIP_CMD}
|
||||
# Nothing useful here...
|
||||
@${RM} -rf ${STAGEDIR}${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1515769119
|
||||
SHA256 (xbmc-xbmc-18.0.g201801112007-4e01f3da2b0f17bd4da4c507691666695393527a_GH0.tar.gz) = dce1ece2c08390eea2b173a6049773e800a6f912fb78418234ce11cef0fabbd2
|
||||
SIZE (xbmc-xbmc-18.0.g201801112007-4e01f3da2b0f17bd4da4c507691666695393527a_GH0.tar.gz) = 40670370
|
||||
SHA256 (xbmc-xbmc-18.0.g201803211302-d571386e6f848db993ac7f855fc911abc23e308a_GH0.tar.gz) = 310597a7ef631ff7220c3d1cfcbff1be4de3464e0b15f6b1ec16ce7fb2adee4d
|
||||
SIZE (xbmc-xbmc-18.0.g201803211302-d571386e6f848db993ac7f855fc911abc23e308a_GH0.tar.gz) = 41177182
|
||||
|
@ -1,43 +1,37 @@
|
||||
--- xbmc/platform/linux/input/LinuxInputDevices.cpp.orig 2017-12-17 12:10:14 UTC
|
||||
--- xbmc/platform/linux/input/LinuxInputDevices.cpp.orig 2018-03-21 13:02:45 UTC
|
||||
+++ xbmc/platform/linux/input/LinuxInputDevices.cpp
|
||||
@@ -30,6 +30,9 @@
|
||||
#include "system.h"
|
||||
#if defined(HAS_LINUX_EVENTS)
|
||||
@@ -31,7 +31,11 @@
|
||||
typedef unsigned long kernel_ulong_t;
|
||||
#define BITS_PER_LONG (sizeof(long)*8)
|
||||
|
||||
+#ifdef TARGET_FREEBSD
|
||||
+#if defined(TARGET_FREEBSD)
|
||||
+#include <dev/evdev/input.h>
|
||||
+#else
|
||||
#include <linux/version.h>
|
||||
|
||||
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,16)
|
||||
@@ -38,6 +41,7 @@ typedef unsigned long kernel_ulong_t;
|
||||
#endif
|
||||
|
||||
+#elif defined(TARGET_LINUX)
|
||||
#include <linux/input.h>
|
||||
+#endif
|
||||
|
||||
#if defined(HAVE_LIBUDEV)
|
||||
#include <libudev.h>
|
||||
@@ -77,8 +81,10 @@ typedef unsigned long kernel_ulong_t;
|
||||
@@ -71,8 +75,10 @@ typedef unsigned long kernel_ulong_t;
|
||||
#define XBMC_BUTTON_WHEELDOWN 5
|
||||
#endif
|
||||
|
||||
+#ifndef TARGET_FREEBSD
|
||||
+#ifdef TARGET_LINUX
|
||||
#include <linux/keyboard.h>
|
||||
#include <linux/kd.h>
|
||||
+#endif
|
||||
|
||||
#include <string.h>
|
||||
#include <unistd.h>
|
||||
@@ -352,6 +358,7 @@ XBMCKey CLinuxInputDevice::TranslateKey(unsigned short
|
||||
@@ -346,6 +352,7 @@ XBMCKey CLinuxInputDevice::TranslateKey(unsigned short
|
||||
|
||||
int CLinuxInputDevice::KeyboardGetSymbol(unsigned short value)
|
||||
{
|
||||
+#ifndef TARGET_FREEBSD
|
||||
+#ifdef TARGET_LINUX
|
||||
unsigned char type = KTYP(value);
|
||||
unsigned char index = KVAL(value);
|
||||
|
||||
@@ -409,12 +416,16 @@ int CLinuxInputDevice::KeyboardGetSymbol(unsigned shor
|
||||
@@ -403,12 +410,16 @@ int CLinuxInputDevice::KeyboardGetSymbol(unsigned shor
|
||||
break;
|
||||
*/
|
||||
}
|
||||
@ -55,7 +49,7 @@
|
||||
struct kbentry entry;
|
||||
|
||||
entry.kb_table = table;
|
||||
@@ -429,6 +440,7 @@ unsigned short CLinuxInputDevice::KeyboardReadValue(un
|
||||
@@ -423,6 +434,7 @@ unsigned short CLinuxInputDevice::KeyboardReadValue(un
|
||||
}
|
||||
|
||||
return entry.kb_value;
|
||||
@ -63,7 +57,7 @@
|
||||
}
|
||||
|
||||
XBMCMod CLinuxInputDevice::UpdateModifiers(XBMC_Event& devt)
|
||||
@@ -1371,6 +1383,9 @@ driver_open_device_error:
|
||||
@@ -1365,6 +1377,9 @@ driver_open_device_error:
|
||||
*/
|
||||
bool CLinuxInputDevice::GetKeymapEntry(KeymapEntry& entry)
|
||||
{
|
||||
@ -73,7 +67,7 @@
|
||||
int code = entry.code;
|
||||
unsigned short value;
|
||||
//DFBInputDeviceKeyIdentifier identifier;
|
||||
@@ -1421,6 +1436,7 @@ bool CLinuxInputDevice::GetKeymapEntry(KeymapEntry& en
|
||||
@@ -1415,6 +1430,7 @@ bool CLinuxInputDevice::GetKeymapEntry(KeymapEntry& en
|
||||
entry.altShift = value; //KeyboardGetSymbol(code, value, LI_KEYLEVEL_ALT_SHIFT);
|
||||
|
||||
return true;
|
||||
@ -81,7 +75,7 @@
|
||||
}
|
||||
|
||||
/*
|
||||
--- xbmc/windowing/wayland/InputProcessorPointer.cpp.orig 2017-12-17 12:10:14 UTC
|
||||
--- xbmc/windowing/wayland/InputProcessorPointer.cpp.orig 2018-03-21 13:02:45 UTC
|
||||
+++ xbmc/windowing/wayland/InputProcessorPointer.cpp
|
||||
@@ -22,7 +22,11 @@
|
||||
|
||||
@ -93,9 +87,9 @@
|
||||
#include <linux/input-event-codes.h>
|
||||
+#endif
|
||||
|
||||
#include "input/MouseStat.h"
|
||||
#include "input/mouse/MouseStat.h"
|
||||
|
||||
--- xbmc/windowing/wayland/WindowDecorator.cpp.orig 2017-12-17 12:10:14 UTC
|
||||
--- xbmc/windowing/wayland/WindowDecorator.cpp.orig 2018-03-21 13:02:45 UTC
|
||||
+++ xbmc/windowing/wayland/WindowDecorator.cpp
|
||||
@@ -25,7 +25,11 @@
|
||||
#include <cmath>
|
||||
@ -108,4 +102,4 @@
|
||||
+#endif
|
||||
|
||||
#include "threads/SingleLock.h"
|
||||
#include "utils/EndianSwap.h"
|
||||
#include "Util.h"
|
||||
|
@ -33,17 +33,7 @@
|
||||
+xbmc/cores/RetroPlayer/process/rbpi cores/RetroPlayer/process/rbpi
|
||||
+xbmc/cores/VideoPlayer/Process/rbpi cores/VideoPlayer/Process/rbpi
|
||||
xbmc/freebsd freebsdsupport
|
||||
--- xbmc/cores/VideoPlayer/VideoRenderers/HwDecRender/MMALRenderer.h.orig 2018-01-04 22:35:33 UTC
|
||||
+++ xbmc/cores/VideoPlayer/VideoRenderers/HwDecRender/MMALRenderer.h
|
||||
@@ -31,6 +31,7 @@
|
||||
#include "cores/VideoSettings.h"
|
||||
#include "cores/VideoPlayer/DVDStreamInfo.h"
|
||||
#include "guilib/Geometry.h"
|
||||
+#include "platform/linux/RBP.h"
|
||||
#include "threads/Thread.h"
|
||||
|
||||
// worst case number of buffers. 12 for decoder. 8 for multi-threading in ffmpeg. NUM_BUFFERS for renderer.
|
||||
--- xbmc/windowing/rpi/WinSystemRpi.cpp.orig 2018-01-05 07:10:41 UTC
|
||||
--- xbmc/windowing/rpi/WinSystemRpi.cpp.orig 2018-02-09 09:50:14 UTC
|
||||
+++ xbmc/windowing/rpi/WinSystemRpi.cpp
|
||||
@@ -32,9 +32,16 @@
|
||||
#include "settings/DisplaySettings.h"
|
||||
@ -59,10 +49,10 @@
|
||||
+#ifdef HAS_SNDIO
|
||||
+#include "cores/AudioEngine/Sinks/AESinkSNDIO.h"
|
||||
+#endif
|
||||
#include "powermanagement/linux/LinuxPowerSyscall.h"
|
||||
|
||||
#include <EGL/egl.h>
|
||||
#include <EGL/eglplatform.h>
|
||||
@@ -54,7 +61,36 @@ CWinSystemRpi::CWinSystemRpi()
|
||||
@@ -55,7 +62,36 @@ CWinSystemRpi::CWinSystemRpi()
|
||||
|
||||
m_winEvents.reset(new CWinEventsLinux());
|
||||
AE::CAESinkFactory::ClearSinks();
|
||||
@ -97,6 +87,6 @@
|
||||
+ CAESinkPi::Register();
|
||||
+#endif
|
||||
+ }
|
||||
CLinuxPowerSyscall::Register();
|
||||
}
|
||||
|
||||
CWinSystemRpi::~CWinSystemRpi()
|
||||
|
@ -1,6 +1,16 @@
|
||||
--- xbmc/windowing/wayland/WinSystemWayland.cpp.orig 2018-01-05 12:46:19 UTC
|
||||
--- xbmc/windowing/wayland/ShellSurfaceXdgShell.h.orig 2018-03-21 13:02:45 UTC
|
||||
+++ xbmc/windowing/wayland/ShellSurfaceXdgShell.h
|
||||
@@ -22,6 +22,7 @@
|
||||
#include "Connection.h"
|
||||
#include "ShellSurface.h"
|
||||
|
||||
+#include <wayland-client-protocol.hpp>
|
||||
#include <wayland-extra-protocols.hpp>
|
||||
|
||||
namespace KODI
|
||||
--- xbmc/windowing/wayland/WinSystemWayland.cpp.orig 2018-03-21 13:02:45 UTC
|
||||
+++ xbmc/windowing/wayland/WinSystemWayland.cpp
|
||||
@@ -1308,7 +1308,7 @@ void CWinSystemWayland::PrepareFramePresentation()
|
||||
@@ -1331,7 +1331,7 @@ void CWinSystemWayland::PrepareFramePresentation()
|
||||
};
|
||||
feedback.on_presented() = [this,iter](std::uint32_t tvSecHi, std::uint32_t tvSecLo, std::uint32_t tvNsec, std::uint32_t refresh, std::uint32_t seqHi, std::uint32_t seqLo, wayland::presentation_feedback_kind flags)
|
||||
{
|
||||
@ -9,3 +19,13 @@
|
||||
std::int64_t latency{KODI::LINUX::TimespecDifference(iter->submissionTime, tv)};
|
||||
std::uint64_t msc{(static_cast<std::uint64_t>(seqHi) << 32) + seqLo};
|
||||
m_presentationFeedbackHandlers.Invoke(tv, refresh, m_syncOutputID, m_syncOutputRefreshRate, msc);
|
||||
--- xbmc/windowing/wayland/WinSystemWayland.h.orig 2018-03-21 13:02:45 UTC
|
||||
+++ xbmc/windowing/wayland/WinSystemWayland.h
|
||||
@@ -28,6 +28,7 @@
|
||||
#include <set>
|
||||
|
||||
#include <wayland-client.hpp>
|
||||
+#include <wayland-client-protocol.hpp>
|
||||
#include <wayland-cursor.hpp>
|
||||
#include <wayland-extra-protocols.hpp>
|
||||
|
||||
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user