Fix build on -current.

This commit is contained in:
Adam Weinberger 2014-08-16 23:40:00 +00:00
parent 12e9ef1a2f
commit 906b6449fb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=365143
2 changed files with 12 additions and 1 deletions

View File

@ -15,7 +15,7 @@ COMMENT= Text based Hotline Communications client for Unix
LICENSE= GPLv1
OPTIONS_DEFINE= WARNINGS HTXF_PTHREAD HFS HOPE CIPHER COMPRESS HAL XMMS NOIPV4
OPTIONS_DEFAULT= HTXF_PTHREAD HFS HOPE CIPHER COMPRESS XMMS
OPTIONS_DEFAULT=HTXF_PTHREAD HFS HOPE CIPHER COMPRESS XMMS
WARNINGS_DESC= Show compiler warnings
HTXF_PTHREAD_DESC= Use pthread instead of fork or clone for htxf

View File

@ -0,0 +1,11 @@
--- ./src/Makefile.in.orig 2014-08-16 19:38:31.000000000 -0400
+++ ./src/Makefile.in 2014-08-16 19:38:57.000000000 -0400
@@ -34,7 +34,7 @@
LDFLAGS = @LDFLAGS@
SYS_INCLUDES = @SYS_INCLUDES@
INCLUDE = -I. -I./include -I$(top_include)
-CFLAGS = @CFLAGS@ $(INCLUDE) $(SYS_INCLUDES) $(DEFS)
+CFLAGS = @CFLAGS@ $(INCLUDE) $(SYS_INCLUDES) @CPPFLAGS@ $(DEFS)
# Libraries