- Update to version 1.55

PR:		57354
Submitted by:	Ports Fury
This commit is contained in:
Kirill Ponomarev 2003-10-01 10:44:26 +00:00
parent 3fec57a168
commit 906b54bd81
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=89959
4 changed files with 100 additions and 106 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= scite
PORTVERSION= 1.50
PORTVERSION= 1.55
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.scintilla.org/
@ -23,11 +23,26 @@ WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehier gtk12
MAKEFILE= makefile
MAKE_ENV= MKDIR="${MKDIR}"
post-extract:
@${PERL} -pi -e 's|\x0d||' ${WRKSRC}/makefile
.if defined(WITH_GTK2)
USE_GNOME= gtk20
PKGNAMESUFFIX= -gtk2
.else
USE_GNOME= gtk12
MAKE_ARGS= GTK1=yes
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/../bin/SciTE ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/../doc/scite.1 ${MANPREFIX}/man/man1
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/../src/*.properties ${DATADIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/../doc/*.html ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/../doc/*.jpg ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/../doc/*.png ${DOCSDIR}
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (scite150.tgz) = ae1c5936acca2040dd09b42d266f1294
MD5 (scite155.tgz) = f5292ac35853207d648c39decc165d63

View File

@ -1,25 +1,31 @@
$FreeBSD$
--- makefile.orig Thu Feb 6 10:52:36 2003
+++ makefile Thu Feb 6 10:56:10 2003
@@ -10,34 +10,34 @@
--- makefile.orig Fri Aug 15 23:31:32 2003
+++ makefile Sun Sep 28 13:23:50 2003
@@ -5,7 +5,7 @@
# GNU make does not like \r\n line endings so should be saved to CVS in binary form.
# For the Gnome desktop stuff to work, prefix must point to where Gnome thinks it is.
# "h@h@" is printed here when gnome-config unavailable. Seems harmless.
.SUFFIXES: .cxx .o .h .a
-CC = g++
+CC ?= g++
AR = ar
# If explicit setting of GTK1 or GTK2 then use that else look for
@@ -27,9 +27,9 @@
CONFIGLIB=pkg-config --libs gtk+-2.0 gthread-2.0
gnomeprefix:=$(shell pkg-config --variable=prefix gtk+-2.0 2>/dev/null)
else
-CONFIGFLAGS=gtk-config --cflags
-CONFIGLIB=gtk-config --libs
-gnomeprefix:=$(shell gnome-config --prefix 2>/dev/null)
+CONFIGFLAGS=pkg-config --cflags gtk+ gthread
+CONFIGLIB=pkg-config --libs gtk+ gthread
+gnomeprefix:=$(PREFIX)
endif
ifdef gnomeprefix
prefix=$(gnomeprefix)
- datadir=$(gnomeprefix)/share
+ datadir=$(gnomeprefix)/share/gnome
pixmapdir=$(datadir)/pixmaps
else
prefix=/usr/local
endif
bindir=$(prefix)/bin
-SYSCONF_PATH=$(prefix)/share/scite
+SYSCONF_PATH=$(prefix)/share/gnome/scite
@@ -43,17 +43,17 @@
PROG = ../bin/SciTE
@ -34,58 +40,21 @@ $FreeBSD$
ifdef DEBUG
-CXXFLAGS=-DDEBUG -g $(CXXBASEFLAGS)
+CXXFLAGS+=-DDEBUG -g $(CXXBASEFLAGS)
+CXXFLAGS+=-DDEBUG $(CXXBASEFLAGS)
else
-CXXFLAGS=-DNDEBUG -Os $(CXXBASEFLAGS)
+CXXFLAGS+=-DNDEBUG $(CXXBASEFLAGS)
endif
.cxx.o:
- $(CC) `gtk-config --cflags` $(CXXFLAGS) -c $< -o $@
+ $(CC) $(shell $(GTK_CONFIG) --cflags) $(CXXFLAGS) -c $< -o $@
all: $(PROG)
@@ -45,14 +45,14 @@
rm -f *.o $(PROG)
deps:
- $(CC) -MM `gtk-config --cflags` $(CXXFLAGS) *.cxx ../src/*.cxx >deps.mak
+ $(CC) -MM `$(GTK_CONFIG) --cflags` $(CXXFLAGS) *.cxx ../src/*.cxx >deps.mak
# make should be run in ../../scintilla/gtk to compile all the lexers.
@@ -71,8 +71,8 @@
LEXEROBJS=$(wildcard ../../scintilla/gtk/Lex*.o)
-$(PROG): SciTEGTK.o SciTEBase.o SciTEBuffers.o SciTEIO.o Exporters.o DirectorExtension.o \
$(PROG): SciTEGTK.o SciTEBase.o SciTEBuffers.o SciTEIO.o Exporters.o DirectorExtension.o \
-SciTEProps.o Utf8_16.o $(LEXEROBJS) ../../scintilla/bin/scintilla.a
- $(CC) `gtk-config --libs` `glib-config --libs gthread` -DGTK $^ -o $@
+$(PROG): SciTEGTK.o SciTEBase.o SciTEBuffers.o SciTEIO.o Exporters.o DirectorExtension.o Utf8_16.o \
+SciTEProps.o # $(LEXEROBJS) ../../scintilla/bin/scintilla.a
+ $(CC) $(shell $(GTK_CONFIG) --libs) $(shell $(GLIB_CONFIG) --libs gthread) -DGTK $^ -L$(X11BASE)/lib -lscintilla -lscintilla_lexers -o $@
- $(CC) `$(CONFIGLIB)` `glib-config --libs gthread` -DGTK $^ -o $@
+SciTEProps.o Utf8_16.o
+ $(CC) `$(CONFIGLIB)` -lscintilla -lscintilla_lexers -DGTK $^ -o $@
# SciTE-static no longer builds. Kept here in case of later need.
SciTE-static: SciTEGTK.o SciTEBase.o SciTEBuffers.o SciTEIO.o Exporters.o SciTEProps.o \
@@ -66,15 +66,15 @@
# This is OK - just means no SciTE in the Gnome Applications menu
# Dead: install -D SciTEGTK.properties $(SYSCONF_PATH)/SciTEGlobal.properties
install:
- install -s $(PROG) $(bindir)
- install -d $(SYSCONF_PATH)
- install ../src/*.properties $(SYSCONF_PATH)
- install ../doc/*.html $(SYSCONF_PATH)
- install ../doc/SciTEIco.png $(SYSCONF_PATH)
- install ../doc/PrintHi.png $(SYSCONF_PATH)
+ $(BSD_INSTALL_PROGRAM) $(PROG) $(bindir)
+ $(MKDIR) $(SYSCONF_PATH)
+ $(BSD_INSTALL_DATA) ../src/*.properties $(SYSCONF_PATH)
+ $(BSD_INSTALL_DATA) ../doc/*.html $(SYSCONF_PATH)
+ $(BSD_INSTALL_DATA) ../doc/SciTEIco.png $(SYSCONF_PATH)
+ $(BSD_INSTALL_DATA) ../doc/PrintHi.png $(SYSCONF_PATH)
ifdef gnomeprefix
- install SciTE.desktop $(datadir)/gnome/apps/Applications
- install Sci48M.png $(pixmapdir)
+ $(BSD_INSTALL_DATA) SciTE.desktop $(datadir)/apps/Applications
+ $(BSD_INSTALL_DATA) Sci48M.png $(pixmapdir)
endif
uninstall:

View File

@ -1,44 +1,54 @@
bin/SciTE
share/gnome/apps/Applications/SciTE.desktop
share/gnome/pixmaps/Sci48M.png
share/gnome/scite/Embedded.properties
share/gnome/scite/PrintHi.png
share/gnome/scite/SciTE.html
share/gnome/scite/SciTE.properties
share/gnome/scite/SciTEDirector.html
share/gnome/scite/SciTEDoc.html
share/gnome/scite/SciTEDownload.html
share/gnome/scite/SciTEExtension.html
share/gnome/scite/SciTEExtras.html
share/gnome/scite/SciTEGlobal.properties
share/gnome/scite/SciTEIco.png
share/gnome/scite/SciTEImage.html
share/gnome/scite/SciTELexer.html
share/gnome/scite/SciTERegEx.html
share/gnome/scite/SciTETranslation.html
share/gnome/scite/abbrev.properties
share/gnome/scite/ada.properties
share/gnome/scite/asm.properties
share/gnome/scite/ave.properties
share/gnome/scite/baan.properties
share/gnome/scite/bullant.properties
share/gnome/scite/conf.properties
share/gnome/scite/cpp.properties
share/gnome/scite/css.properties
share/gnome/scite/eiffel.properties
share/gnome/scite/fortran.properties
share/gnome/scite/html.properties
share/gnome/scite/latex.properties
share/gnome/scite/lisp.properties
share/gnome/scite/lua.properties
share/gnome/scite/matlab.properties
share/gnome/scite/nncrontab.properties
share/gnome/scite/others.properties
share/gnome/scite/pascal.properties
share/gnome/scite/perl.properties
share/gnome/scite/python.properties
share/gnome/scite/ruby.properties
share/gnome/scite/sql.properties
share/gnome/scite/tcl.properties
share/gnome/scite/vb.properties
@dirrm share/gnome/scite
%%PORTDOCS%%%%DOCSDIR%%/PrintHi.png
%%PORTDOCS%%%%DOCSDIR%%/SciBreak2.jpg
%%PORTDOCS%%%%DOCSDIR%%/SciTE.html
%%PORTDOCS%%%%DOCSDIR%%/SciTEDirector.html
%%PORTDOCS%%%%DOCSDIR%%/SciTEDoc.html
%%PORTDOCS%%%%DOCSDIR%%/SciTEDownload.html
%%PORTDOCS%%%%DOCSDIR%%/SciTEExtension.html
%%PORTDOCS%%%%DOCSDIR%%/SciTEExtras.html
%%PORTDOCS%%%%DOCSDIR%%/SciTEIco.png
%%PORTDOCS%%%%DOCSDIR%%/SciTEImage.html
%%PORTDOCS%%%%DOCSDIR%%/SciTELexer.html
%%PORTDOCS%%%%DOCSDIR%%/SciTERegEx.html
%%PORTDOCS%%%%DOCSDIR%%/SciTETranslation.html
%%PORTDOCS%%%%DOCSDIR%%/SciTEWord.jpg
%%PORTDOCS%%%%DOCSDIR%%/demo.png
%%DATADIR%%/Embedded.properties
%%DATADIR%%/SciTE.properties
%%DATADIR%%/SciTEGlobal.properties
%%DATADIR%%/abbrev.properties
%%DATADIR%%/ada.properties
%%DATADIR%%/asm.properties
%%DATADIR%%/ave.properties
%%DATADIR%%/baan.properties
%%DATADIR%%/bullant.properties
%%DATADIR%%/conf.properties
%%DATADIR%%/cpp.properties
%%DATADIR%%/css.properties
%%DATADIR%%/eiffel.properties
%%DATADIR%%/escript.properties
%%DATADIR%%/fortran.properties
%%DATADIR%%/html.properties
%%DATADIR%%/latex.properties
%%DATADIR%%/lisp.properties
%%DATADIR%%/lout.properties
%%DATADIR%%/lua.properties
%%DATADIR%%/matlab.properties
%%DATADIR%%/mmixal.properties
%%DATADIR%%/nncrontab.properties
%%DATADIR%%/nsis.properties
%%DATADIR%%/others.properties
%%DATADIR%%/pascal.properties
%%DATADIR%%/perl.properties
%%DATADIR%%/pov.properties
%%DATADIR%%/ps.properties
%%DATADIR%%/python.properties
%%DATADIR%%/ruby.properties
%%DATADIR%%/scriptol.properties
%%DATADIR%%/sql.properties
%%DATADIR%%/tcl.properties
%%DATADIR%%/vb.properties
%%DATADIR%%/yaml.properties
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%