lang/io, lang/io-devel: fix build on !x86

While at it, add test target to io-devel.

PR:		246225
Submitted by:	pkubaj
This commit is contained in:
Pietro Cerutti 2020-05-26 09:15:55 +00:00
parent 169f18b15e
commit 9059621629
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=536598
4 changed files with 10 additions and 4 deletions

View File

@ -31,9 +31,13 @@ CMAKE_ARGS= -DWITHOUT_EERIE:BOOL=ON
.include <bsd.port.pre.mk>
# disable sse on non-x86 archs
# disable SSE on non-x86 archs
.if ${ARCH} != amd64 && ${ARCH} != i386
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-CMakeLists.txt
.endif
do-test:
cd ${BUILD_WRKSRC} && \
./_build/binaries/io ${WRKSRC}/libs/iovm/tests/correctness/run.io
.include <bsd.port.post.mk>

View File

@ -1,10 +1,11 @@
--- CMakeLists.txt.orig 2018-08-07 11:40:49 UTC
+++ CMakeLists.txt
@@ -41,7 +41,6 @@ IF(CMAKE_COMPILER_IS_GNUCC OR (CMAKE_C_C
@@ -41,7 +41,7 @@ IF(CMAKE_COMPILER_IS_GNUCC OR (CMAKE_C_C
SET(CMAKE_BUILD_TYPE_DebugFast)
SET(CMAKE_CXX_FLAGS_DEBUGFAST "-g -O0")
SET(CMAKE_C_FLAGS_DEBUGFAST "-g -O0")
- SET(CMAKE_C_FLAGS "-msse2")
+ SET(CMAKE_C_FLAGS "-D__SIMD_NO_SIMD__")
if(NOT CMAKE_BUILD_TYPE)
SET(CMAKE_BUILD_TYPE "DebugFast")
endif(NOT CMAKE_BUILD_TYPE)

View File

@ -35,7 +35,7 @@ OPTIONS_SUB= yes
.include <bsd.port.pre.mk>
# disable sse on non-x86 archs
# disable SSE on non-x86 archs
.if ${ARCH} != amd64 && ${ARCH} != i386
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-CMakeLists.txt
.endif

View File

@ -1,10 +1,11 @@
--- CMakeLists.txt.orig 2019-04-05 06:24:16 UTC
+++ CMakeLists.txt
@@ -39,7 +39,6 @@ IF(CMAKE_COMPILER_IS_GNUCC OR (CMAKE_C_C
@@ -39,7 +39,7 @@ IF(CMAKE_COMPILER_IS_GNUCC OR (CMAKE_C_C
SET(CMAKE_BUILD_TYPE_DebugFast)
SET(CMAKE_CXX_FLAGS_DEBUGFAST "-g -O0")
SET(CMAKE_C_FLAGS_DEBUGFAST "-g -O0")
- SET(CMAKE_C_FLAGS "-msse2")
+ SET(CMAKE_C_FLAGS "-D__SIMD_NO_SIMD__")
if(NOT CMAKE_BUILD_TYPE)
SET(CMAKE_BUILD_TYPE "DebugFast")
endif(NOT CMAKE_BUILD_TYPE)