- Support CFLAGS/CXXFLAGS properly

- Mark as BROKEN on 4-stable

PR:		42901
Submitted by:	Ports Fury
This commit is contained in:
Ying-Chieh Liao 2002-09-20 07:14:30 +00:00
parent c4aab5ee8b
commit 90321d0701
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=66807
3 changed files with 58 additions and 31 deletions

View File

@ -8,6 +8,7 @@
PORTNAME= imlib3d
PORTVERSION= 0.8.0
PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -15,24 +16,30 @@ DISTNAME= ImLib3D-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl \
fftw:${PORTSDIR}/math/fftw \
LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw \
gsl.3:${PORTSDIR}/math/gsl \
xml2.5:${PORTSDIR}/textproc/libxml2 \
gtkmm:${PORTSDIR}/x11-toolkits/gtk-- \
gtkgl:${PORTSDIR}/x11-toolkits/gtkglarea \
gtkglmm:${PORTSDIR}/x11-toolkits/gtkglarea--
gtkglmm.1:${PORTSDIR}/x11-toolkits/gtkglarea--
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_MESA= yes
USE_FREETYPE= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2/libxml" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-libimx --enable-optimize
#USE_FREETYPE= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-optimize
INSTALLS_SHLIB= yes
post-patch:
@${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
.include <bsd.port.pre.mk>
.include <bsd.port.mk>
.if ${OSVERSION} < 500000
#BROKEN= "does not build with GCC 2.x"
.endif
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|OPTIMIZE_FLAGS=.*$$|OPTIMIZE_FLAGS=|g ; \
s|<xmlversion.h>|<libxml/xmlversion.h>|g' ${WRKSRC}/configure
.include <bsd.port.post.mk>

View File

@ -0,0 +1,25 @@
--- ltmain.sh.orig Mon Sep 16 04:01:31 2002
+++ ltmain.sh Mon Sep 16 04:02:12 2002
@@ -2408,6 +2408,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
if test "$build_libtool_need_lc" = "yes"; then
@@ -4175,10 +4178,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -222,37 +222,32 @@ include/newmat/newmatrm.h
include/newmat/precisio.h
include/newmat/solution.h
lib/libGnuPlotInterface.a
lib/libGnuPlotInterface.la
lib/libGnuPlotInterface.so
lib/libGnuPlotInterface.so.0
lib/libImLib3D-0.8.so
lib/libImLib3D-0.8.so.1
lib/libImLib3D.a
lib/libImLib3D.la
lib/libImLib3D.so
lib/libImLib3DCalls.a
lib/libImLib3DCalls.la
lib/libImLib3DCalls.so
lib/libImLib3DCalls.so.0
lib/libavwio.a
lib/libavwio.la
lib/libavwio.so
lib/libavwio.so.0
lib/libnewmat.a
lib/libnewmat.la
lib/libnewmat.so
lib/libnewmat.so.0
@dirrm include/GnuPlotInterface
@dirrm include/ImLib3D
@dirrm include/boost/config/compiler
@dirrm include/boost/config/platform
@dirrm include/boost/config/stdlib
@dirrm include/boost/config
@dirrm include/boost/preprocessor/arithmetic
@dirrm include/boost/preprocessor/comparison
@dirrm include/boost/preprocessor/list
@dirrm include/boost/preprocessor/logical
@dirrm include/boost/preprocessor/tuple
@dirrm include/boost/preprocessor
@dirrm include/boost/type_traits
@dirrm include/boost/preprocessor/tuple
@dirrm include/boost/preprocessor/logical
@dirrm include/boost/preprocessor/list
@dirrm include/boost/preprocessor/comparison
@dirrm include/boost/preprocessor/arithmetic
@dirrm include/boost/preprocessor
@dirrm include/boost/config/stdlib
@dirrm include/boost/config/platform
@dirrm include/boost/config/compiler
@dirrm include/boost/config
@dirrm include/boost
@dirrm include/ImLib3D
@dirrm include/GnuPlotInterface