www/mod_md-devel: Don't require full boulder install

See: https://github.com/icing/mod_md/issues/80
This commit is contained in:
Bernard Spil 2018-03-11 20:00:47 +00:00
parent 92d20276e2
commit 902b9e3f74
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=464201

View File

@ -0,0 +1,44 @@
diff --git a/ChangeLog b/ChangeLog
index 6de5fc4..2f70ce4 100644
--- ChangeLog.orig
+++ ChangeLog
@@ -1,3 +1,8 @@
+v1.1.9-DEV
+----------------------------------------------------------------------------------------------------
+ * Removed bould check from configure. Not everone building the module needs it installed.
+ Fixes #76.
+
v1.1.8
----------------------------------------------------------------------------------------------------
* new configuration directive "MDBaseServer on|off" to allow/inhibit management of the base
diff --git a/configure.ac b/configure.ac
index 0e1a44a..7b54209 100644
--- configure.ac.orig
+++ configure.ac
@@ -177,10 +177,8 @@ AC_SUBST(BOULDER_TOS)
# the path where boulder is installed
if test "x$request_boulder_dir" = "xdef"; then
BOULDER_DIR="$GOPATH/src/github.com/letsencrypt/boulder"
- test -d "$BOULDER_DIR" || AC_MSG_ERROR([boulder installation not found in default location $BOULDER_DIR. Please use --with-boulder-dir to specify the correct location. ])
else
BOULDER_DIR="$request_boulder_dir"
- test -d "$BOULDER_DIR" || AC_MSG_ERROR([boulder installation not found as specified in $BOULDER_DIR.])
fi
AC_SUBST(BOULDER_DIR)
diff --git a/test/Makefile.am b/test/Makefile.am
index bca8fc6..e30eb6d 100644
--- test/Makefile.am.orig
+++ test/Makefile.am
@@ -89,7 +89,11 @@ test-configs: $(SERVER_DIR)/.test-setup
# The certificates we need to verify the cert chain we retrieved from ACME
# For now, we need these two, although a fix is underway that only one becomes
# necessary. See: https://github.com/letsencrypt/boulder/issues/3307
+@BOULDER_DIR@:
+ @test -d $(BOULDER_DIR) || echo "boulder installation not found. Please configure using --with-boulder-dir to specify the correct location."; exit 1
+
$(GEN)/ca.pem: \
+ $(BOULDER_DIR) \
$(BOULDER_DIR)/test/test-ca.pem \
$(BOULDER_DIR)/test/test-ca2.pem
@cat $(BOULDER_DIR)/test/test-root.pem $(BOULDER_DIR)/test/test-ca2.pem > $(GEN)/ca.pem