As announced on May 6, remove the broken net/qtella port.

This commit is contained in:
Kris Kennaway 2003-08-08 03:54:51 +00:00
parent 809a601863
commit 8fe1b9ab21
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=86554
17 changed files with 0 additions and 227 deletions

View File

@ -1,27 +0,0 @@
# New ports collection makefile for: qtella
# Date created: Sunday September 2nd, 2001
# Whom: Jonathan Belson (jon@witchspace.com)
#
# $FreeBSD$
#
PORTNAME= qtella
PORTVERSION= 0.5.4
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= qtella
MAINTAINER= jon@witchspace.com
COMMENT= A Gnutella client using Qt
BROKEN= "Does not compile"
HAS_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS+= --with-qt-dir=${X11BASE} --with-qt-moc=${X11BASE}/bin
CONFIGURE_ENV+= LDFLAGS=-pthread CXXFLAGS="${CXXFLAGS} -pthread"
MAKE_ARGS+= -j2
USE_KDELIBS_VER=3
.include <bsd.port.mk>

View File

@ -1 +0,0 @@
MD5 (qtella-0.5.4.tar.gz) = 6971c6c27d31537f2c38f3702c9c545e

View File

@ -1,11 +0,0 @@
--- include/SHA1Storage.h.orig Sun Jan 26 21:43:06 2003
+++ include/SHA1Storage.h Sun Jan 26 21:41:40 2003
@@ -7,7 +7,7 @@
#include <qobject.h>
#include <qstring.h>
#include <qtimer.h>
-#include <stdint.h>
+#include <inttypes.h>
#include "SharedFile.h"

View File

@ -1,23 +0,0 @@
--- include/sha1.h.orig Wed Oct 2 08:27:57 2002
+++ include/sha1.h Mon Jan 27 17:24:25 2003
@@ -5,7 +5,7 @@
extern "C" {
#endif
-#include <stdint.h>
+#include <inttypes.h>
/*
* If you do not have the ISO standard stdint.h header file, then you
* must typdef the following:
@@ -27,6 +27,11 @@
};
#endif
#define SHA1HashSize 20
+
+#include <osreldate.h>
+#if __FreeBSD_version < 500000
+typedef uint32_t int_least16_t;
+#endif
/*
* This structure will hold context information for the SHA-1

View File

@ -1,10 +0,0 @@
--- src/HostCacheConnection.cpp.orig Fri Dec 20 14:26:30 2002
+++ src/HostCacheConnection.cpp Fri Dec 20 14:26:44 2002
@@ -10,6 +10,7 @@
#include <qlistbox.h>
#include <qcheckbox.h>
#include <qlineedit.h>
+#include <iostream>
#include <string>
#include <vector>

View File

@ -1,11 +0,0 @@
--- src/SHA1Storage.cpp.orig Fri Dec 20 14:06:10 2002
+++ src/SHA1Storage.cpp Fri Dec 20 14:13:03 2002
@@ -100,7 +100,7 @@
QString *SHA1Storage::get(SharedFile *sf)
{
std::string n = sf -> completeFilename();
- n += std::string::traits_type::eos();
+ n += '\0'; // std::string::traits_type::eos();
QString fileName(n.data());
QString *result = _cache[fileName];
if (!result) {

View File

@ -1,6 +0,0 @@
A Gnutella client using Qt.
WWW: http://qtella.sourceforge.net
- Jon Belson
jon@witchspace.com

View File

@ -1,24 +0,0 @@
bin/qtella
share/qtella/language/qtella_cs.qm
share/qtella/language/qtella_de.qm
share/qtella/language/qtella_fi.qm
share/qtella/language/qtella_fr.qm
share/qtella/language/qtella_nb.qm
share/qtella/language/qtella_nn.qm
share/qtella/language/qtella_no.qm
share/qtella/language/qtella_po.qm
share/qtella/language/qtella_pt_BR.qm
share/qtella/language/qtella_sv.qm
share/qtella/pixmaps/ball_d.xpm
share/qtella/pixmaps/ball_g.xpm
share/qtella/pixmaps/ball_r.xpm
share/qtella/pixmaps/ball_y.xpm
share/qtella/pixmaps/gsmile.xpm
share/qtella/pixmaps/remove.xpm
share/qtella/pixmaps/removeresearch.xpm
share/qtella/pixmaps/research.xpm
share/qtella/pixmaps/smile.xpm
@comment directories
@dirrm share/qtella/pixmaps
@dirrm share/qtella/language
@dirrm share/qtella

View File

@ -574,7 +574,6 @@
SUBDIR += pygopherd
SUBDIR += pyslsk
SUBDIR += qadsl
SUBDIR += qtella
SUBDIR += queso
SUBDIR += radiator
SUBDIR += radiusclient

View File

@ -1,27 +0,0 @@
# New ports collection makefile for: qtella
# Date created: Sunday September 2nd, 2001
# Whom: Jonathan Belson (jon@witchspace.com)
#
# $FreeBSD$
#
PORTNAME= qtella
PORTVERSION= 0.5.4
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= qtella
MAINTAINER= jon@witchspace.com
COMMENT= A Gnutella client using Qt
BROKEN= "Does not compile"
HAS_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS+= --with-qt-dir=${X11BASE} --with-qt-moc=${X11BASE}/bin
CONFIGURE_ENV+= LDFLAGS=-pthread CXXFLAGS="${CXXFLAGS} -pthread"
MAKE_ARGS+= -j2
USE_KDELIBS_VER=3
.include <bsd.port.mk>

View File

@ -1 +0,0 @@
MD5 (qtella-0.5.4.tar.gz) = 6971c6c27d31537f2c38f3702c9c545e

View File

@ -1,11 +0,0 @@
--- include/SHA1Storage.h.orig Sun Jan 26 21:43:06 2003
+++ include/SHA1Storage.h Sun Jan 26 21:41:40 2003
@@ -7,7 +7,7 @@
#include <qobject.h>
#include <qstring.h>
#include <qtimer.h>
-#include <stdint.h>
+#include <inttypes.h>
#include "SharedFile.h"

View File

@ -1,23 +0,0 @@
--- include/sha1.h.orig Wed Oct 2 08:27:57 2002
+++ include/sha1.h Mon Jan 27 17:24:25 2003
@@ -5,7 +5,7 @@
extern "C" {
#endif
-#include <stdint.h>
+#include <inttypes.h>
/*
* If you do not have the ISO standard stdint.h header file, then you
* must typdef the following:
@@ -27,6 +27,11 @@
};
#endif
#define SHA1HashSize 20
+
+#include <osreldate.h>
+#if __FreeBSD_version < 500000
+typedef uint32_t int_least16_t;
+#endif
/*
* This structure will hold context information for the SHA-1

View File

@ -1,10 +0,0 @@
--- src/HostCacheConnection.cpp.orig Fri Dec 20 14:26:30 2002
+++ src/HostCacheConnection.cpp Fri Dec 20 14:26:44 2002
@@ -10,6 +10,7 @@
#include <qlistbox.h>
#include <qcheckbox.h>
#include <qlineedit.h>
+#include <iostream>
#include <string>
#include <vector>

View File

@ -1,11 +0,0 @@
--- src/SHA1Storage.cpp.orig Fri Dec 20 14:06:10 2002
+++ src/SHA1Storage.cpp Fri Dec 20 14:13:03 2002
@@ -100,7 +100,7 @@
QString *SHA1Storage::get(SharedFile *sf)
{
std::string n = sf -> completeFilename();
- n += std::string::traits_type::eos();
+ n += '\0'; // std::string::traits_type::eos();
QString fileName(n.data());
QString *result = _cache[fileName];
if (!result) {

View File

@ -1,6 +0,0 @@
A Gnutella client using Qt.
WWW: http://qtella.sourceforge.net
- Jon Belson
jon@witchspace.com

View File

@ -1,24 +0,0 @@
bin/qtella
share/qtella/language/qtella_cs.qm
share/qtella/language/qtella_de.qm
share/qtella/language/qtella_fi.qm
share/qtella/language/qtella_fr.qm
share/qtella/language/qtella_nb.qm
share/qtella/language/qtella_nn.qm
share/qtella/language/qtella_no.qm
share/qtella/language/qtella_po.qm
share/qtella/language/qtella_pt_BR.qm
share/qtella/language/qtella_sv.qm
share/qtella/pixmaps/ball_d.xpm
share/qtella/pixmaps/ball_g.xpm
share/qtella/pixmaps/ball_r.xpm
share/qtella/pixmaps/ball_y.xpm
share/qtella/pixmaps/gsmile.xpm
share/qtella/pixmaps/remove.xpm
share/qtella/pixmaps/removeresearch.xpm
share/qtella/pixmaps/research.xpm
share/qtella/pixmaps/smile.xpm
@comment directories
@dirrm share/qtella/pixmaps
@dirrm share/qtella/language
@dirrm share/qtella