x11/sterm: Update to 0.8

- Fix LICENSE and set it to MIT
- Fix the way we handle the terminfo of x11/sterm.  FreeBSD 12,
  11-STABLE, and 11.2-RELEASE do not require any additional
  configuration (thanks to bapt@) [1].  For older versions, there is a
  simple set of instructions on how to configure terminfo for x11/sterm
  in pkg-message.
- Create a symbolic link to user-defined config.h instead of making a
  copy as is done in other suckless.org ports such as x11-wm/dwm and
  www/quark.
- Respect CPPFLAGS
- Add some files to DOCS and DATA
- Eliminate an unnecessary .for loop during install
- Use HTTPS in WWW
- Add UPDATING entry as old config.h files will need to be updated for
  the newer version

[1] https://svnweb.freebsd.org/changeset/base/331006

Changes:	https://git.suckless.org/st/log/?qt=range&q=0.7..0.8
PR:		226632
Submitted by:	0mp
Approved by:	Piotr Kubaj <pkubaj@anongoth.pl> (maintainer)
This commit is contained in:
Tobias Kortkamp 2018-03-20 17:10:09 +00:00
parent 2b188a165b
commit 8f66372557
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=465094
6 changed files with 39 additions and 24 deletions

View File

@ -5,6 +5,13 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20180320: users of x11/sterm
AUTHOR: pkubaj@anongoth.pl
The user-defined options in config.h have changed. You should
compare your config.h file with the default one and change
appropriately.
20180319:
AFFECTS: users of dns/dnsmasq
AUTHOR: mandree@FreeBSD.org

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sterm
PORTVERSION= 0.7
DISTVERSION= 0.8
CATEGORIES= x11
MASTER_SITES= http://dl.suckless.org/st/
DISTNAME= st-${PORTVERSION}
@ -10,10 +10,8 @@ DISTNAME= st-${PORTVERSION}
MAINTAINER= pkubaj@anongoth.pl
COMMENT= Simple X terminal
LICENSE= MITX
LICENSE_NAME= MIT/X Consortium License
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
@ -23,10 +21,16 @@ USE_XORG= x11 xext xft
PLIST_FILES= bin/st man/man1/st.1.gz
PORTDOCS= README
# This way we avoid running tic on st.info which does not work as expected.
BINARY_ALIAS= tic=true
PORTDATA= config.def.h st.info
PORTDOCS= FAQ LEGACY README TODO
OPTIONS_DEFINE= DOCS
SUB_FILES= pkg-message
pre-everything::
@${ECHO_MSG} "You can build st with your own config.h using the ST_CONF knob:"
@${ECHO_MSG} "make ST_CONF=/path/to/st/config.h install clean"
@ -34,23 +38,23 @@ pre-everything::
post-patch:
.if defined(ST_CONF)
@${ECHO_MSG} "creating config.h from ${ST_CONF}"
@${CP} ${ST_CONF} ${WRKSRC}/config.h
@${LN} -sf ${ST_CONF} ${WRKSRC}/config.h
.endif
@${REINPLACE_CMD} -e 's|^VERSION = .*|VERSION = ${PORTVERSION}|' \
-e 's|^PREFIX = .*|PREFIX = ${PREFIX}|' \
-e 's|^LOCALBASE = .*|LOCALBASE = ${LOCALBASE}|' \
-e "s|^MANPREFIX = .*|MANPREFIX = ${MANPREFIX}/man|" \
-e "s|^X11INC = .*|X11INC = ${LOCALBASE}/include|" \
-e "s|^X11LIB = .*|X11LIB = ${LOCALBASE}/lib|" \
-e "s|^CPPFLAGS =|CPPFLAGS +=|" \
${WRKSRC}/config.mk
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/st
@${MKDIR} ${STAGEDIR}${DATADIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDATA} ${STAGEDIR}${DATADIR}
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1471840973
SHA256 (st-0.7.tar.gz) = f7870d906ccc988926eef2cc98950a99cc78725b685e934c422c03c1234e6000
SIZE (st-0.7.tar.gz) = 42418
TIMESTAMP = 1521122661
SHA256 (st-0.8.tar.gz) = 77353920d07d66c684a0f57ec37c2670c42fdc5c871d6382b701601cdc597576
SIZE (st-0.8.tar.gz) = 45401

View File

@ -1,10 +0,0 @@
--- Makefile.orig 2016-08-11 14:25:58 UTC
+++ Makefile
@@ -49,7 +49,6 @@ install: all
@sed "s/VERSION/${VERSION}/g" < st.1 > ${DESTDIR}${MANPREFIX}/man1/st.1
@chmod 644 ${DESTDIR}${MANPREFIX}/man1/st.1
@echo Please see the README file regarding the terminfo entry of st.
- @tic -s st.info
uninstall:
@echo removing executable file from ${DESTDIR}${PREFIX}/bin

View File

@ -0,0 +1,14 @@
If you are running FreeBSD 11.1 or older then in order to add st.info
to the terminal capability database it is required to
* Install tic (included in devel/ncurses)
* Run
# tic -C -K -s -x %%DATADIR%%/st.info >> /usr/share/misc/termcap
# cd /usr/share/misc
# cap_mkdb termcap
Thanks to [1], this hack is not necessary on FreeBSD 11.2-RELEASE,
11-STABLE, and 12-CURRENT.
[1] https://svnweb.freebsd.org/changeset/base/331006

View File

@ -3,4 +3,4 @@ st is a minimalistic X terminal.
It consists of a single binary, configuration is done at compile-time by a
config.h file.
WWW: http://st.suckless.org/
WWW: https://st.suckless.org/