www/ot-recorder: Update to 0.9.2

Add patch to fix linking issues, already patched upstream.
This commit is contained in:
Dan Langille 2022-12-06 15:47:40 +00:00
parent 079641ccb7
commit 8f6592a3cc
3 changed files with 25 additions and 13 deletions

View File

@ -1,5 +1,5 @@
PORTNAME= ot-recorder
PORTVERSION= 0.9.1
PORTVERSION= 0.9.2
CATEGORIES= www
MAINTAINER= dvl@FreeBSD.org
@ -10,12 +10,14 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= curl>0:ftp/curl \
e2fsprogs-libuuid>0:misc/e2fsprogs-libuuid \
libconfig>0:devel/libconfig \
lmdb>0:databases/lmdb \
mosquitto>0:net/mosquitto
mosquitto>0:net/mosquitto \
pkgconf>0:devel/pkgconf
LIB_DEPENDS= libcurl.so:ftp/curl \
libconfig.so:devel/libconfig \
LIB_DEPENDS= libconfig.so:devel/libconfig \
libcurl.so:ftp/curl \
liblmdb.so:databases/lmdb \
libmosquitto.so:net/mosquitto

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1660158594
SHA256 (owntracks-recorder-0.9.1_GH0.tar.gz) = b74c571706d2bd9546b6817951c71490d058fc480c5634d57d9d7a8b81bf68d2
SIZE (owntracks-recorder-0.9.1_GH0.tar.gz) = 3306544
TIMESTAMP = 1670173683
SHA256 (owntracks-recorder-0.9.2_GH0.tar.gz) = d3632895e46c36c1e484c021958e7bfee3b8977942ab28e7d47cf69c974f988e
SIZE (owntracks-recorder-0.9.2_GH0.tar.gz) = 3306898

View File

@ -1,6 +1,16 @@
--- config.mk.in.orig 2022-05-24 07:25:09 UTC
--- config.mk.in.orig 2022-09-29 12:04:51 UTC
+++ config.mk.in
@@ -20,10 +20,10 @@
@@ -13,17 +13,19 @@
# $ cd /usr/ports/devel/libconfig; make install
# $ cd /usr/ports/net/mosquitto; make install
# $ cd /usr/ports/devel/gmake; make install
+# $ cd /usr/ports/devel/pkgconf; make install
+# $ cd /usr/ports/misc/e2fsprogs-libuuid; make install
#
# Or as a package:
#
-# $ sudo pkg install lmdb curl libconfig mosquitto gmake
+# $ sudo pkg install pkgconf lmdb curl libconfig mosquitto gmake e2fsprogs-libuuid
#
# Uncomment the following lines and replace "no" with "yes":
#
@ -10,12 +20,12 @@
-FREEBSD ?= no
+CC = clang
+CFLAGS += -I/usr/local/include
+MORELIBS += -L /usr/local/lib
+MORELIBS += -L /usr/local/lib -luuid
+FREEBSD ?= YES
#
# Now build recorder with the "gmake" command:
#
@@ -57,10 +57,10 @@ WITH_GREENWICH ?= no
@@ -61,10 +63,10 @@ WITH_GREENWICH ?= no
# Where should the recorder store its data? This directory must
# exist and be writeable by recorder (and readable by ocat)
@ -28,7 +38,7 @@
# Define the precision for reverse-geo lookups. The higher
# the number, the more granular reverse-geo will be:
@@ -83,7 +83,7 @@ GHASHPREC = 7
@@ -87,7 +89,7 @@ GHASHPREC = 7
JSON_INDENT ?= no
# Location of optional default configuration file
@ -36,4 +46,4 @@
+CONFIGFILE = /usr/local/etc/ot-recorder/ot-recorder.conf
# Optionally specify the path to the Mosquitto libs, include here
MOSQUITTO_INC = -I/usr/include
MOSQUITTO_CFLAGS = `$(PKG_CONFIG) --cflags libmosquitto`