Add p5-Event-Lib 1.00, makes libevent(3) accessible with Perl.

PR:		ports/98642
Submitted by:	Fabian Keil <fk@fabiankeil.de>
This commit is contained in:
Cheng-Lung Sung 2006-06-08 01:29:52 +00:00
parent 027b392c6f
commit 8f643afd4e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=164783
6 changed files with 63 additions and 0 deletions

View File

@ -953,6 +953,7 @@
SUBDIR += p5-Env-PS1
SUBDIR += p5-Errno
SUBDIR += p5-Event
SUBDIR += p5-Event-Lib
SUBDIR += p5-Event-RPC
SUBDIR += p5-Exception-Class
SUBDIR += p5-Expect-Simple

View File

@ -0,0 +1,30 @@
# New ports collection makefile for: Event-Lib
# Date created: 07 Jun 2006
# Whom: Fabian Keil <fk@fabiankeil.de>
#
# $FreeBSD$
#
PORTNAME= Event-Lib
PORTVERSION= 1.00
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Event
PKGNAMEPREFIX= p5-
MAINTAINER= fk@fabiankeil.de
COMMENT= Makes libevent(3) accessible with Perl
LIB_DEPENDS= event-1.1a:${PORTSDIR}/devel/libevent
PERL_CONFIGURE= yes
MAN3= Event::Lib.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,3 @@
MD5 (Event-Lib-1.00.tar.gz) = 354d8705c791afc0d4128e278e22ca14
SHA256 (Event-Lib-1.00.tar.gz) = 4276c23ea1ad7f7ffc6997770e09fbdc837e3b514a056b8ab90d6209490fbcd6
SIZE (Event-Lib-1.00.tar.gz) = 46325

View File

@ -0,0 +1,15 @@
--- Makefile.PL.orig Tue Mar 7 08:37:40 2006
+++ Makefile.PL Mon Jun 5 23:31:13 2006
@@ -2,7 +2,11 @@
use ExtUtils::MakeMaker;
use Config;
-my %args = map { split /\s*=\s*/ } @ARGV;
+my %args;
+foreach $_ (@ARGV){
+ m/(.*?)=(.*)/;
+ $args{$1} = $2;
+}
# purge @ARGV of CCFLAGS

View File

@ -0,0 +1,6 @@
Event-Lib is a Perl wrapper around libevent(3)
(http://www.monkey.org/~provos/libevent/).
It makes the handling of asynchronous events more comfortable.
WWW: http://search.cpan.org/dist/Event-Lib/
Author: Tassilo von Parseval <tassilo.von.parseval at rwth-aachen dot de>

View File

@ -0,0 +1,8 @@
%%SITE_PERL%%/%%PERL_ARCH%%/Event/Lib.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Event/Lib/.packlist
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Event/Lib/Lib.bs
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Event/Lib/Lib.so
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Event/Lib
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Event
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Event