- Update Unipro UGENE port to version 37.0
- Drop no longer used WebEngine dependencies - Force SSE2 on i386 (required for the build) - Chase HTTP 301 redirection in the WWW line
This commit is contained in:
parent
ecc2831a5d
commit
8f46816990
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=559737
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ugene
|
||||
PORTVERSION= 34.0
|
||||
PORTVERSION= 37.0
|
||||
CATEGORIES= biology science
|
||||
|
||||
MAINTAINER= h2+fbsdports@fsfe.org
|
||||
@ -21,16 +21,16 @@ GH_ACCOUNT= ugeneunipro
|
||||
USES= desktop-file-utils gl qmake qt:5 shared-mime-info xorg
|
||||
USE_GL= gl glu
|
||||
USE_QT= buildtools_build linguisttools_build \
|
||||
core declarative gui opengl location network printsupport \
|
||||
script scripttools sql svg testlib webchannel webengine \
|
||||
websockets widgets xml \
|
||||
core gui network opengl printsupport scripttools script \
|
||||
sql svg testlib widgets xml \
|
||||
imageformats_run
|
||||
USE_XORG= x11 xtst
|
||||
|
||||
QMAKE_ARGS= INSTALL_PREFIX="${PREFIX}" UGENE_INSTALL_DATA="${DATADIR}" \
|
||||
INSTALL_MANDIR="${MAN1PREFIX}/man" LRELEASE="${LRELEASE}" \
|
||||
LUPDATE="${LUPDATE}"
|
||||
INSTALL_MANDIR="${MAN1PREFIX}/man" \
|
||||
UGENE_LRELEASE="${LRELEASE}" UGENE_LUPDATE="${LUPDATE}"
|
||||
ALL_TARGET= release
|
||||
CXXFLAGS_i386= -msse2
|
||||
|
||||
OPTIONS_DEFINE= OPENCL
|
||||
|
||||
@ -43,10 +43,6 @@ OPENCL_QMAKE_ON= UGENE_OPENCL_DETECTED=1
|
||||
QMAKE_ARGS+= CONFIG+=x64
|
||||
.endif
|
||||
|
||||
.if ${MACHINE_CPU:Msse2}
|
||||
QMAKE_ARGS+= UGENE_SSE2_DETECTED=1
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
# yes, bash is required, stuff will not execute with sh
|
||||
@${REINPLACE_CMD} -e 's|/bin/bash|/usr/bin/env bash|' \
|
||||
@ -59,7 +55,10 @@ post-patch:
|
||||
${WRKSRC}/src/plugins_checker/plugins_checker.pri \
|
||||
${WRKSRC}/src/ugenecl/ugenecl.pri \
|
||||
${WRKSRC}/src/ugeneui/ugeneui.pri
|
||||
@${REINPLACE_CMD} -e '422s|NULL|0|' \
|
||||
${WRKSRC}/src/plugins/smith_waterman/src/SmithWatermanAlgorithmOPENCL.cpp
|
||||
@${REINPLACE_CMD} -e '218,220s|NULL)|false)|' \
|
||||
${WRKSRC}/src/plugins/GUITestBase/src/GTUtilsMdi.cpp
|
||||
|
||||
post-stage:
|
||||
@cd ${STAGEDIR}${PREFIX} && ${RM} bin/ecp.* lib/ugene/ecp.*
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1584963065
|
||||
SHA256 (ugeneunipro-ugene-34.0_GH0.tar.gz) = 569b9997497680412e03d821c7d48903830012a65c5899a5aea3cb80e9f4ee25
|
||||
SIZE (ugeneunipro-ugene-34.0_GH0.tar.gz) = 23406266
|
||||
TIMESTAMP = 1607974687
|
||||
SHA256 (ugeneunipro-ugene-37.0_GH0.tar.gz) = c953a1465d766168d1f753cd6757f1333baf07b5c9b60f4de798ef549e059ae4
|
||||
SIZE (ugeneunipro-ugene-37.0_GH0.tar.gz) = 23379406
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- src/corelibs/U2Designer/src/WorkflowGUIUtils.cpp.orig 2020-05-18 19:09:47 UTC
|
||||
+++ src/corelibs/U2Designer/src/WorkflowGUIUtils.cpp
|
||||
@@ -24,6 +24,7 @@
|
||||
#include <U2Lang/Descriptor.h>
|
||||
|
||||
#include <QPainter>
|
||||
+#include <QPainterPath>
|
||||
#include <QPalette>
|
||||
#include <QTextDocument>
|
||||
#include <QAbstractTextDocumentLayout>
|
@ -1,10 +0,0 @@
|
||||
--- src/corelibs/U2Gui/src/util/GUIUtils.cpp.orig 2020-05-18 18:51:22 UTC
|
||||
+++ src/corelibs/U2Gui/src/util/GUIUtils.cpp
|
||||
@@ -25,6 +25,7 @@
|
||||
#include <QFile>
|
||||
#include <QMessageBox>
|
||||
#include <QPainter>
|
||||
+#include <QPainterPath>
|
||||
#include <QProcess>
|
||||
#include <QUrl>
|
||||
|
@ -2,9 +2,9 @@
|
||||
+++ src/corelibs/U2View/src/ov_sequence/Overview.cpp
|
||||
@@ -38,6 +38,7 @@
|
||||
|
||||
#include <QVBoxLayout>
|
||||
#include <QToolTip>
|
||||
#include <QVBoxLayout>
|
||||
+#include <QPainterPath>
|
||||
|
||||
|
||||
namespace U2 {
|
||||
#include <U2Core/AnnotationModification.h>
|
||||
#include <U2Core/AnnotationSettings.h>
|
||||
|
@ -2,21 +2,21 @@ Use the Linux driver for FreeBSD as well. Fixes crash on startup.
|
||||
|
||||
--- src/libs_3rdparty/QSpec/src/drivers/GTKeyboardDriverLinux.cpp.orig 2018-09-02 00:22:54 UTC
|
||||
+++ src/libs_3rdparty/QSpec/src/drivers/GTKeyboardDriverLinux.cpp
|
||||
@@ -22,7 +22,7 @@
|
||||
#include <cctype>
|
||||
@@ -23,7 +23,7 @@
|
||||
|
||||
#include "GTKeyboardDriver.h"
|
||||
|
||||
-#if defined __linux__
|
||||
+#if defined(__linux__) || defined(__FreeBSD__)
|
||||
#define XK_LATIN1 // for latin symbol
|
||||
#define XK_MISCELLANY // for action keys
|
||||
#include <X11/keysymdef.h>
|
||||
@@ -31,7 +31,7 @@
|
||||
# define XK_LATIN1 // for latin symbol
|
||||
# define XK_MISCELLANY // for action keys
|
||||
# include <X11/extensions/XTest.h>
|
||||
@@ -32,7 +32,7 @@
|
||||
|
||||
namespace HI {
|
||||
|
||||
-#if defined __linux__
|
||||
+#if defined(__linux__) || defined(__FreeBSD__)
|
||||
|
||||
#define GT_CLASS_NAME "GTKeyboardDriverLinux"
|
||||
# define GT_CLASS_NAME "GTKeyboardDriverLinux"
|
||||
|
||||
|
@ -2,13 +2,13 @@ Use the Linux driver for FreeBSD as well. Fixes crash on startup.
|
||||
|
||||
--- src/libs_3rdparty/QSpec/src/drivers/GTMouseDriverLinux.cpp.orig 2018-09-02 00:23:24 UTC
|
||||
+++ src/libs_3rdparty/QSpec/src/drivers/GTMouseDriverLinux.cpp
|
||||
@@ -22,13 +22,13 @@
|
||||
@@ -23,13 +23,13 @@
|
||||
|
||||
#include "GTMouseDriver.h"
|
||||
#include <QByteArray>
|
||||
|
||||
-#ifdef __linux__
|
||||
+#if defined(__linux__) || defined(__FreeBSD__)
|
||||
#include <X11/extensions/XTest.h>
|
||||
# include <X11/extensions/XTest.h>
|
||||
#endif
|
||||
|
||||
namespace HI {
|
||||
@ -16,5 +16,5 @@ Use the Linux driver for FreeBSD as well. Fixes crash on startup.
|
||||
-#ifdef __linux__
|
||||
+#if defined(__linux__) || defined(__FreeBSD__)
|
||||
|
||||
#define GT_CLASS_NAME "GTMouseDriver Linux"
|
||||
# define GT_CLASS_NAME "GTMouseDriver Linux"
|
||||
QPoint GTMouseDriver::mousePos = QPoint(-1, -1);
|
||||
|
@ -10,9 +10,9 @@
|
||||
#define TR_SETTINGS_ROOT QString("test_runner/")
|
||||
|
||||
@@ -55,8 +55,10 @@ static void registerCoreServices() {
|
||||
}
|
||||
#endif
|
||||
|
||||
int main(int argc, char **argv)
|
||||
{
|
||||
+#if 0
|
||||
CrashHandler::setupHandler();
|
||||
CrashHandler::setSendCrashReports(false);
|
||||
|
@ -10,9 +10,9 @@
|
||||
// local project imports
|
||||
#include "DumpHelpTask.h"
|
||||
@@ -191,6 +191,7 @@ static void setSearchPaths() {
|
||||
}
|
||||
|
||||
int main(int argc, char **argv)
|
||||
{
|
||||
int main(int argc, char **argv) {
|
||||
+#if 0
|
||||
if (CrashHandler::isEnabled()) {
|
||||
CrashHandler::setupHandler();
|
||||
@ -23,8 +23,8 @@
|
||||
}
|
||||
+#endif
|
||||
|
||||
const char* build = QT_VERSION_STR, *runtime = qVersion();
|
||||
if (strcmp(build, runtime) > 0){
|
||||
if (!Version::checkBuildAndRuntimeVersions()) {
|
||||
return -1;
|
||||
@@ -617,7 +619,7 @@ int main(int argc, char **argv)
|
||||
delete pwr;
|
||||
appContext->setAlignmentAlgorithmsRegistry(NULL);
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/ugeneui/src/Main.cpp.orig 2018-08-16 13:59:19 UTC
|
||||
--- src/ugeneui/src/Main.cpp.orig 2020-06-17 15:14:26 UTC
|
||||
+++ src/ugeneui/src/Main.cpp
|
||||
@@ -136,7 +136,7 @@
|
||||
@@ -151,7 +151,7 @@
|
||||
#include <ServiceRegistryImpl.h>
|
||||
#include <SettingsImpl.h>
|
||||
#include <TaskSchedulerImpl.h>
|
||||
@ -9,23 +9,32 @@
|
||||
|
||||
#include "app_settings/AppSettingsGUIImpl.h"
|
||||
#include "app_settings/logview_settings/LogSettingsGUIController.h"
|
||||
@@ -353,6 +353,7 @@ void fixMacFonts() {
|
||||
@@ -403,6 +403,7 @@ void fixMacFonts() {
|
||||
} // namespace
|
||||
|
||||
int main(int argc, char **argv)
|
||||
{
|
||||
int main(int argc, char **argv) {
|
||||
+#if 0
|
||||
if (CrashHandler::isEnabled()) {
|
||||
CrashHandler::setupHandler();
|
||||
}
|
||||
@@ -360,6 +361,7 @@ int main(int argc, char **argv)
|
||||
@@ -410,6 +411,7 @@ int main(int argc, char **argv) {
|
||||
if (qgetenv(ENV_SEND_CRASH_REPORTS) == "0") {
|
||||
CrashHandler::setSendCrashReports(false);
|
||||
}
|
||||
+#endif
|
||||
|
||||
QT_REQUIRE_VERSION( argc, argv, QT_VERSION_STR );
|
||||
QT_REQUIRE_VERSION(argc, argv, QT_VERSION_STR);
|
||||
|
||||
@@ -973,7 +975,7 @@ int main(int argc, char **argv)
|
||||
@@ -422,7 +424,7 @@ int main(int argc, char **argv) {
|
||||
//QApplication app(argc, argv);
|
||||
GApplication app(argc, argv);
|
||||
|
||||
-#ifdef Q_OS_LINUX
|
||||
+#ifdef Q_OS_UNIX
|
||||
QPixmap pixmap(":/ugene/images/originals/ugene_128.png");
|
||||
app.setWindowIcon(pixmap);
|
||||
#endif
|
||||
@@ -1088,7 +1090,7 @@ int main(int argc, char **argv) {
|
||||
}
|
||||
|
||||
UgeneUpdater::onClose();
|
||||
|
@ -8,22 +8,3 @@
|
||||
src/libs_3rdparty/qscore \
|
||||
src/libs_3rdparty/sqlite3 \
|
||||
src/libs_3rdparty/samtools \
|
||||
@@ -141,16 +140,8 @@ UGENE_TRANSL_QM_TARGET_DIR = $$OUT_PWD/src/_debug $$OU
|
||||
win32 : UGENE_DEV_NULL = nul
|
||||
unix : UGENE_DEV_NULL = /dev/null
|
||||
|
||||
-UGENE_LRELEASE =
|
||||
-UGENE_LUPDATE =
|
||||
-message(Using QT from $$[QT_INSTALL_BINS])
|
||||
-system($$[QT_INSTALL_BINS]/lrelease-qt5 -version > $$UGENE_DEV_NULL 2> $$UGENE_DEV_NULL) {
|
||||
- UGENE_LRELEASE = $$[QT_INSTALL_BINS]/lrelease-qt5
|
||||
- UGENE_LUPDATE = $$[QT_INSTALL_BINS]/lupdate-qt5
|
||||
-} else : system($$[QT_INSTALL_BINS]/lrelease -version > $$UGENE_DEV_NULL 2> $$UGENE_DEV_NULL) {
|
||||
- UGENE_LRELEASE = $$[QT_INSTALL_BINS]/lrelease
|
||||
- UGENE_LUPDATE = $$[QT_INSTALL_BINS]/lupdate
|
||||
-}
|
||||
+UGENE_LRELEASE = $$LRELEASE
|
||||
+UGENE_LUPDATE = $$LUPDATE
|
||||
|
||||
#foreach 'language'
|
||||
for( i, UGENE_TRANSL_IDX ) {
|
||||
|
@ -9,4 +9,4 @@ modules for biological objects such as annotated genome sequences, Next
|
||||
Generation Sequencing (NGS) assembly data, multiple sequence alignments,
|
||||
phylogenetic trees, and 3D structures.
|
||||
|
||||
WWW: http://ugene.unipro.ru/
|
||||
WWW: http://ugene.net/
|
||||
|
@ -1,50 +1,20 @@
|
||||
bin/ugene
|
||||
lib/ugene/libQSpec.so
|
||||
lib/ugene/libU2Algorithm.so
|
||||
lib/ugene/libU2Algorithm.so.1
|
||||
lib/ugene/libU2Algorithm.so.1.0
|
||||
lib/ugene/libU2Algorithm.so.1.0.0
|
||||
lib/ugene/libU2Core.so
|
||||
lib/ugene/libU2Core.so.1
|
||||
lib/ugene/libU2Core.so.1.0
|
||||
lib/ugene/libU2Core.so.1.0.0
|
||||
lib/ugene/libU2Designer.so
|
||||
lib/ugene/libU2Designer.so.1
|
||||
lib/ugene/libU2Designer.so.1.0
|
||||
lib/ugene/libU2Designer.so.1.0.0
|
||||
lib/ugene/libU2Formats.so
|
||||
lib/ugene/libU2Formats.so.1
|
||||
lib/ugene/libU2Formats.so.1.0
|
||||
lib/ugene/libU2Formats.so.1.0.0
|
||||
lib/ugene/libU2Gui.so
|
||||
lib/ugene/libU2Gui.so.1
|
||||
lib/ugene/libU2Gui.so.1.0
|
||||
lib/ugene/libU2Gui.so.1.0.0
|
||||
lib/ugene/libU2Lang.so
|
||||
lib/ugene/libU2Lang.so.1
|
||||
lib/ugene/libU2Lang.so.1.0
|
||||
lib/ugene/libU2Lang.so.1.0.0
|
||||
lib/ugene/libU2Private.so
|
||||
lib/ugene/libU2Private.so.1
|
||||
lib/ugene/libU2Private.so.1.0
|
||||
lib/ugene/libU2Private.so.1.0.0
|
||||
lib/ugene/libU2Script.so
|
||||
lib/ugene/libU2Script.so.1
|
||||
lib/ugene/libU2Script.so.1.0
|
||||
lib/ugene/libU2Script.so.1.0.0
|
||||
lib/ugene/libU2Test.so
|
||||
lib/ugene/libU2Test.so.1
|
||||
lib/ugene/libU2Test.so.1.0
|
||||
lib/ugene/libU2Test.so.1.0.0
|
||||
lib/ugene/libU2View.so
|
||||
lib/ugene/libU2View.so.1
|
||||
lib/ugene/libU2View.so.1.0
|
||||
lib/ugene/libU2View.so.1.0.0
|
||||
lib/ugene/libugenedb.so
|
||||
lib/ugene/libugenedb.so.1
|
||||
lib/ugene/libugenedb.so.1.0
|
||||
lib/ugene/libugenedb.so.1.0.0
|
||||
lib/ugene/plugins/CoreTests.license
|
||||
lib/ugene/plugins/CoreTests.plugin
|
||||
lib/ugene/plugins/GUITestBase.license
|
||||
lib/ugene/plugins/GUITestBase.plugin
|
||||
lib/ugene/plugins/annotator.license
|
||||
lib/ugene/plugins/annotator.plugin
|
||||
lib/ugene/plugins/api_tests.license
|
||||
@ -88,181 +58,50 @@ lib/ugene/plugins/kalign.plugin
|
||||
lib/ugene/plugins/kraken_support.license
|
||||
lib/ugene/plugins/kraken_support.plugin
|
||||
lib/ugene/plugins/libCoreTests.so
|
||||
lib/ugene/plugins/libCoreTests.so.1
|
||||
lib/ugene/plugins/libCoreTests.so.1.0
|
||||
lib/ugene/plugins/libCoreTests.so.1.0.0
|
||||
lib/ugene/plugins/libGUITestBase.so
|
||||
lib/ugene/plugins/libannotator.so
|
||||
lib/ugene/plugins/libannotator.so.1
|
||||
lib/ugene/plugins/libannotator.so.1.0
|
||||
lib/ugene/plugins/libannotator.so.1.0.0
|
||||
lib/ugene/plugins/libapi_tests.so
|
||||
lib/ugene/plugins/libapi_tests.so.1
|
||||
lib/ugene/plugins/libapi_tests.so.1.0
|
||||
lib/ugene/plugins/libapi_tests.so.1.0.0
|
||||
lib/ugene/plugins/libball.so
|
||||
lib/ugene/plugins/libball.so.1
|
||||
lib/ugene/plugins/libball.so.1.0
|
||||
lib/ugene/plugins/libball.so.1.0.0
|
||||
lib/ugene/plugins/libbiostruct3d_view.so
|
||||
lib/ugene/plugins/libbiostruct3d_view.so.1
|
||||
lib/ugene/plugins/libbiostruct3d_view.so.1.0
|
||||
lib/ugene/plugins/libbiostruct3d_view.so.1.0.0
|
||||
lib/ugene/plugins/libchroma_view.so
|
||||
lib/ugene/plugins/libchroma_view.so.1
|
||||
lib/ugene/plugins/libchroma_view.so.1.0
|
||||
lib/ugene/plugins/libchroma_view.so.1.0.0
|
||||
lib/ugene/plugins/libcircular_view.so
|
||||
lib/ugene/plugins/libcircular_view.so.1
|
||||
lib/ugene/plugins/libcircular_view.so.1.0
|
||||
lib/ugene/plugins/libcircular_view.so.1.0.0
|
||||
lib/ugene/plugins/libclark_support.so
|
||||
lib/ugene/plugins/libclark_support.so.1
|
||||
lib/ugene/plugins/libclark_support.so.1.0
|
||||
lib/ugene/plugins/libclark_support.so.1.0.0
|
||||
lib/ugene/plugins/libdbi_bam.so
|
||||
lib/ugene/plugins/libdbi_bam.so.1
|
||||
lib/ugene/plugins/libdbi_bam.so.1.0
|
||||
lib/ugene/plugins/libdbi_bam.so.1.0.0
|
||||
lib/ugene/plugins/libdiamond_support.so
|
||||
lib/ugene/plugins/libdiamond_support.so.1
|
||||
lib/ugene/plugins/libdiamond_support.so.1.0
|
||||
lib/ugene/plugins/libdiamond_support.so.1.0.0
|
||||
lib/ugene/plugins/libdna_export.so
|
||||
lib/ugene/plugins/libdna_export.so.1
|
||||
lib/ugene/plugins/libdna_export.so.1.0
|
||||
lib/ugene/plugins/libdna_export.so.1.0.0
|
||||
lib/ugene/plugins/libdna_flexibility.so
|
||||
lib/ugene/plugins/libdna_flexibility.so.1
|
||||
lib/ugene/plugins/libdna_flexibility.so.1.0
|
||||
lib/ugene/plugins/libdna_flexibility.so.1.0.0
|
||||
lib/ugene/plugins/libdna_graphpack.so
|
||||
lib/ugene/plugins/libdna_graphpack.so.1
|
||||
lib/ugene/plugins/libdna_graphpack.so.1.0
|
||||
lib/ugene/plugins/libdna_graphpack.so.1.0.0
|
||||
lib/ugene/plugins/libdna_stat.so
|
||||
lib/ugene/plugins/libdna_stat.so.1
|
||||
lib/ugene/plugins/libdna_stat.so.1.0
|
||||
lib/ugene/plugins/libdna_stat.so.1.0.0
|
||||
lib/ugene/plugins/libdotplot.so
|
||||
lib/ugene/plugins/libdotplot.so.1
|
||||
lib/ugene/plugins/libdotplot.so.1.0
|
||||
lib/ugene/plugins/libdotplot.so.1.0.0
|
||||
lib/ugene/plugins/libenzymes.so
|
||||
lib/ugene/plugins/libenzymes.so.1
|
||||
lib/ugene/plugins/libenzymes.so.1.0
|
||||
lib/ugene/plugins/libenzymes.so.1.0.0
|
||||
lib/ugene/plugins/libexternal_tool_support.so
|
||||
lib/ugene/plugins/libexternal_tool_support.so.1
|
||||
lib/ugene/plugins/libexternal_tool_support.so.1.0
|
||||
lib/ugene/plugins/libexternal_tool_support.so.1.0.0
|
||||
lib/ugene/plugins/libgenome_aligner.so
|
||||
lib/ugene/plugins/libgenome_aligner.so.1
|
||||
lib/ugene/plugins/libgenome_aligner.so.1.0
|
||||
lib/ugene/plugins/libgenome_aligner.so.1.0.0
|
||||
lib/ugene/plugins/libgor4.so
|
||||
lib/ugene/plugins/libgor4.so.1
|
||||
lib/ugene/plugins/libgor4.so.1.0
|
||||
lib/ugene/plugins/libgor4.so.1.0.0
|
||||
lib/ugene/plugins/libhmm2.so
|
||||
lib/ugene/plugins/libhmm2.so.1
|
||||
lib/ugene/plugins/libhmm2.so.1.0
|
||||
lib/ugene/plugins/libhmm2.so.1.0.0
|
||||
lib/ugene/plugins/libkalign.so
|
||||
lib/ugene/plugins/libkalign.so.1
|
||||
lib/ugene/plugins/libkalign.so.1.0
|
||||
lib/ugene/plugins/libkalign.so.1.0.0
|
||||
lib/ugene/plugins/libkraken_support.so
|
||||
lib/ugene/plugins/libkraken_support.so.1
|
||||
lib/ugene/plugins/libkraken_support.so.1.0
|
||||
lib/ugene/plugins/libkraken_support.so.1.0.0
|
||||
lib/ugene/plugins/liblinkdata_support.so
|
||||
lib/ugene/plugins/liblinkdata_support.so.1
|
||||
lib/ugene/plugins/liblinkdata_support.so.1.0
|
||||
lib/ugene/plugins/liblinkdata_support.so.1.0.0
|
||||
lib/ugene/plugins/libmetaphlan2_support.so
|
||||
lib/ugene/plugins/libmetaphlan2_support.so.1
|
||||
lib/ugene/plugins/libmetaphlan2_support.so.1.0
|
||||
lib/ugene/plugins/libmetaphlan2_support.so.1.0.0
|
||||
lib/ugene/plugins/libngs_reads_classification.so
|
||||
lib/ugene/plugins/libngs_reads_classification.so.1
|
||||
lib/ugene/plugins/libngs_reads_classification.so.1.0
|
||||
lib/ugene/plugins/libngs_reads_classification.so.1.0.0
|
||||
lib/ugene/plugins/libopencl_support.so
|
||||
lib/ugene/plugins/libopencl_support.so.1
|
||||
lib/ugene/plugins/libopencl_support.so.1.0
|
||||
lib/ugene/plugins/libopencl_support.so.1.0.0
|
||||
lib/ugene/plugins/liborf_marker.so
|
||||
lib/ugene/plugins/liborf_marker.so.1
|
||||
lib/ugene/plugins/liborf_marker.so.1.0
|
||||
lib/ugene/plugins/liborf_marker.so.1.0.0
|
||||
lib/ugene/plugins/libpcr.so
|
||||
lib/ugene/plugins/libpcr.so.1
|
||||
lib/ugene/plugins/libpcr.so.1.0
|
||||
lib/ugene/plugins/libpcr.so.1.0.0
|
||||
lib/ugene/plugins/libperf_monitor.so
|
||||
lib/ugene/plugins/libperf_monitor.so.1
|
||||
lib/ugene/plugins/libperf_monitor.so.1.0
|
||||
lib/ugene/plugins/libperf_monitor.so.1.0.0
|
||||
lib/ugene/plugins/libphylip.so
|
||||
lib/ugene/plugins/libphylip.so.1
|
||||
lib/ugene/plugins/libphylip.so.1.0
|
||||
lib/ugene/plugins/libphylip.so.1.0.0
|
||||
lib/ugene/plugins/libprimer3.so
|
||||
lib/ugene/plugins/libprimer3.so.1
|
||||
lib/ugene/plugins/libprimer3.so.1.0
|
||||
lib/ugene/plugins/libprimer3.so.1.0.0
|
||||
lib/ugene/plugins/libpsipred.so
|
||||
lib/ugene/plugins/libpsipred.so.1
|
||||
lib/ugene/plugins/libpsipred.so.1.0
|
||||
lib/ugene/plugins/libpsipred.so.1.0.0
|
||||
lib/ugene/plugins/libptools.so
|
||||
lib/ugene/plugins/libptools.so.1
|
||||
lib/ugene/plugins/libptools.so.1.0
|
||||
lib/ugene/plugins/libptools.so.1.0.0
|
||||
lib/ugene/plugins/libquery_designer.so
|
||||
lib/ugene/plugins/libquery_designer.so.1
|
||||
lib/ugene/plugins/libquery_designer.so.1.0
|
||||
lib/ugene/plugins/libquery_designer.so.1.0.0
|
||||
lib/ugene/plugins/libremote_blast.so
|
||||
lib/ugene/plugins/libremote_blast.so.1
|
||||
lib/ugene/plugins/libremote_blast.so.1.0
|
||||
lib/ugene/plugins/libremote_blast.so.1.0.0
|
||||
lib/ugene/plugins/librepeat_finder.so
|
||||
lib/ugene/plugins/librepeat_finder.so.1
|
||||
lib/ugene/plugins/librepeat_finder.so.1.0
|
||||
lib/ugene/plugins/librepeat_finder.so.1.0.0
|
||||
lib/ugene/plugins/libsitecon.so
|
||||
lib/ugene/plugins/libsitecon.so.1
|
||||
lib/ugene/plugins/libsitecon.so.1.0
|
||||
lib/ugene/plugins/libsitecon.so.1.0.0
|
||||
lib/ugene/plugins/libsmith_waterman.so
|
||||
lib/ugene/plugins/libsmith_waterman.so.1
|
||||
lib/ugene/plugins/libsmith_waterman.so.1.0
|
||||
lib/ugene/plugins/libsmith_waterman.so.1.0.0
|
||||
lib/ugene/plugins/libtest_runner.so
|
||||
lib/ugene/plugins/libtest_runner.so.1
|
||||
lib/ugene/plugins/libtest_runner.so.1.0
|
||||
lib/ugene/plugins/libtest_runner.so.1.0.0
|
||||
lib/ugene/plugins/libumuscle.so
|
||||
lib/ugene/plugins/libumuscle.so.1
|
||||
lib/ugene/plugins/libumuscle.so.1.0
|
||||
lib/ugene/plugins/libumuscle.so.1.0.0
|
||||
lib/ugene/plugins/libvariants.so
|
||||
lib/ugene/plugins/libvariants.so.1
|
||||
lib/ugene/plugins/libvariants.so.1.0
|
||||
lib/ugene/plugins/libvariants.so.1.0.0
|
||||
lib/ugene/plugins/libweight_matrix.so
|
||||
lib/ugene/plugins/libweight_matrix.so.1
|
||||
lib/ugene/plugins/libweight_matrix.so.1.0
|
||||
lib/ugene/plugins/libweight_matrix.so.1.0.0
|
||||
lib/ugene/plugins/libwevote_support.so
|
||||
lib/ugene/plugins/libwevote_support.so.1
|
||||
lib/ugene/plugins/libwevote_support.so.1.0
|
||||
lib/ugene/plugins/libwevote_support.so.1.0.0
|
||||
lib/ugene/plugins/libworkflow_designer.so
|
||||
lib/ugene/plugins/libworkflow_designer.so.1
|
||||
lib/ugene/plugins/libworkflow_designer.so.1.0
|
||||
lib/ugene/plugins/libworkflow_designer.so.1.0.0
|
||||
lib/ugene/plugins/linkdata_support.license
|
||||
lib/ugene/plugins/linkdata_support.plugin
|
||||
lib/ugene/plugins/metaphlan2_support.license
|
||||
|
Loading…
Reference in New Issue
Block a user