Add configure script patches for click port.

This commit is contained in:
Bruce M Simpson 2006-11-02 13:21:11 +00:00
parent 7bf5c34e60
commit 8f2491df96
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=176186
2 changed files with 90 additions and 0 deletions

View File

@ -0,0 +1,53 @@
--- configure.orig Fri May 19 21:50:14 2006
+++ configure Fri Oct 13 02:41:33 2006
@@ -4449,14 +4449,14 @@
=========================================" >&2;}
{ (exit 1); exit 1; }; }
-elif test -r $freebsd_includedir/net/if_var.h -a -r $freebsd_srcdir/kern/vnode_if.pl; then
+elif test -r $freebsd_includedir/net/if_var.h -a -r $freebsd_srcdir/kern/vnode_if.src; then
ac_have_bsd_kernel=y
else
{ { echo "$as_me:$LINENO: error:
=========================================
Can't find $freebsd_includedir/net/if_var.h and/or
-$freebsd_srcdir/kern/vnode_if.pl. Are you sure $freebsd_srcdir
+$freebsd_srcdir/kern/vnode_if.src. Are you sure $freebsd_srcdir
and $freebsd_includedir contain FreeBSD kernel source?
=========================================" >&5
@@ -4464,7 +4464,7 @@
=========================================
Can't find $freebsd_includedir/net/if_var.h and/or
-$freebsd_srcdir/kern/vnode_if.pl. Are you sure $freebsd_srcdir
+$freebsd_srcdir/kern/vnode_if.src. Are you sure $freebsd_srcdir
and $freebsd_includedir contain FreeBSD kernel source?
=========================================" >&2;}
@@ -12279,7 +12279,7 @@
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
#include <sys/param.h>
-#if __FreeBSD_version < 440002 || __FreeBSD_version >= 500000
+#if __FreeBSD_version < 500000
#include <NONEXISTENT_FILE>
#endif
_ACEOF
@@ -12330,13 +12330,13 @@
{ echo "$as_me:$LINENO: WARNING:
=========================================
-Your version of FreeBSD is old. Click works with FreeBSD 4.5 and later.
+Your version of FreeBSD is old. Click works with FreeBSD 5.x and later.
=========================================" >&5
echo "$as_me: WARNING:
=========================================
-Your version of FreeBSD is old. Click works with FreeBSD 4.5 and later.
+Your version of FreeBSD is old. Click works with FreeBSD 5.x and later.
=========================================" >&2;}
fi

View File

@ -0,0 +1,37 @@
--- configure.in.orig Fri May 19 21:48:10 2006
+++ configure.in Fri Oct 13 02:41:47 2006
@@ -208,14 +208,14 @@
are relative. You must supply absolute paths starting with /.
=========================================])
-elif test -r $freebsd_includedir/net/if_var.h -a -r $freebsd_srcdir/kern/vnode_if.pl; then
+elif test -r $freebsd_includedir/net/if_var.h -a -r $freebsd_srcdir/kern/vnode_if.src; then
ac_have_bsd_kernel=y
else
AC_MSG_ERROR([
=========================================
Can't find $freebsd_includedir/net/if_var.h and/or
-$freebsd_srcdir/kern/vnode_if.pl. Are you sure $freebsd_srcdir
+$freebsd_srcdir/kern/vnode_if.src. Are you sure $freebsd_srcdir
and $freebsd_includedir contain FreeBSD kernel source?
=========================================])
@@ -549,7 +549,7 @@
save_flags="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS -I$freebsd_includedir"
AC_COMPILE_IFELSE([AC_LANG_SOURCE([[#include <sys/param.h>
-#if __FreeBSD_version < 440002 || __FreeBSD_version >= 500000
+#if __FreeBSD_version < 500000
#include <NONEXISTENT_FILE>
#endif]])], ac_cv_freebsd_version=yes, ac_cv_freebsd_version=no)
CPPFLAGS="$save_flags"])
@@ -560,7 +560,7 @@
AC_MSG_WARN([
=========================================
-Your version of FreeBSD is old. Click works with FreeBSD 4.5 and later.
+Your version of FreeBSD is old. Click works with FreeBSD 5.x and later.
=========================================])
fi