graphics/jogamp-jogl:
- Update to 2.1.5 - Change MASTER_SITES to official site - Resolve conflict with jogl-1.* - Add stage support - Drop stale patches - Take maintainership (this port is required for math/scilab) PR: ports/189200 Approved by: Tassilo Philipp (former maintainer)
This commit is contained in:
parent
35dce6f3e8
commit
8f1c2dcdc8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=352767
@ -2,128 +2,60 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= jogamp-jogl
|
||||
PORTVERSION= 2.0.20100914
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 2.1.5
|
||||
CATEGORIES= graphics devel java
|
||||
MASTER_SITES= http://www.potion-studios.com/ \
|
||||
LOCAL/makc
|
||||
DISTFILES= sgothel-gluegen-VALID_BUILDS_01-144-ga61c650.tar.gz \
|
||||
sgothel-jogl-OpenGL_3_3_Integration-8-gdc9191f.tar.gz
|
||||
MASTER_SITES= http://jogamp.org/deployment/jogamp-current/archive/Sources/
|
||||
DISTFILES= jogl-v${PORTVERSION}.tar.7z \
|
||||
gluegen-v${PORTVERSION}.tar.7z
|
||||
|
||||
MAINTAINER= tphilipp@potion-studios.com
|
||||
MAINTAINER= makc@FreeBSD.org
|
||||
COMMENT= Java bindings for OpenGL
|
||||
|
||||
LIB_DEPENDS= drm.2:${PORTSDIR}/graphics/libdrm
|
||||
BUILD_DEPENDS= java:${PORTSDIR}/java/javavmwrapper \
|
||||
${JAVALIBDIR}/antlr.jar:${PORTSDIR}/devel/antlr
|
||||
RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
|
||||
EXTRACT_DEPENDS= ${7Z_CMD}:${PORTSDIR}/archivers/p7zip
|
||||
BUILD_DEPENDS= ${JAVALIBDIR}/swt-devel.jar:${PORTSDIR}/x11-toolkits/swt-devel
|
||||
RUN_DEPENDS= ${JAVALIBDIR}/swt-devel.jar:${PORTSDIR}/x11-toolkits/swt-devel
|
||||
|
||||
CONFLICTS= jogl-1.*
|
||||
|
||||
MAKE_ENV+= _JAVA_OPTIONS="-Xmx512m"
|
||||
NO_WRKSUBDIR= yes
|
||||
WRKSRC= ${WRKDIR}
|
||||
|
||||
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
|
||||
|
||||
ALL_TARGET= all
|
||||
|
||||
# This JOGL port features supported for i386 and amd64, only.
|
||||
ONLY_FOR_ARCHS= i386 amd64
|
||||
|
||||
USE_XORG= x11 xau xdamage xdmcp xext xf86vidmodeproto xfixes xproto xt \
|
||||
xxf86vm
|
||||
USE_GL= gl
|
||||
USE_ANT= yes
|
||||
USE_LDCONFIG= yes
|
||||
USE_GCC= yes
|
||||
USE_JAVA= yes
|
||||
JAVA_VERSION= 1.6+
|
||||
USE_XORG= x11 xcursor xrandr xrender xxf86vm
|
||||
|
||||
7Z_CMD= ${LOCALBASE}/bin/7z
|
||||
EXTRACT_CMD= ${7Z_CMD}
|
||||
EXTRACT_BEFORE_ARGS= x -so
|
||||
EXTRACT_AFTER_ARGS= | ${TAR} -xf -
|
||||
|
||||
PATCH_WRKSRC= ${WRKDIR}
|
||||
BUILD_WRKSRC= ${WRKDIR}/jogl/make
|
||||
BUILD_BINPATH= ${WRKSRC}/bin
|
||||
MAKE_ENV+= PATH="${BUILD_BINPATH}:${PATH}"
|
||||
|
||||
NO_STAGE= yes
|
||||
post-extract:
|
||||
${MV} ${WRKDIR}/sgothel-gluegen-a61c650 ${WRKDIR}/gluegen
|
||||
${MV} ${WRKDIR}/sgothel-jogl-dc9191f ${WRKDIR}/jogl
|
||||
${MV} ${WRKDIR}/gluegen-v${PORTVERSION} ${WRKDIR}/gluegen
|
||||
${MV} ${WRKDIR}/jogl-v${PORTVERSION} ${WRKDIR}/jogl
|
||||
${MKDIR} ${BUILD_BINPATH}
|
||||
${LN} -sf ${LOCALBASE}/bin/${CC} ${BUILD_BINPATH}/gcc
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%JAVALIBDIR%%|${JAVALIBDIR}|g' \
|
||||
${WRKDIR}/gluegen/make/build.xml \
|
||||
${WRKDIR}/gluegen/make/gluegen.properties
|
||||
@${REINPLACE_CMD} -e 's|%%WRKSRC%%|${WRKDIR}|g' \
|
||||
${WRKDIR}/gluegen/make/gluegen-properties.xml
|
||||
${REINPLACE_CMD} -e 's|%%JAVALIBDIR%%|${JAVALIBDIR}|g' \
|
||||
${BUILD_WRKSRC}/build-common.xml
|
||||
|
||||
pre-build:
|
||||
@(cd ${WRKDIR}/gluegen/make; \
|
||||
${SETENV} ${MAKE_ENV} ${ANT} ${MAKE_ARGS} ${ALL_TARGET})
|
||||
|
||||
do-install:
|
||||
cd ${WRKDIR}/jogl/build/lib && ${INSTALL_DATA} \
|
||||
libgluegen-rt.so \
|
||||
libjogl_desktop.so \
|
||||
libjogl_es1.so \
|
||||
libjogl_es2.so \
|
||||
libjogl_gl2es12.so \
|
||||
libnativewindow_awt.so \
|
||||
libnativewindow_x11.so \
|
||||
libnewt.so \
|
||||
${PREFIX}/lib
|
||||
cd ${WRKDIR}/jogl/build/jar && ${INSTALL_DATA} \
|
||||
gluegen-rt-cdc.jar \
|
||||
gluegen-rt.jar \
|
||||
jogl.all-noawt.jar \
|
||||
jogl.all.cdc.jar \
|
||||
jogl.all.jar \
|
||||
jogl.awt.jar \
|
||||
jogl.core.cdc.jar \
|
||||
jogl.core.jar \
|
||||
jogl.egl.cdc.jar \
|
||||
jogl.egl.jar \
|
||||
jogl.gl2es12.cdc.jar \
|
||||
jogl.gl2es12.jar \
|
||||
jogl.gldesktop.dbg.jar \
|
||||
jogl.gldesktop.jar \
|
||||
jogl.gles1.cdc.jar \
|
||||
jogl.gles1.dbg.cdc.jar \
|
||||
jogl.gles1.dbg.jar \
|
||||
jogl.gles1.jar \
|
||||
jogl.gles2.cdc.jar \
|
||||
jogl.gles2.dbg.cdc.jar \
|
||||
jogl.gles2.dbg.jar \
|
||||
jogl.gles2.jar \
|
||||
jogl.glu.gldesktop.jar \
|
||||
jogl.glu.mipmap.cdc.jar \
|
||||
jogl.glu.mipmap.jar \
|
||||
jogl.glu.tess.cdc.jar \
|
||||
jogl.glu.tess.jar \
|
||||
jogl.os.x11.cdc.jar \
|
||||
jogl.os.x11.jar \
|
||||
jogl.sdk.jar \
|
||||
jogl.test.jar \
|
||||
jogl.util.awt.jar \
|
||||
jogl.util.cdc.jar \
|
||||
jogl.util.fixedfuncemu.cdc.jar \
|
||||
jogl.util.fixedfuncemu.jar \
|
||||
jogl.util.gldesktop.jar \
|
||||
jogl.util.jar \
|
||||
nativewindow.all-noawt.jar \
|
||||
nativewindow.all.cdc.jar \
|
||||
nativewindow.all.jar \
|
||||
nativewindow.awt.jar \
|
||||
nativewindow.core.cdc.jar \
|
||||
nativewindow.core.jar \
|
||||
nativewindow.os.x11.cdc.jar \
|
||||
nativewindow.os.x11.jar \
|
||||
newt.all-noawt.jar \
|
||||
newt.all.cdc.jar \
|
||||
newt.all.jar \
|
||||
newt.awt.jar \
|
||||
newt.broadcomegl.cdc.jar \
|
||||
newt.broadcomegl.jar \
|
||||
newt.core.cdc.jar \
|
||||
newt.core.jar \
|
||||
newt.intelgdl.cdc.jar \
|
||||
newt.intelgdl.jar \
|
||||
newt.ogl.cdc.jar \
|
||||
newt.ogl.jar \
|
||||
newt.os.x11.cdc.jar \
|
||||
newt.os.x11.jar \
|
||||
${JAVAJARDIR}
|
||||
${INSTALL_LIB} ${WRKDIR}/gluegen/build/obj/libgluegen-rt.so \
|
||||
${STAGEDIR}${PREFIX}/lib/libgluegen2-rt.so
|
||||
${INSTALL_DATA} ${WRKDIR}/gluegen/build/gluegen-rt.jar \
|
||||
${STAGEDIR}${JAVAJARDIR}/gluegen2-rt.jar
|
||||
${INSTALL_DATA} ${WRKDIR}/gluegen/build/gluegen.jar \
|
||||
${STAGEDIR}${JAVAJARDIR}/gluegen2.jar
|
||||
${INSTALL_LIB} ${WRKDIR}/jogl/build/lib/*.so \
|
||||
${STAGEDIR}${PREFIX}/lib
|
||||
${INSTALL_DATA} ${WRKDIR}/jogl/build/jar/jogl-all.jar \
|
||||
${STAGEDIR}${JAVAJARDIR}/jogl2.jar
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,4 +1,4 @@
|
||||
SHA256 (sgothel-gluegen-VALID_BUILDS_01-144-ga61c650.tar.gz) = f80a9067f26d8eb5ad16227d35b5085707570dc459124702a06fea144b3adfba
|
||||
SIZE (sgothel-gluegen-VALID_BUILDS_01-144-ga61c650.tar.gz) = 6030238
|
||||
SHA256 (sgothel-jogl-OpenGL_3_3_Integration-8-gdc9191f.tar.gz) = f1df1ebcc71751ec9e32317fddb71283d5626342e446b04cc4d5d6f383bc3e63
|
||||
SIZE (sgothel-jogl-OpenGL_3_3_Integration-8-gdc9191f.tar.gz) = 4894626
|
||||
SHA256 (jogl-v2.1.5.tar.7z) = e64474c28e4dd64f2a926ef2c8a645fe4de0ca9db482f939b1b84ba624d42bd5
|
||||
SIZE (jogl-v2.1.5.tar.7z) = 21513866
|
||||
SHA256 (gluegen-v2.1.5.tar.7z) = 9ca3c0961f790e778bf4453a6d676e6cfa72a0ca9cd461bd65710777bc3c9247
|
||||
SIZE (gluegen-v2.1.5.tar.7z) = 38641669
|
||||
|
@ -1,15 +0,0 @@
|
||||
--- gluegen/make/build.xml.orig 2010-09-18 13:33:32.000000000 +0200
|
||||
+++ gluegen/make/build.xml 2010-09-18 13:33:44.000000000 +0200
|
||||
@@ -11,10 +11,10 @@
|
||||
-->
|
||||
<project name="GlueGen" basedir="." default="all">
|
||||
|
||||
- <fail message="Please build using Ant 1.8.0 or higher.">
|
||||
+ <fail message="Please build using Ant 1.7.0 or higher.">
|
||||
<condition>
|
||||
<not>
|
||||
- <antversion atleast="1.8.0"/>
|
||||
+ <antversion atleast="1.7.0"/>
|
||||
</not>
|
||||
</condition>
|
||||
</fail>
|
@ -1,13 +0,0 @@
|
||||
--- gluegen/make/gluegen-cpptasks-base.xml.orig 2010-10-03 12:47:50.000000000 +0200
|
||||
+++ gluegen/make/gluegen-cpptasks-base.xml 2010-10-03 12:48:27.000000000 +0200
|
||||
@@ -772,6 +772,10 @@
|
||||
<linker id="linker.cfg.hpux" name="aCC">
|
||||
</linker>
|
||||
|
||||
+ <linker id="linker.cfg.freebsd" name="gcc">
|
||||
+ <linkerarg value="-m32"/>
|
||||
+ </linker>
|
||||
+
|
||||
<linker id="linker.cfg.freebsd.x86" name="gcc">
|
||||
<linkerarg value="-m32"/>
|
||||
</linker>
|
@ -0,0 +1,13 @@
|
||||
--- ./jogl/make/build-common.xml.orig 2014-04-29 16:52:29.835776699 +0000
|
||||
+++ ./jogl/make/build-common.xml 2014-04-29 16:56:14.552780952 +0000
|
||||
@@ -128,8 +128,8 @@
|
||||
<condition property="swt.jar" value="${project.root}/make/lib/swt/win32-win32-x86/swt-debug.jar">
|
||||
<istrue value="${isWindowsX86}" />
|
||||
</condition>
|
||||
- <condition property="swt.jar" value="${project.root}/make/lib/swt/gtk-freebsd-x86_64/swt.jar">
|
||||
- <istrue value="${isFreeBSDAMD64}" />
|
||||
+ <condition property="swt.jar" value="%%JAVALIBDIR%%/swt-devel.jar">
|
||||
+ <istrue value="${isFreeBSD}" />
|
||||
</condition>
|
||||
<condition property="swt.jar" value="${project.root}/make/lib/swt/gtk-linux-x86_64/swt-debug.jar">
|
||||
<istrue value="${isLinuxAMD64}" />
|
@ -1,15 +0,0 @@
|
||||
--- jogl/make/build-common.xml.orig 2010-09-12 18:59:12.000000000 +0200
|
||||
+++ jogl/make/build-common.xml 2010-09-12 18:59:35.000000000 +0200
|
||||
@@ -4,10 +4,10 @@
|
||||
|
||||
<description>Common JOGL Stuff</description>
|
||||
|
||||
- <fail message="Please build using Ant 1.8.0 or higher.">
|
||||
+ <fail message="Please build using Ant 1.7.0 or higher.">
|
||||
<condition>
|
||||
<not>
|
||||
- <antversion atleast="1.8.0"/>
|
||||
+ <antversion atleast="1.7.0"/>
|
||||
</not>
|
||||
</condition>
|
||||
</fail>
|
@ -1,67 +1,10 @@
|
||||
lib/libgluegen-rt.so
|
||||
lib/libgluegen2-rt.so
|
||||
lib/libjogl_cg.so
|
||||
lib/libjogl_desktop.so
|
||||
lib/libjogl_es1.so
|
||||
lib/libjogl_es2.so
|
||||
lib/libjogl_gl2es12.so
|
||||
lib/libjogl_mobile.so
|
||||
lib/libnativewindow_awt.so
|
||||
lib/libnativewindow_x11.so
|
||||
lib/libnewt.so
|
||||
%%JAVAJARDIR%%/gluegen-rt-cdc.jar
|
||||
%%JAVAJARDIR%%/gluegen-rt.jar
|
||||
%%JAVAJARDIR%%/jogl.all-noawt.jar
|
||||
%%JAVAJARDIR%%/jogl.all.cdc.jar
|
||||
%%JAVAJARDIR%%/jogl.all.jar
|
||||
%%JAVAJARDIR%%/jogl.awt.jar
|
||||
%%JAVAJARDIR%%/jogl.core.cdc.jar
|
||||
%%JAVAJARDIR%%/jogl.core.jar
|
||||
%%JAVAJARDIR%%/jogl.egl.cdc.jar
|
||||
%%JAVAJARDIR%%/jogl.egl.jar
|
||||
%%JAVAJARDIR%%/jogl.gl2es12.cdc.jar
|
||||
%%JAVAJARDIR%%/jogl.gl2es12.jar
|
||||
%%JAVAJARDIR%%/jogl.gldesktop.dbg.jar
|
||||
%%JAVAJARDIR%%/jogl.gldesktop.jar
|
||||
%%JAVAJARDIR%%/jogl.gles1.cdc.jar
|
||||
%%JAVAJARDIR%%/jogl.gles1.dbg.cdc.jar
|
||||
%%JAVAJARDIR%%/jogl.gles1.dbg.jar
|
||||
%%JAVAJARDIR%%/jogl.gles1.jar
|
||||
%%JAVAJARDIR%%/jogl.gles2.cdc.jar
|
||||
%%JAVAJARDIR%%/jogl.gles2.dbg.cdc.jar
|
||||
%%JAVAJARDIR%%/jogl.gles2.dbg.jar
|
||||
%%JAVAJARDIR%%/jogl.gles2.jar
|
||||
%%JAVAJARDIR%%/jogl.glu.gldesktop.jar
|
||||
%%JAVAJARDIR%%/jogl.glu.mipmap.cdc.jar
|
||||
%%JAVAJARDIR%%/jogl.glu.mipmap.jar
|
||||
%%JAVAJARDIR%%/jogl.glu.tess.cdc.jar
|
||||
%%JAVAJARDIR%%/jogl.glu.tess.jar
|
||||
%%JAVAJARDIR%%/jogl.os.x11.cdc.jar
|
||||
%%JAVAJARDIR%%/jogl.os.x11.jar
|
||||
%%JAVAJARDIR%%/jogl.sdk.jar
|
||||
%%JAVAJARDIR%%/jogl.test.jar
|
||||
%%JAVAJARDIR%%/jogl.util.awt.jar
|
||||
%%JAVAJARDIR%%/jogl.util.cdc.jar
|
||||
%%JAVAJARDIR%%/jogl.util.fixedfuncemu.cdc.jar
|
||||
%%JAVAJARDIR%%/jogl.util.fixedfuncemu.jar
|
||||
%%JAVAJARDIR%%/jogl.util.gldesktop.jar
|
||||
%%JAVAJARDIR%%/jogl.util.jar
|
||||
%%JAVAJARDIR%%/nativewindow.all-noawt.jar
|
||||
%%JAVAJARDIR%%/nativewindow.all.cdc.jar
|
||||
%%JAVAJARDIR%%/nativewindow.all.jar
|
||||
%%JAVAJARDIR%%/nativewindow.awt.jar
|
||||
%%JAVAJARDIR%%/nativewindow.core.cdc.jar
|
||||
%%JAVAJARDIR%%/nativewindow.core.jar
|
||||
%%JAVAJARDIR%%/nativewindow.os.x11.cdc.jar
|
||||
%%JAVAJARDIR%%/nativewindow.os.x11.jar
|
||||
%%JAVAJARDIR%%/newt.all-noawt.jar
|
||||
%%JAVAJARDIR%%/newt.all.cdc.jar
|
||||
%%JAVAJARDIR%%/newt.all.jar
|
||||
%%JAVAJARDIR%%/newt.awt.jar
|
||||
%%JAVAJARDIR%%/newt.broadcomegl.cdc.jar
|
||||
%%JAVAJARDIR%%/newt.broadcomegl.jar
|
||||
%%JAVAJARDIR%%/newt.core.cdc.jar
|
||||
%%JAVAJARDIR%%/newt.core.jar
|
||||
%%JAVAJARDIR%%/newt.intelgdl.cdc.jar
|
||||
%%JAVAJARDIR%%/newt.intelgdl.jar
|
||||
%%JAVAJARDIR%%/newt.ogl.cdc.jar
|
||||
%%JAVAJARDIR%%/newt.ogl.jar
|
||||
%%JAVAJARDIR%%/newt.os.x11.cdc.jar
|
||||
%%JAVAJARDIR%%/newt.os.x11.jar
|
||||
%%JAVAJARDIR%%/gluegen2-rt.jar
|
||||
%%JAVAJARDIR%%/gluegen2.jar
|
||||
%%JAVAJARDIR%%/jogl2.jar
|
||||
|
Loading…
Reference in New Issue
Block a user