Create port for xlog, an amateur radio logging app
This commit is contained in:
parent
0ea0b23f32
commit
8eecc07db5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=69535
@ -50,6 +50,7 @@
|
||||
SUBDIR += vrflash
|
||||
SUBDIR += wy60
|
||||
SUBDIR += xcept
|
||||
SUBDIR += xlog
|
||||
SUBDIR += yaps
|
||||
SUBDIR += yawmppp
|
||||
SUBDIR += zmtx-zmrx
|
||||
|
20
comms/xlog/Makefile
Normal file
20
comms/xlog/Makefile
Normal file
@ -0,0 +1,20 @@
|
||||
# New ports collection makefile for: xlog
|
||||
# Date created: 2002-11-05
|
||||
# Whom: Patrick Gardella <patrick@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= xlog
|
||||
PORTVERSION= 0.7
|
||||
CATEGORIES= comms
|
||||
MASTER_SITES= http://people.debian.org/~pa3aba/download/
|
||||
|
||||
MAINTAINER= patrick@FreeBSD.org
|
||||
|
||||
USE_GTK= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= GTKCONFIG=${GTK_CONFIG}
|
||||
|
||||
MAN1= xlog.1
|
||||
|
||||
.include <bsd.port.mk>
|
1
comms/xlog/distinfo
Normal file
1
comms/xlog/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (xlog-0.7.tar.gz) = a86a32473bf24750dc98f68f730d8408
|
21
comms/xlog/files/patch-aa
Normal file
21
comms/xlog/files/patch-aa
Normal file
@ -0,0 +1,21 @@
|
||||
--- src/callbacks.c.orig Tue Nov 5 08:44:15 2002
|
||||
+++ src/callbacks.c Tue Nov 5 11:00:58 2002
|
||||
@@ -74,6 +74,9 @@
|
||||
extern RIG *myrig;
|
||||
#endif
|
||||
|
||||
+/* qsort/bsearch callback functions */
|
||||
+typedef int (*compar_callback_fn) (const void *, const void *);
|
||||
+
|
||||
/* ABOUT DIALOG */
|
||||
void on_aboutbutton_clicked (GtkButton *button, gpointer user_data)
|
||||
{
|
||||
@@ -1627,7 +1630,7 @@
|
||||
if (fields[i] != logw->logfields[i]) break;
|
||||
|
||||
/* copy and re-order the array */
|
||||
- qsort(fields, QSO_FIELDS, sizeof(gint), (__compar_fn_t)compare_fields);
|
||||
+ qsort(fields, QSO_FIELDS, sizeof(gint), (compar_callback_fn)compare_fields);
|
||||
if (i < QSO_FIELDS)
|
||||
{
|
||||
for (i = 0; i < QSO_FIELDS; i++)
|
13
comms/xlog/files/patch-ab
Normal file
13
comms/xlog/files/patch-ab
Normal file
@ -0,0 +1,13 @@
|
||||
--- src/callbacks_qsoframe.c.orig Tue Nov 5 11:02:05 2002
|
||||
+++ src/callbacks_qsoframe.c Tue Nov 5 11:16:32 2002
|
||||
@@ -25,6 +25,10 @@
|
||||
#include <time.h>
|
||||
#include <math.h>
|
||||
#include <ctype.h>
|
||||
+#ifdef __FreeBSD__
|
||||
+#include <machine/param.h>
|
||||
+#include <sys/types.h>
|
||||
+#endif
|
||||
#include <sys/ipc.h>
|
||||
#include <sys/shm.h>
|
||||
#include <errno.h>
|
20
comms/xlog/files/patch-ac
Normal file
20
comms/xlog/files/patch-ac
Normal file
@ -0,0 +1,20 @@
|
||||
--- src/utils.c.orig Tue Nov 5 11:22:20 2002
|
||||
+++ src/utils.c Tue Nov 5 11:23:06 2002
|
||||
@@ -284,7 +284,7 @@
|
||||
|
||||
str = g_new0(gchar, 100);
|
||||
|
||||
- fr = atoll(arg);
|
||||
+ fr = strtoll(arg, (char **)NULL, 10);
|
||||
|
||||
if (fr > 1325) /* no dot */
|
||||
{
|
||||
@@ -295,7 +295,7 @@
|
||||
str[strlen(str) - 6] = '\0';
|
||||
else if (strlen(str) > 3)
|
||||
str[strlen(str) - 3] = '\0';
|
||||
- fr = atoll(str);
|
||||
+ fr = strtoll(str, (char **)NULL, 10);
|
||||
}
|
||||
|
||||
switch (fr)
|
11
comms/xlog/files/patch-ad
Normal file
11
comms/xlog/files/patch-ad
Normal file
@ -0,0 +1,11 @@
|
||||
--- intl/dcigettext.c.orig Tue Nov 5 11:32:40 2002
|
||||
+++ intl/dcigettext.c Tue Nov 5 11:33:55 2002
|
||||
@@ -58,7 +58,7 @@
|
||||
#include <stdlib.h>
|
||||
|
||||
#include <string.h>
|
||||
-#if !HAVE_STRCHR && !defined _LIBC
|
||||
+#if !HAVE_STRCHR && !defined _LIBC && !defined __FreeBSD__
|
||||
# ifndef strchr
|
||||
# define strchr index
|
||||
# endif
|
1
comms/xlog/pkg-comment
Normal file
1
comms/xlog/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
An Amateur Radio station logging application
|
14
comms/xlog/pkg-descr
Normal file
14
comms/xlog/pkg-descr
Normal file
@ -0,0 +1,14 @@
|
||||
Xlog is a basic Amateur Radio station log. Xlog is able to do
|
||||
DXCC lookups and will display country information, CQ and ITU zone,
|
||||
location in latitude and longitude and distance and heading in
|
||||
kilometers or miles, both for short and long path. Locator distance
|
||||
and heading calculation for VHF logging is also supported.
|
||||
|
||||
If your rig supports data retrieval over the serial line, you
|
||||
should have a look at the Hamradio Control Libraries (hamlib)
|
||||
port, which will allow for automatic retrieval of information
|
||||
from your radio.
|
||||
|
||||
Xlog supports cabrillo and ADIF and can import twlog and editest files.
|
||||
|
||||
WWW: http://people.debian.org/~pa3aba/xlog.html
|
38
comms/xlog/pkg-plist
Normal file
38
comms/xlog/pkg-plist
Normal file
@ -0,0 +1,38 @@
|
||||
bin/xlog
|
||||
share/locale/da/LC_MESSAGES/xlog.mo
|
||||
share/locale/nl/LC_MESSAGES/xlog.mo
|
||||
share/locale/fr/LC_MESSAGES/xlog.mo
|
||||
share/locale/es/LC_MESSAGES/xlog.mo
|
||||
share/xlog/pixmaps/add.xpm
|
||||
share/xlog/pixmaps/cancel.xpm
|
||||
share/xlog/pixmaps/del.xpm
|
||||
share/xlog/pixmaps/mini-clock.xpm
|
||||
share/xlog/pixmaps/mini-trx.xpm
|
||||
share/xlog/pixmaps/mini-xlog.xpm
|
||||
share/xlog/pixmaps/ok.xpm
|
||||
share/xlog/pixmaps/s.xpm
|
||||
share/xlog/pixmaps/s0.xpm
|
||||
share/xlog/pixmaps/s1.xpm
|
||||
share/xlog/pixmaps/s2.xpm
|
||||
share/xlog/pixmaps/s3.xpm
|
||||
share/xlog/pixmaps/s4.xpm
|
||||
share/xlog/pixmaps/s5.xpm
|
||||
share/xlog/pixmaps/s6.xpm
|
||||
share/xlog/pixmaps/s7.xpm
|
||||
share/xlog/pixmaps/s8.xpm
|
||||
share/xlog/pixmaps/s9.xpm
|
||||
share/xlog/pixmaps/update.xpm
|
||||
share/xlog/pixmaps/xlog.png
|
||||
share/xlog/pixmaps/xlog.xpm
|
||||
share/xlog/dxcc/dxcck2di.changes
|
||||
share/xlog/dxcc/dxcck2di.txt
|
||||
share/xlog/remote/Makefile
|
||||
share/xlog/remote/README
|
||||
share/xlog/remote/fromxlog.c
|
||||
share/xlog/remote/sendtoxlog.c
|
||||
share/xlog/themes/xlogrc
|
||||
@dirrm share/xlog/pixmaps
|
||||
@dirrm share/xlog/dxcc
|
||||
@dirrm share/xlog/remote
|
||||
@dirrm share/xlog/themes
|
||||
@dirrm share/xlog
|
Loading…
Reference in New Issue
Block a user