Add new port emulators/libretro-vice:
libretro cores for emulating Commodore computers. PR: 251936 Submitted by: Daniel Menelkir
This commit is contained in:
parent
75bd849e54
commit
8ed769bb08
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=559963
@ -63,6 +63,7 @@
|
||||
SUBDIR += libc6-shim
|
||||
SUBDIR += libdsk
|
||||
SUBDIR += libretro-ppsspp
|
||||
SUBDIR += libretro-vice
|
||||
SUBDIR += libspectrum
|
||||
SUBDIR += linux-c7
|
||||
SUBDIR += linux-power10-functional-sim
|
||||
|
40
emulators/libretro-vice/Makefile
Normal file
40
emulators/libretro-vice/Makefile
Normal file
@ -0,0 +1,40 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libretro-vice
|
||||
PORTVERSION= 0.20201218
|
||||
CATEGORIES= emulators games
|
||||
PKGNAMESUFFIX= -${FLAVOR}
|
||||
|
||||
MAINTAINER= menelkir@itroll.org
|
||||
COMMENT= ${${FLAVOR}_COMMENT}
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
FLAVORS= x128 x64 x64sc xcbm2 xcbm5x0 xpet xplus4 xscpu64 xvic
|
||||
FLAVOR?= ${FLAVORS:[2]}
|
||||
|
||||
USES= gmake
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= libretro
|
||||
GH_PROJECT= vice-libretro
|
||||
GH_TAGNAME= 5725415
|
||||
|
||||
MAKE_ARGS= EMUTYPE=${FLAVOR}
|
||||
PLIST_FILES= lib/libretro/vice_${FLAVOR}_libretro.so
|
||||
|
||||
x128_COMMENT= Commodore C128 core for libretro API
|
||||
x64_COMMENT= Commodore C64 core for libretro API
|
||||
x64sc_COMMENT= Commodore C64 core for libretro API focused on accuracy
|
||||
xcbm2_COMMENT= Commodore CBM-6x0/7x0 core for libretro API
|
||||
xcbm5x0_COMMENT= Commodore C64 core for libretro API focused on accuracy
|
||||
xpet_COMMENT= Commodore PET core for libretro API
|
||||
xplus4_COMMENT= Commodore PLUS4 core for libretro API
|
||||
xscpu64_COMMENT= Commodore C64+SuperCPU core for libretro API
|
||||
xvic_COMMENT= Commodore VIC20 core for libretro API
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro
|
||||
${INSTALL_LIB} ${WRKSRC}/${COREDIR}/vice_${FLAVOR}_libretro.so ${STAGEDIR}/${PREFIX}/lib/libretro
|
||||
|
||||
.include <bsd.port.mk>
|
3
emulators/libretro-vice/distinfo
Normal file
3
emulators/libretro-vice/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1608741122
|
||||
SHA256 (libretro-vice-libretro-0.20201218-5725415_GH0.tar.gz) = 7cdfa471462c56d7602e664ac4d150c9545ac766a42a8c3f41faf8936a1c4542
|
||||
SIZE (libretro-vice-libretro-0.20201218-5725415_GH0.tar.gz) = 24296248
|
13
emulators/libretro-vice/files/patch-vice_src_rtc_rtc.h
Normal file
13
emulators/libretro-vice/files/patch-vice_src_rtc_rtc.h
Normal file
@ -0,0 +1,13 @@
|
||||
--- vice/src/rtc/rtc.h.orig 2020-12-18 10:39:47 UTC
|
||||
+++ vice/src/rtc/rtc.h
|
||||
@@ -28,10 +28,7 @@
|
||||
#define VICE_RTC_H
|
||||
|
||||
#include "types.h"
|
||||
-
|
||||
-#ifdef HAVE_TIME_T_IN_TIME_H
|
||||
#include <time.h>
|
||||
-#endif
|
||||
|
||||
#ifdef HAVE_TIME_T_IN_TYPES_H
|
||||
#include <sys/types.h>
|
3
emulators/libretro-vice/pkg-descr
Normal file
3
emulators/libretro-vice/pkg-descr
Normal file
@ -0,0 +1,3 @@
|
||||
Commodore computer emulator core for libretro API.
|
||||
|
||||
WWW: https://github.com/libretro/vice-libretro
|
Loading…
Reference in New Issue
Block a user