Add patches to fix a problem which prevents this from working
with VCP::Dest::SVK. Submitted by: June-Yen Huang (jihuang at gate dot sinica dot edu dot tw) PR: ports/71201
This commit is contained in:
parent
4829d989ab
commit
8ec5eb8071
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=117843
@ -6,7 +6,7 @@
|
||||
|
||||
PORTNAME= VCP
|
||||
PORTVERSION= 0.9
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= devel perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
|
||||
MASTER_SITE_SUBDIR= XML/RBS
|
||||
@ -26,7 +26,6 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-X
|
||||
${SITE_PERL}/BFD.pm:${PORTSDIR}/devel/p5-BFD \
|
||||
${SITE_PERL}/Text/Table.pm:${PORTSDIR}/textproc/p5-Text-Table \
|
||||
${SITE_PERL}/${PERL_ARCH}/List/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
|
||||
|
||||
RUN_DEPENDS= ${BUILD_DEPENDS}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
@ -77,7 +76,6 @@ MAN3= RevML::Doctype.3 \
|
||||
VCP::Filter::dumpdata.3 \
|
||||
VCP::Filter::identity.3 \
|
||||
VCP::Filter::labelmap.3 \
|
||||
VCP::Filter::logmemsize.3 \
|
||||
VCP::Filter::map.3 \
|
||||
VCP::Filter::sort.3 \
|
||||
VCP::Filter::stringedit.3 \
|
||||
@ -114,4 +112,7 @@ MAN3= RevML::Doctype.3 \
|
||||
VCP::Utils::revml.3 \
|
||||
VCP::Utils::vss.3
|
||||
|
||||
post-patch:
|
||||
${FIND} ${WRKSRC} -name "*.orig" -a -exec ${RM} -f {} \;
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
16
devel/p5-VCP/files/patch-MANIFEST
Normal file
16
devel/p5-VCP/files/patch-MANIFEST
Normal file
@ -0,0 +1,16 @@
|
||||
--- MANIFEST.orig Fri Mar 19 05:38:29 2004
|
||||
+++ MANIFEST Mon Jul 12 04:45:29 2004
|
||||
@@ -53,7 +53,6 @@
|
||||
lib/VCP/Filter/dumpdata.pm
|
||||
lib/VCP/Filter/identity.pm
|
||||
lib/VCP/Filter/labelmap.pm
|
||||
-lib/VCP/Filter/logmemsize.pm
|
||||
lib/VCP/Filter/map.pm
|
||||
lib/VCP/Filter/sort.pm
|
||||
lib/VCP/Filter/stringedit.pm
|
||||
@@ -164,4 +163,4 @@
|
||||
t/95p42p4.t
|
||||
t/99p4_label_branch_rev_1.t
|
||||
t/buildpss.ksh,v
|
||||
-t/swapnfs.c,v
|
||||
+META.yml Module meta-data (added by MakeMaker)
|
27
devel/p5-VCP/files/patch-META.yml
Normal file
27
devel/p5-VCP/files/patch-META.yml
Normal file
@ -0,0 +1,27 @@
|
||||
--- META.yml.orig Thu Jan 1 08:00:00 1970
|
||||
+++ META.yml Sun Jul 18 01:49:37 2004
|
||||
@@ -0,0 +1,24 @@
|
||||
+# http://module-build.sourceforge.net/META-spec.html
|
||||
+#XXXXXXX This is a prototype!!! It will change in the future!!! XXXXX#
|
||||
+name: VCP
|
||||
+version: 0.9
|
||||
+version_from: lib/VCP.pm
|
||||
+installdirs: site
|
||||
+requires:
|
||||
+ Digest::MD5: 0
|
||||
+ File::Temp: 0
|
||||
+ HTML::Element: 0
|
||||
+ IPC::Run3: 0
|
||||
+ MIME::Base64: 0
|
||||
+ Pod::HTML_Elements: 0
|
||||
+ Pod::Links: 0
|
||||
+ Pod::Select: 0
|
||||
+ Pod::Text: 0
|
||||
+ Pod::Usage: 0
|
||||
+ Regexp::Shellish: 0.93
|
||||
+ Text::Diff: 0
|
||||
+ XML::Parser: 0
|
||||
+ XML::ValidWriter: 0.38
|
||||
+
|
||||
+distribution_type: module
|
||||
+generated_by: ExtUtils::MakeMaker version 6.17
|
47
devel/p5-VCP/files/patch-bin::build_vcp_executable.pl
Normal file
47
devel/p5-VCP/files/patch-bin::build_vcp_executable.pl
Normal file
@ -0,0 +1,47 @@
|
||||
--- bin/build_vcp_executable.pl.orig Sat Jan 31 12:03:32 2004
|
||||
+++ bin/build_vcp_executable.pl Tue Apr 13 02:08:36 2004
|
||||
@@ -7,7 +7,8 @@
|
||||
=head1 SYNOPSIS
|
||||
|
||||
cd VCP
|
||||
- bin\build_vcp_executable.pl
|
||||
+ bin\build_vcp_executable.pl ## build ./vcp-bin or ./vcp.exe
|
||||
+ bin\build_vcp_executable.pl --build-vcp-pl ## build ./vcp.pl
|
||||
|
||||
=head1 DESCRIPTION
|
||||
|
||||
@@ -65,8 +66,13 @@
|
||||
use lib "lib";
|
||||
use constant is_win32 => $^O =~ /Win32/i;
|
||||
|
||||
+use Getopt::Long;
|
||||
use VCP::TestUtils qw( run );
|
||||
|
||||
+GetOptions( "build-vcp-pl" => \my $build_vcp_pl ) or die $!;
|
||||
+warn "ignoring command line parameter(s): ", join ", ", map "\"$_\"", @ARGV
|
||||
+ if @ARGV;
|
||||
+
|
||||
## VCP uses lazy loading extensively...
|
||||
my %skip_modules = (
|
||||
"VCP::TestUtils" => 1,
|
||||
@@ -121,7 +127,7 @@
|
||||
close VCP_OUT;
|
||||
}
|
||||
|
||||
-my $exe_name = is_win32 ? "vcp.exe" : "vcp-bin";
|
||||
+my $exe_name = $build_vcp_pl ? "vcp.pl" : is_win32 ? "vcp.exe" : "vcp-bin";
|
||||
|
||||
if ( 1 ) {
|
||||
if ( -e $exe_name ) {
|
||||
@@ -130,8 +136,9 @@
|
||||
|
||||
my @cmd = (
|
||||
"pp",
|
||||
- "-o", $exe_name,
|
||||
-# "-p", "-B", "-o", "vcp.pl",
|
||||
+ $build_vcp_pl
|
||||
+ ? ( "-P", "-o", "vcp.pl" )
|
||||
+ : ( "-o", $exe_name ),
|
||||
"-lib=lib",
|
||||
sort(
|
||||
map "--add=$_", @modules#, map "lib/$_", @pod_files
|
11
devel/p5-VCP/files/patch-bin::dump_rev_map
Normal file
11
devel/p5-VCP/files/patch-bin::dump_rev_map
Normal file
@ -0,0 +1,11 @@
|
||||
--- bin/dump_rev_map.orig Thu Oct 9 03:09:00 2003
|
||||
+++ bin/dump_rev_map Fri Apr 16 01:25:58 2004
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
use strict;
|
||||
use VCP::Debug qw( :debug );
|
||||
-BEGIN { enable_debug ".*"; }
|
||||
+#BEGIN { enable_debug ".*"; }
|
||||
|
||||
use VCP::RevMapDB;
|
||||
|
41
devel/p5-VCP/files/patch-bin::vcp
Normal file
41
devel/p5-VCP/files/patch-bin::vcp
Normal file
@ -0,0 +1,41 @@
|
||||
--- bin/vcp.orig Fri Mar 19 05:30:20 2004
|
||||
+++ bin/vcp Tue Apr 13 02:08:37 2004
|
||||
@@ -360,8 +360,6 @@
|
||||
|| -S _ < 1_000_000 # That would be toooo big
|
||||
);
|
||||
|
||||
- print banner() if $is_vcp_file;
|
||||
-
|
||||
$vcp_spec = $is_vcp_file
|
||||
? VCP::ConfigFileUtils::parse_config_file( $source_spec )
|
||||
: ! $cant_be_vcp_file
|
||||
@@ -375,6 +373,7 @@
|
||||
$vcp_filename = $source_spec;
|
||||
shift @ARGV;
|
||||
}
|
||||
+
|
||||
};
|
||||
|
||||
if ( $vcp_spec ) {
|
||||
@@ -418,6 +417,10 @@
|
||||
$spec = "";
|
||||
}
|
||||
|
||||
+ print banner()
|
||||
+ if $type eq "dest" && length $spec && $spec ne "-";
|
||||
+ ## Don't emit the banner if we're emitting to STDOUT.
|
||||
+
|
||||
push @plugins, load_module( $spec, $type, $default_scheme, $value );
|
||||
|
||||
die "extra parameters for $tag: ", shell_quote( @$value ), "\n"
|
||||
@@ -442,6 +445,10 @@
|
||||
$type = "Dest";
|
||||
$default_scheme = "revml";
|
||||
}
|
||||
+
|
||||
+ print banner()
|
||||
+ if $type eq "Dest" && length $spec && $spec ne "-";
|
||||
+ ## Don't emit the banner if we're emitting to STDOUT.
|
||||
|
||||
## We pass \@ARGV to the constructors for source and dest so
|
||||
## that they may parse some of @ARGV and leave the rest.
|
7
devel/p5-VCP/files/patch-lib::VCP.pm
Normal file
7
devel/p5-VCP/files/patch-lib::VCP.pm
Normal file
@ -0,0 +1,7 @@
|
||||
--- lib/VCP.pm.orig Fri Mar 19 05:30:51 2004
|
||||
+++ lib/VCP.pm Mon Jul 12 21:21:10 2004
|
||||
@@ -174,3 +174,4 @@
|
||||
=cut
|
||||
|
||||
1
|
||||
+;
|
22
devel/p5-VCP/files/patch-lib::VCP::Filter::changesets.pm
Normal file
22
devel/p5-VCP/files/patch-lib::VCP::Filter::changesets.pm
Normal file
@ -0,0 +1,22 @@
|
||||
--- lib/VCP/Filter/changesets.pm.orig Fri Jan 30 10:48:34 2004
|
||||
+++ lib/VCP/Filter/changesets.pm Sun Jul 18 01:39:02 2004
|
||||
@@ -666,8 +666,8 @@
|
||||
if ( !$change ) {
|
||||
my @future_indexes =
|
||||
grep $_ != $r_index,
|
||||
- unpack "w*", $changes->[$change_index]
|
||||
- if $changes->[$change_index];
|
||||
+ unpack "w*",
|
||||
+ exists $changes->[$change_index] ? $changes->[$change_index] : '';
|
||||
|
||||
undef $changes->[$change_index];
|
||||
|
||||
@@ -780,7 +780,7 @@
|
||||
|
||||
my $r_index = delete $self->{INDEXES_BY_ID}->{$r->id};
|
||||
|
||||
- if ( $children->[$r_index] ) {
|
||||
+ if ( exists $children->[$r_index] ) {
|
||||
push @cur_indexes, unpack "w*", $children->[$r_index];
|
||||
}
|
||||
undef $children->[$r_index]; ## undef $foo releases extra memory
|
110
devel/p5-VCP/files/patch-lib::VCP::Filter::logmemsize.pm
Normal file
110
devel/p5-VCP/files/patch-lib::VCP::Filter::logmemsize.pm
Normal file
@ -0,0 +1,110 @@
|
||||
--- lib/VCP/Filter/logmemsize.pm.orig Sat Nov 15 04:41:49 2003
|
||||
+++ lib/VCP/Filter/logmemsize.pm Thu Jan 1 08:00:00 1970
|
||||
@@ -1,107 +0,0 @@
|
||||
-package VCP::Filter::logmemsize ;
|
||||
-
|
||||
-=head1 NAME
|
||||
-
|
||||
-VCP::Filter::logmemsize - developement logging filter
|
||||
-
|
||||
-=head1 DESCRIPTION
|
||||
-
|
||||
-Watches memory size. Only works on linux for now.
|
||||
-
|
||||
-Not a supported module, API and behavior may change without warning.
|
||||
-
|
||||
-=cut
|
||||
-
|
||||
-$VERSION = 0.1 ;
|
||||
-
|
||||
-use strict ;
|
||||
-
|
||||
-my $start_size;
|
||||
-
|
||||
-
|
||||
-sub get_size {
|
||||
- open F, "/proc/$$/statm" or return 0;
|
||||
- my ( $s ) = <F> =~ /^(\d+)/;
|
||||
- close F;
|
||||
-
|
||||
- return $s * 4;
|
||||
-}
|
||||
-
|
||||
-sub get_sizes {
|
||||
- my $s = get_size;
|
||||
-
|
||||
- return ( $s - $start_size, "KB (", $s, "KB)" );
|
||||
-}
|
||||
-
|
||||
-BEGIN {
|
||||
- $start_size = get_size;
|
||||
-}
|
||||
-
|
||||
-use base qw( VCP::Filter );
|
||||
-use fields qw( LogString );
|
||||
-
|
||||
-use VCP::Utils qw( empty );
|
||||
-use VCP::Logger qw( pr lg );
|
||||
-
|
||||
-END {
|
||||
- lg "memsize: ", get_sizes;
|
||||
-}
|
||||
-
|
||||
-sub new {
|
||||
- my $class = shift ;
|
||||
- $class = ref $class || $class ;
|
||||
-
|
||||
- my ( $spec, $options ) = @_;
|
||||
-
|
||||
- my $self = $class->SUPER::new( @_ );
|
||||
- $self->{LogString} = shift @$options if $options;
|
||||
- $self->{LogString} = "" unless defined $self->{LogString};
|
||||
- $self->{LogString} .= " " unless empty $self->{LogString};
|
||||
-
|
||||
- lg $self->{LogString}, "starting memsize: (${start_size}KB)";
|
||||
- lg $self->{LogString}, "memsize: ", get_sizes;
|
||||
-
|
||||
- return $self;
|
||||
-}
|
||||
-
|
||||
-
|
||||
-sub handle_header {
|
||||
- my VCP::Filter::logmemsize $self = shift ;
|
||||
-
|
||||
- lg $self->{LogString}, "memsize: ", get_sizes;
|
||||
-
|
||||
- $self->SUPER::handle_header( @_ );
|
||||
-}
|
||||
-
|
||||
-sub handle_rev {
|
||||
- my VCP::Filter::logmemsize $self = shift ;
|
||||
-
|
||||
- lg $self->{LogString}, "memsize: ", get_sizes;
|
||||
- $self->SUPER::handle_rev( @_ );
|
||||
-}
|
||||
-
|
||||
-
|
||||
-sub handle_footer {
|
||||
- my VCP::Filter::logmemsize $self = shift ;
|
||||
-
|
||||
- lg $self->{LogString}, "memsize: ", get_sizes;
|
||||
- $self->SUPER::handle_footer ( @_ );
|
||||
- lg $self->{LogString}, "memsize: ", get_sizes;
|
||||
-}
|
||||
-
|
||||
-=back
|
||||
-
|
||||
-=head1 AUTHOR
|
||||
-
|
||||
-Barrie Slaymaker <barries@slaysys.com>
|
||||
-
|
||||
-=head1 COPYRIGHT
|
||||
-
|
||||
-Copyright (c) 2000, 2001, 2002 Perforce Software, Inc.
|
||||
-All rights reserved.
|
||||
-
|
||||
-See L<VCP::License|VCP::License> (C<vcp help license>) for the terms of use.
|
||||
-
|
||||
-=cut
|
||||
-
|
||||
-1
|
13
devel/p5-VCP/files/patch-lib::VCP::Source::p4.pm
Normal file
13
devel/p5-VCP/files/patch-lib::VCP::Source::p4.pm
Normal file
@ -0,0 +1,13 @@
|
||||
--- lib/VCP/Source/p4.pm.orig Fri Jan 30 10:48:36 2004
|
||||
+++ lib/VCP/Source/p4.pm Mon Apr 19 01:10:03 2004
|
||||
@@ -781,8 +781,9 @@
|
||||
next ;
|
||||
}
|
||||
next if $spec =~ m{^error: //\.\.\.\@.+ file(\(s\))?( not in label.)?$} ;
|
||||
+ next if $spec =~ m{^error: //\.\.\..+ - no such file\(s\)\.};
|
||||
$spec =~ /^.*?: *(\/\/.*#\d+)/
|
||||
- or die "Couldn't parse name & rev from '$spec' in p4 output:\n$files\n" ;
|
||||
+ or die "Couldn't parse name & rev from '$spec' in p4 output:\n$files\n";
|
||||
my $id = $1;
|
||||
|
||||
debug "p4 label '$label' => '$id'" if debugging ;
|
11
devel/p5-VCP/files/patch-lib::VCP::Utils::p4.pm
Normal file
11
devel/p5-VCP/files/patch-lib::VCP::Utils::p4.pm
Normal file
@ -0,0 +1,11 @@
|
||||
--- lib/VCP/Utils/p4.pm.orig Fri Jan 30 10:48:39 2004
|
||||
+++ lib/VCP/Utils/p4.pm Mon Apr 19 00:35:59 2004
|
||||
@@ -830,7 +830,7 @@
|
||||
$self->p4( [ "client", "-i" ], \$client_spec, \my $out ) ;
|
||||
|
||||
die "unexpected stdout from p4:\np4: ", $out
|
||||
- unless $out =~ /^Client\s.*\ssaved\./ ;
|
||||
+ unless $out =~ /^Client\s.*\s(saved|.*not changed)\./ ;
|
||||
}
|
||||
|
||||
=item split_repo_server
|
@ -39,7 +39,6 @@ bin/vcp
|
||||
%%SITE_PERL%%/VCP/Filter/dumpdata.pm
|
||||
%%SITE_PERL%%/VCP/Filter/identity.pm
|
||||
%%SITE_PERL%%/VCP/Filter/labelmap.pm
|
||||
%%SITE_PERL%%/VCP/Filter/logmemsize.pm
|
||||
%%SITE_PERL%%/VCP/Filter/map.pm
|
||||
%%SITE_PERL%%/VCP/Filter/sort.pm
|
||||
%%SITE_PERL%%/VCP/Filter/stringedit.pm
|
||||
|
Loading…
Reference in New Issue
Block a user