AdPlug is a free, cross-platform, hardware independent AdLib sound player

library, mainly written in C++ and released under the LGPL. AdPlug plays
sound data, originally created for the AdLib (OPL2) audio board, directly
from its original format on top of an OPL2 emulator or by using the real
hardware. No OPL chip is required for playback.

AdPlug itself is just the backend to many different audio player frontends,
which are also being developed here. There are plugins for popular audio
players, like Winamp and XMMS, as well as stand-alone players for many
different systems available.

WWW: http://adplug.sourceforge.net/

PR:		ports/80727
Submitted by:	Emanuel Haupt <ehaupt@critical.ch>
This commit is contained in:
Jean-Yves Lefort 2005-05-09 20:18:51 +00:00
parent dfc8eb9877
commit 8e9ee1ebda
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=134947
6 changed files with 141 additions and 0 deletions

View File

@ -226,6 +226,7 @@
SUBDIR += ladspa
SUBDIR += lame
SUBDIR += liba52
SUBDIR += libadplug
SUBDIR += libao
SUBDIR += libaudiofile
SUBDIR += libcdaudio

42
audio/libadplug/Makefile Normal file
View File

@ -0,0 +1,42 @@
# New ports collection makefile for: adplug
# Date created: 10 August 2004
# Whom: Emanuel Haupt <ehaupt@critical.ch>
#
# $FreeBSD$
#
PORTNAME= libadplug
PORTVERSION= 1.5
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= adplug
DISTNAME= adplug-${PORTVERSION}
MAINTAINER= ehaupt@critical.ch
COMMENT= AdLib emulator library supporting many formats
LIB_DEPENDS= binio.1:${PORTSDIR}/devel/libbinio
INSTALLS_SHLIB= yes
USE_LIBTOOL_VER=15
USE_REINPLACE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CFLAGS="${CFLAGS} ${CPPFLAGS}" \
CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}" \
CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
MAN1= adplugdb.1
post-patch:
@${REINPLACE_CMD} -e 's|^\(SUBDIRS\ =\).*|\1 src adplugdb test|' \
${WRKSRC}/Makefile.in
post-install:
${MKDIR} ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/doc/adplugdb.1 ${MANPREFIX}/man/man1
.include <bsd.port.mk>

2
audio/libadplug/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (adplug-1.5.tar.gz) = b93a162bc5cfb1493d2affdfed18e9a1
SIZE (adplug-1.5.tar.gz) = 962345

View File

@ -0,0 +1,27 @@
--- adplugdb/adplugdb.cpp.orig Sun Aug 8 21:17:40 2004
+++ adplugdb/adplugdb.cpp Sat May 7 06:16:26 2005
@@ -29,6 +29,7 @@
#include <binfile.h>
#include <string>
#include <iostream>
+#include <unistd.h>
#if defined(HAVE_SYS_TYPES_H) && defined(HAVE_SYS_STAT_H)
# if HAVE_SYS_TYPES_H
@@ -46,16 +47,6 @@
#include "../src/adplug.h"
#include "../src/silentopl.h"
#include "../src/database.h"
-
-/*
- * Apple (OS X) and Sun systems declare getopt in unistd.h, other systems
- * (Linux) use getopt.h.
- */
-#if defined ( __APPLE__ ) || ( defined (__SVR4) && defined (__sun) )
-# include <unistd.h>
-#else
-# include "getopt.h"
-#endif
/***** Defines *****/

15
audio/libadplug/pkg-descr Normal file
View File

@ -0,0 +1,15 @@
AdPlug is a free, cross-platform, hardware independent AdLib sound player
library, mainly written in C++ and released under the LGPL. AdPlug plays
sound data, originally created for the AdLib (OPL2) audio board, directly
from its original format on top of an OPL2 emulator or by using the real
hardware. No OPL chip is required for playback.
AdPlug itself is just the backend to many different audio player frontends,
which are also being developed here. There are plugins for popular audio
players, like Winamp and XMMS, as well as stand-alone players for many
different systems available.
WWW: http://adplug.sourceforge.net/
- ehaupt
ehaupt@critical.ch

54
audio/libadplug/pkg-plist Normal file
View File

@ -0,0 +1,54 @@
bin/adplugdb
include/adplug/a2m.h
include/adplug/adlibemu.h
include/adplug/adplug.h
include/adplug/adtrack.h
include/adplug/amd.h
include/adplug/bam.h
include/adplug/bmf.h
include/adplug/cff.h
include/adplug/d00.h
include/adplug/database.h
include/adplug/dfm.h
include/adplug/diskopl.h
include/adplug/dmo.h
include/adplug/dro.h
include/adplug/dtm.h
include/adplug/emuopl.h
include/adplug/flash.h
include/adplug/fmc.h
include/adplug/fmopl.h
include/adplug/fprovide.h
include/adplug/hsc.h
include/adplug/hsp.h
include/adplug/hybrid.h
include/adplug/hyp.h
include/adplug/imf.h
include/adplug/kemuopl.h
include/adplug/ksm.h
include/adplug/lds.h
include/adplug/mad.h
include/adplug/mid.h
include/adplug/mkj.h
include/adplug/mtk.h
include/adplug/opl.h
include/adplug/player.h
include/adplug/players.h
include/adplug/protrack.h
include/adplug/psi.h
include/adplug/rad.h
include/adplug/rat.h
include/adplug/raw.h
include/adplug/rol.h
include/adplug/s3m.h
include/adplug/sa2.h
include/adplug/silentopl.h
include/adplug/sng.h
include/adplug/u6m.h
include/adplug/xad.h
include/adplug/xsm.h
lib/libadplug-1.5.so
lib/libadplug-1.5.so.0
lib/libadplug.a
lib/libadplug.so
@dirrm include/adplug