get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead. respect CC, CFLAGS.
This commit is contained in:
parent
3971644de4
commit
8e775bbe3a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=84837
@ -7,22 +7,20 @@
|
||||
|
||||
PORTNAME= lbrate
|
||||
PORTVERSION= 1.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= archivers
|
||||
MASTER_SITES= ftp://ftp.ibiblio.org/pub/Linux/utils/compress/
|
||||
|
||||
MAINTAINER= gslin@ccca.nctu.edu.tw
|
||||
COMMENT= Extract/decompress CP/M LBR archives
|
||||
|
||||
LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
|
||||
|
||||
USE_GETOPT_LONG=yes
|
||||
USE_REINPLACE= yes
|
||||
MAKE_ENV= CPPFLAGS="${CPPFLAGS}" \
|
||||
LDFLAGS="${LDFLAGS}"
|
||||
|
||||
MAN1= lbrate.1
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s,^CC|^PREFIX,#,g" ${WRKSRC}/Makefile
|
||||
@${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
|
@ -1,20 +1,28 @@
|
||||
--- Makefile.orig Wed Aug 29 19:07:24 2001
|
||||
+++ Makefile Wed Aug 29 19:08:13 2001
|
||||
@@ -1,7 +1,7 @@
|
||||
--- Makefile.orig Fri Aug 31 01:03:17 2001
|
||||
+++ Makefile Sun Jul 6 05:09:19 2003
|
||||
@@ -1,13 +1,13 @@
|
||||
# Makefile - makefile for lbrate
|
||||
|
||||
CC=gcc
|
||||
-CC=gcc
|
||||
-CFLAGS=-O2 -Wall
|
||||
+CFLAGS+=-I%%LOCALBASE%%/include
|
||||
+CC?= gcc
|
||||
+CFLAGS+=$(CPPFLAGS)
|
||||
|
||||
# Set BINDIR to directory for binary,
|
||||
# MANDIR to directory for man page.
|
||||
# Usually it will be simpler to just set PREFIX.
|
||||
#
|
||||
-PREFIX=/usr/local
|
||||
+PREFIX?=/usr/local
|
||||
BINDIR=$(PREFIX)/bin
|
||||
MANDIR=$(PREFIX)/man/man1
|
||||
|
||||
@@ -19,7 +19,7 @@
|
||||
all: lbrate
|
||||
|
||||
lbrate: $(OBJ)
|
||||
- $(CC) $(CFLAGS) -o lbrate $(OBJ)
|
||||
+ $(CC) $(CFLAGS) -o lbrate $(OBJ) -L%%LOCALBASE%%/lib -lgnugetopt
|
||||
+ $(CC) $(CFLAGS) -o lbrate $(OBJ) $(LDFLAGS)
|
||||
|
||||
installdirs:
|
||||
/bin/sh ./mkinstalldirs $(BINDIR) $(MANDIR)
|
||||
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= qcl
|
||||
PORTVERSION= 0.4.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= emulators math
|
||||
MASTER_SITES= http://tph.tuwien.ac.at/~oemer/tgz/
|
||||
EXTRACT_SUFX= .tgz
|
||||
@ -14,12 +15,12 @@ EXTRACT_SUFX= .tgz
|
||||
MAINTAINER= huntting@glarp.com
|
||||
COMMENT= A quantum computer simulator
|
||||
|
||||
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
|
||||
USE_GETOPT_LONG=yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 500113
|
||||
BROKEN= "Does not compile (bad C++ code)"
|
||||
BROKEN= "Does not compile (bad C++ code)"
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
|
@ -16,7 +16,7 @@
|
||||
|
||||
-DEBUG = -g -DQCL_DEBUG -DQC_DEBUG
|
||||
-#DEBUG = -O2
|
||||
+DEBUG = -O2
|
||||
+DEBUG =
|
||||
|
||||
# Comment out if you don't have GNU readline on your system
|
||||
# explicit linking against libtermcap or libncurses may be required
|
||||
|
@ -6,6 +6,7 @@
|
||||
|
||||
PORTNAME= metapixel
|
||||
PORTVERSION= 0.7
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.complang.tuwien.ac.at/~schani/metapixel/
|
||||
|
||||
@ -13,11 +14,13 @@ MAINTAINER= arved@FreeBSD.org
|
||||
COMMENT= "Metapixel is a program for generating photomosaics"
|
||||
|
||||
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
|
||||
jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
|
||||
jpeg.9:${PORTSDIR}/graphics/jpeg
|
||||
|
||||
USE_GETOPT_LONG=yes
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
MAKE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
|
||||
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
|
||||
|
||||
post-patch:
|
||||
@${RM} ${WRKSRC}/getopt.h
|
||||
|
@ -1,22 +1,20 @@
|
||||
--- Makefile.orig Fri Jan 21 23:32:17 2000
|
||||
+++ Makefile Tue Sep 24 03:40:26 2002
|
||||
@@ -1,18 +1,18 @@
|
||||
--- Makefile.orig Sat Jan 22 07:32:17 2000
|
||||
+++ Makefile Sun Jul 6 19:40:11 2003
|
||||
@@ -1,5 +1,3 @@
|
||||
-PREFIX = /usr/local
|
||||
-INSTALL = install
|
||||
|
||||
BINDIR = $(PREFIX)/bin
|
||||
|
||||
VERSION = 0.7
|
||||
@@ -7,12 +5,12 @@
|
||||
|
||||
#PROFILE = -pg
|
||||
+CFLAGS+= -I/usr/local/include
|
||||
+LDFLAGS+= -L/usr/local/lib -lgnugetopt
|
||||
|
||||
-LDOPTS = -L/usr/X11R6/lib $(PROFILE)
|
||||
-CCOPTS = -I/usr/X11R6/include -I/usr/X11R6/include/X11 -Wall -O9 $(PROFILE) -DMETAPIXEL_VERSION=\"$(VERSION)\"
|
||||
-CC = gcc
|
||||
+LDOPTS = ${LDFLAGS} -L/usr/X11R6/lib $(PROFILE)
|
||||
+CCOPTS = ${CFLAGS} -I/usr/X11R6/include -I/usr/X11R6/include/X11 -Wall $(PROFILE) -DMETAPIXEL_VERSION=\"$(VERSION)\"
|
||||
+LDOPTS = ${LDFLAGS} $(PROFILE)
|
||||
+CCOPTS = ${CFLAGS} ${CPPFLAGS} -Wall $(PROFILE) -DMETAPIXEL_VERSION=\"$(VERSION)\"
|
||||
+#CC = gcc
|
||||
#LIBFFM = -lffm
|
||||
|
||||
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= qcl
|
||||
PORTVERSION= 0.4.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= emulators math
|
||||
MASTER_SITES= http://tph.tuwien.ac.at/~oemer/tgz/
|
||||
EXTRACT_SUFX= .tgz
|
||||
@ -14,12 +15,12 @@ EXTRACT_SUFX= .tgz
|
||||
MAINTAINER= huntting@glarp.com
|
||||
COMMENT= A quantum computer simulator
|
||||
|
||||
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
|
||||
USE_GETOPT_LONG=yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 500113
|
||||
BROKEN= "Does not compile (bad C++ code)"
|
||||
BROKEN= "Does not compile (bad C++ code)"
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
|
@ -16,7 +16,7 @@
|
||||
|
||||
-DEBUG = -g -DQCL_DEBUG -DQC_DEBUG
|
||||
-#DEBUG = -O2
|
||||
+DEBUG = -O2
|
||||
+DEBUG =
|
||||
|
||||
# Comment out if you don't have GNU readline on your system
|
||||
# explicit linking against libtermcap or libncurses may be required
|
||||
|
@ -7,19 +7,21 @@
|
||||
|
||||
PORTNAME= bbrun
|
||||
PORTVERSION= 1.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://www.dwave.net/~jking/bbrun/
|
||||
|
||||
MAINTAINER= adamw@FreeBSD.org
|
||||
COMMENT= A Run box for Blackbox
|
||||
|
||||
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
|
||||
|
||||
USE_GETOPT_LONG=yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_GNOME= gtk12
|
||||
USE_GMAKE= yes
|
||||
USE_XPM= yes
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/bbrun
|
||||
MAKE_ENV= CPPFLAGS="${CPPFLAGS}" \
|
||||
LDFLAGS="${LDFLAGS}"
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/bbrun ${PREFIX}/bin
|
||||
|
@ -4,8 +4,8 @@
|
||||
-CC = gcc
|
||||
-LIBS = -lXpm `gtk-config --libs`
|
||||
-CFLAGS = `gtk-config --cflags`
|
||||
+LIBS = -lXpm `${GTK_CONFIG} --libs` -L${LOCALBASE}/lib -lgnugetopt
|
||||
+CFLAGS = `${GTK_CONFIG} --cflags` -Wall
|
||||
+LIBS = -lXpm `${GTK_CONFIG} --libs`
|
||||
+CFLAGS += `${GTK_CONFIG} --cflags` -Wall
|
||||
OBJS = bbrun.o \
|
||||
../wmgeneral/wmgeneral.o \
|
||||
../wmgeneral/misc.o \
|
||||
@ -17,7 +17,7 @@
|
||||
|
||||
bbrun: $(OBJS)
|
||||
- $(CC) -Wall -g -o bbrun $^ $(LIBS)
|
||||
+ $(CC) -o bbrun $^ $(LIBS)
|
||||
+ $(CC) -o bbrun $^ $(LDFLAGS) $(LIBS)
|
||||
|
||||
install:
|
||||
cp bbrun /usr/local/bin/
|
||||
|
Loading…
Reference in New Issue
Block a user