Adding port converters/p5-XML-WBXML, Convert between XML and WBXML using libwbxml2.

Approved by:	tobez (implicit)
This commit is contained in:
Aaron Dalton 2006-05-25 21:24:38 +00:00
parent bd37a487b6
commit 8e510cc367
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=163421
6 changed files with 65 additions and 0 deletions

View File

@ -64,6 +64,7 @@
SUBDIR += p5-Unicode-RecursiveDowngrade
SUBDIR += p5-Unicode-String
SUBDIR += p5-Unicode-UTF8simple
SUBDIR += p5-XML-WBXML
SUBDIR += pecl-fribidi
SUBDIR += php4-iconv
SUBDIR += php4-mbstring

View File

@ -0,0 +1,30 @@
# New ports collection makefile for: p5-XML-WBXML
# Date created: 25 May 2006
# Whom: Aaron Dalton <aaron@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= XML-WBXML
PORTVERSION= 0.02
CATEGORIES= converters perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= XML
PKGNAMEPREFIX= p5-
MAINTAINER= aaron@FreeBSD.org
COMMENT= Convert between XML and WBXML using libwbxml2
LIB_DEPENDS= wbxml2:${PORTSDIR}/textproc/wbxml2
MAN3= XML::WBXML.3
PERL_CONFIGURE= yes
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
IGNORE= currently requires Perl 5.8. Please install lang/perl5.8 and try again
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,3 @@
MD5 (XML-WBXML-0.02.tar.gz) = e8c255cdcb64cfa3883a932daaf9d813
SHA256 (XML-WBXML-0.02.tar.gz) = 4fc4c6fa6487d96fa7b6ee96b846abf391b55c5a096d6cfb5b61f366e81601bd
SIZE (XML-WBXML-0.02.tar.gz) = 51830

View File

@ -0,0 +1,14 @@
--- Makefile.PL Thu Aug 11 19:31:58 2005
+++ Makefile.PL Thu May 25 15:13:58 2006
@@ -8,9 +8,9 @@
PREREQ_PM => {}, # e.g., Module::Name => 1.1
ABSTRACT_FROM => 'lib/XML/WBXML.pm', # retrieve abstract from module
AUTHOR => 'David Glasser <glasser@bestpractical.com>',
- LIBS => ['-lwbxml2'], # e.g., '-lm'
+ LIBS => ['-L/usr/local/lib -lwbxml2'], # e.g., '-lm'
DEFINE => '', # e.g., '-DHAVE_SOMETHING'
- INC => '-I.', # e.g., '-I. -I/usr/include/other'
+ INC => '-I. -I/usr/local/include', # e.g., '-I. -I/usr/include/other'
# Un-comment this if you add C files to link with later:
# OBJECT => '$(O_FILES)', # link all the C files too
);

View File

@ -0,0 +1,10 @@
This module is a wrapper around Aymerick Jehanne's libwbxml (or perhaps
libwbxml2, I am not sure what the distinction is) library for handling
Wireless Binary XML. You must install libwbxml2 prior to installing this
module. The library can be found at http://libwbxml.aymerick.com/
(libwbxml2 itself requires the expat library to be installed.)
The module defines two functions: xml_to_wbxml and wbxml_to_xml.
WWW: http://search.cpan.org/dist/XML-WBXML
Author: David Glasser <glasser@bestpractical.com>

View File

@ -0,0 +1,7 @@
%%SITE_PERL%%/%%PERL_ARCH%%/XML/WBXML.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/WBXML/.packlist
%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/WBXML/WBXML.bs
%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/WBXML/WBXML.so
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/WBXML
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/XML