add replaceit 1.0.0
A light replacement to the combination of sed/awk/grep/head/tail PR: 29837 Submitted by: Patrick Li <pat@databits.net>
This commit is contained in:
parent
abf557dacc
commit
8e17bd7210
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46813
@ -158,6 +158,7 @@
|
||||
SUBDIR += py-trex
|
||||
SUBDIR += py-xml
|
||||
SUBDIR += rand
|
||||
SUBDIR += replaceit
|
||||
SUBDIR += rman
|
||||
SUBDIR += ruby-csv
|
||||
SUBDIR += ruby-erb
|
||||
|
18
textproc/replaceit/Makefile
Normal file
18
textproc/replaceit/Makefile
Normal file
@ -0,0 +1,18 @@
|
||||
# New ports collection makefile for: replaceit
|
||||
# Date created: Fri Aug 17 20:15:02 EDT 2001
|
||||
# Whom: Patrick Li <pat@databits.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= replaceit
|
||||
PORTVERSION= 1.0.0
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://pldaniels.com/replaceit/
|
||||
|
||||
MAINTAINER= pat@databits.net
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/replaceit ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
1
textproc/replaceit/distinfo
Normal file
1
textproc/replaceit/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (replaceit-1.0.0.tar.gz) = d6455d616df1f3d7fdad8de8dc4d4379
|
18
textproc/replaceit/files/patch-Makefile
Normal file
18
textproc/replaceit/files/patch-Makefile
Normal file
@ -0,0 +1,18 @@
|
||||
--- Makefile.orig Fri Aug 17 20:18:18 2001
|
||||
+++ Makefile Fri Aug 17 20:20:35 2001
|
||||
@@ -1,12 +1,11 @@
|
||||
-PRF=-O2 -Wall
|
||||
-CC=cc
|
||||
+CFLAGS+= -Wall
|
||||
+all: replaceit
|
||||
|
||||
replaceit: replaceit.c
|
||||
- $(CC) $(PRF) replaceit.c -o replaceit
|
||||
+ $(CC) $(CFLAGS) $< -o $@
|
||||
|
||||
clean:
|
||||
rm replaceit
|
||||
|
||||
-all: install
|
||||
install: replaceit
|
||||
cp replaceit /usr/local/bin
|
1
textproc/replaceit/pkg-comment
Normal file
1
textproc/replaceit/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A light replacement to the combination of sed/awk/grep/head/tail
|
9
textproc/replaceit/pkg-descr
Normal file
9
textproc/replaceit/pkg-descr
Normal file
@ -0,0 +1,9 @@
|
||||
ReplaceIt was written as a quick, light and effective replacement to
|
||||
the combination of sed/awk/grep/head/tail and other such shell
|
||||
utilities, as well as being quicker in startup (at least) than an
|
||||
equivilant Perl solution.
|
||||
|
||||
WWW: http://pldaniels.com/replaceit/
|
||||
Author: Paul L Daniels <pldaniels@pldaniels.com>
|
||||
|
||||
- Patrick Li <pat@databits.net>
|
1
textproc/replaceit/pkg-plist
Normal file
1
textproc/replaceit/pkg-plist
Normal file
@ -0,0 +1 @@
|
||||
bin/replaceit
|
Loading…
Reference in New Issue
Block a user