Update poppler to 0.86.1
Release 0.86.1: core: * Fix regression in Browse Link handling * Internal code improvements Release 0.86.0: core: * Fix link content exfiltration attack * Splash: Implement gouraudTriangleShadedFill for some non parametrized shadings. Issue #881 * Fix case unsensitive search for Old Hungarian, Warang Citi, Medefaidrin and Adlam * Internal code improvements glib: * Automatic handle of page's cropbox on annots. Issue #129 * Fix memory leak if poppler_document_new_from_file fails * Minor speed optimization on poppler_page_get_annot_mapping utils: * pdfdetach: add 'savefile' option * pdftoppm/pdftocairo: Fix more odd/even mismatch qt5: * Fix loading from iodevice PR: 244827 Exp-run by: antoine
This commit is contained in:
parent
5aaf1f97cf
commit
8e124cb8fb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=528853
@ -2,6 +2,7 @@
|
||||
|
||||
PORTNAME= pdf2djvu
|
||||
DISTVERSION= 0.9.17
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= converters
|
||||
MASTER_SITES= https://github.com/jwilk/${PORTNAME}/releases/download/${PORTVERSION}/
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= kbibtex
|
||||
DISTVERSION= 0.9.1
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= databases kde
|
||||
MASTER_SITES= KDE/stable/KBibTeX/${DISTVERSION}
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= calibre
|
||||
PORTVERSION= 4.12.0
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= deskutils python
|
||||
MASTER_SITES= http://download.calibre-ebook.com/${PORTVERSION}/
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
PORTNAME= cfiles
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 1.8
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= deskutils
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
|
@ -2,6 +2,7 @@
|
||||
|
||||
PORTNAME= lumina-pdf
|
||||
DISTVERSION= 1.6.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= deskutils
|
||||
|
||||
MAINTAINER= lbartoletti@FreeBSD.org
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= recoll
|
||||
DISTVERSION= 1.25.22
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= deskutils
|
||||
MASTER_SITES= https://www.lesbonscomptes.com/recoll/
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= tumbler
|
||||
PORTVERSION= 0.2.8
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= deskutils xfce
|
||||
MASTER_SITES= XFCE
|
||||
PKGNAMEPREFIX= xfce4-
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= efl
|
||||
DISTVERSION= 1.20.7
|
||||
PORTREVISION= 21
|
||||
PORTREVISION= 22
|
||||
CATEGORIES= devel enlightenment
|
||||
MASTER_SITES= http://download.enlightenment.org/rel/libs/${PORTNAME}/
|
||||
DIST_SUBDIR= enlightenment
|
||||
|
@ -2,6 +2,7 @@
|
||||
|
||||
PORTNAME= kfilemetadata
|
||||
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel kde kde-frameworks
|
||||
|
||||
MAINTAINER= kde@FreeBSD.org
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= calligra
|
||||
DISTVERSION= 3.1.0
|
||||
PORTREVISION= 33
|
||||
PORTREVISION= 34
|
||||
CATEGORIES= editors kde
|
||||
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
|
||||
DIST_SUBDIR= KDE/${PORTNAME}
|
||||
|
@ -3,7 +3,7 @@
|
||||
PORTNAME= kile
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 3.0b3
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= editors kde
|
||||
|
||||
MAINTAINER= kde@FreeBSD.org
|
||||
|
@ -1,6 +1,6 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
|
||||
.include "${.CURDIR}/Makefile.common"
|
||||
|
||||
|
@ -7,17 +7,9 @@ Change-Id: I7a3684932b8f9c403a3368b42fa4d8039c67f1a9
|
||||
Reviewed-on: https://gerrit.libreoffice.org/84384
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Michael Stahl <michael.stahl@cib.de>
|
||||
---
|
||||
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx | 7 +++++++
|
||||
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 4 ++++
|
||||
sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx | 4 ++++
|
||||
3 files changed, 15 insertions(+)
|
||||
|
||||
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
||||
index 26048177e87d..e9c2a407c279 100644
|
||||
--- sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
||||
--- sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx.orig 2019-12-05 19:59:23 UTC
|
||||
+++ sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
||||
@@ -491,11 +491,18 @@ void PDFOutDev::writeFontFile( GfxFont* gfxFont ) const
|
||||
@@ -491,11 +491,18 @@ void PDFOutDev::writeFontFile( GfxFont* gfxFont ) cons
|
||||
gfree(pBuf);
|
||||
}
|
||||
|
||||
@ -36,9 +28,23 @@ index 26048177e87d..e9c2a407c279 100644
|
||||
GfxSubpath* pSub = pPath->getSubpath( i );
|
||||
const int nPoints = pSub->getNumPoints();
|
||||
|
||||
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
||||
index 02f6b59f6f15..2e7d2186f9a1 100644
|
||||
--- sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
||||
@@ -556,7 +563,9 @@ void PDFOutDev::processLink(Link* link, Catalog*)
|
||||
if (!(pAction && pAction->getKind() == actionURI))
|
||||
return;
|
||||
|
||||
-#if POPPLER_CHECK_VERSION(0, 72, 0)
|
||||
+#if POPPLER_CHECK_VERSION(0, 86, 0)
|
||||
+ const char* pURI = static_cast<LinkURI*>(pAction)->getURI().c_str();
|
||||
+#elif POPPLER_CHECK_VERSION(0, 72, 0)
|
||||
const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->c_str();
|
||||
#else
|
||||
const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->getCString();
|
||||
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx | 7 +++++++
|
||||
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 4 ++++
|
||||
sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx | 4 ++++
|
||||
3 files changed, 15 insertions(+)
|
||||
|
||||
--- sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx.orig 2019-12-05 19:59:23 UTC
|
||||
+++ sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
||||
@@ -149,7 +149,11 @@ namespace pdfi
|
||||
|
||||
@ -52,9 +58,7 @@ index 02f6b59f6f15..2e7d2186f9a1 100644
|
||||
|
||||
public:
|
||||
explicit PDFOutDev( PDFDoc* pDoc );
|
||||
diff --git a/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
|
||||
index 42178b650cdd..b1a54bd09c5f 100644
|
||||
--- sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
|
||||
--- sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx.orig 2019-12-05 19:59:23 UTC
|
||||
+++ sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
|
||||
@@ -68,7 +68,11 @@ int main(int argc, char **argv)
|
||||
}
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= apache-openoffice
|
||||
PORTVERSION= ${AOOVERSION1}.${AOOVERSION2}.${TIMESTAMP}
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
PORTEPOCH= 4
|
||||
CATEGORIES= editors java
|
||||
MASTER_SITES= https://dist.apache.org/repos/dist/dev/openoffice/${AOOVERSION}-${AOORC}-${TIMESTAMP}/source/ \
|
||||
|
@ -2,6 +2,7 @@
|
||||
|
||||
PORTNAME= texstudio
|
||||
DISTVERSION= 2.12.22
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= editors
|
||||
|
||||
MAINTAINER= rigoletto@FreeBSD.org
|
||||
|
@ -4,7 +4,7 @@
|
||||
PORTNAME= texworks
|
||||
DISTVERSIONPREFIX= release-
|
||||
DISTVERSION= 0.6.2
|
||||
PORTREVISION= 14
|
||||
PORTREVISION= 15
|
||||
CATEGORIES= editors
|
||||
|
||||
MAINTAINER= hrs@FreeBSD.org
|
||||
|
@ -5,7 +5,7 @@
|
||||
|
||||
PORTNAME= atril
|
||||
PORTVERSION= 1.22.3
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= graphics print mate
|
||||
MASTER_SITES= MATE
|
||||
DIST_SUBDIR= mate
|
||||
|
@ -3,7 +3,7 @@
|
||||
PORTNAME= diff-pdf
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.3-20190713
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= graphics
|
||||
|
||||
MAINTAINER= uzsolt@uzsolt.hu
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= diffpdf
|
||||
PORTVERSION= 2.1.3
|
||||
PORTREVISION= 15
|
||||
PORTREVISION= 16
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.qtrac.eu/
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
PORTNAME= dspdfviewer
|
||||
PORTVERSION= 1.15.1
|
||||
DISTVERSIONPREFIX= v
|
||||
PORTREVISION= 26
|
||||
PORTREVISION= 27
|
||||
CATEGORIES= graphics
|
||||
|
||||
MAINTAINER= fox@FreeBSD.org
|
||||
|
@ -3,7 +3,7 @@
|
||||
PORTNAME= engauge-digitizer
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 12.1
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= graphics math science
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= epdfview
|
||||
PORTVERSION= 0.1.8
|
||||
PORTREVISION= 27
|
||||
PORTREVISION= 28
|
||||
CATEGORIES= graphics print gnome
|
||||
MASTER_SITES= FRUGALWARE/xapps-extra/${PORTNAME} \
|
||||
ftp://ftp.slackware.com/.1/blfs/conglomeration/${PORTNAME}/ \
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= evince
|
||||
PORTVERSION= 3.28.5
|
||||
PORTREVISION= 11
|
||||
PORTREVISION= 12
|
||||
CATEGORIES= graphics print gnome
|
||||
MASTER_SITES= GNOME
|
||||
DIST_SUBDIR= gnome3
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= gdal
|
||||
PORTVERSION= 3.0.4
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= graphics geography
|
||||
MASTER_SITES= https://download.osgeo.org/gdal/${PORTVERSION}/ \
|
||||
LOCAL/sunpoet
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= geeqie
|
||||
PORTVERSION= 1.5.1
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.geeqie.org/
|
||||
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= gegl
|
||||
PORTVERSION= 0.4.22
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= GIMP
|
||||
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME?= gimp-app
|
||||
PORTVERSION= 2.10.18
|
||||
PORTREVISION= 1
|
||||
PORTEPOCH?= 1
|
||||
CATEGORIES?= graphics gnome
|
||||
MASTER_SITES= GIMP/gimp/v${PORTVERSION:R}
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= graphviz
|
||||
PORTVERSION= 2.42.3
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics tk
|
||||
MASTER_SITES= https://www2.graphviz.org/Packages/stable/portable_source/
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= impressive
|
||||
PORTVERSION= 0.12.1
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= graphics python
|
||||
MASTER_SITES= SF/${PORTNAME}/Impressive/${PORTVERSION}/
|
||||
DISTNAME= Impressive-${PORTVERSION}
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= inkscape
|
||||
PORTVERSION= 0.92.4
|
||||
PORTREVISION= 14
|
||||
PORTREVISION= 15
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= https://media.inkscape.org/dl/resources/file/
|
||||
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= krita
|
||||
DISTVERSION= 4.2.8.2
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= graphics kde
|
||||
MASTER_SITES= KDE/stable/${PORTNAME}/${DISTVERSION:R}
|
||||
DIST_SUBDIR= KDE/${PORTNAME}
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= okular
|
||||
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= graphics kde kde-applications
|
||||
|
||||
PATCH_SITES= https://invent.kde.org/kde/okular/-/commit/
|
||||
|
@ -3,7 +3,7 @@
|
||||
PORTNAME= openfx-arena
|
||||
PORTVERSION= 2.3.14
|
||||
DISTVERSIONPREFIX= Natron-
|
||||
PORTREVISION= 18
|
||||
PORTREVISION= 19
|
||||
CATEGORIES= graphics
|
||||
|
||||
MAINTAINER= olivier@FreeBSD.org
|
||||
|
@ -4,7 +4,7 @@
|
||||
PORTNAME= osg
|
||||
PORTVERSION= 3.6.5
|
||||
DISTVERSIONPREFIX= OpenSceneGraph-
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= graphics
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= pdf2svg
|
||||
PORTVERSION= 0.2.3
|
||||
PORTREVISION= 14
|
||||
PORTREVISION= 15
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= graphics
|
||||
|
||||
|
@ -4,6 +4,7 @@ PORTNAME= pdfpc
|
||||
DISTVERSION= 4.4.0
|
||||
CATEGORIES= graphics
|
||||
DISTVERSIONPREFIX= v
|
||||
PORTREVISION= 1
|
||||
|
||||
MAINTAINER= bapt@FreeBSD.org
|
||||
COMMENT= Keynote-like multi-monitor presentation viewer
|
||||
|
@ -1,7 +1,7 @@
|
||||
# Created by: Michael Johnson <ahze@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTREVISION= 0
|
||||
PORTREVISION= 1
|
||||
|
||||
COMMENT= GLib bindings to poppler
|
||||
|
||||
|
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= poppler
|
||||
DISTVERSION= 0.85.0
|
||||
DISTVERSION= 0.86.1
|
||||
CATEGORIES= graphics print
|
||||
MASTER_SITES= https://poppler.freedesktop.org/
|
||||
|
||||
@ -47,6 +47,7 @@ CMAKE_OFF+= ${_POPPLER_SLAVES:N${_SLAVE_PORT}:tu:S/^/ENABLE_/}
|
||||
PORTSCOUT= limitw:1,even
|
||||
USES+= iconv
|
||||
CMAKE_ON+= ENABLE_CPP
|
||||
PLIST_SUB+= SHLIB_VER=97
|
||||
|
||||
OPTIONS_DEFINE= CURL OPENJPEG
|
||||
OPTIONS_DEFAULT= OPENJPEG
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1580408023
|
||||
SHA256 (poppler-0.85.0.tar.xz) = 2bc875eb323002ae6b287e09980473518e2b2ed6b5b7d2e1089e36a6cd00d94b
|
||||
SIZE (poppler-0.85.0.tar.xz) = 1588616
|
||||
TIMESTAMP = 1584260973
|
||||
SHA256 (poppler-0.86.1.tar.xz) = af630a277c8e194c31339c5446241834aed6ed3d4b4dc7080311e51c66257f6c
|
||||
SIZE (poppler-0.86.1.tar.xz) = 1593856
|
||||
|
@ -132,8 +132,8 @@ lib/libpoppler-cpp.so
|
||||
lib/libpoppler-cpp.so.0
|
||||
lib/libpoppler-cpp.so.0.7.0
|
||||
lib/libpoppler.so
|
||||
lib/libpoppler.so.95
|
||||
lib/libpoppler.so.95.0.0
|
||||
lib/libpoppler.so.%%SHLIB_VER%%
|
||||
lib/libpoppler.so.%%SHLIB_VER%%.0.0
|
||||
libdata/pkgconfig/poppler-cairo.pc
|
||||
libdata/pkgconfig/poppler-cpp.pc
|
||||
libdata/pkgconfig/poppler-splash.pc
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= pqiv
|
||||
PORTVERSION= 2.11
|
||||
PORTREVISION= 6
|
||||
PORTREVISION= 7
|
||||
CATEGORIES= graphics
|
||||
|
||||
MAINTAINER= danilo@FreeBSD.org
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= poppler
|
||||
PORTVERSION= 0.12.1
|
||||
PORTREVISION= 18
|
||||
PORTREVISION= 19
|
||||
CATEGORIES= graphics python
|
||||
MASTER_SITES= https://launchpad.net/poppler-python/trunk/development/+download/ \
|
||||
http://launchpadlibrarian.net/30270080/ \
|
||||
|
@ -3,7 +3,7 @@
|
||||
PORTNAME= python-poppler-qt5
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.75.0
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= graphics python
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= QComicBook
|
||||
PORTVERSION= 0.9.1
|
||||
PORTREVISION= 12
|
||||
PORTREVISION= 13
|
||||
CATEGORIES= graphics
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= vips
|
||||
PORTVERSION= 8.8.3
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= https://github.com/libvips/libvips/releases/download/v${PORTVERSION}/
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= xournal
|
||||
PORTVERSION= 0.4.8.2016
|
||||
PORTREVISION= 10
|
||||
PORTREVISION= 11
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= SF
|
||||
|
||||
|
@ -2,6 +2,7 @@
|
||||
|
||||
PORTNAME= xournalpp
|
||||
DISTVERSION= 1.0.17
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= yacreader
|
||||
DISTVERSION= 9.6.2
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= graphics
|
||||
|
||||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= zathura-pdf-mupdf
|
||||
DISTVERSION= 0.3.5
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= https://pwmt.org/projects/zathura-pdf-mupdf/download/ \
|
||||
http://freebsd.uzsolt.hu/src/
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= zathura-pdf-poppler
|
||||
PORTVERSION= 0.2.9
|
||||
PORTREVISION= 11
|
||||
PORTREVISION= 12
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= https://pwmt.org/projects/zathura/plugins/download/ \
|
||||
http://www.madpilot.net/~mad/pwmt.org/
|
||||
|
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pdf_viewer
|
||||
PORTREVISION= 5
|
||||
PORTREVISION= 6
|
||||
|
||||
COMMENT= PDF and PostScript viewer plugin for Claws Mail
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= textmail
|
||||
PORTVERSION= 20070803
|
||||
PORTREVISION= 11
|
||||
PORTREVISION= 12
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://raf.org/textmail/
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= labplot
|
||||
PORTVERSION= 2.7.0
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= math kde
|
||||
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
|
||||
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= auto-multiple-choice
|
||||
PORTVERSION= 1.3.0
|
||||
PORTREVISION= 18
|
||||
PORTREVISION= 19
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://download.gna.org/auto-qcm/
|
||||
DISTNAME= auto-multiple-choice_${PORTVERSION}_precomp
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= rabbit
|
||||
PORTVERSION= 2.2.1
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= misc rubygems
|
||||
MASTER_SITES= RG
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= tellico
|
||||
DISTVERSION= 3.2.3
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= misc kde
|
||||
MASTER_SITES= http://tellico-project.org/files/
|
||||
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= kitinerary
|
||||
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= net kde kde-applications
|
||||
|
||||
MAINTAINER= kde@FreeBSD.org
|
||||
|
@ -2,6 +2,7 @@
|
||||
|
||||
PORTNAME= cups-filters
|
||||
PORTVERSION= 1.27.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= https://www.openprinting.org/download/cups-filters/
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= pdfviewer
|
||||
PORTVERSION= 0.0.2
|
||||
PORTREVISION= 10
|
||||
PORTREVISION= 11
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= http://www.defora.org/os/download/download/4431/
|
||||
PKGNAMEPREFIX= deforaos-
|
||||
|
@ -4,7 +4,7 @@
|
||||
PORTNAME= frescobaldi
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 3.0.0
|
||||
PORTREVISION= 5
|
||||
PORTREVISION= 6
|
||||
CATEGORIES= print kde
|
||||
|
||||
MAINTAINER= m.ne@gmx.net
|
||||
|
@ -2,6 +2,7 @@
|
||||
|
||||
PORTNAME= ghostscript
|
||||
PORTVERSION= 9.52
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${PORTVERSION:S/.//}/
|
||||
PKGNAMESUFFIX= 9-agpl-base
|
||||
|
@ -4,7 +4,7 @@ PORTNAME= pdf-tools
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.90-34
|
||||
DISTVERSIONSUFFIX= -g29d9f4f
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= print elisp
|
||||
PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX}
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= pdfcube
|
||||
PORTVERSION= 0.0.5
|
||||
PORTREVISION= 35
|
||||
PORTREVISION= 36
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= http://code.100allora.it/releases/pdfcube/
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= qpdfview
|
||||
DISTVERSION= 0.4.18
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= https://launchpadlibrarian.net/294276875/ \
|
||||
https://launchpad.net/${PORTNAME}/trunk/${DISTVERSION}/+download/
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= scribus
|
||||
PORTVERSION= 1.5.5
|
||||
PORTREVISION= 9
|
||||
PORTREVISION= 10
|
||||
CATEGORIES= print editors
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/${PORTVERSION}/ \
|
||||
http://www.scribus.net/downloads/${PORTVERSION}/
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- scribus/plugins/import/pdf/importpdf.cpp.orig 2020-01-18 17:59:00 UTC
|
||||
--- scribus/plugins/import/pdf/importpdf.cpp.orig 2020-03-15 14:15:45 UTC
|
||||
+++ scribus/plugins/import/pdf/importpdf.cpp
|
||||
@@ -75,7 +75,7 @@ PdfPlug::PdfPlug(ScribusDoc* doc, int flags)
|
||||
QImage PdfPlug::readThumbnail(const QString& fName)
|
||||
@ -54,6 +54,22 @@
|
||||
return false;
|
||||
}
|
||||
pageString = optImp->getPagesString();
|
||||
@@ -839,13 +834,13 @@ bool PdfPlug::convert(const QString& fn)
|
||||
if (names.isDict())
|
||||
{
|
||||
LinkAction *linkAction = nullptr;
|
||||
- linkAction = LinkAction::parseAction(&names, pdfDoc->getCatalog()->getBaseURI());
|
||||
+ linkAction = LinkAction::parseAction(&names, pdfDoc->getCatalog()->getBaseURI()).get();
|
||||
if (linkAction)
|
||||
{
|
||||
LinkJavaScript *jsa = (LinkJavaScript*)linkAction;
|
||||
if (jsa->isOk())
|
||||
{
|
||||
- QString script = UnicodeParsedString(jsa->getScript());
|
||||
+ QString script = QString::fromStdString(jsa->getScript());
|
||||
if (script.startsWith("this."))
|
||||
{
|
||||
script.remove(0, 5);
|
||||
@@ -908,7 +903,7 @@ bool PdfPlug::convert(const QString& fn)
|
||||
}
|
||||
delete pdfDoc;
|
||||
|
@ -1,5 +1,167 @@
|
||||
--- scribus/plugins/import/pdf/slaoutput.cpp.orig 2020-01-18 17:22:17 UTC
|
||||
--- scribus/plugins/import/pdf/slaoutput.cpp.orig 2020-03-15 14:15:45 UTC
|
||||
+++ scribus/plugins/import/pdf/slaoutput.cpp
|
||||
@@ -324,7 +324,7 @@ LinkAction* SlaOutputDev::SC_getAdditionalAction(const
|
||||
{
|
||||
Object actionObject = additionalActionsObject.dictLookup(key);
|
||||
if (actionObject.isDict())
|
||||
- linkAction = LinkAction::parseAction(&actionObject, pdfDoc->getCatalog()->getBaseURI());
|
||||
+ linkAction = LinkAction::parseAction(&actionObject, pdfDoc->getCatalog()->getBaseURI()).get();
|
||||
}
|
||||
}
|
||||
return linkAction;
|
||||
@@ -455,7 +455,7 @@ bool SlaOutputDev::handleLinkAnnot(Annot* annota, doub
|
||||
POPPLER_CONST GooString *ndst = gto->getNamedDest();
|
||||
if (ndst)
|
||||
{
|
||||
- LinkDest *dstn = pdfDoc->findDest(ndst);
|
||||
+ LinkDest *dstn = pdfDoc->findDest(ndst).get();
|
||||
if (dstn)
|
||||
{
|
||||
if (dstn->getKind() == destXYZ)
|
||||
@@ -499,7 +499,7 @@ bool SlaOutputDev::handleLinkAnnot(Annot* annota, doub
|
||||
POPPLER_CONST GooString *ndst = gto->getNamedDest();
|
||||
if (ndst)
|
||||
{
|
||||
- LinkDest *dstn = pdfDoc->findDest(ndst);
|
||||
+ LinkDest *dstn = pdfDoc->findDest(ndst).get();
|
||||
if (dstn)
|
||||
{
|
||||
if (dstn->getKind() == destXYZ)
|
||||
@@ -517,7 +517,7 @@ bool SlaOutputDev::handleLinkAnnot(Annot* annota, doub
|
||||
{
|
||||
LinkURI *gto = (LinkURI*)act;
|
||||
validLink = true;
|
||||
- fileName = UnicodeParsedString(gto->getURI());
|
||||
+ fileName = QString::fromStdString(gto->getURI());
|
||||
}
|
||||
if (validLink)
|
||||
{
|
||||
@@ -930,7 +930,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
|
||||
if (jsa->isOk())
|
||||
{
|
||||
ite->annotation().setActionType(1);
|
||||
- ite->annotation().setAction(UnicodeParsedString(jsa->getScript()));
|
||||
+ ite->annotation().setAction(QString::fromStdString(jsa->getScript()));
|
||||
}
|
||||
}
|
||||
else if (Lact->getKind() == actionGoTo)
|
||||
@@ -967,7 +967,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
|
||||
POPPLER_CONST GooString *ndst = gto->getNamedDest();
|
||||
if (ndst)
|
||||
{
|
||||
- LinkDest *dstn = pdfDoc->findDest(ndst);
|
||||
+ LinkDest *dstn = pdfDoc->findDest(ndst).get();
|
||||
if (dstn)
|
||||
{
|
||||
if (dstn->getKind() == destXYZ)
|
||||
@@ -1019,7 +1019,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
|
||||
POPPLER_CONST GooString *ndst = gto->getNamedDest();
|
||||
if (ndst)
|
||||
{
|
||||
- LinkDest *dstn = pdfDoc->findDest(ndst);
|
||||
+ LinkDest *dstn = pdfDoc->findDest(ndst).get();
|
||||
if (dstn)
|
||||
{
|
||||
if (dstn->getKind() == destXYZ)
|
||||
@@ -1039,7 +1039,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
|
||||
else if (Lact->getKind() == actionUnknown)
|
||||
{
|
||||
LinkUnknown *uno = (LinkUnknown*)Lact;
|
||||
- QString actString = UnicodeParsedString(uno->getAction());
|
||||
+ QString actString = QString::fromStdString(uno->getAction());
|
||||
if (actString == "ResetForm")
|
||||
{
|
||||
ite->annotation().setActionType(4);
|
||||
@@ -1083,7 +1083,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
|
||||
{
|
||||
LinkNamed *uno = (LinkNamed*)Lact;
|
||||
ite->annotation().setActionType(10);
|
||||
- ite->annotation().setAction(UnicodeParsedString(uno->getName()));
|
||||
+ ite->annotation().setAction(QString::fromStdString(uno->getName()));
|
||||
}
|
||||
else
|
||||
qDebug() << "Found unsupported Action of type" << Lact->getKind();
|
||||
@@ -1096,7 +1096,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
|
||||
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
|
||||
if (jsa->isOk())
|
||||
{
|
||||
- ite->annotation().setD_act(UnicodeParsedString(jsa->getScript()));
|
||||
+ ite->annotation().setD_act(QString::fromStdString(jsa->getScript()));
|
||||
ite->annotation().setAAact(true);
|
||||
}
|
||||
}
|
||||
@@ -1110,7 +1110,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
|
||||
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
|
||||
if (jsa->isOk())
|
||||
{
|
||||
- ite->annotation().setE_act(UnicodeParsedString(jsa->getScript()));
|
||||
+ ite->annotation().setE_act(QString::fromStdString(jsa->getScript()));
|
||||
ite->annotation().setAAact(true);
|
||||
}
|
||||
}
|
||||
@@ -1124,7 +1124,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
|
||||
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
|
||||
if (jsa->isOk())
|
||||
{
|
||||
- ite->annotation().setX_act(UnicodeParsedString(jsa->getScript()));
|
||||
+ ite->annotation().setX_act(QString::fromStdString(jsa->getScript()));
|
||||
ite->annotation().setAAact(true);
|
||||
}
|
||||
}
|
||||
@@ -1138,7 +1138,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
|
||||
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
|
||||
if (jsa->isOk())
|
||||
{
|
||||
- ite->annotation().setFo_act(UnicodeParsedString(jsa->getScript()));
|
||||
+ ite->annotation().setFo_act(QString::fromStdString(jsa->getScript()));
|
||||
ite->annotation().setAAact(true);
|
||||
}
|
||||
}
|
||||
@@ -1152,7 +1152,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
|
||||
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
|
||||
if (jsa->isOk())
|
||||
{
|
||||
- ite->annotation().setBl_act(UnicodeParsedString(jsa->getScript()));
|
||||
+ ite->annotation().setBl_act(QString::fromStdString(jsa->getScript()));
|
||||
ite->annotation().setAAact(true);
|
||||
}
|
||||
}
|
||||
@@ -1166,7 +1166,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
|
||||
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
|
||||
if (jsa->isOk())
|
||||
{
|
||||
- ite->annotation().setC_act(UnicodeParsedString(jsa->getScript()));
|
||||
+ ite->annotation().setC_act(QString::fromStdString(jsa->getScript()));
|
||||
ite->annotation().setAAact(true);
|
||||
}
|
||||
}
|
||||
@@ -1180,7 +1180,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
|
||||
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
|
||||
if (jsa->isOk())
|
||||
{
|
||||
- ite->annotation().setF_act(UnicodeParsedString(jsa->getScript()));
|
||||
+ ite->annotation().setF_act(QString::fromStdString(jsa->getScript()));
|
||||
ite->annotation().setAAact(true);
|
||||
ite->annotation().setFormat(5);
|
||||
}
|
||||
@@ -1195,7 +1195,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
|
||||
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
|
||||
if (jsa->isOk())
|
||||
{
|
||||
- ite->annotation().setK_act(UnicodeParsedString(jsa->getScript()));
|
||||
+ ite->annotation().setK_act(QString::fromStdString(jsa->getScript()));
|
||||
ite->annotation().setAAact(true);
|
||||
ite->annotation().setFormat(5);
|
||||
}
|
||||
@@ -1210,7 +1210,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
|
||||
LinkJavaScript *jsa = (LinkJavaScript*)Aact;
|
||||
if (jsa->isOk())
|
||||
{
|
||||
- ite->annotation().setV_act(UnicodeParsedString(jsa->getScript()));
|
||||
+ ite->annotation().setV_act(QString::fromStdString(jsa->getScript()));
|
||||
ite->annotation().setAAact(true);
|
||||
}
|
||||
}
|
||||
@@ -1224,16 +1224,7 @@ void SlaOutputDev::startDoc(PDFDoc *doc, XRef *xrefA,
|
||||
catalog = catA;
|
||||
pdfDoc = doc;
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= luatex
|
||||
PORTVERSION= 0.80.0
|
||||
PORTREVISION= 14
|
||||
PORTREVISION= 15
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= ftp://tug.org/historic/systems/texlive/2015/
|
||||
PKGNAMEPREFIX= tex-
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= xetex
|
||||
PORTVERSION= 0.99992
|
||||
PORTREVISION= 29
|
||||
PORTREVISION= 30
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= ftp://tug.org/historic/systems/texlive/2015/
|
||||
PKGNAMEPREFIX= tex-
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= texlive
|
||||
PORTVERSION= 20150521
|
||||
PORTREVISION= 46
|
||||
PORTREVISION= 47
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= TEX_CTAN/systems/texlive/Source/
|
||||
PKGNAMESUFFIX= -base
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= tracker-miners
|
||||
PORTVERSION= 2.0.5
|
||||
PORTREVISION= 13
|
||||
PORTREVISION= 14
|
||||
CATEGORIES= sysutils gnome
|
||||
MASTER_SITES= GNOME
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= pdfgrep
|
||||
PORTVERSION= 2.1.1
|
||||
PORTREVISION= 13
|
||||
PORTREVISION= 14
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= https://pdfgrep.org/download/
|
||||
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= pdfsandwich
|
||||
DISTVERSION= 0.1.7
|
||||
PORTREVISION= 7
|
||||
PORTREVISION= 8
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= SF/${PORTNAME}/pdfsandwich%20${DISTVERSION}/
|
||||
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= pdftotext
|
||||
PORTVERSION= 2.1.4
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= textproc python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= hotcrp
|
||||
PORTVERSION= 2.94
|
||||
PORTREVISION= 10
|
||||
PORTREVISION= 11
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.read.seas.harvard.edu/~kohler/hotcrp/
|
||||
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= poppler
|
||||
PORTVERSION= 3.4.1
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= x11-toolkits rubygems
|
||||
MASTER_SITES= RG
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= eaglemode
|
||||
PORTVERSION= 0.94.2
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= gnome
|
||||
PORTVERSION= 3.4.1
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= x11 gnome rubygems
|
||||
PKGNAMEPREFIX= rubygem-
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user