math/slepc: Re-add port: Scalable Library for Eigenvalue Problem Computations
This commit is contained in:
parent
dd6443221c
commit
8dfcd1f2a8
1
MOVED
1
MOVED
@ -15701,7 +15701,6 @@ databases/py-bsddb||2020-12-29|Has expired: Uses deprecated version of python
|
|||||||
www/py-webhelpers||2020-12-29|Has expired: Uses deprecated version of python
|
www/py-webhelpers||2020-12-29|Has expired: Uses deprecated version of python
|
||||||
security/py-pyptlib||2020-12-29|Has expired: Uses deprecated version of python
|
security/py-pyptlib||2020-12-29|Has expired: Uses deprecated version of python
|
||||||
japanese/py-zinnia||2020-12-29|Has expired: Uses deprecated version of python
|
japanese/py-zinnia||2020-12-29|Has expired: Uses deprecated version of python
|
||||||
math/slepc||2020-12-29|Has expired: Broken, uses deprecated version of python
|
|
||||||
www/py-pastescript||2020-12-29|Has expired: Uses deprecated version of python
|
www/py-pastescript||2020-12-29|Has expired: Uses deprecated version of python
|
||||||
databases/ldb14||2020-12-29|Has expired: Uses deprecated version of python
|
databases/ldb14||2020-12-29|Has expired: Uses deprecated version of python
|
||||||
math/py-slepc4py||2020-12-29|Has expired: Depends on broken and expiring math/slepc
|
math/py-slepc4py||2020-12-29|Has expired: Depends on broken and expiring math/slepc
|
||||||
|
@ -1095,6 +1095,7 @@
|
|||||||
SUBDIR += sisl
|
SUBDIR += sisl
|
||||||
SUBDIR += slatec
|
SUBDIR += slatec
|
||||||
SUBDIR += sleef
|
SUBDIR += sleef
|
||||||
|
SUBDIR += slepc
|
||||||
SUBDIR += slgrace
|
SUBDIR += slgrace
|
||||||
SUBDIR += slicot
|
SUBDIR += slicot
|
||||||
SUBDIR += snns
|
SUBDIR += snns
|
||||||
|
40
math/slepc/Makefile
Normal file
40
math/slepc/Makefile
Normal file
@ -0,0 +1,40 @@
|
|||||||
|
PORTNAME= slepc
|
||||||
|
DISTVERSION= 3.18.1
|
||||||
|
CATEGORIES= math devel
|
||||||
|
MASTER_SITES= http://slepc.upv.es/download/distrib/
|
||||||
|
|
||||||
|
MAINTAINER= yuri@FreeBSD.org
|
||||||
|
COMMENT= Scalable Library for Eigenvalue Problem Computations
|
||||||
|
WWW= http://slepc.upv.es/
|
||||||
|
|
||||||
|
LICENSE= BSD2CLAUSE
|
||||||
|
LICENSE_FILE= ${WRKSRC}/LICENSE.md
|
||||||
|
|
||||||
|
LIB_DEPENDS= libblas.so:math/blas \
|
||||||
|
liblapack.so:math/lapack \
|
||||||
|
libmpich.so:net/mpich \
|
||||||
|
libpetsc.so:science/PETSc
|
||||||
|
|
||||||
|
USES= gmake fortran python:3.9 shebangfix xorg
|
||||||
|
USE_XORG= x11 # not really needed, but is inherited from the PETSc setup
|
||||||
|
USE_LDCONFIG= yes
|
||||||
|
|
||||||
|
SHEBANG_FILES= configure
|
||||||
|
SHEBANG_GLOB= *.py
|
||||||
|
|
||||||
|
MAKEFILE= makefile
|
||||||
|
MAKE_ENV= PETSC_DIR=${LOCALBASE} PETSC_ARCH="" SLEPC_DIR=${WRKSRC} PYTHON=${PYTHON_CMD}
|
||||||
|
|
||||||
|
BINARY_ALIAS= python=${PYTHON_CMD}
|
||||||
|
|
||||||
|
OPTIONS_DEFINE= EXAMPLES
|
||||||
|
|
||||||
|
PORTEXAMPLES= *
|
||||||
|
|
||||||
|
do-configure:
|
||||||
|
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./configure --prefix=${PREFIX}
|
||||||
|
|
||||||
|
post-install:
|
||||||
|
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libslepc.so.${PORTVERSION}
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
3
math/slepc/distinfo
Normal file
3
math/slepc/distinfo
Normal file
@ -0,0 +1,3 @@
|
|||||||
|
TIMESTAMP = 1671617061
|
||||||
|
SHA256 (slepc-3.18.1.tar.gz) = f6e6e16d8399c3f94d187da9d4bfdfca160de50ebda7d63f6fa8ef417597e9b4
|
||||||
|
SIZE (slepc-3.18.1.tar.gz) = 6013016
|
11
math/slepc/files/patch-config_install.py
Normal file
11
math/slepc/files/patch-config_install.py
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- config/install.py.orig 2022-12-21 10:04:56 UTC
|
||||||
|
+++ config/install.py
|
||||||
|
@@ -331,7 +331,7 @@ for dir in dirs:
|
||||||
|
|
||||||
|
def installShare(self):
|
||||||
|
self.copies.extend(self.copytree(self.rootShareDir, self.destShareDir))
|
||||||
|
- examplesdir=os.path.join(self.destShareDir,'slepc','examples')
|
||||||
|
+ examplesdir=os.path.join(self.destShareDir,'examples','slepc')
|
||||||
|
if os.path.exists(examplesdir):
|
||||||
|
shutil.rmtree(examplesdir)
|
||||||
|
os.mkdir(examplesdir)
|
7
math/slepc/pkg-descr
Normal file
7
math/slepc/pkg-descr
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
SLEPc is a software library for the solution of large scale sparse eigenvalue
|
||||||
|
problems on parallel computers. It is an extension of PETSc and can be used for
|
||||||
|
linear eigenvalue problems in either standard or generalized form, with real or
|
||||||
|
complex arithmetic. It can also be used for computing a partial SVD of a large,
|
||||||
|
sparse, rectangular matrix, and to solve nonlinear eigenvalue problems
|
||||||
|
(polynomial or general). Additionally, SLEPc provides solvers for the
|
||||||
|
computation of the action of a matrix function on a vector.
|
98
math/slepc/pkg-plist
Normal file
98
math/slepc/pkg-plist
Normal file
@ -0,0 +1,98 @@
|
|||||||
|
include/slepc.h
|
||||||
|
include/slepc/finclude/slepc.h
|
||||||
|
include/slepc/finclude/slepcbv.h
|
||||||
|
include/slepc/finclude/slepcds.h
|
||||||
|
include/slepc/finclude/slepceps.h
|
||||||
|
include/slepc/finclude/slepcfn.h
|
||||||
|
include/slepc/finclude/slepclme.h
|
||||||
|
include/slepc/finclude/slepcmfn.h
|
||||||
|
include/slepc/finclude/slepcnep.h
|
||||||
|
include/slepc/finclude/slepcpep.h
|
||||||
|
include/slepc/finclude/slepcrg.h
|
||||||
|
include/slepc/finclude/slepcst.h
|
||||||
|
include/slepc/finclude/slepcsvd.h
|
||||||
|
include/slepc/finclude/slepcsys.h
|
||||||
|
include/slepc/private/bvimpl.h
|
||||||
|
include/slepc/private/dsimpl.h
|
||||||
|
include/slepc/private/epsimpl.h
|
||||||
|
include/slepc/private/fnimpl.h
|
||||||
|
include/slepc/private/lmeimpl.h
|
||||||
|
include/slepc/private/mfnimpl.h
|
||||||
|
include/slepc/private/nepimpl.h
|
||||||
|
include/slepc/private/pepimpl.h
|
||||||
|
include/slepc/private/rgimpl.h
|
||||||
|
include/slepc/private/slepccontour.h
|
||||||
|
include/slepc/private/slepcimpl.h
|
||||||
|
include/slepc/private/slepcscalapack.h
|
||||||
|
include/slepc/private/stimpl.h
|
||||||
|
include/slepc/private/svdimpl.h
|
||||||
|
include/slepc/private/vecimplslepc.h
|
||||||
|
include/slepcblaslapack.h
|
||||||
|
include/slepcblaslapack_mangle.h
|
||||||
|
include/slepcbv.h
|
||||||
|
include/slepcbv.mod
|
||||||
|
include/slepcbvdef.mod
|
||||||
|
include/slepcconf.h
|
||||||
|
include/slepccublas.h
|
||||||
|
include/slepcds.h
|
||||||
|
include/slepcds.mod
|
||||||
|
include/slepcdsdef.mod
|
||||||
|
include/slepceps.h
|
||||||
|
include/slepceps.mod
|
||||||
|
include/slepcepsdef.mod
|
||||||
|
include/slepcfn.h
|
||||||
|
include/slepcfn.mod
|
||||||
|
include/slepcfndef.mod
|
||||||
|
include/slepclme.h
|
||||||
|
include/slepclme.mod
|
||||||
|
include/slepclmedef.mod
|
||||||
|
include/slepcmagma.h
|
||||||
|
include/slepcmat.h
|
||||||
|
include/slepcmath.h
|
||||||
|
include/slepcmfn.h
|
||||||
|
include/slepcmfn.mod
|
||||||
|
include/slepcmfndef.mod
|
||||||
|
include/slepcnep.h
|
||||||
|
include/slepcnep.mod
|
||||||
|
include/slepcnepdef.mod
|
||||||
|
include/slepcpep.h
|
||||||
|
include/slepcpep.mod
|
||||||
|
include/slepcpepdef.mod
|
||||||
|
include/slepcrg.h
|
||||||
|
include/slepcrg.mod
|
||||||
|
include/slepcrgdef.mod
|
||||||
|
include/slepcrgtypes.h
|
||||||
|
include/slepcsc.h
|
||||||
|
include/slepcst.h
|
||||||
|
include/slepcst.mod
|
||||||
|
include/slepcstdef.mod
|
||||||
|
include/slepcsvd.h
|
||||||
|
include/slepcsvd.mod
|
||||||
|
include/slepcsvddef.mod
|
||||||
|
include/slepcsys.h
|
||||||
|
include/slepcsys.mod
|
||||||
|
include/slepcsysdef.mod
|
||||||
|
include/slepcvec.h
|
||||||
|
include/slepcversion.h
|
||||||
|
lib/libslepc.so
|
||||||
|
lib/libslepc.so.3.18
|
||||||
|
lib/libslepc.so.3.18.1
|
||||||
|
lib/slepc/conf/memoryerror.log
|
||||||
|
lib/slepc/conf/modules/slepc/3.18.1
|
||||||
|
lib/slepc/conf/slepc_common
|
||||||
|
lib/slepc/conf/slepc_rules
|
||||||
|
lib/slepc/conf/slepc_test
|
||||||
|
lib/slepc/conf/slepc_variables
|
||||||
|
lib/slepc/conf/slepcrules
|
||||||
|
lib/slepc/conf/slepcvariables
|
||||||
|
lib/slepc/conf/uninstall.py
|
||||||
|
libdata/pkgconfig/slepc.pc
|
||||||
|
%%DATADIR%%/CMakeLists.txt
|
||||||
|
%%DATADIR%%/Makefile.user
|
||||||
|
%%DATADIR%%/datafiles/matrices/bfw62a.petsc
|
||||||
|
%%DATADIR%%/datafiles/matrices/bfw62b.petsc
|
||||||
|
%%DATADIR%%/datafiles/matrices/rdb200.petsc
|
||||||
|
%%DATADIR%%/datafiles/matrices/readme
|
||||||
|
%%DATADIR%%/datafiles/matrices/speaker107c.petsc
|
||||||
|
%%DATADIR%%/datafiles/matrices/speaker107k.petsc
|
||||||
|
%%DATADIR%%/datafiles/matrices/speaker107m.petsc
|
Loading…
Reference in New Issue
Block a user