Allow PCM to be an available mixer track.

Tested by:	Joseph S. Atkinson
This commit is contained in:
Joe Marcus Clarke 2008-12-24 16:14:10 +00:00
parent 5af07790f1
commit 8df9736e97
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=224686
2 changed files with 12 additions and 1 deletions

View File

@ -6,7 +6,7 @@
# $MCom: ports/multimedia/gstreamer-plugins-good/Makefile,v 1.14 2008/03/19 14:05:36 ahze Exp $
#
PORTREVISION= 0
PORTREVISION= 1
CATEGORIES= multimedia
COMMENT= Good gstreamer-plugins

View File

@ -0,0 +1,11 @@
--- sys/oss/gstossmixer.c.bak 2006-08-16 05:25:17.000000000 -0400
+++ sys/oss/gstossmixer.c 2008-12-24 00:27:14.000000000 -0500
@@ -146,7 +146,7 @@ gst_ossmixer_ensure_track_list (GstOssMi
/* do we want this in our list? */
if (!((mixer->dir & GST_OSS_MIXER_CAPTURE && input == TRUE) ||
- (mixer->dir & GST_OSS_MIXER_PLAYBACK && i != SOUND_MIXER_PCM)))
+ (mixer->dir & GST_OSS_MIXER_PLAYBACK)))
/* the PLAYBACK case seems hacky, but that's how 0.8 had it */
continue;