Update to 0.8.0 release.

This commit is contained in:
Alex Dupre 2020-12-17 13:32:27 +00:00
parent 23ffd03a62
commit 8d6e222e00
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=558291
5 changed files with 22 additions and 9 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= solidity
PORTVERSION= 0.7.4
PORTVERSION= 0.8.0
CATEGORIES= lang
MASTER_SITES= https://github.com/ethereum/solidity/releases/download/v${PORTVERSION}/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@ -41,6 +41,5 @@ PLIST_FILES= bin/solc \
pre-patch:
@${CP} ${FILESDIR}/jsoncpp.cmake ${WRKSRC}/cmake/
@${REINPLACE_CMD} '/EthCcache/d' ${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} '/-Werror/d' ${WRKSRC}/cmake/EthCompilerSettings.cmake
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1603118563
SHA256 (solidity_0.7.4.tar.gz) = 3994482ed1104f55cbd7614649c2129adaf3fc9a782d910e688d0010abeb7a9c
SIZE (solidity_0.7.4.tar.gz) = 2425924
TIMESTAMP = 1608206279
SHA256 (solidity_0.8.0.tar.gz) = 5a8f9f421dcf65d552b2e6fea4929aef68706a8db8b2e626e7a81e4e5ee11549
SIZE (solidity_0.8.0.tar.gz) = 2538492

View File

@ -0,0 +1,14 @@
--- cmake/EthCompilerSettings.cmake.orig 2020-12-16 17:41:40 UTC
+++ cmake/EthCompilerSettings.cmake
@@ -53,9 +53,10 @@ if (("${CMAKE_CXX_COMPILER_ID}" MATCHES "GNU") OR ("${
add_compile_options(-Wimplicit-fallthrough)
add_compile_options(-Wsign-conversion)
add_compile_options(-Wconversion)
+ add_compile_options(-Qunused-arguments)
eth_add_cxx_compiler_flag_if_supported(
- $<$<COMPILE_LANGUAGE:CXX>:-Wextra-semi>
+ -Wextra-semi
)
eth_add_cxx_compiler_flag_if_supported(-Wfinal-dtor-non-final-class)
eth_add_cxx_compiler_flag_if_supported(-Wnewline-eof)

View File

@ -1,6 +1,6 @@
--- libevmasm/Instruction.h.orig 2020-01-28 10:08:51 UTC
--- libevmasm/Instruction.h.orig 2020-12-16 17:41:40 UTC
+++ libevmasm/Instruction.h
@@ -26,6 +26,8 @@
@@ -27,6 +27,8 @@
#include <libsolutil/Assertions.h>
#include <functional>

View File

@ -1,6 +1,6 @@
--- libsolutil/JSON.cpp.orig 2020-01-27 15:36:51 UTC
--- libsolutil/JSON.cpp.orig 2020-12-16 17:41:40 UTC
+++ libsolutil/JSON.cpp
@@ -31,10 +31,12 @@
@@ -32,10 +32,12 @@
using namespace std;