- Update to 1.0.3

PR:		180508
Submitted by:	ports fury
This commit is contained in:
Martin Wilke 2013-07-16 05:47:05 +00:00
parent 708bb6f43c
commit 8d5f3c22d7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=323094
4 changed files with 52 additions and 41 deletions

View File

@ -1,15 +1,10 @@
# New ports collection makefile for: vsftpd
# Date created: 17 Mar 2002
# Whom: Gea-Suan Lin <gslin@ccca.nctu.edu.tw>
#
# Created by: Gea-Suan Lin <gslin@ccca.nctu.edu.tw>
# $FreeBSD$
#
PORTNAME= pftpd
PORTVERSION= 1.0.2
PORTVERSION= 1.0.3
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.lysator.liu.se/pub/unix/pftpd/ \
ftp://ftp.ifm.liu.se/pub/unix/pftpd/
MASTER_SITES= ftp://ftp.ifm.liu.se/pub/unix/pftpd/
MAINTAINER= ports@FreeBSD.org
COMMENT= Multithreaded anonymous FTP daemon
@ -20,19 +15,13 @@ MAKE_JOBS_UNSAFE= yes
MAN1= pftpd.1 rpad.1
PLIST_FILES= sbin/pftpd
post-extract:
.for f in ${MAN1}
@${TOUCH} ${TOUCH_FLAGS} ${WRKSRC}/doc/${f}
.endfor
post-patch:
@${REINPLACE_CMD} -e 's|mktemp|mkstemp|g' \
${WRKSRC}/src/rpa.c
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure \
${WRKSRC}/plib/configure
@${FIND} ${WRKSRC} -name "configure" | ${XARGS} ${REINPLACE_CMD} -e \
's|-lpthread|${PTHREAD_LIBS}|g'
post-install:
do-install:
(cd ${WRKSRC}/src && ${INSTALL_PROGRAM} pftpd ${PREFIX}/sbin)
(cd ${WRKSRC}/doc && ${INSTALL_MAN} *.1 ${MANPREFIX}/man/man1)
@${CAT} ${WRKSRC}/ISSUES
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (pftpd-1.0.2.tar.gz) = 9067f957b408dd2ac2760adc869f8c2f5fc85530c0c27eefde00d38ea2705913
SIZE (pftpd-1.0.2.tar.gz) = 273656
SHA256 (pftpd-1.0.3.tar.gz) = 2e60df82de5302d904823287931ac6b001bee0fea0de3155fadc0b70cfbf444e
SIZE (pftpd-1.0.3.tar.gz) = 234154

View File

@ -1,18 +1,32 @@
--- plib/support.c.orig Thu Jan 9 14:25:01 2003
+++ plib/support.c Mon May 23 20:46:01 2005
@@ -145,6 +145,15 @@
pthread_mutex_init(&pwd_lock, NULL);
}
--- plib/support.c.orig Thu Jan 9 22:25:01 2003
+++ plib/support.c Wed Apr 6 00:38:41 2005
@@ -369,11 +369,13 @@
return code;
#else
+ pthread_once_t grp_once;
+ pthread_mutex_t grp_lock;
struct group *gp;
int i, len;
+static pthread_mutex_t grp_lock;
+static pthread_once_t grp_once = PTHREAD_ONCE_INIT;
+
+static void
+grp_lock_init(void)
+{
+ pthread_mutex_init(&grp_lock, NULL);
+}
+
static char *
strcopy(const char *str, char **buf, size_t *avail)
{
- pthread_once(&grp_once, grp_lock_init);
+ pthread_once(&grp_once, NULL);
pthread_mutex_lock(&grp_lock);
gp = getgrgid(gid);
@@ -452,11 +454,13 @@
return code;
#else
+ pthread_once_t grp_once;
+ pthread_mutex_t grp_lock;
struct group *gp;
int i, len;
- pthread_once(&grp_once, grp_lock_init);
+ pthread_once(&grp_once, NULL);
pthread_mutex_lock(&grp_lock);
gp = getgrnam(name);

View File

@ -9,7 +9,15 @@
#ifdef HAVE_UNISTD_H
#include <unistd.h>
@@ -196,7 +196,7 @@
@@ -198,14 +198,14 @@
}
strcpy(path, "/var/tmp/rpa.XXXXXX");
- mktemp(path);
+ mkstemp(path);
if (!path[0])
{
syslog(LOG_ERR, "rpa_unix_open: unable to create local socket name");
goto Fail;
}
@ -18,7 +26,7 @@
usb.sun_family = AF_UNIX;
strcpy(usb.sun_path, path);
@@ -210,7 +210,7 @@
@@ -219,7 +219,7 @@
s_snprintf(path, sizeof(path), "%s/%s/unix", PATH_RPAD_DIR, rp->service);
@ -27,7 +35,7 @@
usb.sun_family = AF_UNIX;
strcpy(usb.sun_path, path);
@@ -399,8 +399,6 @@
@@ -408,8 +408,6 @@
msg.msg_iov = iov;
msg.msg_iovlen = 1;
msg.msg_name = NULL;