STAGE support, replace a wacky "NO_SSL" with an OPTION,

remove extraneous stuff and pick some patch nits.

Most interestingly, it appears that 16 months ago I started
installing a binary as a manpage. So, we're fixing that too,
and a PORTREVISION bump.
This commit is contained in:
Adam Weinberger 2014-04-18 03:12:16 +00:00
parent 48138b7a0a
commit 8d20660b20
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=351516
4 changed files with 13 additions and 26 deletions

View File

@ -3,32 +3,27 @@
PORTNAME= mini_httpd
PORTVERSION= 1.19
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= www ipv6
MASTER_SITES= http://www.acme.com/software/mini_httpd/
MAINTAINER= ports@FreeBSD.org
COMMENT= Small HTTP server with support for GET, HEAD, POST, CGI, SSL, IPv6
.ifndef NO_SSL
MAKE_ARGS+= -DUSE_OPENSSL
.endif
OPTIONS_DEFINE= SSL
SSL_MAKE_ARGS= -DUSE_OPENSSL
MAN1= ${PORTNAME}-htpasswd.1
MAN8= ${PORTNAME}.8
NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's/htpasswd/${PORTNAME}-htpasswd/g' ${WRKSRC}/htpasswd.1
${REINPLACE_CMD} -e 's/\(htpasswd(1)\)/${PORTNAME}-\1/g' ${WRKSRC}/${PORTNAME}.8
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mini_httpd ${PREFIX}/sbin/
${INSTALL_PROGRAM} ${WRKSRC}/htpasswd ${PREFIX}/sbin/${PORTNAME}-htpasswd
${INSTALL_SCRIPT} ${WRKSRC}/scripts/mini_httpd_wrapper ${PREFIX}/sbin/
${INSTALL_SCRIPT} ${WRKSRC}/scripts/mini_httpd.sh ${PREFIX}/etc/rc.d/
${INSTALL_MAN} ${WRKSRC}/htpasswd ${PREFIX}/man/man1/${MAN1}
${INSTALL_MAN} ${WRKSRC}/${MAN8} ${PREFIX}/man/man8
${INSTALL_DATA} ${WRKSRC}/mini_httpd.cnf ${PREFIX}/etc/mini_httpd.cnf.sample
${INSTALL_PROGRAM} ${WRKSRC}/mini_httpd ${STAGEDIR}${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/htpasswd ${STAGEDIR}${PREFIX}/sbin/${PORTNAME}-htpasswd
${INSTALL_SCRIPT} ${WRKSRC}/scripts/mini_httpd_wrapper ${STAGEDIR}${PREFIX}/sbin
${INSTALL_SCRIPT} ${WRKSRC}/scripts/mini_httpd.sh ${STAGEDIR}${PREFIX}/etc/rc.d
${INSTALL_MAN} ${WRKSRC}/htpasswd.1 ${STAGEDIR}${PREFIX}/man/man1/${PORTNAME}-htpasswd.1
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${STAGEDIR}${PREFIX}/man/man8
${INSTALL_DATA} ${WRKSRC}/mini_httpd.cnf ${STAGEDIR}${PREFIX}/etc/mini_httpd.cnf.sample
.include <bsd.port.mk>

View File

@ -24,13 +24,3 @@
#CFLAGS = -g ${CDEFS}
LDFLAGS = -s
#LDFLAGS = -g
@@ -76,9 +79,7 @@
-mkdir -p ${BINDIR}
cp mini_httpd htpasswd ${BINDIR}
rm -f ${MANDIR}/man8/mini_httpd.8 ${MANDIR}/man1/htpasswd.1
- -mkdir -p ${MANDIR}/man8
cp mini_httpd.8 ${MANDIR}/man8
- -mkdir -p ${MANDIR}/man1
cp htpasswd.1 ${MANDIR}/man1
clean:

View File

@ -1,4 +1,4 @@
--- mini_httpd.c~ Wed Dec 3 19:27:22 2003
--- mini_httpd.c.orig Wed Dec 3 19:27:22 2003
+++ mini_httpd.c Thu May 6 23:36:20 2004
@@ -816,7 +816,7 @@
}

View File

@ -1,5 +1,7 @@
etc/mini_httpd.cnf.sample
etc/rc.d/mini_httpd.sh
man/man1/mini_httpd-htpasswd.1.gz
man/man8/mini_httpd.8.gz
sbin/mini_httpd
sbin/mini_httpd-htpasswd
sbin/mini_httpd_wrapper