MFH: r418897 r419992 r420804 r421247 r421297 r421586 r421587 r421633 r421673 r421696
- Update net/asterisk11 to 11.23.0 - Update net/asterisk13 to 13.10.0 Add patch to fix build with libressl. PR: 211707 Submitted by: olivierw1+bugzilla-freebsd@hotmail.com Patch by: brnrd@ Obtained From: http://cvsweb.openbsd.org/cgi-bin/cvsweb/~checkout~/ports/telephony/asterisk/patches/patch-res_res_rtp_asterisk_c?rev=1.1&content-type=text/plain Fix build on head after r303920. - Update to 13.11.0 - Make using base compiler the dafault on amd64 and i386 - Prevent asterisk build system from unconditionally using -march=native - Add an OPTIMIZED_CFLAGS option, disabled by default, to allow enabling the native flag - While here, convert to option target helpers. Update net/asterisk11 to 11.23.1 Security: 5cb18881-7604-11e6-b362-001999f8d30b Update net/asterisk13 to 13.11.1 Security: 5cb18881-7604-11e6-b362-001999f8d30b 7fda7920-7603-11e6-b362-001999f8d30b net/asterisk13: Fix broken patch file - Patch was the svn diff to the tree - Convert to a regular patch file PR: 211707 Push ncurses USES after ssl USES, it has been reported to solve problems when compiling with non base SSL library. PR: 211707 Submitted by: OlivierW <olivierw1+bugzilla-freebsd@hotmail.com> Update to 13.11.2 Approved by: ports-secteam (feld)
This commit is contained in:
parent
1417d29ebe
commit
8d15052808
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2016Q3/; revision=421733
@ -1,8 +1,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= asterisk
|
||||
PORTVERSION= 11.22.0
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 11.23.1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/%SUBDIR%/:DEFAULT,g729
|
||||
MASTER_SITE_SUBDIR= asterisk/ \
|
||||
|
@ -1,5 +1,6 @@
|
||||
SHA256 (asterisk-11.22.0.tar.gz) = 590c361f8926e08eeaf320a35985cd39a2ea651ec3e94fb62484a7179c32f527
|
||||
SIZE (asterisk-11.22.0.tar.gz) = 35101090
|
||||
TIMESTAMP = 1473367385
|
||||
SHA256 (asterisk-11.23.1.tar.gz) = 5696a7f999dc01afdce91ed3afbd62f54b49ed37b4cbddb02bab124a88656d5c
|
||||
SIZE (asterisk-11.23.1.tar.gz) = 35098451
|
||||
SHA256 (asterisk-core-sounds-en-g729-1.5.tar.gz) = 8b28a59cfa53b59c76e0a191704f0708e3d83acffab8c5e6f25dfc599f0123f9
|
||||
SIZE (asterisk-core-sounds-en-g729-1.5.tar.gz) = 1551123
|
||||
SHA256 (asterisk-moh-opsound-g729-2.03.tar.gz) = 0147ca9a97f0c550227aacb7793499057c4d2c64e021c95f93722f27d5549585
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- apps/app_queue.c.orig 2016-03-29 19:25:17 UTC
|
||||
+++ apps/app_queue.c
|
||||
@@ -3641,7 +3641,7 @@ static int can_ring_entry(struct queue_e
|
||||
return 0;
|
||||
}
|
||||
|
||||
- if (call->member->in_call && call->lastqueue->wrapuptime) {
|
||||
+ if (call->member->in_call && call->lastqueue && call->lastqueue->wrapuptime) {
|
||||
ast_debug(1, "%s is in call, so not available (wrapuptime %d)\n",
|
||||
call->interface, call->lastqueue->wrapuptime);
|
||||
return 0;
|
@ -1,8 +1,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= asterisk
|
||||
PORTVERSION= 13.9.1
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 13.11.2
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/%SUBDIR%/:DEFAULT,g729
|
||||
MASTER_SITE_SUBDIR= asterisk/ \
|
||||
@ -24,8 +23,8 @@ EXTRACT_ONLY:= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
||||
ONLY_FOR_ARCHS= i386 amd64 powerpc sparc64 armv6
|
||||
|
||||
USES= bison cpe gmake iconv libedit localbase ncurses \
|
||||
shebangfix sqlite ssl
|
||||
USES= bison cpe gmake iconv libedit localbase \
|
||||
shebangfix sqlite ssl ncurses
|
||||
USE_CSTD= gnu89
|
||||
USE_GNOME= libxml2
|
||||
USE_LDCONFIG= yes
|
||||
@ -58,7 +57,7 @@ CONFLICTS_BUILD= linuxthreads-*
|
||||
CONFLICTS_INSTALL= asterisk*-1.8* asterisk*-11*
|
||||
|
||||
OPTIONS_DEFINE= ASTVERSION BACKTRACE CURL EXCHANGE FREETDS LDAP LUA \
|
||||
MP3PLAYER OOH323 PJSIP PORTAUDIO RADIUS SNMP \
|
||||
MP3PLAYER OOH323 OPTIMIZED_CFLAGS PJSIP PORTAUDIO RADIUS SNMP \
|
||||
SPANDSP SRTP SYSINFO XMPP
|
||||
OPTIONS_DEFAULT= CURL FREETDS GSM LUA MP3PLAYER NEWT ODBC MYSQL PGSQL PJSIP \
|
||||
PORTAUDIO RADIUS SNMP SPANDSP SPEEX SQLITE2 VORBIS
|
||||
@ -67,8 +66,8 @@ OPTIONS_DEFINE_i386= DAHDI
|
||||
OPTIONS_DEFINE_amd64= DAHDI
|
||||
OPTIONS_DEFINE_sparc64= DAHDI
|
||||
|
||||
OPTIONS_DEFAULT_i386= DAHDI GCC XMPP
|
||||
OPTIONS_DEFAULT_amd64= DAHDI GCC XMPP
|
||||
OPTIONS_DEFAULT_i386= DAHDI BASE XMPP
|
||||
OPTIONS_DEFAULT_amd64= DAHDI BASE XMPP
|
||||
OPTIONS_DEFAULT_sparc64= DAHDI GCC XMPP
|
||||
OPTIONS_DEFAULT_powerpc= GCC XMPP
|
||||
OPTIONS_DEFAULT_armv6= BASE
|
||||
@ -238,19 +237,19 @@ PLIST_SUB+= ASTERISK_USER=${ASTERISK_USER} \
|
||||
post-extract:
|
||||
@${FIND} ${WRKSRC} -name '*.d' -delete
|
||||
|
||||
.if ${PORT_OPTIONS:MG729}
|
||||
post-extract-G729-on:
|
||||
${CP} ${DISTDIR}/${ASTERISK_CORE_G729_SOUNDS} ${WRKSRC}/sounds
|
||||
${CP} ${DISTDIR}/${ASTERISK_MOH_G729_SOUNDS} ${WRKSRC}/sounds
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/samples/musiconhold.conf.sample
|
||||
.if ${PORT_OPTIONS:MSYSINFO}
|
||||
|
||||
post-patch-SYSINFO-on:
|
||||
@${REINPLACE_CMD} -e 's/%%LIBSYSINFO%%/-lsysinfo/' ${WRKSRC}/main/Makefile
|
||||
.else
|
||||
|
||||
post-patch-SYSINFO-off:
|
||||
@${REINPLACE_CMD} -e '/#define HAVE_SYSINFO 1/d' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e '/%%LIBSYSINFO%%/d' ${WRKSRC}/main/Makefile
|
||||
.endif
|
||||
|
||||
.if exists(${FILESDIR}/.asterisk.makeopts)
|
||||
USER_MAKEOPTS_FILE=${FILESDIR}/.asterisk.makeopts
|
||||
@ -263,23 +262,23 @@ post-configure:
|
||||
@cd ${WRKSRC} && ./menuselect/menuselect --disable res_timing_kqueue menuselect.makeopts
|
||||
@cd ${WRKSRC} && ./menuselect/menuselect --enable chan_mgcp menuselect.makeopts
|
||||
@cd ${WRKSRC} && ./menuselect/menuselect --enable res_pktccops menuselect.makeopts
|
||||
.if ${PORT_OPTIONS:MMYSQL}
|
||||
|
||||
post-configure-MYSQL-on:
|
||||
@cd ${WRKSRC} && ./menuselect/menuselect --enable res_config_mysql menuselect.makeopts
|
||||
@cd ${WRKSRC} && ./menuselect/menuselect --enable app_mysql menuselect.makeopts
|
||||
@cd ${WRKSRC} && ./menuselect/menuselect --enable cdr_mysql menuselect.makeopts
|
||||
.endif
|
||||
.if ${PORT_OPTIONS:MOOH323}
|
||||
|
||||
post-configure-OOH323-on:
|
||||
@cd ${WRKSRC} && ./menuselect/menuselect --enable chan_ooh323 menuselect.makeopts
|
||||
.endif
|
||||
.if ${PORT_OPTIONS:MNEWG711}
|
||||
|
||||
post-configure-NEWG711-on:
|
||||
@cd ${WRKSRC} && ./menuselect/menuselect --enable G711_NEW_ALGORITHM menuselect.makeopts
|
||||
.endif
|
||||
|
||||
post-configure-OPTIMIZED_CFLAGS-off:
|
||||
@cd ${WRKSRC} && ./menuselect/menuselect --disable BUILD_NATIVE menuselect.makeopts
|
||||
|
||||
post-install:
|
||||
@${RM} ${STAGEDIR}${ETCDIR}/*.conf ${STAGEDIR}${ETCDIR}/extensions.ael ${STAGEDIR}${ETCDIR}/extensions.lua
|
||||
.if ! ${PORT_OPTIONS:MASTVERSION}
|
||||
@${RM} ${STAGEDIR}${PREFIX}/sbin/astversion
|
||||
.endif
|
||||
${FIND} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/modules -type f -name '*.so' | ${SED} "s,^${STAGEDIR}${PREFIX}/,," >> ${TMPPLIST}
|
||||
${FIND} ${STAGEDIR}${DATADIR}/sounds -type f | ${SED} "s,^${STAGEDIR}${DATADIR},${DATADIR}," >> ${TMPPLIST}
|
||||
${FIND} ${STAGEDIR}${DATADIR}/moh -type f | ${SED} "s,^${STAGEDIR}${DATADIR},${DATADIR}," >> ${TMPPLIST}
|
||||
@ -292,4 +291,7 @@ post-install:
|
||||
${ECHO} "@owner" >> ${TMPPLIST} && \
|
||||
${ECHO} "@group" >> ${TMPPLIST});
|
||||
|
||||
post-install-ASTVERSION-off:
|
||||
@${RM} ${STAGEDIR}${PREFIX}/sbin/astversion
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,6 +1,6 @@
|
||||
TIMESTAMP = 1463169882
|
||||
SHA256 (asterisk-13.9.1.tar.gz) = 00e51aeaf077b54e610ebb5ebe64097f3d64da2cc2aecab25306dd74de96a236
|
||||
SIZE (asterisk-13.9.1.tar.gz) = 32537561
|
||||
TIMESTAMP = 1473494815
|
||||
SHA256 (asterisk-13.11.2.tar.gz) = 6ea7001bb11ba11fcdbb5febb028b2fd62c44c7bda3cc966b8aaafcb429c5a3a
|
||||
SIZE (asterisk-13.11.2.tar.gz) = 32630702
|
||||
SHA256 (asterisk-core-sounds-en-g729-1.5.tar.gz) = 8b28a59cfa53b59c76e0a191704f0708e3d83acffab8c5e6f25dfc599f0123f9
|
||||
SIZE (asterisk-core-sounds-en-g729-1.5.tar.gz) = 1551123
|
||||
SHA256 (asterisk-moh-opsound-g729-2.03.tar.gz) = 0147ca9a97f0c550227aacb7793499057c4d2c64e021c95f93722f27d5549585
|
||||
|
@ -1,40 +1,20 @@
|
||||
--- main/Makefile.orig 2016-04-25 21:44:00 UTC
|
||||
--- main/Makefile.orig 2016-07-21 14:54:02 UTC
|
||||
+++ main/Makefile
|
||||
@@ -82,6 +82,7 @@ ifeq ($(OSARCH),FreeBSD)
|
||||
BSDVERSION=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
|
||||
@@ -79,9 +79,12 @@ endif
|
||||
|
||||
ifeq ($(OSARCH),FreeBSD)
|
||||
# -V is understood by BSD Make, not by GNU make.
|
||||
- BSDVERSION=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
|
||||
+ BSDVERSION=$(OSVERSION)
|
||||
+ BSDVERSION?=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
|
||||
AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
|
||||
+ CRYPT_LIB=$(shell if test $(BSDVERSION) -ge 1200001 ; then echo "-lcrypt"; fi)
|
||||
AST_LIBS+=-lcrypto
|
||||
+ AST_LIBS+=%%LIBSYSINFO%%
|
||||
endif
|
||||
|
||||
ifneq ($(findstring $(OSARCH), mingw32 cygwin ),)
|
||||
@@ -224,11 +225,7 @@ endif
|
||||
|
||||
$(ASTSSL_LIB): $(ASTSSL_LIB).$(ASTSSL_SO_VERSION)
|
||||
$(ECHO_PREFIX) echo " [LN] $< -> $@"
|
||||
- $(CMD_PREFIX) if [ -x "$(LDCONFIG)" ] ; then \
|
||||
- $(LDCONFIG) $(LDCONFIG_FLAGS) . 2>/dev/null ;\
|
||||
- else \
|
||||
- $(LN) -sf $< $@ ;\
|
||||
- fi
|
||||
+ $(LN) -sf $< $@
|
||||
|
||||
else # Darwin
|
||||
ASTSSL_LIB:=libasteriskssl.dylib
|
||||
@@ -304,11 +301,7 @@ $(ASTPJ_LIB).$(ASTPJ_SO_VERSION): libast
|
||||
|
||||
$(ASTPJ_LIB): $(ASTPJ_LIB).$(ASTPJ_SO_VERSION)
|
||||
$(ECHO_PREFIX) echo " [LN] $< -> $@"
|
||||
- $(CMD_PREFIX) if [ -x "$(LDCONFIG)" ] ; then \
|
||||
- $(LDCONFIG) $(LDCONFIG_FLAGS) . 2>/dev/null ;\
|
||||
- else \
|
||||
- $(LN) -sf $< $@ ;\
|
||||
- fi
|
||||
+ $(LN) -sf $< $@
|
||||
|
||||
else # Darwin
|
||||
ASTPJ_LIB:=libasteriskpj.dylib
|
||||
@@ -359,9 +352,6 @@ else # Darwin
|
||||
@@ -351,9 +354,6 @@ else # Darwin
|
||||
$(INSTALL) -m 755 $(ASTPJ_LIB) "$(DESTDIR)$(ASTLIBDIR)/"
|
||||
endif
|
||||
endif
|
||||
|
11
net/asterisk13/files/patch-main_crypt.c
Normal file
11
net/asterisk13/files/patch-main_crypt.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- main/crypt.c.orig 2016-07-21 14:54:02 UTC
|
||||
+++ main/crypt.c
|
||||
@@ -31,7 +31,7 @@
|
||||
ASTERISK_FILE_VERSION(__FILE__, "$Revision$")
|
||||
|
||||
#include <unistd.h>
|
||||
-#if defined(HAVE_CRYPT_R)
|
||||
+#if defined(HAVE_CRYPT_R) && !defined(__FreeBSD__)
|
||||
#include <crypt.h>
|
||||
#endif
|
||||
|
15
net/asterisk13/files/patch-res_res__rtp__asterisk.c
Normal file
15
net/asterisk13/files/patch-res_res__rtp__asterisk.c
Normal file
@ -0,0 +1,15 @@
|
||||
$OpenBSD: patch-res_res_rtp_asterisk_c,v 1.1 2016/07/30 21:12:15 sthen Exp $
|
||||
|
||||
Obtained from OpenBSD cvs
|
||||
|
||||
--- res/res_rtp_asterisk.c.orig 2016-07-21 14:54:02 UTC
|
||||
+++ res/res_rtp_asterisk.c
|
||||
@@ -1357,7 +1357,7 @@ static int ast_rtp_dtls_set_configuratio
|
||||
return 0;
|
||||
}
|
||||
|
||||
-#if OPENSSL_VERSION_NUMBER < 0x10002000L
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10002000L || defined(LIBRESSL_VERSION_NUMBER)
|
||||
rtp->ssl_ctx = SSL_CTX_new(DTLSv1_method());
|
||||
#else
|
||||
rtp->ssl_ctx = SSL_CTX_new(DTLS_method());
|
@ -221,6 +221,7 @@ include/asterisk/mixmonitor.h
|
||||
include/asterisk/mod_format.h
|
||||
include/asterisk/module.h
|
||||
include/asterisk/monitor.h
|
||||
include/asterisk/multicast_rtp.h
|
||||
include/asterisk/musiconhold.h
|
||||
include/asterisk/named_locks.h
|
||||
include/asterisk/netsock.h
|
||||
|
Loading…
Reference in New Issue
Block a user