Crude hack to get all this running on the alpha architecutre as well.
Since gcc (in the assumption of generating a native compiler) doesn't want to cbe configured for an alpha*-*-freebsd* system, we hack the configure script to allow this (similarly to netbsd). In the end, all this will be ignored anyway since it's getting to become a cross-compiler.
This commit is contained in:
parent
95a035f6d7
commit
8cf5d0f539
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=39892
22
devel/avr-gcc-3/files/patch-aa
Normal file
22
devel/avr-gcc-3/files/patch-aa
Normal file
@ -0,0 +1,22 @@
|
||||
--- gcc/configure.in.orig Sat Mar 10 22:07:33 2001
|
||||
+++ gcc/configure.in Sat Mar 10 22:13:54 2001
|
||||
@@ -626,7 +626,7 @@
|
||||
thread_file='posix'
|
||||
fi
|
||||
;;
|
||||
- alpha*-*-netbsd*)
|
||||
+ alpha*-*-netbsd*|alpha*-*-freebsd*)
|
||||
tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsd-elf.h"
|
||||
target_cpu_default="MASK_GAS"
|
||||
tmake_file="alpha/t-crtbe alpha/t-ieee"
|
||||
--- gcc/configure.orig Wed Oct 13 09:58:02 1999
|
||||
+++ gcc/configure Thu Mar 15 17:52:27 2001
|
||||
@@ -3059,7 +3059,7 @@
|
||||
thread_file='posix'
|
||||
fi
|
||||
;;
|
||||
- alpha*-*-netbsd*)
|
||||
+ alpha*-*-netbsd*|alpha*-*-freebsd*)
|
||||
tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsd-elf.h"
|
||||
target_cpu_default="MASK_GAS"
|
||||
tmake_file="alpha/t-crtbe alpha/t-ieee"
|
22
devel/avr-gcc/files/patch-aa
Normal file
22
devel/avr-gcc/files/patch-aa
Normal file
@ -0,0 +1,22 @@
|
||||
--- gcc/configure.in.orig Sat Mar 10 22:07:33 2001
|
||||
+++ gcc/configure.in Sat Mar 10 22:13:54 2001
|
||||
@@ -626,7 +626,7 @@
|
||||
thread_file='posix'
|
||||
fi
|
||||
;;
|
||||
- alpha*-*-netbsd*)
|
||||
+ alpha*-*-netbsd*|alpha*-*-freebsd*)
|
||||
tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsd-elf.h"
|
||||
target_cpu_default="MASK_GAS"
|
||||
tmake_file="alpha/t-crtbe alpha/t-ieee"
|
||||
--- gcc/configure.orig Wed Oct 13 09:58:02 1999
|
||||
+++ gcc/configure Thu Mar 15 17:52:27 2001
|
||||
@@ -3059,7 +3059,7 @@
|
||||
thread_file='posix'
|
||||
fi
|
||||
;;
|
||||
- alpha*-*-netbsd*)
|
||||
+ alpha*-*-netbsd*|alpha*-*-freebsd*)
|
||||
tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsd-elf.h"
|
||||
target_cpu_default="MASK_GAS"
|
||||
tmake_file="alpha/t-crtbe alpha/t-ieee"
|
Loading…
Reference in New Issue
Block a user