- Update to version 1.3
PR: ports/63137 Submitted by: Ports Fury
This commit is contained in:
parent
c513e3c18e
commit
8cebaee266
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=101515
@ -6,25 +6,31 @@
|
||||
#
|
||||
|
||||
PORTNAME= cadubi
|
||||
PORTVERSION= 1.2
|
||||
PORTVERSION= 1.3
|
||||
CATEGORIES= graphics editors
|
||||
MASTER_SITES= ftp://ftp.dei.uc.pt/.raid1/linux/files/console/graphics/ \
|
||||
http://www.logicallemon.com/projects/cadubi/downloads/
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}
|
||||
MASTER_SITES= http://langworth.com/downloads/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= ASCII drawing utility
|
||||
|
||||
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
|
||||
|
||||
USE_PERL5= yes
|
||||
NO_BUILD= yes
|
||||
|
||||
do-configure:
|
||||
@${PERL} -pi -e \
|
||||
's|Bin/help|Bin/../share/cadubi/help|g' ${WRKSRC}/cadubi
|
||||
|
||||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/cadubi ${PREFIX}/bin
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/CADUBI.pl ${PREFIX}/libexec
|
||||
@${MKDIR} ${DATADIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/help.txt ${DATADIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/logo.txt ${DATADIR}
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/cadubi
|
||||
${INSTALL_DATA} ${WRKSRC}/CADUBI.help ${PREFIX}/share/doc/cadubi
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/extras/ansi_term_codes.txt ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (cadubi_1.2.tar.gz) = 53315c148dffda233f04ad83bafd20aa
|
||||
SIZE (cadubi_1.2.tar.gz) = 46347
|
||||
MD5 (cadubi-1.3.tar.gz) = e4ba1f6995bfdae8639341446782b859
|
||||
SIZE (cadubi-1.3.tar.gz) = 12559
|
||||
|
@ -1,32 +0,0 @@
|
||||
--- CADUBI.pl.orig Thu Jan 27 03:54:45 2000
|
||||
+++ CADUBI.pl Sun Jul 29 01:10:28 2001
|
||||
@@ -59,6 +59,7 @@ $AUDIBLE = 1; # beep unless -m, --mute
|
||||
$status_changed = 1; # used with &status so we don't constantly redraw.
|
||||
$current_filename = undef; # name of file we're working with
|
||||
$cadubi_done = 0; # main loop var
|
||||
+$Helpfile = $Bin . "/../share/doc/cadubi";
|
||||
|
||||
# runtime statements
|
||||
&initKeys(); # setup %controlkeys and %keymap
|
||||
@@ -716,10 +717,10 @@ sub HandleKeystroke {
|
||||
|
||||
# help
|
||||
if (ord($key) == $keymap{'^h'}) { #Help
|
||||
- if (-e $Bin.'/CADUBI.help') {
|
||||
+ if (-e $Helpfile.'/CADUBI.help') {
|
||||
my @oldmap = @charmap;
|
||||
my @oldpos = @pos;
|
||||
- &readfile($Bin.'/CADUBI.help');
|
||||
+ &readfile($Helpfile.'/CADUBI.help');
|
||||
&status('Press a key to continue...', 1);
|
||||
my $temp = ReadKey(0);
|
||||
@charmap = @oldmap;
|
||||
@@ -729,7 +730,7 @@ sub HandleKeystroke {
|
||||
&status;
|
||||
} else {
|
||||
&beep;
|
||||
- &status("'".$Bin."/CADUBI.help' not available");
|
||||
+ &status("'".$Helpfile."/CADUBI.help' not available");
|
||||
}
|
||||
return 0;
|
||||
}
|
@ -1,9 +0,0 @@
|
||||
--- cadubi.orig Thu Jan 27 03:54:51 2000
|
||||
+++ cadubi Sun Jul 29 01:10:59 2001
|
||||
@@ -32,5 +32,5 @@ use FindBin qw($Bin); use lib "$Bin/../l
|
||||
my $CADUBI_Arguments = undef;
|
||||
$CADUBI_Arguments .= ' --mute' unless $AUDIBLE;
|
||||
$CADUBI_Arguments .= ' '.$ADD_OPS if $ADD_OPS;
|
||||
-exec ('perl '.$Bin.'/CADUBI.pl'.$CADUBI_Arguments.' '.join(' ',@ARGV));
|
||||
+exec ('perl '.$Bin.'/../libexec/CADUBI.pl'.$CADUBI_Arguments.' '.join(' ',@ARGV));
|
||||
|
@ -6,4 +6,4 @@ foreground colors, bold, and inverse. This text art, commonly
|
||||
called "ASCII art," is used in various places such as online
|
||||
BBSes, email and login prompts.
|
||||
|
||||
WWW: http://www.logicallemon.com/projects/cadubi/
|
||||
WWW: http://langworth.com/CadubiProject
|
||||
|
@ -1,4 +1,7 @@
|
||||
bin/cadubi
|
||||
libexec/CADUBI.pl
|
||||
%%PORTDOCS%%share/doc/cadubi/CADUBI.help
|
||||
%%PORTDOCS%%@dirrm share/doc/cadubi
|
||||
%%DATADIR%%/help.txt
|
||||
%%DATADIR%%/logo.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ansi_term_codes.txt
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm %%DATADIR%%
|
||||
|
Loading…
Reference in New Issue
Block a user