Retire NetHack 3.2.2 ports as prearranged.
Implicitly approved by: sf (MAINTAINER of games/nethack32-gtk)
This commit is contained in:
parent
b525ae5416
commit
8cdcacf95a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=61244
@ -184,8 +184,6 @@
|
||||
SUBDIR += myth2_demo
|
||||
SUBDIR += mythserver
|
||||
SUBDIR += nadar
|
||||
SUBDIR += nethack32
|
||||
SUBDIR += nethack32-gtk
|
||||
SUBDIR += nethack33
|
||||
SUBDIR += nethack33-gnome
|
||||
SUBDIR += nethack33-nox11
|
||||
|
@ -1,58 +0,0 @@
|
||||
# New ports collection makefile for: nethack-gtk
|
||||
# Date created: June 15, 2000
|
||||
# Whom: Kelly Yancey <kbyanc@posi.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= nethack
|
||||
PORTVERSION= 1.1.5
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= sf
|
||||
#MASTER_SITES= ftp://ftp.jnethack.org/pub/jnethack/
|
||||
PKGNAMESUFFIX= -gtk
|
||||
DISTNAME= ${PORTNAME}-3.2.2.1
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${GTK_PATCH}
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
||||
PATCH_SITES= ftp://ftp.jnethack.org/pub/nethack/
|
||||
PATCHFILES= nh-3.2.2-3.2.3.diff \
|
||||
nethack-gtk-1.1.5-nethack-3.2.3.patch.gz
|
||||
|
||||
MAINTAINER= sf@FreeBSD.org
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${XFREE86_VERSION} == 4
|
||||
BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients
|
||||
RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
|
||||
.endif
|
||||
|
||||
USE_XPM= yes
|
||||
USE_GTK= yes
|
||||
USE_GMAKE= yes
|
||||
MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-3.2.2
|
||||
|
||||
pre-configure:
|
||||
@ ${ECHO} "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
|
||||
@ ${ECHO} "!! You cannot install nethack and nethack-gtk in parallel !!"
|
||||
@ ${ECHO} "!! But nethack-gtk might read your prior nethack scores !!"
|
||||
@ ${ECHO} "!! Don't forget to backup your nethack libdir if it's !!"
|
||||
@ ${ECHO} "!! important for you !!"
|
||||
@ ${ECHO} "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
|
||||
@ cd ${WRKSRC}/sys/unix; ${SH} setup.sh
|
||||
@ cd ${WRKSRC}; ${PATCH} -s < ${FILESDIR}/src-Makefile.diff
|
||||
|
||||
post-install:
|
||||
@cd ${WRKSRC}/doc; ${CHMOD} 644 *.6
|
||||
@cd ${WRKSRC}/doc; PREFIX=${PREFIX} ${MAKE} manpages
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/nethack
|
||||
${CP} ${WRKSRC}/doc/Guidebook.txt ${PREFIX}/share/doc/nethack
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
@ -1,3 +0,0 @@
|
||||
MD5 (nethack-3.2.2.1.tar.gz) = 2571a63135b4d0aa910d52c386b669a6
|
||||
MD5 (nh-3.2.2-3.2.3.diff) = 440141990df326d5a973d890179cffae
|
||||
MD5 (nethack-gtk-1.1.5-nethack-3.2.3.patch.gz) = a9e75005f23a5eea2a4879237ac851d4
|
@ -1,13 +0,0 @@
|
||||
--- sys/unix/Makefile.top.orig Thu Jun 15 15:58:10 2000
|
||||
+++ sys/unix/Makefile.top Thu Jun 15 15:58:23 2000
|
||||
@@ -32,8 +32,8 @@
|
||||
# therefore there should not be anything in GAMEDIR that you want to keep
|
||||
# (if there is, you'll have to do the installation by hand or modify the
|
||||
# instructions)
|
||||
-GAMEDIR = /usr/games/lib/$(GAME)dir
|
||||
-SHELLDIR = /usr/games
|
||||
+GAMEDIR = ${PREFIX}/share/$(GAME)
|
||||
+SHELLDIR = ${PREFIX}/bin
|
||||
|
||||
# per discussion in Install.X11
|
||||
VARDATND =
|
@ -1,11 +0,0 @@
|
||||
--- include/config.h.orig Wed Jun 14 22:54:31 2000
|
||||
+++ include/config.h Wed Jun 14 22:54:34 2000
|
||||
@@ -374,7 +374,7 @@
|
||||
* otherwise it will be the current directory.
|
||||
*/
|
||||
# ifndef HACKDIR
|
||||
-# define HACKDIR "/usr/games/lib/nethackdir" /* nethack directory */
|
||||
+# define HACKDIR "/usr/local/share/nethack" /* nethack directory */
|
||||
# endif
|
||||
|
||||
/*
|
@ -1,11 +0,0 @@
|
||||
--- include/system.h.orig Wed Jun 14 23:00:05 2000
|
||||
+++ include/system.h Wed Jun 14 23:00:07 2000
|
||||
@@ -512,7 +512,7 @@
|
||||
# if defined(ULTRIX) || defined(SYSV) || defined(MICRO) || defined(VMS) || defined(MAC)
|
||||
E time_t FDECL(time, (time_t *));
|
||||
# else
|
||||
-E long FDECL(time, (time_t *));
|
||||
+E time_t FDECL(time, (time_t *));
|
||||
# endif /* ULTRIX */
|
||||
|
||||
#ifdef VMS
|
@ -1,12 +0,0 @@
|
||||
diff -ruN ./sys/unix/Makefile.doc ../nethack-3.2.2/sys/unix/Makefile.doc
|
||||
--- ./sys/unix/Makefile.doc Wed Dec 11 05:20:08 1996
|
||||
+++ ../nethack-3.2.2/sys/unix/Makefile.doc Sun Mar 21 17:25:02 1999
|
||||
@@ -31,7 +31,7 @@
|
||||
|
||||
|
||||
GAME = nethack
|
||||
-MANDIR = /usr/man/man6
|
||||
+MANDIR = ${PREFIX}/man/man6
|
||||
MANEXT = 6
|
||||
|
||||
# manual installation for most BSD-style systems
|
@ -1,10 +0,0 @@
|
||||
--- win/gtk/gtk.c.orig Thu Jun 14 23:10:35 2001
|
||||
+++ win/gtk/gtk.c Thu Jun 14 23:12:03 2001
|
||||
@@ -742,6 +742,7 @@
|
||||
gtk_set_locale();
|
||||
nh_rc();
|
||||
|
||||
+ setregid(getegid(), -1);
|
||||
gtk_init(argc, &argv);
|
||||
/*
|
||||
creat credit widget and show
|
@ -1,88 +0,0 @@
|
||||
OPTIONS=!silent
|
||||
OPTIONS=!time
|
||||
OPTIONS=catname:Ghisteslwchlohm
|
||||
OPTIONS=color
|
||||
OPTIONS=dogname:Dhairrhuwyth
|
||||
OPTIONS=hilite_pet
|
||||
OPTIONS=lit_corridor
|
||||
OPTIONS=menustyle:partial
|
||||
OPTIONS=msghistory:200
|
||||
OPTIONS=news
|
||||
OPTIONS=noautopickup
|
||||
OPTIONS=rest_on_space
|
||||
OPTIONS=safe_pet
|
||||
OPTIONS=showexp
|
||||
OPTIONS=showscore
|
||||
OPTIONS=sortpack
|
||||
OPTIONS=time
|
||||
OPTIONS=tombstone
|
||||
OPTIONS=toptenwin
|
||||
OPTIONS=verbose
|
||||
SOUNDDIR=/usr/local/lib/nethackdir
|
||||
SOUND=MESG "needs food, badly" "weak.au" 100
|
||||
SOUND=MESG "feel weak" "weak.au" 100
|
||||
SOUND=MESG "bear trap closes" "beartrap.au" 100
|
||||
SOUND=MESG "board beneath you squeaks" "squeek.au" 100
|
||||
SOUND=MESG "board beneath .....* squeaks" "squeek.au" 60
|
||||
SOUND=MESG "a distant squeak" "squeek.au" 25
|
||||
SOUND=MESG "mind releases itself from" "memories.au" 100
|
||||
SOUND=MESG "on itself, you forget" "memories.au" 100
|
||||
SOUND=MESG "Who was that Maud person" "memories.au" 100
|
||||
SOUND=MESG "Thinking of Maud you forget" "memories.au" 100
|
||||
SOUND=MESG "you forget everything" "memories.au" 100
|
||||
SOUND=MESG "smell marsh gas" "frogs.au" 100
|
||||
SOUND=MESG "must have been exercising" "tada.au" 100
|
||||
SOUND=MESG "must have been very obs" "tada.au" 100
|
||||
SOUND=MESG "must have been working on" "tada.au" 100
|
||||
SOUND=MESG "must be leading a healthy" "tada.au" 100
|
||||
SOUND=MESG "Keystone Kops appear!" "kops.au" 100
|
||||
SOUND=MESG "Keystone Kops are after you" "kops.au" 100
|
||||
SOUND=MESG "interesting topological ex" "mock.au" 100
|
||||
SOUND=MESG "Interesting\.\.\." "mock.au" 100
|
||||
SOUND=MESG "deathly sick\." "ohdear.au" 80
|
||||
SOUND=MESG "feel feverish" "ohdear.au" 80
|
||||
SOUND=MESG "brain is eaten" "minderode.au" 80
|
||||
SOUND=MESG "thought thou couldst kill" "yendor.au" 120
|
||||
SOUND=MESG "begin praying to" "latin_short.au" 70
|
||||
SOUND=MESG "sense of peace" "latin.au" 20
|
||||
SOUND=MESG "have a.* forbidding feeling" "latin.au" 20
|
||||
#SOUND=MESG "door opens\." "dooropen2.au" 100
|
||||
#SOUND=MESG "You drop " "drop.au" 10
|
||||
#SOUND=MESG "You destroy " "destroy2.au" 30
|
||||
#SOUND=MESG "You kill " "destroy2.au" 20
|
||||
#SOUND=MESG "is killed" "destroy2.au" 10
|
||||
#SOUND=MESG "You miss " "miss2.au" 20
|
||||
#SOUND=MESG "fiery blade burns" "hit2.au" 30
|
||||
#SOUND=MESG "ice-cold blade freezes" "hit2.au" 30
|
||||
#SOUND=MESG "You hit " "hit2.au" 20
|
||||
#SOUND=MESG "The spell hits" "hit2.au" 20
|
||||
SOUND=MESG "breathes" "breath.au" 100
|
||||
SOUND=MESG "a door open\." "dooropen2.au" 100
|
||||
SOUND=MESG "Klunk" "clunk.au" 100
|
||||
SOUND=MESG "guard on patrol" "coin.au" 50
|
||||
SOUND=MESG "quarterback calling" "coin.au" 50
|
||||
SOUND=MESG "someone counting" "coin.au" 50
|
||||
SOUND=MESG "Ebenezer Scrooge" "coin.au" 50
|
||||
SOUND=MESG "someone cursing shoplifters" "gong.au" 50
|
||||
SOUND=MESG "chime of a cash register" "gong.au" 50
|
||||
SOUND=MESG "Neiman and Marcus" "gong.au" 50
|
||||
SOUND=MESG "You die" "death.au" 100
|
||||
SOUND=MESG "sad feeling" "death.au" 50
|
||||
SOUND=MESG "door closes\." "doorclos.au" 100
|
||||
SOUND=MESG "cosmic" "hallu.au" 100
|
||||
SOUND=MESG "explosion" "landmine.au" 100
|
||||
SOUND=MESG "KABOOM" "landmine.au" 100
|
||||
#SOUND=MESG "KAABLAM" "landmine.au" 100
|
||||
SOUND=MESG "trigger.* a land *mine" "landmine.au" 100
|
||||
SOUND=MESG "elcome to experi" "level_up.au" 100
|
||||
SOUND=MESG "memorize" "memor.au" 100
|
||||
#SOUND=MESG "Ouch" "ouch2.au" 100
|
||||
#SOUND=MESG "XXXfall through\.\.\." "trapdoor.au" 100
|
||||
SOUND=MESG "vomit" "vomit.au" 100
|
||||
SOUND=MESG "whistling" "whistle2.au" 100
|
||||
SOUND=MESG "crashes open" "thump.au" 100
|
||||
SOUND=MESG "You break open the lock" "thump.au" 100
|
||||
#SOUND=MESG "THUD" "thump.au" 40
|
||||
#SOUND=MESG "WHAMM" "thump.au" 50
|
||||
SOUND=MESG "welcome to NetHack" "awaits.au" 100
|
||||
SOUND=MESG "strange vibration under" "forcefld.au" 100
|
@ -1,13 +0,0 @@
|
||||
--- src/Makefile.orig Wed Jun 14 22:37:10 2000
|
||||
+++ src/Makefile Wed Jun 14 22:38:40 2000
|
||||
@@ -124,8 +124,8 @@
|
||||
# flags for debugging:
|
||||
# CFLAGS = -g -I../include
|
||||
|
||||
-CFLAGS = -O -I../include -I/usr/X11R6/include `gtk-config --cflags`
|
||||
-LFLAGS = -O -L/usr/X11R6/lib `gtk-config --libs`
|
||||
+CFLAGS += -I../include -I${X11BASE}/include `${GTK_CONFIG} --cflags`
|
||||
+LFLAGS = -L${X11BASE}/lib `${GTK_CONFIG} --libs`
|
||||
|
||||
# Set the WINSRC, WINOBJ, and WINLIB lines to correspond to your desired
|
||||
# combination of windowing systems. Also set windowing systems in config.h.
|
@ -1 +0,0 @@
|
||||
Nethack 3.2.3 with GTK interface and graphics
|
@ -1,7 +0,0 @@
|
||||
This is the clasic hack'n'slash adventure game, nethack, revamped with a GTK
|
||||
interface and graphics.
|
||||
|
||||
WWW: http://www.jnethack.org/jnethack-e.html
|
||||
|
||||
-Kelly
|
||||
kbyanc@posi.net
|
@ -1,131 +0,0 @@
|
||||
bin/nethack
|
||||
share/nethack/nethack
|
||||
@exec mkdir %D/share/nethack/save
|
||||
@exec chmod -R 775 %D/share/nethack
|
||||
@exec chmod 2755 %D/share/nethack/nethack
|
||||
@exec chown games:games %D/share/nethack/save
|
||||
@unexec rm -rf %D/share/nethack/save
|
||||
share/doc/nethack/Guidebook.txt
|
||||
share/nethack/x11tiles
|
||||
share/nethack/W-start.lev
|
||||
share/nethack/V-start.lev
|
||||
share/nethack/T-start.lev
|
||||
share/nethack/S-start.lev
|
||||
share/nethack/R-start.lev
|
||||
share/nethack/P-start.lev
|
||||
share/nethack/K-start.lev
|
||||
share/nethack/H-start.lev
|
||||
share/nethack/E-start.lev
|
||||
share/nethack/C-start.lev
|
||||
share/nethack/B-start.lev
|
||||
share/nethack/A-start.lev
|
||||
share/nethack/W-locate.lev
|
||||
share/nethack/V-locate.lev
|
||||
share/nethack/T-locate.lev
|
||||
share/nethack/S-locate.lev
|
||||
share/nethack/R-locate.lev
|
||||
share/nethack/P-locate.lev
|
||||
share/nethack/K-locate.lev
|
||||
share/nethack/H-locate.lev
|
||||
share/nethack/E-locate.lev
|
||||
share/nethack/C-locate.lev
|
||||
share/nethack/B-locate.lev
|
||||
share/nethack/A-locate.lev
|
||||
share/nethack/W-fillb.lev
|
||||
share/nethack/W-filla.lev
|
||||
share/nethack/V-fillb.lev
|
||||
share/nethack/V-filla.lev
|
||||
share/nethack/T-fillb.lev
|
||||
share/nethack/T-filla.lev
|
||||
share/nethack/S-fillb.lev
|
||||
share/nethack/S-filla.lev
|
||||
share/nethack/R-fillb.lev
|
||||
share/nethack/R-filla.lev
|
||||
share/nethack/P-fillb.lev
|
||||
share/nethack/P-filla.lev
|
||||
share/nethack/K-fillb.lev
|
||||
share/nethack/K-filla.lev
|
||||
share/nethack/H-fillb.lev
|
||||
share/nethack/H-filla.lev
|
||||
share/nethack/E-fillb.lev
|
||||
share/nethack/E-filla.lev
|
||||
share/nethack/C-fillb.lev
|
||||
share/nethack/C-filla.lev
|
||||
share/nethack/B-fillb.lev
|
||||
share/nethack/B-filla.lev
|
||||
share/nethack/A-fillb.lev
|
||||
share/nethack/A-filla.lev
|
||||
share/nethack/W-goal.lev
|
||||
share/nethack/V-goal.lev
|
||||
share/nethack/T-goal.lev
|
||||
share/nethack/S-goal.lev
|
||||
share/nethack/R-goal.lev
|
||||
share/nethack/P-goal.lev
|
||||
share/nethack/K-goal.lev
|
||||
share/nethack/H-goal.lev
|
||||
share/nethack/E-goal.lev
|
||||
share/nethack/C-goal.lev
|
||||
share/nethack/B-goal.lev
|
||||
share/nethack/A-goal.lev
|
||||
share/nethack/floor.xpm
|
||||
share/nethack/credit.xpm
|
||||
share/nethack/t32-1024.xpm
|
||||
share/nethack/rip.xpm
|
||||
share/nethack/pet_mark.xbm
|
||||
share/nethack/NetHack
|
||||
share/nethack/gtkrc
|
||||
share/nethack/nh10.pcf
|
||||
share/nethack/fonts.dir
|
||||
share/nethack/quest.dat
|
||||
share/nethack/options
|
||||
share/nethack/oracles
|
||||
share/nethack/data
|
||||
share/nethack/water.lev
|
||||
share/nethack/fire.lev
|
||||
share/nethack/earth.lev
|
||||
share/nethack/air.lev
|
||||
share/nethack/astral.lev
|
||||
share/nethack/wizard3.lev
|
||||
share/nethack/wizard2.lev
|
||||
share/nethack/dungeon
|
||||
share/nethack/wizard1.lev
|
||||
share/nethack/valley.lev
|
||||
share/nethack/tower3.lev
|
||||
share/nethack/tower2.lev
|
||||
share/nethack/tower1.lev
|
||||
share/nethack/sanctum.lev
|
||||
share/nethack/orcus.lev
|
||||
share/nethack/oracle.lev
|
||||
share/nethack/minetn-2.lev
|
||||
share/nethack/minetn-1.lev
|
||||
share/nethack/minefill.lev
|
||||
share/nethack/minend-2.lev
|
||||
share/nethack/minend-1.lev
|
||||
share/nethack/medusa-2.lev
|
||||
share/nethack/medusa-1.lev
|
||||
share/nethack/knox.lev
|
||||
share/nethack/juiblex.lev
|
||||
share/nethack/fakewiz2.lev
|
||||
share/nethack/fakewiz1.lev
|
||||
share/nethack/castle.lev
|
||||
share/nethack/bigrm-5.lev
|
||||
share/nethack/bigrm-4.lev
|
||||
share/nethack/bigrm-3.lev
|
||||
share/nethack/wizhelp
|
||||
share/nethack/bigrm-2.lev
|
||||
share/nethack/bigrm-1.lev
|
||||
share/nethack/baalz.lev
|
||||
share/nethack/asmodeus.lev
|
||||
share/nethack/opthelp
|
||||
share/nethack/history
|
||||
share/nethack/cmdhelp
|
||||
share/nethack/hh
|
||||
share/nethack/help
|
||||
share/nethack/license
|
||||
share/nethack/rumors
|
||||
@mode 664
|
||||
share/nethack/logfile
|
||||
share/nethack/record
|
||||
share/nethack/perm
|
||||
@dirrm share/nethack
|
||||
@dirrm share/doc/nethack
|
@ -1,37 +0,0 @@
|
||||
# New ports collection makefile for: nethack
|
||||
# Date created: 27 March 1995
|
||||
# Whom: asami
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= nethack
|
||||
PORTVERSION= 3.2.3
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ftp://ftp.nethack.org/pub/nethack/nh322/src/ \
|
||||
ftp://ftp.wtower.com/nethack/sources/
|
||||
DISTNAME= nethack-3.2.2
|
||||
|
||||
PATCH_SITES= ftp://ftp.nethack.org/pub/nethack/nh323/src/
|
||||
PATCHFILES= nh-3.2.2-3.2.3.diff
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
NO_LATEST_LINK= yes
|
||||
|
||||
USE_XPM= yes
|
||||
USE_GMAKE= yes
|
||||
MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
|
||||
|
||||
pre-configure:
|
||||
@cd ${WRKSRC}/sys/unix; ${SH} setup.sh
|
||||
|
||||
post-install:
|
||||
@cd ${WRKSRC}/doc; ${CHMOD} 644 *.6
|
||||
@cd ${WRKSRC}/doc; PREFIX=${PREFIX} ${MAKE} manpages
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/Guidebook.txt ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,2 +0,0 @@
|
||||
MD5 (nethack-3.2.2.tar.gz) = c85de4d14453b3a2d182d1dfc2ca04df
|
||||
MD5 (nh-3.2.2-3.2.3.diff) = 440141990df326d5a973d890179cffae
|
@ -1,49 +0,0 @@
|
||||
--- sys/unix/Makefile.src.orig Wed Dec 11 05:20:09 1996
|
||||
+++ sys/unix/Makefile.src Sun Mar 21 17:50:08 1999
|
||||
@@ -124,8 +124,8 @@
|
||||
# flags for debugging:
|
||||
# CFLAGS = -g -I../include
|
||||
|
||||
-CFLAGS = -O -I../include
|
||||
-LFLAGS =
|
||||
+CFLAGS += -O -I../include -I${X11BASE}/include
|
||||
+LFLAGS = -L${X11BASE}/lib
|
||||
|
||||
|
||||
# Set the WINSRC, WINOBJ, and WINLIB lines to correspond to your desired
|
||||
@@ -146,8 +146,8 @@
|
||||
winmisc.o winstat.o wintext.o winval.o tile.o
|
||||
#
|
||||
#
|
||||
-WINSRC = $(WINTTYSRC)
|
||||
-WINOBJ = $(WINTTYOBJ)
|
||||
+WINSRC = $(WINTTYSRC) $(WINX11SRC)
|
||||
+WINOBJ = $(WINTTYOBJ) $(WINX11OBJ)
|
||||
|
||||
# on some systems the termcap library is in -ltermcap or -lcurses
|
||||
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
|
||||
@@ -167,13 +167,13 @@
|
||||
#
|
||||
# libraries for X11
|
||||
# If USE_XPM is defined in config.h, you will also need -lXpm here.
|
||||
-WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
|
||||
+WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11 -lXpm
|
||||
# WINX11LIB = -lXaw -lXmu -lXt -lX11
|
||||
# WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
|
||||
# WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
|
||||
#
|
||||
#
|
||||
-WINLIB = $(WINTTYLIB)
|
||||
+WINLIB = $(WINTTYLIB) $(WINX11LIB)
|
||||
|
||||
# any other strange libraries your system needs (for Sysunix only -- the more
|
||||
# specialized targets should already be right)
|
||||
@@ -197,7 +197,7 @@
|
||||
# IRIX 4.0.x needs -lsun if NIS (YP) is being used for passwd file lookup
|
||||
# LIBS = -lsun
|
||||
#
|
||||
-LIBS =
|
||||
+LIBS = -lSM -lICE
|
||||
|
||||
# make NetHack
|
||||
GAME = nethack
|
@ -1,47 +0,0 @@
|
||||
diff -ruN ./include/config.h ../nethack-3.2.2/include/config.h
|
||||
--- ./include/config.h Wed Dec 11 05:20:07 1996
|
||||
+++ ../nethack-3.2.2/include/config.h Sun Mar 21 17:25:02 1999
|
||||
@@ -211,7 +211,7 @@
|
||||
* Some combinations make no sense. See the installation document.
|
||||
*/
|
||||
#define TTY_GRAPHICS /* good old tty based graphics */
|
||||
-/* #define X11_GRAPHICS /* X11 interface */
|
||||
+#define X11_GRAPHICS /* X11 interface */
|
||||
|
||||
/*
|
||||
* Define the default window system. This should be one that is compiled
|
||||
@@ -256,7 +256,7 @@
|
||||
* would allow:
|
||||
* xpmtoppm <x11tiles.xpm | pnmscale 1.25 | ppmquant 90 >x11tiles_big.xpm
|
||||
*/
|
||||
-/* # define USE_XPM /* Disable if you do not have the XPM library */
|
||||
+# define USE_XPM /* Disable if you do not have the XPM library */
|
||||
# ifdef USE_XPM
|
||||
# define GRAPHIC_TOMBSTONE /* Use graphical tombstone (rip.xpm) */
|
||||
# endif
|
||||
@@ -296,12 +296,12 @@
|
||||
|
||||
#ifdef UNIX
|
||||
/* path and file name extension for compression program */
|
||||
-# define COMPRESS "/usr/ucb/compress" /* Lempel-Ziv compression */
|
||||
-# define COMPRESS_EXTENSION ".Z" /* compress's extension */
|
||||
+/* # define COMPRESS "/usr/ucb/compress" /* Lempel-Ziv compression */
|
||||
+/* # define COMPRESS_EXTENSION ".Z" /* compress's extension */
|
||||
|
||||
/* An example of one alternative you might want to use: */
|
||||
-/* # define COMPRESS "/usr/local/bin/gzip" /* FSF gzip compression */
|
||||
-/* # define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
|
||||
+# define COMPRESS "/usr/bin/gzip" /* FSF gzip compression */
|
||||
+# define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
|
||||
#endif
|
||||
#ifndef COMPRESS
|
||||
# define INTERNAL_COMP /* control use of NetHack's compression routines */
|
||||
@@ -331,7 +331,7 @@
|
||||
* otherwise it will be the current directory.
|
||||
*/
|
||||
# ifndef HACKDIR
|
||||
-# define HACKDIR "/usr/games/lib/nethackdir" /* nethack directory */
|
||||
+# define HACKDIR "/usr/local/share/nethack" /* nethack directory */
|
||||
# endif
|
||||
|
||||
/*
|
@ -1,20 +0,0 @@
|
||||
--- include/system.h.orig Mon Nov 4 08:01:25 1996
|
||||
+++ include/system.h Sat Jun 19 16:18:02 1999
|
||||
@@ -80,7 +80,7 @@
|
||||
# if !defined(SUNOS4) || defined(RANDOM)
|
||||
E void FDECL(srandom, (unsigned int));
|
||||
# else
|
||||
-# ifndef bsdi
|
||||
+# if !defined(bsdi) && !defined(__FreeBSD__)
|
||||
E int FDECL(srandom, (unsigned int));
|
||||
# endif
|
||||
# endif
|
||||
@@ -510,7 +510,7 @@
|
||||
# if defined(ULTRIX) || defined(SYSV) || defined(MICRO) || defined(VMS) || defined(MAC)
|
||||
E time_t FDECL(time, (time_t *));
|
||||
# else
|
||||
-E long FDECL(time, (time_t *));
|
||||
+E time_t FDECL(time, (time_t *));
|
||||
# endif /* ULTRIX */
|
||||
|
||||
#ifdef VMS
|
@ -1,37 +0,0 @@
|
||||
diff -ruN ./include/unixconf.h ../nethack-3.2.2/include/unixconf.h
|
||||
--- ./include/unixconf.h Wed Dec 11 05:20:08 1996
|
||||
+++ ../nethack-3.2.2/include/unixconf.h Sun Mar 21 17:25:02 1999
|
||||
@@ -31,7 +31,7 @@
|
||||
|
||||
/* define any of the following that are appropriate */
|
||||
/* #define SVR4 /* use in addition to SYSV for System V Release 4 */
|
||||
-#define NETWORK /* if running on a networked system */
|
||||
+/* #define NETWORK /* if running on a networked system */
|
||||
/* e.g. Suns sharing a playground through NFS */
|
||||
#define SUNOS4 /* SunOS 4.x */
|
||||
/* #define LINUX /* Another Unix clone */
|
||||
@@ -42,12 +42,12 @@
|
||||
/* #define AIX_31 /* In AIX 3.1 (IBM RS/6000) use BSD ioctl's to gain
|
||||
* job control (note that AIX is SYSV otherwise)
|
||||
* Also define this for AIX 3.2 */
|
||||
-/* #define TEXTCOLOR /* Use System V r3.2 terminfo color support */
|
||||
+#define TEXTCOLOR /* Use System V r3.2 terminfo color support */
|
||||
/* and/or ANSI color support on termcap systems */
|
||||
/* and/or X11 color */
|
||||
-/* #define POSIX_JOB_CONTROL /* use System V / POSIX job control
|
||||
+#define POSIX_JOB_CONTROL /* use System V / POSIX job control
|
||||
* (e.g., VSUSP) */
|
||||
-/* #define POSIX_TYPES /* use POSIX types for system calls and termios */
|
||||
+#define POSIX_TYPES /* use POSIX types for system calls and termios */
|
||||
/* define for many recent OS releases, including
|
||||
* those with specific defines (since types are
|
||||
* changing toward the standard from earlier chaos).
|
||||
@@ -125,7 +125,7 @@
|
||||
* A stat system call is done on the mailbox every MAILCKFREQ moves.
|
||||
*/
|
||||
|
||||
-#define MAIL /* Deliver mail during the game */
|
||||
+/* #define MAIL /* Deliver mail during the game */
|
||||
|
||||
/* The Andrew Message System does mail a little differently from normal
|
||||
* UNIX. Mail is deposited in the user's own directory in ~/Mailbox
|
@ -1,12 +0,0 @@
|
||||
diff -ruN ./sys/unix/Makefile.doc ../nethack-3.2.2/sys/unix/Makefile.doc
|
||||
--- ./sys/unix/Makefile.doc Wed Dec 11 05:20:08 1996
|
||||
+++ ../nethack-3.2.2/sys/unix/Makefile.doc Sun Mar 21 17:25:02 1999
|
||||
@@ -31,7 +31,7 @@
|
||||
|
||||
|
||||
GAME = nethack
|
||||
-MANDIR = /usr/man/man6
|
||||
+MANDIR = ${PREFIX}/man/man6
|
||||
MANEXT = 6
|
||||
|
||||
# manual installation for most BSD-style systems
|
@ -1,40 +0,0 @@
|
||||
diff -ruN ./sys/unix/Makefile.top ../nethack-3.2.2/sys/unix/Makefile.top
|
||||
--- ./sys/unix/Makefile.top Wed Dec 11 05:20:10 1996
|
||||
+++ ../nethack-3.2.2/sys/unix/Makefile.top Sun Mar 21 17:29:27 1999
|
||||
@@ -16,14 +16,14 @@
|
||||
# make NetHack
|
||||
GAME = nethack
|
||||
GAMEUID = games
|
||||
-GAMEGRP = bin
|
||||
+GAMEGRP = games
|
||||
|
||||
# Permissions - some places use setgid instead of setuid, for instance
|
||||
# See also the option "SECURE" in include/config.h
|
||||
-GAMEPERM = 04755
|
||||
-FILEPERM = 0644
|
||||
+GAMEPERM = 02755
|
||||
+FILEPERM = 0664
|
||||
EXEPERM = 0755
|
||||
-DIRPERM = 0755
|
||||
+DIRPERM = 0775
|
||||
|
||||
# GAMEDIR also appears in config.h as "HACKDIR".
|
||||
#
|
||||
@@ -32,13 +32,13 @@
|
||||
# therefore there should not be anything in GAMEDIR that you want to keep
|
||||
# (if there is, you'll have to do the installation by hand or modify the
|
||||
# instructions)
|
||||
-GAMEDIR = /usr/games/lib/$(GAME)dir
|
||||
-SHELLDIR = /usr/games
|
||||
+GAMEDIR = ${PREFIX}/share/$(GAME)
|
||||
+SHELLDIR = ${PREFIX}/bin
|
||||
|
||||
# per discussion in Install.X11
|
||||
-VARDATND =
|
||||
+# VARDATND =
|
||||
# VARDATND = x11tiles pet_mark.xbm
|
||||
-# VARDATND = x11tiles pet_mark.xbm rip.xpm
|
||||
+VARDATND = x11tiles pet_mark.xbm rip.xpm
|
||||
|
||||
VARDATD = data oracles options quest.dat rumors
|
||||
VARDAT = $(VARDATD) $(VARDATND)
|
@ -1 +0,0 @@
|
||||
A dungeon explorin', slashin', hackin' game
|
@ -1,13 +0,0 @@
|
||||
This is nethack. You and your puppy (or kitten) will explore the deep
|
||||
dungeons to retrieve the long-lost magical item that causes so much
|
||||
trouble to anyone.
|
||||
|
||||
Take care, and try not to miss meals.
|
||||
|
||||
WWW: http://www.win.tue.nl/games/roguelike/nethack/
|
||||
|
||||
- Satoshi
|
||||
asami@cs.berkeley.edu
|
||||
|
||||
P.S. There is a newsgroup "rec.games.roguelike.nethack" if you are
|
||||
truly interested.
|
@ -1,124 +0,0 @@
|
||||
bin/nethack
|
||||
share/nethack/nethack
|
||||
@exec mkdir %D/share/nethack/save
|
||||
@exec chmod -R 775 %D/share/nethack
|
||||
@exec chmod 2755 %D/share/nethack/nethack
|
||||
@exec chown games:games %D/share/nethack/save
|
||||
@unexec rm -rf %D/share/nethack/save
|
||||
%%PORTDOCS%%share/doc/nethack/Guidebook.txt
|
||||
share/nethack/pet_mark.xbm
|
||||
share/nethack/rip.xpm
|
||||
share/nethack/x11tiles
|
||||
share/nethack/A-filla.lev
|
||||
share/nethack/A-fillb.lev
|
||||
share/nethack/A-goal.lev
|
||||
share/nethack/A-locate.lev
|
||||
share/nethack/A-start.lev
|
||||
share/nethack/B-filla.lev
|
||||
share/nethack/B-fillb.lev
|
||||
share/nethack/B-goal.lev
|
||||
share/nethack/B-locate.lev
|
||||
share/nethack/B-start.lev
|
||||
share/nethack/C-filla.lev
|
||||
share/nethack/C-fillb.lev
|
||||
share/nethack/C-goal.lev
|
||||
share/nethack/C-locate.lev
|
||||
share/nethack/C-start.lev
|
||||
share/nethack/E-filla.lev
|
||||
share/nethack/E-fillb.lev
|
||||
share/nethack/E-goal.lev
|
||||
share/nethack/E-locate.lev
|
||||
share/nethack/E-start.lev
|
||||
share/nethack/H-filla.lev
|
||||
share/nethack/H-fillb.lev
|
||||
share/nethack/H-goal.lev
|
||||
share/nethack/H-locate.lev
|
||||
share/nethack/H-start.lev
|
||||
share/nethack/K-filla.lev
|
||||
share/nethack/K-fillb.lev
|
||||
share/nethack/K-goal.lev
|
||||
share/nethack/K-locate.lev
|
||||
share/nethack/K-start.lev
|
||||
share/nethack/P-filla.lev
|
||||
share/nethack/P-fillb.lev
|
||||
share/nethack/P-goal.lev
|
||||
share/nethack/P-locate.lev
|
||||
share/nethack/P-start.lev
|
||||
share/nethack/R-filla.lev
|
||||
share/nethack/R-fillb.lev
|
||||
share/nethack/R-goal.lev
|
||||
share/nethack/R-locate.lev
|
||||
share/nethack/R-start.lev
|
||||
share/nethack/S-filla.lev
|
||||
share/nethack/S-fillb.lev
|
||||
share/nethack/S-goal.lev
|
||||
share/nethack/S-locate.lev
|
||||
share/nethack/S-start.lev
|
||||
share/nethack/T-filla.lev
|
||||
share/nethack/T-fillb.lev
|
||||
share/nethack/T-goal.lev
|
||||
share/nethack/T-locate.lev
|
||||
share/nethack/T-start.lev
|
||||
share/nethack/V-filla.lev
|
||||
share/nethack/V-fillb.lev
|
||||
share/nethack/V-goal.lev
|
||||
share/nethack/V-locate.lev
|
||||
share/nethack/V-start.lev
|
||||
share/nethack/W-filla.lev
|
||||
share/nethack/W-fillb.lev
|
||||
share/nethack/W-goal.lev
|
||||
share/nethack/W-locate.lev
|
||||
share/nethack/W-start.lev
|
||||
share/nethack/air.lev
|
||||
share/nethack/asmodeus.lev
|
||||
share/nethack/astral.lev
|
||||
share/nethack/baalz.lev
|
||||
share/nethack/bigrm-1.lev
|
||||
share/nethack/bigrm-2.lev
|
||||
share/nethack/bigrm-3.lev
|
||||
share/nethack/bigrm-4.lev
|
||||
share/nethack/bigrm-5.lev
|
||||
share/nethack/castle.lev
|
||||
share/nethack/cmdhelp
|
||||
share/nethack/data
|
||||
share/nethack/dungeon
|
||||
share/nethack/earth.lev
|
||||
share/nethack/fakewiz1.lev
|
||||
share/nethack/fakewiz2.lev
|
||||
share/nethack/fire.lev
|
||||
share/nethack/help
|
||||
share/nethack/hh
|
||||
share/nethack/history
|
||||
share/nethack/juiblex.lev
|
||||
share/nethack/knox.lev
|
||||
share/nethack/license
|
||||
share/nethack/medusa-1.lev
|
||||
share/nethack/medusa-2.lev
|
||||
share/nethack/minefill.lev
|
||||
share/nethack/minend-1.lev
|
||||
share/nethack/minend-2.lev
|
||||
share/nethack/minetn-1.lev
|
||||
share/nethack/minetn-2.lev
|
||||
share/nethack/opthelp
|
||||
share/nethack/options
|
||||
share/nethack/oracle.lev
|
||||
share/nethack/oracles
|
||||
share/nethack/orcus.lev
|
||||
share/nethack/quest.dat
|
||||
share/nethack/rumors
|
||||
share/nethack/sanctum.lev
|
||||
share/nethack/tower1.lev
|
||||
share/nethack/tower2.lev
|
||||
share/nethack/tower3.lev
|
||||
share/nethack/valley.lev
|
||||
share/nethack/water.lev
|
||||
share/nethack/wizard1.lev
|
||||
share/nethack/wizard2.lev
|
||||
share/nethack/wizard3.lev
|
||||
share/nethack/wizhelp
|
||||
@mode 664
|
||||
share/nethack/logfile
|
||||
share/nethack/record
|
||||
share/nethack/perm
|
||||
@dirrm share/nethack
|
||||
%%PORTDOCS%%@dirrm share/doc/nethack
|
Loading…
Reference in New Issue
Block a user