- Revive devel/libparserutils
- Take maintainership - Update to 0.2.3
This commit is contained in:
parent
7775a23baf
commit
8cd438e8b2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=411458
1
MOVED
1
MOVED
@ -6541,7 +6541,6 @@ devel/entity||2014-09-01|Not staged
|
||||
devel/flowdesigner||2014-09-01|Not staged
|
||||
devel/gjstest||2014-09-01|Not staged
|
||||
devel/jzmq||2014-09-01|Not staged
|
||||
devel/libparserutils||2014-09-01|Not staged
|
||||
devel/libslave||2014-09-01|Not staged
|
||||
devel/linux-kmod-compat||2014-09-01|Not staged
|
||||
devel/ml-doc||2014-09-01|Not staged
|
||||
|
@ -1285,6 +1285,7 @@
|
||||
SUBDIR += libowfat
|
||||
SUBDIR += libpafe
|
||||
SUBDIR += libpafe-ruby
|
||||
SUBDIR += libparserutils
|
||||
SUBDIR += libpasori
|
||||
SUBDIR += libpci
|
||||
SUBDIR += libpciaccess
|
||||
|
30
devel/libparserutils/Makefile
Normal file
30
devel/libparserutils/Makefile
Normal file
@ -0,0 +1,30 @@
|
||||
# Created by: David Romano <unobe@cpan.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libparserutils
|
||||
PORTVERSION= 0.2.3
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://download.netsurf-browser.org/libs/releases/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
|
||||
|
||||
MAINTAINER= olivierd@FreeBSD.org
|
||||
COMMENT= Lexer/parser utility functions for NetSurf
|
||||
|
||||
LICENSE= MIT
|
||||
|
||||
BUILD_DEPENDS= netsurf-buildsystem>=1.5:${PORTSDIR}/devel/netsurf-buildsystem
|
||||
|
||||
USES= gmake iconv localbase pkgconfig
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
MAKE_ENV+= COMPONENT_TYPE="lib-shared"
|
||||
LDFLAGS+= ${ICONV_LIB}
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}
|
||||
|
||||
PLIST_SUB+= VERSION=${PORTVERSION}
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libparserutils.so*
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/libparserutils/distinfo
Normal file
2
devel/libparserutils/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
SHA256 (libparserutils-0.2.3-src.tar.gz) = c5d93fb41b9c006ba392b32d724a7239238d656aa81cd45804ddd0b794a6ff05
|
||||
SIZE (libparserutils-0.2.3-src.tar.gz) = 74509
|
10
devel/libparserutils/files/patch-Makefile
Normal file
10
devel/libparserutils/files/patch-Makefile
Normal file
@ -0,0 +1,10 @@
|
||||
--- Makefile.orig 2016-02-16 08:49:51 UTC
|
||||
+++ Makefile
|
||||
@@ -55,5 +55,5 @@ Is := include/parserutils/utils
|
||||
I := /$(INCLUDEDIR)/parserutils/utils
|
||||
INSTALL_ITEMS := $(INSTALL_ITEMS) $(I):$(Is)/buffer.h;$(Is)/stack.h;$(Is)/vector.h
|
||||
|
||||
-INSTALL_ITEMS := $(INSTALL_ITEMS) /$(LIBDIR)/pkgconfig:lib$(COMPONENT).pc.in
|
||||
-INSTALL_ITEMS := $(INSTALL_ITEMS) /$(LIBDIR):$(OUTPUT)
|
||||
+INSTALL_ITEMS := $(INSTALL_ITEMS) /libdata/pkgconfig:lib$(COMPONENT).pc.in
|
||||
+INSTALL_ITEMS := $(INSTALL_ITEMS) /lib:$(OUTPUT)
|
15
devel/libparserutils/files/patch-libparserutils.pc.in
Normal file
15
devel/libparserutils/files/patch-libparserutils.pc.in
Normal file
@ -0,0 +1,15 @@
|
||||
--- libparserutils.pc.in.orig 2016-02-16 08:49:51 UTC
|
||||
+++ libparserutils.pc.in
|
||||
@@ -1,10 +1,10 @@
|
||||
prefix=PREFIX
|
||||
exec_prefix=${prefix}
|
||||
-libdir=${exec_prefix}/LIBDIR
|
||||
+libdir=${exec_prefix}/lib
|
||||
includedir=${prefix}/INCLUDEDIR
|
||||
|
||||
Name: libparserutils
|
||||
Description: Utility library for facilitating parser development
|
||||
Version: VERSION
|
||||
-Libs: -L${libdir} -lparserutils
|
||||
+Libs: -L${libdir} -lparserutils -liconv
|
||||
Cflags: -I${includedir}
|
10
devel/libparserutils/pkg-descr
Normal file
10
devel/libparserutils/pkg-descr
Normal file
@ -0,0 +1,10 @@
|
||||
LibParserUtils provides various pieces of functionality that are useful when
|
||||
writing parsers. These are:
|
||||
|
||||
+ A number of character set convertors
|
||||
+ Mapping of character set names to/from MIB enum values
|
||||
+ UTF-8 and UTF-16 (host endian) support functions
|
||||
+ Various simple data structures (resizeable buffer, stack, vector)
|
||||
+ A UTF-8 input stream
|
||||
|
||||
WWW: http://www.netsurf-browser.org/projects/libparserutils/
|
16
devel/libparserutils/pkg-plist
Normal file
16
devel/libparserutils/pkg-plist
Normal file
@ -0,0 +1,16 @@
|
||||
include/parserutils/charset/codec.h
|
||||
include/parserutils/charset/mibenum.h
|
||||
include/parserutils/charset/utf16.h
|
||||
include/parserutils/charset/utf8.h
|
||||
include/parserutils/errors.h
|
||||
include/parserutils/functypes.h
|
||||
include/parserutils/input/inputstream.h
|
||||
include/parserutils/parserutils.h
|
||||
include/parserutils/types.h
|
||||
include/parserutils/utils/buffer.h
|
||||
include/parserutils/utils/stack.h
|
||||
include/parserutils/utils/vector.h
|
||||
lib/libparserutils.so
|
||||
lib/libparserutils.so.0
|
||||
lib/libparserutils.so.%%VERSION%%
|
||||
libdata/pkgconfig/libparserutils.pc
|
Loading…
Reference in New Issue
Block a user