Update to nscache 0.6
Submitted by: Ports Fury
This commit is contained in:
parent
02d19fd440
commit
8cad1e04e6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=38666
@ -6,21 +6,30 @@
|
||||
#
|
||||
|
||||
PORTNAME= nscache
|
||||
PORTVERSION= 0.2p2
|
||||
PORTVERSION= 0.6
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.idata.sk/~ondrej/sw/
|
||||
DISTNAME= nscache-0.2pl2
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
http://www.idata.sk/~ondrej/sw/
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= kris@FreeBSD.org
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GTK= yes
|
||||
WANT_GNOME= yes
|
||||
USE_AUTOMAKE= yes
|
||||
AUTOMAKE= automake -a -i
|
||||
CONFIGURE_ENV= CPPFALGS="-I${LOCALBASE}/include" \
|
||||
AUTOMAKE_ARGS= --include-deps
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --with-gtk-config=${GTK_CONFIG}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(HAVE_GNOME)
|
||||
USE_GNOME= yes
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-gnome
|
||||
.endif
|
||||
|
||||
pre-configure:
|
||||
@cd ${WRKSRC}; aclocal -I ${X11BASE}/share/aclocal
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (nscache-0.2pl2.tgz) = e95b59b90d7e1f567e2263853be26f7b
|
||||
MD5 (nscache-0.6.tgz) = aa88ad458be394a2fccac39906226cff
|
||||
|
@ -1,22 +1,23 @@
|
||||
--- configure.in.orig Sun Jan 16 02:40:55 2000
|
||||
+++ configure.in Sat Jul 1 19:10:54 2000
|
||||
@@ -41,17 +41,11 @@
|
||||
--- configure.in.orig Sun Jan 14 20:49:31 2001
|
||||
+++ configure.in Tue Jan 16 03:06:10 2001
|
||||
@@ -195,13 +195,15 @@
|
||||
fi
|
||||
|
||||
AC_CHECK_LIB(c, gettext, CFLAGS="$CFLAGS -DHAVE_GETTEXT -DNLS_DIR=\"\\\"\$(prefix)/share/locale\\\"\"";MSUBDIRS="po", AC_CHECK_LIB(intl, gettext, LIBS="$LIBS -lintl";CFLAGS="$CFLAGS -DHAVE_GETTEXT -DNLS_DIR=\"\\\"\$(prefix)/share/locale\\\"\"";MSUBDIRS="po"))
|
||||
|
||||
-AC_CHECK_LIB(db1, dbopen, CFLAGS="$CFLAGS -DHAVE_DBOPEN";LIBS="$LIBS -ldb1", AC_CHECK_LIB(db, dbopen, CFLAGS="$CFLAGS -DHAVE_DBOPEN";LIBS="$LIBS -ldb", AC_MSG_ERROR("NScache can\'t work withou clasical Berkeley DB libraries")))
|
||||
+AC_CHECK_LIB(db1, dbopen, CFLAGS="$CFLAGS -DHAVE_DBOPEN";LIBS="$LIBS -ldb1", AC_CHECK_LIB(c, dbopen, CFLAGS="$CFLAGS -DHAVE_DBOPEN", AC_MSG_ERROR("NScache can\'t work withou clasical Berkeley DB libraries")))
|
||||
|
||||
AC_CHECK_HEADER(db1/db.h, CFLAGS="$CFLAGS -DHAVE_DB1_H", AC_CHECK_HEADER(db.h, CFLAGS="$CFLAGS -DHAVE_DB_H"))
|
||||
|
||||
-AC_CHECK_PROG(GTK_CONFIG, gtk-config, "yes", "no")
|
||||
-if eval "test x$GTK_CONFIG = xyes"; then
|
||||
- CFLAGS="$CFLAGS `gtk-config --cflags`"
|
||||
- LIBS="$LIBS `gtk-config --libs`"
|
||||
-else
|
||||
- AC_MSG_ERROR("Unable to find \"gtk-config\" program")
|
||||
-fi
|
||||
+AM_PATH_GTK(1.2.0, , AC_MSG_ERROR(GTK+ is not installed or badly configured on your system...))
|
||||
|
||||
AC_SUBST(CFLAGS)
|
||||
AC_SUBST(LIBS)
|
||||
if eval "test x$WITH_GNOME = xyes"; then
|
||||
- AC_CHECK_PROG(GNOME_CONFIG, gnome-config, "yes", "no")
|
||||
- if eval "test x$GNOME_CONFIG = xyes"; then
|
||||
- GNOME_PREFIX=`gnome-config --prefix`
|
||||
+ AC_PATH_PROG(GNOME_CONFIG, gnome-config, "no")
|
||||
+ if eval "test x$GNOME_CONFIG = no"; then
|
||||
+ GNOME_PREFIX=
|
||||
+ else
|
||||
+ GNOME_PREFIX=`$GNOME_CONFIG --prefix`
|
||||
AC_WARN("Will install Gnome things to $GNOME_PREFIX")
|
||||
if eval "test x$WITH_GNOME = xyes"; then
|
||||
- GNOME_LIBS=`gnome-config --libs gnomeui`
|
||||
- GNOME_CFLAGS=`gnome-config --cflags gnomeui`
|
||||
+ GNOME_LIBS=`$GNOME_CONFIG --libs gnomeui`
|
||||
+ GNOME_CFLAGS=`$GNOME_CONFIG --cflags gnomeui`
|
||||
GNOME_CFLAGS="$GNOME_CFLAGS -DHAVE_GNOME"
|
||||
fi
|
||||
fi
|
||||
|
@ -1,19 +1,25 @@
|
||||
--- Makefile.am.orig Tue Jan 18 04:49:06 2000
|
||||
+++ Makefile.am Sat Jul 1 20:03:06 2000
|
||||
@@ -1,5 +1,7 @@
|
||||
SUBDIRS = @MSUBDIRS@
|
||||
--- Makefile.am.orig Thu Oct 5 07:38:32 2000
|
||||
+++ Makefile.am Tue Jan 16 03:06:23 2001
|
||||
@@ -6,16 +6,16 @@
|
||||
|
||||
+INCLUDES = $(GTK_CFLAGS)
|
||||
+
|
||||
bin_PROGRAMS = nscache
|
||||
install-data-local:
|
||||
if test -n "$(GNOME_PREFIX)"; then \
|
||||
- $(mkinstalldirs) $(DESTDIR)$(GNOME_PREFIX)/share/gnome/apps/Internet; \
|
||||
- $(INSTALL_DATA) $(srcdir)/nscache.desktop $(DESTDIR)$(GNOME_PREFIX)/share/gnome/apps/Internet; \
|
||||
- $(mkinstalldirs) $(DESTDIR)$(GNOME_PREFIX)/share/pixmaps; \
|
||||
- $(INSTALL_DATA) $(srcdir)/nscache.xpm $(DESTDIR)$(GNOME_PREFIX)/share/pixmaps; \
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(datadir)/apps/Internet; \
|
||||
+ $(INSTALL_DATA) $(srcdir)/nscache.desktop $(DESTDIR)$(datadir)/apps/Internet; \
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(datadir)/pixmaps; \
|
||||
+ $(INSTALL_DATA) $(srcdir)/nscache.xpm $(DESTDIR)$(datadir)/pixmaps; \
|
||||
fi
|
||||
|
||||
uninstall-local:
|
||||
if test -n "$(GNOME_PREFIX)"; then \
|
||||
- rm -f $(DESTDIR)$(GNOME_PREFIX)/share/gnome/apps/Internet/nscache.desktop; \
|
||||
- rm -f $(DESTDIR)$(GNOME_PREFIX)/share/pixmaps/nscache.xpm; \
|
||||
+ rm -f $(DESTDIR)$(datadir)/apps/Internet/nscache.desktop; \
|
||||
+ rm -f $(DESTDIR)$(datadir)/pixmaps/nscache.xpm; \
|
||||
fi
|
||||
|
||||
nscache_SOURCES = \
|
||||
@@ -12,6 +14,8 @@
|
||||
indexdb.h \
|
||||
nls.h \
|
||||
setup.c
|
||||
+
|
||||
+nscache_LDADD = $(GTK_LIBS)
|
||||
|
||||
nscache.pot: $(nscache_SOURCES)
|
||||
xgettext --default-domain=nscache -n -E -o $@ $(nscache_SOURCES)
|
||||
|
10
www/nscache/files/patch-ac
Normal file
10
www/nscache/files/patch-ac
Normal file
@ -0,0 +1,10 @@
|
||||
--- src/re.h.orig Sun Nov 12 23:09:38 2000
|
||||
+++ src/re.h Tue Jan 16 03:06:40 2001
|
||||
@@ -3,6 +3,7 @@
|
||||
|
||||
#ifdef HAVE_REGEX
|
||||
#ifdef HAVE_REGEX_H
|
||||
+#include <sys/types.h>
|
||||
#include <regex.h>
|
||||
#endif
|
||||
|
@ -19,4 +19,4 @@ subtree. You can launch any viewer command on cache file or on source URL.
|
||||
The viewers you can assign to any MIME type. You can also copy selected URL
|
||||
to clipboard.
|
||||
|
||||
WWW: http://www.idata.sk/~ondrej/
|
||||
WWW: http://www.idata.sk/~ondrej/nscache/
|
||||
|
@ -1,4 +1,11 @@
|
||||
bin/nscache
|
||||
share/locale/de/LC_MESSAGES/nscache.mo
|
||||
share/locale/es/LC_MESSAGES/nscache.mo
|
||||
share/locale/fr/LC_MESSAGES/nscache.mo
|
||||
share/locale/it/LC_MESSAGES/nscache.mo
|
||||
share/locale/ja/LC_MESSAGES/nscache.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/nscache.mo
|
||||
share/locale/sk/LC_MESSAGES/nscache.mo
|
||||
share/locale/tr/LC_MESSAGES/nscache.mo
|
||||
%%GNOME:%%share/gnome/apps/Internet/nscache.desktop
|
||||
%%GNOME:%%share/gnome/pixmaps/nscache.xpm
|
||||
|
Loading…
Reference in New Issue
Block a user